Application: Behold TV Plugins

ТВ тунери Beholder в България
Описание на ПЛЪГИНИ за фирмен софтуерен комплекс Behold TV
Next page >
Behold TV Plugins
User guide

Created with DrExplain

Next page >
Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията!
© Beholder / Beholder-Europe BPO 117813/20012011


Application: Behold TV Plugins

< Previous page Next page >

Behold TV Plugins

www.beholder.ru

www.beholder-europe.com / www.beholder-europe.eu

Ръководства, справочна и помощна информация за инсталиране и експлоатация на

ТV тунери Beholder® и софтуерен комплекс Behold ТV©

Тематично обособена част:

Ръководство, справочна и помощна информация за инсталиране и използване на плъгини за ТV тунери Beholder® и софтуерен комплекс Behold ТV©.

Особености при използване на плъгини с функция Timeshift и при излъчване в мрежа.

Структура на помощните материали:

Съдържание - Behold TV Plugins (BG)

Съдържание - Behold TV (BG)

The contents of Behold TV Plugins

Предговор
Интегриране в програмата
Функции и настройки
Описание на интерфейса
Въпроси и отговори
Информация за контакти
Reserve

Created with DrExplain

< Previous page Next page >


Topic: Предговор

Предговор

Встъпителни бележки

От автора на настоящия материал (български превод, допълнение и редакция)

  • Предназначение, структура и обхват

    Материалите се публикуват за улеснение на потребители на ТВ тунери Beholder®, които ползват български език.

    Цитираните материали (препратки) представляват разширени и редактирани преводи, публикувани на официалния сайт на производителя след предварителното съгласуване с носителите на авторски права, считано от версия Behold TV_v.5.05 въз основа на оригиналния интерфейс и Help към програмата:

    - инсталация на драйвери и софтуер;

    - Help-файлове към програмни пакети btv_v.5.05~v.5.07~v.5.09~v.5.10~v.5.11~v.5.15~v.5.17;

    - Многократно разширяване на възможностите при използване на плъгини;

    - авторски материали, както и

    - статии, ревюта, коментари и публикации от други източници в интернет-пространството.

    Информацията се допълва, редактира и актуализирана периодично. Към момента са нанесени изменения до версия Behold TV_v.5.17 включително.

    Кратки бележки по превода и редакцията**

    В някои от последните официални редакции на справочна информация целият раздел за инсталиране на драйвери и софтуер е изведен отделно като препратка към официалния сайт, поради което по аналогия българската версия на тези материали се публикува също отделно от Help-файла към софтуерния пакет за по-пълно съответствие с постройката на оригиналния софтуер и фирмения интернет-сайт. В настоящата инструкция са запазени основни моменти от първоначалната редакция за v.5.05, които са построени по следната логическа структура:

    избор на ТВ тунер (желания и обективни възможности/ограничения)

    инсталиране на хардуер

    инсталиране на драйвери/софтуер

    основни настройки

    ползване

    разширени (индивидуални) настройки

    конфигуриране и използване на допълнителни възможности...

    По аналогия са публикувани отделни материали в помощ при избор на ТВ тунер, описание и настройки на плъгини за Behold TV, възможности за борба с реклами и др.

Инструкциите за инсталиране на драйвери и софтуерния пакет са приложими за всички модели PCI/PCIе/USB тунери BeholdTV.

Материали за SТВ (Set-Тop Вox) тунери и софтуер за управление на такива се публикуват отделно.

** При превода, редактирането и графичното оформление на материалите на български език има някои особености, които са внесени с желание същите да бъдат по-достъпни, изчерпателни и сравними. Тази информация е изнесена в българската секция към материалите.

  • Личен опит - съвет за спестяване на време и усилия

    Препоръчително е потребителите на ТВ тунери Beholder и софтуерния комплекс BeholdTV да се запознаят със следващите бележки – това впоследствие би могло да спести много ценно време при инсталиране на хардуер, драйвери и работа със софтуерните модули. В материала се съдържат отговори на ред въпроси (възникнали при затруднения/проблеми от различен характер, но все пак - основно поради непознаване на описаното в инструкциите), които са подробно разяснени в детайли. Направени са и връзки на общодостъпно ниво с някои други основни теоретични постановки, които имат пряко отношение към определени процеси и/или настройки.

    За потенциални потребители, които все още не са се ориентирали в многообразието от модели TV-тунери* и може би един от най-съществените фактори – перфектен софтуер с безупречната работа и поддръжка в различни версии на операционни системи, в материала се съдържа изчерпателна справочна информация, въз основа на която би могло да се постигане оптимално съотношение цена/качество в съответствие с търсен краен резултат при планиране на определен бюджет за закупуване на съвременен ТV-тунер с лесен за употреба софтуер, драйвери и постоянна поддръжка на същите в реално време.

    *При необходимост от помощ при избор на конкретен модел, съобразен с желанията и възможностите на потребителите, както и с изискванията към хардуера, софтуера и операционната система, респ. ограниченията на налична (или предстояща за придобиване) компютърна конфигурация със съответна архитектура и свободни слотове/портове, допълнителна разширена информация за подбор на конкретен тип и модел ТВ тунер е публикувана в специализиран отделен материал.

  • Общи условия за ползване и разпространение на информация

    Внимание!

    Този раздел представлява част (тематична извадка) от материали, за които са приложими права върху интелектуална собственост и условия за ползване , публикувани в интернет на адреси © beholder.ru / beholder-europe.com

  • Обратна връзка

    Авторът на българския интерфейс на софтуерния комплекс Behold TV, превода и редакцията на помощни инструкции и други материали, свързани с представянето на фирмен софтуер и ТВ тунери Beholder на българския и европейския пазар с внимание и благодарност ще очаква всякакви коментари или забележки за установени евентуално допуснати неточности/грешки, както и отзиви във връзка с практическото ползване на тунерите и фирмения софтуер.

The contents of Предговор

Обща информация
Изисквания към системата


Topic: Обща информация

Обща информация

Комплекс Behold TV

Подробно описание за възможностите и настройките на комплексния софтуерен продукт* Behold TV ( [image] по-нататък за краткост съкр. само Behold TV или „програма/та”) е публикувано в обособен материал . В същия са изведени също така основни технически характеристики на всички модели** ТВ тунери Beholder и свързаните с това функционални възможности.

Без да се навлиза в многобройните детайли на целия софтуерен комплекс Behold TV, за целите на настоящия обособен раздел е важно да се припомнят някои съществени уточнения, посочени в уводната част на основния материал:

* В българската редакция не случайно е употребено определението "софтуерен комплекс", доколкото Behold TV не е само "компютърна програма":

  • Възможностите на системата се разширяват многократно чрез специално разработена за Beholder система от плъгини, които работят както в независими режими на

    гледане (диалогов прозорец за настройки в « Панел за настройки » [image] ) и

    запис (диалогов прозорец за настройки в « Панел за запис » [image] ), така и в

    & комбиниран режим на запис с едновременно гледане на видео.

«+» Към посоченото по-горе могат да се прибавят още допълнителни възможности при използване на видеообработка с плъгини в

  • режим Таймшифт и за

  • излъчване на ТВ програми в реално време или материали от външни източници в ІР мрежа,

    като специфични видове видеозапис.

** Някои модели са спрени от производство поради независещи от Beholder обстоятелства (промени в продуктовата спецификация на NXP или поради пазарните условия).

Независимо от това, че посочените модели не се произвеждат, притежателите на такива тунери могат да бъдат напълно спокойни и уверени, че последните версии драйвери и софтуер осигуряват пълна поддръжка, вкл. за операционни системи Windows Vista/ [image] .

Програмното осигуряване и плъгините за разширяване на функционалните възможности също така са напълно съвместими с всички серии.

Обща информация за плъгини в Behold TV.

В ТВ тунери Beholder и фирмения софтуер за тях са реализирани уникални функции за видеообработка***, с което възможностите на системата се разширяват многократно. Видеообработка в Behold TV се реализира както чрез многобройните инструменти на самата програма, така и при подбор и използване на специално разработени допълнителни плъгини.

Разширяването на функционалните възможности на програмата се реализират при

  • Използване на различни включени в програмния пакет плъгини за деинтерлейсинг -

    - за премахване на т.н. „гребеновиден” (рус.„расческа”, англ. "comb") ефект;

    - за премахване на високочестотни шумове;

    - за подобряване острота на изображение,

    и други.

  • Видеообработка на изображение и използване (вграждане, наслагване) на многобройни ефекти с плъгини за процесинг - както

    при гледане, така и

    при видеозапис на ефирни/кабелни ТВ-програми или от външни източници (само за програмен запис);

    Видеоматериали могат да бъдат излъчвани в IP-мрежа или да се ползва

    режим за отложено гледане Таймшифт.

    Забележка***: Видеообработка не е достъпна в DVB-режим на тунерите.

Принцип на работа:

От технологична гледна точка, приемано видео изображение се

цифровизира от тунера,

по системната шина попада в оперативната памет* на компютъра, където

може да бъде обработвано програмно с плъгини,

По-нататък постъпва на разположение на т.н. видеорендерер – програмно-апаратен механизъм на операционната система, който обезпечава извеждане на видеоизображение на екрана на монитор.

*Важно [image] (подробни обяснения следват в съответните раздели):

  • В процеса на работа на Behold TV телевизионен кадър се предава последователно на всеки плъгин по веригата (списъка).

  • Обработка на кадър се завършва от плъгин за деинтерлейс.

  • Всеки наличен в списъците плъгин преминава през инициализация при стартиране на Behold TV, респ. заема ресурси на операционната система (памет), дори ако в даден момент е изключен (не е активен) от процесинг (свалена е отметката срещу съответен плъгин). Поради тези технологични особености,

    ако даден плъгин не се използва често е по-добре да бъде премахнат от списъка

Основни видове плъгини:

Според функционалното предназначение плъгините в Behold TV се подразделят на два вида:

  • плъгини за процесинг (файлове с префикс BPP_ и разширение .dll), и

  • плъгини за деинтерлейсинг (.dll-файлове с префикс BPD_).

    Допълнителна информация за интерлейсно/прогресивно изображение и свързаните с това възможности за подобряване на картина при използване на плъгини за деинтерлейсинг в Behold TV е поместена в началото на раздела за деинтерлейс-филтри .

В зависимост от режима на ползване са обособени отделни процеси:

  • - в режим на «гледане»

  • - в режим на «запис»

  • & възможно е използване и в комбиниран режим - едновременно при «гледане» и «запис».

Настройки за различните режими се извършват в отделни секции и диалогови прозорци! Подробно описание на настройки в диалогови прозорци за работа с плъгини в режими на « гледане » и « запис » се намират в отделни раздели на това упътване.

Автономни STB (Set-Top Box) модели:

не се поддържат външни плъгини. На разположение са някои вградени функции за видеообработка**, като

  • мащабиране на кадър (размери на видеопрозорец);

  • Аспект (съотношение на страните на кадър) - 4:3, 16:9 PanSkan, 16:9 Anamorphic, NEW! ПАНОРАМА;

  • POD (Picture on desktop / "Картина в картината") - отделен прозорец на монитора при работа с РС;

  • Сърфинг (предварителен преглед на ТV-канали в до 16 самостоятелни мащабирани прозорци на екран);

  • Стоп-кадър (Freeze);

  • и др.

    (**в зависимост от модела - при поддръжка на управление от компютър)

The contents of Обща информация

Сравнителни спецификации


Topic: Сравнителни спецификации

Сравнителни спецификации

Основни технически спецификации на РСІ/РСІе/USB/PCMCIA ТВ тунери Behold TV

Този подраздел е оставен като кратка справочна информация, която би могла да бъде полезна в процеса на запознаване с плъгините за Behold TV.

Подробни технически данни за всички произвеждани модели са посочени в основния материал . Следващите таблици съдържат информация само за актуалната производствена листа:

  • Сравнителна таблица за ТВ тунери Behold TV с РСІ/РСІе интерфейс

  • Сравнителна таблица на ТВ-тунери Behold TV с USB интерфейс

The contents of Сравнителни спецификации

Тунери с РСІ / РСІе интерфейс
Тунери с USB интерфейс


Topic: Тунери с РСІ / РСІе интерфейс

Тунери с РСІ / РСІе интерфейс

Сравнителна таблица за ТВ тунери Behold TV с РСІ/РСІе интерфейс:

  • 7-а/8-а серии с нископрофилна архитектура

  • Behold TV 5-а/Behold TV 6-а серии

    (модели "501" и "503FM" - с нископрофилна архитектура)

Според едни от първите публикувани ревюта за модел Behold TV 501 в специализиран сайт , функция FM тунер е възможна (при ръчни нстройки - вж. по-долу), въпреки че това не е изрично посочено в спецификацията:

(по Reviews.ru / 08.07.2010) "...Новият Behold TV 501 функционално много прилича на другите PCI тунери от пета серия. Единственото, което не достига е FM- приемник, което може би не е толкова важно за тунер от такава ценова категория...

Независимо от това, че в спецификацията на тунера не е заявена поддръжка на FM- радио, бутон [image] за преход в режим радио се оказва активен. При превключване този режим се установява, че радио в този тунер все пак има, при това съвсем прилично.

Както се изяснили по-късно, режим FM не е документиран само поради едно малко ограничение. Става въпрос за отсъствие на режим за автоматична настройка на станции... Важното е, че режим FM работи, което в действителност е отлична новина!

...Използването на връзка между ВЧ- блок XCeive XC4100 и чипсет NXP SAA7130 налага някои ограничения върху възможностите за работа на режим FM- приемник. В частност, тук отсъства режим за автоматично сканиране на канали.

Приемникът може да бъде настроен чрез пряко въвеждане на честоти за радиостанции или по слух при бързо преминаване през целия диапазон, като се определи наличие на излъчване в една или друга честота.

Още едно ограничение на режим FM- радио е невъзможност за настройки на аудио параметри, екулайзер и звукови ефекти - такива просто не съществуват в NXP SAA7130.

За потребители, за които тези възможности са от особено значение - определени настройки могат да бъдат извършени в менютата за настройки на аудио драйвера.

Наличието (макар и недокументирано, но работещо) на FM- радио е приятна изненада, която позволява да се разглежда този модел не само като сериозна конкуренция на бюджетни тунери на други производители, но и като вид "заплаха" за модел BeholdTV 505FM, който е примерно наполовина по-скъп."

(доп.,: Reviews.ru / 07.09.2010) Напомняме, че връзката между XCeive XC4100 и чипсет NXP SAA7130, която се използва в BeholdTV 501 не позволява да се реализира функция за автосканиране за FM. Именно поради тази причина разработчиците не са заявили поддръжка на FM приемник за 501 модел. Фактически приемник в този тунер има и той работи прилично. Единственото ограничение се касае до необходимост да се задават честоти на радиостанции в ръчен режим.


Topic: Тунери с USB интерфейс

Тунери с USB интерфейс

  • Сравнителна таблица на ТВ-тунери Behold TV с USB интерфейс


Topic: Изисквания към системата

Изисквания към системата

Изисквания към системата по отношение на хардуер, софтуер, OS

В основната тема са публикувани минимални и някои препоръчителни изисквания по отношение на софтуер и хардуер.

За целите на този материал следва да бъде обърнато внимание, че за пълно използване на всички възможности за видеообработка с плъгини, посочените минимални изисквания не са достатъчни, респ. е необходимо завишаване на някои критерии, като:

  • За използване на всички функции на видеопроцесинг е необходим процесор, не по-слаб от PIII-1000.

  • За запис на пълен кадър 720x576 с компресия MPEG2, DivX, WMV е необходим процесор, не по-слаб от AMD Athlon XP 2500+ или Intel P4 2400.

  • (доп., v.5.09) За USB2 модели е необходим CPU с тактова честота не по-ниска от 1000 МНz.

  • Оперативна памет >= 256 МB.

  • DirectDraw-съвместим AGP или PCI-Express видеоадаптер с поддръжка на овърлей (overlay) във формат YUY2.

  • HDD – препоръчително с поддръжка на 7200 RPM или RAID масив.

За безпроблемна работа с плъгини настоятелно се препоръчва да бъдат спазени не само горните, а всички изисквания, посочени в цитирания материал!


Topic: Интегриране в програмата

Интегриране в програмата

Особености при инсталиране на плъгини:

Процесите по инсталиране и активиране на плъгини преминават през няколко основни етапи:

  1. Допълнителни плъгини за Behold TV се намират в

    папка \Plugins на инсталационния компакт-диск, както и

    на страницата за техническа поддръжка .

    Препоръчително е последни версии на желани за ползване плъгини да бъдат свалени от официалния сайт, където своевременно се добавят нови плъгини и/или се актуализират версиите на вече публикувани плъгини.

    (файловете са компресирани в .zip формат)

  2. Избрани за ползване файлове с плъгини трябва да бъдат разархивирани (в отделна временна папка) и копирани в подпапка \Plugins (по подразбиране [image]) на основното приложение Behold TV:

  3. При правилно изпълнени стъпки 1. и 2. всички избрани и инсталирани плъгини за Behold TV - както за процесинг, така и за деинтерлейсинг се намират в готовност за използване.

    В зависимост от режима на ползване са обособени отделни процеси за добавяне в списък, включване/изключване от употреба (и други действия) в основното приложение на желани за ползване плъгини:

  • В режим на гледане -

  • В режим на запис -

    Забележки:

    N.B. Процесите по

  • включване,

  • активиране,

  • ред/приоритет за изпълнение,

  • настройки и

  • използванео

    на различни плъгини не са подчинени на произволен принцип! Това е основната причина в материала да бъдат обособени отделни раздели за включване и основни действия с плъгини , настройки в различните режими на гледане и запис , и пр.

    При напълно съзнателно поет риск от няколкократно повторение, но в интерес на потребителите това ще бъде [image] напомняно в различни раздели на материала.

    Добавяне/премахване/разместване, активиране/деактивиране и др. настройки на плъгини за запис се извършват отделно (независимо) от настройки на плъгини при гледане.

    Достъп до диалогови прозорци за настройки в различните режими (гледане/запис) се извършва чрез

  • съответните командни редове в контекстното меню на основния видеопрозорец, или от

  • бутони в основния панел.

The contents of Интегриране в програмата

Български интерфейс и Help


Topic: Български интерфейс и Help

Български интерфейс и Help

За улеснение на потребители, които срещат затруднения при използване на руски или английски език, още при първите стъпки на инсталационния процес е възможно да бъде използван български интерфейс за основната програма Behold TV и за Agent BeholdTV.

  • Основна програма Behold TV:

    За потребители, които вече са се запознали с основния материал, елементарните основни стъпки за интегриране на ресурсния файл за български интерфейс и промяна на настройки не би трябвало да предизвикват допълнителни въпроси.

    За читатели, за които това е първоначално запознаване с материали за Beholder, по-нататък има връзки към някои части от основния Help с екранни снимки, от които може да бъде добита представа и за основната програма. Такива са:

    - контекстно меню и основен панел за управление във видеопрозорец за гледане на ТV;

    - секция за [image] настройки ;

    - [image] диалогови прозорци за настройки в режим на запис ;

    - [image] основни диалогови прозорци за настройки на плъгини;

    - настройки в режим [image] ;

    - настройки на [image] ;

    - и други.

    За ползване на български интерфейс в Behold TV и Agent BeholdTV , респ. за основни менюта за настройки на плъгини, (ако това не е направено веднага след инсталиране на универсалния драйвер ) е необходимо да бъде избран желан език -

    Опция «Избор на език» в секция [image] на панел за «Настройки» [image].

  • Плъгини:

    На този етап с пълен превод на български език е основният интерфейс за настройки на плъгини в Behold TV (всички следващи екранни снимки в материала, с изключение на индивидуален интерфейс за настройки на плъгини, както следва):

    § Собственият интерфейс за настройки

    § наименования [image] и

    § кратко текстово информационно описание

    са в процес на превод и интегриране, поради което (за сега) индивидуалните диалогови и информационни прозорци на плъгините са в оригинал - на руски език (независимо дали основният интерфейс е на друг език - български или английски).

Действията за инсталиране на български интерфейс са подробно описани в основния материал. При закупуване на ТВ тунер Beholder от официалния дистрибутор за България безплатно се предоставя диск с помощна информация и ресурсен файл за интерфейс на български език.

Предвижда се по аналогичен начин да се процедира и с допълнителния интерфейс за всички плъгини. За преодоляване на евентуални затруднения с индивидуалния интерфейс и текстово информационно описание на руски език, в този материал са оставени паралелно руски менюта и български превод/транскрипции.

Технология за интегриране на български интерфейс за плъгини в BeholdTV: (under construction)

  • Допълнителна директория, в която се разполагат папки и файлове с помощна информация е

    C:\Program Files\BeholdTV\Bulgaria (файловете могат да бъдат достъпни директно или да бъдат структурирани в съответни подпапки).

  • Ресурсен файл за български интерфейс - Bulgarian.btl се разполага съответно в

    C:\Program Files\BeholdTV\LangRes.

  • Ресурсни файлове за български интерфейс на плъгини -

    (under construction)


Topic: Функции и настройки

Функции и настройки

Описание на основни функции и настройки

The contents of Функции и настройки

Управление
Излъчване в мрежа
Функция TimeShift
Включване и Основни действия с плъгини


Topic: Управление

Управление

Управление на тунера - достъп до плъгини

Управлението на тунера се осъществява посредством:

Контекстни менюта на видеопрозореца и икона на приложението в tray;

«Панел за управление» на Behold TV;

Пулт за дистанционно управление;

„горещи” клавиши („hot keys”) от клавиатурата (командите на всички hot keys са изведени непосредствено в прозореца за настройки на програмата – в секции «Управление» и «Пулт ДУ»);

мишка.

Контекстното меню се извиква с [image] десен клик на мишката в областта на видеопрозореца.

Интерфейсът се променя в зависимост от текущия режим на работа на тунера -

  • Обикновено гледане (TV) – разширено меню;

  • Обикновено гледане (TV) – съкратено меню;

  • Обикновено гледане (DVB-T);

  • Режим «Таймшифт»;

  • Активен «Телетекст».

В зависимост от версията на Behold TV има различия в командните редове на основните прозорци и падащи менюта/подменюта.

Интерфейс-v.5.11:

Описание на командните редове в контекстното меню:

......

Група команди за управление на режими за извеждане на основен видеопрозорец и прозорец на контекстното меню:

......

Достъп до

  • диалогови прозорци за настройки на видеообработка с плъгини или

  • индивидуални настройки на включен(и) плъгин(и)

    в режим на гледане

Достъп до [image] «Панел за запис», респ.

  • диалогови прозорци за настройки на видеообработка с плъгини и

  • мащабиране на кадър

    в режим на запис

......

The contents of Управление

Достъп до прозорци за настройки


Topic: Достъп до прозорци за настройки

Достъп до прозорци за настройки

Достъп до диалогови прозорци за настройки на видеообработка в Behold TV се осъществява чрез:

  1. Контекстното меню ( [image] десен клик с мишка в областта на видеопрозореца) -

    - в зависимост от необходимия режим:

    команден ред [image] в режим на гледане [image] ;

    команден ред [image] в режим на запис [image] .

  2. От основния панел -

    - в зависимост от необходимия режим:

    бутон «Настройки» в режим на гледане [image] ;

    бутон «Панел за запис» в режим на запис [image] .

Достъп до диалогов прозорец за настройки в режим на гледане [image] :

  • от контекстното меню на видеопрозореца

    команден ред

    (директно се извежда [image] диалогов прозорец за настройки - вж. по-долу), или

  • с бутон «Настройки»_през основния прозорец за настройки в Behold TV

    раздел

    бутон

    Забележка: Ако при избор на ред [image] от контекстното меню на видеопрозореца за гледане в списъка на подпрозореца вече има включени плъгини -

    при селекция на друг активен команден ред освен [image] (респ. плъгин за процесинг или за деинтерлейсинг), директно ще се отвори индивидуален прозорец за настройки на съответния плъгин.

Достъп до диалогов прозорец за настройки в режим на запис [image] :

  • от контекстното меню на видеопрозореца

    команден ред [image] , или

  • с бутон «Панел за запис» [image] през основния панел за запис в Behold TV

    секция

    подсекция

    бутони

Диалогови прозорци за настройки [image] :

В зависимост от режима на работа (гледане [image] /запис [image]), по описаните по-горе начини се отварят диалогови прозорци, в които са достъпни настройки и на двата основни вида плъгини - за процесинг и за деинтерлейсинг .

В различните режими диалоговите прозорци имат еднотипен интерфейс за работа с плъгини, което улеснява работата по настройки в същите:

За съответния режим ( [image] гледане/запис [image]) и в съответния подпрозорец (за процесинг/деинтерлейсинг) се извършват както основни действия за

включване на необходим(и) плъгин(и)* за видеопроцесинг

и/или

избор на филтър* за деинтерлейсинг,

така и други важни действия и настройки - вж. раздел « Включване и Основни действия с плъгини »!

Напомняне*: За видеообработка могат да се използват

няколко (всички) плъгини за процесинг,

но само един филтър за деинтерлейсинг.

Подробно описание на посочените диалогови прозорци следват съотнетно за

интерфейс - в раздел [image] _ [image] ;

опции за настройки - в раздел [image] _ [image] _ [image] _ [image] .


Topic: Излъчване в мрежа

Излъчване в мрежа

Излъчване (ретранслиране) на аудио/видео потоци в мрежа

  1. Излъчване в ІР мрежа на видео потоци, обработвани с плъгини.

    Като специфичен случай на видеозапис, при обработка на видеоматериали с плъгини с цел излъчване в мрежа в реално време важат същите особености и настройки, които са посочени в разделите за видеообработка с плъгини при обикновен видеозапис в реално време от тунера [image] или от външни източници [image] .

    Пример за ефектно приложение е следващият screenshot от излъчване в ІР-мрежа на материал, който е обработен с плъгини за получаване на обемен (анаглифен) ефект, маскирано е логото на ТВ-канал и е вградено собствено лого, в горния десен край е включен OSD часовник, а в долната част "тече" "бягаща" информационна лента:

    По-долу са посочени някои по-общи основни моменти от основната програма Behold TV във връзка с излъчване на потоци в мрежа.

  2. Общи положения при излъчване в ІР мрежа в Behold TV

    Излъчване (ретранслиране) на видео/аудио по мрежа е еквивалентно на процес на запис, само че не във файл, а в IP-мрежа. Респективно настройки за ретранслиране в мрежа се осъществяват също от [image] « Панел за запис ».

    За целта в настройките за запис е достатъчно да се зададе направление на поток - «Излъчване в IP-мрежа». (Настройки на формати за запис

    са описани подробно в раздел [image] «Панел за запис»).

    След настройка на всички параметри на избрания кодек, излъчване в мрежа се стартира като обикновен запис ( с натискане на бутон [image] за стартиране / респ. за спиране на излъчване. Видима контролна индикация за излъчване в мрежа са

    промяна на иконката в трея - [image] и

    надпис "NET (време:на:излъчване)" в LCD дисплея на основния панел -


Topic: Функция TimeShift

Функция TimeShift

Функция ТimeShift / Таймшифт

Таймшифт е функция, която по аналогия с пауза при гледане/слушане на обикновени видео/аудио записи позволява временно спиране на възпроизвеждани телевизионни или радио програми, излъчвани в реално време с възможност за последващ преглед от момента на спиране или от произволно място във времевата скала по време на действието на функцията отметка, вкл. до края.

Пауза (freeze) има и при някои "традиционни" ТВ-приемници, както и в STB модели на Beholder. Възможностите на обикновен стоп-кадър обаче са ограничени - възпроизвеждане продължава от момента на преустановяване на това действие, при което съдържанието на видеоматериала през времето на паузата е недостъпно и изгубено във времето, ако не се прави отделен видеозапис. С Таймшифт възможностите на Behold TV са допълнително разширени - на практика с функцията са достъпни всички възможности, които имат (но струват допълнително) отделни устройства като съвременните DVD-плейъри и по-"древните" видеомагнетофони.

При използване на Таймшифт за отложено гледане/слушане (обикновено за по-кратко време, но принципно няма ограничения - зависи от свободното дисково пространство) не е необходимо да се прибягва до "класически" запис, както обикновено се прави за такива цели, респ. да се влагат допълнителни средства за отделни устройства.

Работата на режим Таймшифт може да бъде илюстрирана като аналогия при работа с мултимедийни файлове, но в реално време. По същия начин, както при гледане на такива материали с обикновен видеокасетофон, DVD плейър или на компютър, във всеки един момент гледането може например да бъде спряно на пауза (примерно докато се отговаря на телефонно повикване), след което да бъде върнато от самото начало на временното спиране или до необходим момент и отново да бъде възобновено гледане.

За онагледяване на полезните страни на функцията може да се посочи например гледане на футболен мач в реално време, в който пред гол е имало съмнение за засада - изображението може да бъде върнато до момента на подаване към играча "в засада" и да се разглежда колкото пъти е необходимо, при това кадър по кадър...

  1. Използване на TimeShift за видео потоци, обработвани с плъгини.

    Като специфичен случай на видеозапис в реално време, при използване на функцията съвместно с обработка на видеоматериали с плъгини важат същите

    особености при включване (активиране) (вж. Включване и Основни действия с плъгини [image] Плъгини за Процесинг [image] При запис [image] Видеообработка на кадър [image] Особености в режим Таймшифт ) и

    настройки (вж. Описание на интерфейса [image] Панел за настройки [image] Видео [image] TimeShift ),

    които са посочени в разделите за видеообработка с плъгини при обикновен видеозапис в реално време от ефир или от външни източници през А/V вход.

    По-долу са посочени някои по-общи основни моменти от основната програма Behold TV във връзка с използване на функция Таймшифт.

  2. TimeShift в Behold TV

    В съответствие с посочената аналогия на пауза при гледане/слушане, режимът се включва

    с бутон «Pause» от основния панел за управление, или

    чрез избор на команда [image] от контекстното меню на видеопрозореца.

    В режим Таймшифт се включва запис на аудио/видео във временен файл.

    респ. е необходимо да бъде предвидено достатъчно дисково място за временния файл.

    По време на работа на режима някои функционални прозорци са недостъпни. При избиране на такива прозорци Behold TV напомня за това

    с "балонно" съобщение над иконата в трея.

    Важно! По време на работа в режим Таймшифт програмата Behold TV изключва основния канал на работа с аудиокартата и извежда звук от записвания файл.

    Внимание [image] (Често задаван въпрос):

    Ако по време на Таймшифт се прослушват едновременно два аудиоканала, изместени по време един спрямо друг, това означава, че в настройките в секция «Аудио» на тунера е

    - неправилно избран «Миксер за възпроизвеждане»

    - или «Линия за управление на звук», с които работи тунерът,

    - или тунерът е включен към звуковата карта едновременно с два аудио кабела – вътрешен и външен.

    Препоръки: Да се проверят настройките и да се изключи излишният аудио кабел.

    При запис на временен таймшифт-файл, звук може да се цифровизира както от самия тунер, така и от аудиокартата.

    Във втория случай избор и настройки на аудиокартата се извършват в [image] «Панел за запис» [image] «Настройки за аудио запис».

    Важно! Дори ако има инсталирана само една аудиокарта, задължително е необходимо да се провери дали именно тя е избрана като «Устройство за аудио запис», а не например гласов модем, който по дефиниция също се явява стандартно устройство за звукозапис в компютъра.


Topic: Включване и Основни действия с плъгини

Включване и Основни действия с плъгини

Включване на плъгини за процесинг,

Избор на плъгин за деинтерлейсинг.

Основни действия.

Напомняне: И двата вида плъгини в Behold TV -

  • за процесинг и

  • за деинтерлейсинг

    могат да се използват както в

  • В режим на гледане (Диалогов прозорец за настройки - в « Панел за настройки » [image] ), така и

  • В режим на запис (Диалогов прозорец за настройки - в « Панел за запис » [image] )

Интерфейсът на прозорците за настройки, както и основните действия в същите при различните режими са еднотипни.

След успешно инсталиране в съответната папка на програмата, в зависимост от индивидуалните предпочитания, възможности на системата и в съответствие с режима за работа за който ще се използват плъгини,

Избрани плъгини за процесинг за съответния режим трябва да бъдат включени в подпрозореца на

  • Група «Използвани филтри за процесинг» - Списък с плъгини за видеообработка и/или наслагване на всевъзможни ефекти

    (при първо инсталиране на Behold TV по подразбиране списъкът е празен [image] ).

    В съответния подпрозорец за видеообработка при гледане/запис могат да бъдат [image] добавяни достъпни плъгини

    (вече инсталирани в системната папка

    )

    за всевъзможни ефекти и видеообработка, респ. да бъдат извършвани други действия:

    с поставяне/премахване на отметка в checkbox на съответния ред в прозореца се извършва временно Активиране/ДЕактивиране на наличен(и) в списъка плъгин(и) без да се премахва(т) от същия (т.е. ако се предвижда последващо използване на по-късен етап*);

    премахване* на плъгин(и);

    в зависимост от включените плъгини може да се сменя техния ред в списъка, респ. последователност за изпълнение и приоритет**;

    промяна на зададени по подразбиране настройки в индивидуалния интерфейс на отделните плъгини.

    В долната част на групата се визуализира кратка текстова информация [image] за съответен маркиран плъгин.

Важно!

  • *Всеки наличен в списъка плъгин преминава през инициализация при стартиране на Behold TV, следователно заема ресурси на операционната система (памет), дори когато е изключен от процесинг (респ.. дори ако фигурира в списъка, макар и да не активен - не е поставена или е свалена отметка в [image] "checkbox").

  • **В процеса на работа на програма Behold TV телевизионен кадър се предава последователно на всеки плъгин по веригата. Това има пряко отношение към приоритета на изпълнение на плъгини, който при неправилно задаване на ред за последователност в списъка може да доведе до възможни нежелани ефекти!

    За подробности вж. « Местоположение на плъгини в общия списък ».

  • Обработка на кадър се завършва от плъгин за деинтерлейсинг.

Предвид горните забележки, ако даден плъгин не се използва (често) е по-добре да бъде премахнат от списъка.

Ако се предвижда използване на плъгин за деинтерлейсинг, предпочитан такъв трябва да бъде избран в

  • Група «Използван филтър за деинтерлейсинг »

    (при първо инсталиране на Behold TV по подразбиране филтър не е избран: ).

    Процесите за деинтерлейсинг представляват частен случай на процесинг. Същността на такива процеси се състои в обработка на кадър с цел премахване на интерлейсна (междуредова) структура. Плъгините за деинтерлейс трябва да отчитат ред параметри на видеопотока, които не са задължителни за обичайния процесинг с плъгини, поради което такива плъгини са изнесени в отделна група.

    Избор на достъпен инсталиран плъгин за деинтерлейсинг от "падащ" списък:

    - бутон за отваряне на индивидуален прозорец за допълнителни настройки на избран плъгин за деинтерлейсинг

    (вж. « Настройки за видеообработка на изображение с използване на плъгини »).

Забележка: (Важи и за двете групи - «Използвани филтри за процесинг» и «Използван филтър за деинтерлейсинг »):

1. Ако при избор на ред [image] от контекстното меню на видеопрозореца за гледане в списъка на подпрозореца вече има включени плъгини,

при селекция на друго меню освен «Конфигурация» (респ. плъгин за процесинг или за деинтерлейсинг) директно се отваря индивидуален прозорец за настройки на съответния плъгин.

2. Различните плъгини имат различен индивидуален интерфейс и опции за настройки!

Други настройки:

  • В режим на гледане: Група «Механизъм за удвояване честотата на кадрите» -

    вж. « Interlace / Progressive изображение » и « Настройки ».

Пълно описание на настройки в диалоговите прозорци за настройки при работа с плъгини се намират в съответните раздели за

  • режим на гледане ,

  • режим на запис .

The contents of Включване и Основни действия с плъгини

Плъгини за Процесинг (BPProcessing)
Плъгини за Деинтерлейсинг (BPDеinterlace)
Други
За програмисти


Topic: Плъгини за Процесинг (BPProcessing)

Плъгини за Процесинг (BPProcessing)

Плъгини за Процесинг (BPProcessing)

The contents of Плъгини за Процесинг (BPProcessing)

При гледане
При запис


Topic: При гледане

При гледане

Видео обработка при гледане

В рози раздел по функционален признак са отделени плъгини, с които може

  • Да се скриват или да се направят по-незабележими на екрана всякакви логотипи (лого, емблема) за произволни телевизионни канали;

  • Да се наслагва или вгражда произволно избрано (или собствено) лого върху видеоред при програмен запис във файл, както и при излъчване на видео в мрежа;

  • Да се отделят и съхраняват статични елементи на видеоизображение (логотипи на канали и пр.);

  • N.B. Да се извършват определени действия (да се намали звук, или ако например в същия момент се извършва запис да се включи пауза, да се премине към друг канал и пр.).

    С плъгините от група «Обработка на логотипи и потоци» може да се води ефективна борба с реклами!

The contents of При гледане

1. Настройки и филтрация на изображение
2. Обработка на логотипи и потоци
3. Ефекти и полезни допълнения
4. Информационни и други ПРОЗОРЦИ
5. Мащабиране/пропорции на кадър/видеопрозорец


Topic: 1. Настройки и филтрация на изображение

1. Настройки и филтрация на изображение

Настройки и филтрация на изображение

В този раздел са поместени плъгини, които могат да бъдат използвани за:

обработка и подобряване на изображение (борба с шумове, изкривявания, артефакти и пр.);

извеждане на справочна информация, графики

  • и други.

The contents of 1. Настройки и филтрация на изображение

BPP_AMPPlugin
BPP_AdvDenoise
BPP_MCDenoise
BPP_UVDenoise
BPP_ChromaOffset
BPP_LineView
BPP_Sharpn
BPP_Denoise
BPP_Levels
BPP_Gamma


Topic: BPP_AMPPlugin

BPP_AMPPlugin

е предназначен е за намаляване на внесени изкривявания от антена в условия на многолъчев прием.

Плъгинът може да бъде полезен както при ползване на индивидуални или колективни ефирни антени, така и при приемане на кабелна ТВ.

Изкривявания, които възникват при многолъчев прием на

  • ефирна ТВ по правило са следствие от недостатъчна избирателност на приемащата телевизионна антена, която освен основния сигнал приема и отразени сигнали от други обекти. Поради разликата в разстоянията между различните отразяващи източници и приемащата антена, отразените лъчи попадат в същата с известно закъснение по време, като при това се сумират с основния сигнал. На екрана на телевизора/монитора това изглежда като раздвояване и разтрояване на изображение. В зависимост от ширината на диаграмата за насоченост на антената, количеството, размера, структурата и разположението на обектите (жилищни фасади, покриви и др.), които имат способност да отразяват сигнали, картината с изкривявания може да бъде различна, но достатъчно постоянна по време.

  • В кабелните мрежи подобен род изкривявания могат да възникват при преотразяване на сигнали поради несъгласуваност на отделни участъци от кабелните магистрали; при наличие на повече устройства; при ползване на некачествени разклонители (сплитери).

В зависимост от това, дали отразен сигнал идва във фаза или в противофаза, той се наслагва или изважда от основния сигнал, с което усилва или отслабва яркостта на основното изображение. На екрана това изглежда като контури с повишена или понижена яркост, дори до негатив.

При използване на BPP_AMPPlugin се моделира обратен процес - отслабване, изместване (закъснение по време) и изваждане или събиране на получената картина от основното изображение.

Отразените лъчи по правило са няколко типа. В зависимост от производителността на компютъра c помощта на плъгина могат да бъдат отслабени до осем отразени сигнала.

Тъй като изкривяванията се проявяват различно при отделните канали, е предвидена индивидуална група за настройки за всеки канал. Нискочестотните VHS- и S-VHS- входове не правят изключение.

Настройки:

Започва се с избор на подходящ кадър, в който изкривяванията са най-забележими. За това е необходимо да се изчака подходяща сцена и да се включи стоп-кадър в прозореца за настройки на плъгина.

Плъгинът обработва картината по стъпки. С всяка стъпка се отслабва по един лъч (отразен сигнал) и за всяка стъпка е необходимо да се настроят собствени стойности за изместване (задръжка) и ниво (отслабване) на сигнал. Процесът за подбор на тези стойности е достатъчно интуитивен:

  • Най-напред е необходимо да бъде избран най-силен отразен сигнал (най-ярък контур) и на първо време да се направи опит да бъде потиснат. За целта в прозорец «Уровень»~«Ниво» на избраната и отметната стъпка трябва да се зададат някакви положителни или отрицателни стойности (различни от нула) и да се измести получената картина с няколко пиксела странично.

  • След тази процедура става ясно дали нивото на коригиращия сигнал трябва да бъде положително или отрицателно. По-нататък трябва да се съвместят двата контура и окончателно да се подбере такова ниво, при което те да се компенсират един с друг. След тази стъпка може да се премине към потискане на друг(и) лъч(и).

За да бъде добита ясна представа как работи плъгинът, може принудително да бъде симулиран многолъчев прием. Това се прави по следния начин:

  1. Избира се произволен канал.

  2. Отваря се прозореца за настройки на плъгина и се включва обработка на кадър.

  3. Първа стъпка – симулира се многолъчев прием с установяване на ниво –30% и изместване на картината с 5% надясно. За всеки елемент от изображението на екрана ще се появи собствен негативен двойник. Точно това представлява следствието от многолъчев прием.

  4. Настройва се втората стъпка на плъгина за да се компенсират тези изкривявания. Естествено се предполага, че компенсиращо трябва да бъде изображение с обратна полярност, т.е. с ниво +30% и изместено със същата стойност.

  5. След тези манипулации следите от многолъчев прием остават слабо видни на екран и може да се компенсират по аналогичен начин.

При корекция на изкривявания нивото на цифровизиран сигнал може да излезе извън границите на динамичния диапазон, което визуално ще изглежда като преосветяване или пропадане на тъмни участъци от изображението. За да не бъде допуснато това, плъгинът позволява да бъдат направени корекции на яркост и контраст на изходния кадър преди към него да бъдат приложени настройките на филтъра. Настройките на плъгина дублират настройките за яркост и контраст на самия софтуер, и ако те бъдат изключени а се използват настройките на основната програма, могат да бъдат спестени 3~4% от ресурсите на процесора.

В режим на стоп-кадър или на видео в реално време, чрез включване или изключване на обработка (на плъгина) може да се контролират процесите на настройки на плъгина.

При правилно настроен плъгин се получават примерно следните резултати:

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.03 | Първа версия на плъгина |  |
2.00 | Величината на преместване на изображението се задава в проценти спрямо ширината на кадъра, което позволява отказ от импорт на настройки в други разрешения; Добавено е автоматично съхранение на настройки отделно за всеки потребителски профил. | 26.04.2007 |
2.01 | Реализирано е съхранение на настройки в Windows 7 | 14.09.2009 | BPP_AMPPlugin_v201.zip (19 kb)


Topic: BPP_AdvDenoise

BPP_AdvDenoise

- Плъгинът е предназначен за независимо потискане на шум

в

  • Y, U, V или

  • R, G, B канали на изображение.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 |  |  |
1.02 |  | 16.09.2009 | BPP_AdvDenoise_v102.zip (17 kb)


Topic: BPP_MCDenoise

BPP_MCDenoise

- Motion Compensated Denoise

представлява комбинация от

  • поканален темпорален метод за потискане на шум, използван по-рано в плъгин BPP_AdvDenoise , и

  • детектор за движение, позволяващ да се минимизират изкривявания, които се внасят при темпорално шумопотискане.

& За разлика от

  • пространствено шумопотискане, при което шум се оценява като отклонение на стойностите на пикселите от такива най-близки съседни в пределите на един кадър, при

  • темпорално шумопотискане се оперира със стойности на пиксели в последователност от кадри (във времето).

    Благодарение на това, при неподвижни статични сцени с темпорално шумопотискане се гарантира съхраняване на детайли в изображение и ясни граници на обекти на екран.

    Въпреки това, при наличие на динамика на всякакви „полезни” изменения в кадър (нивото на които е под зададен в плъгина праг на шум) неизбежно се определя като шум, с който трябва да се води борба, което води до размазване на текстури, появяване на сенки и контури след подвижни обекти.

    Анализът на изменения в кадър позволява при темпорално шумопотискане да се взимат под внимание всякакви движения на обекти по екрана и да се взимат правилни решения по отношение на сложни фрагменти в изображение.

Следващите скрийншотове илюстрират работата на плъгин BPP_MCDenoise с включен (горната половина на кадъра) и изключен (долната половина на кадъра) механизъм за компенсация на движение (MC).

(За по-добро визуализиране на ефекта величината на шумов праг в плъгина е изкуствено завишена до 100):

Като допълнителен бонус при използване на метод за компенсация на движение се явява възможност за непосредствено изчисляване на отношение сигнал/шум (SNR) по целия кадър, което позволява автоматично да се поддържа оптимална величина на праг на нивото на шум в плъгина. Въпреки това, при сложни, интензивно сменящи се сцени (каквито отчасти също така могат да бъдат възприети като шум), прагът на шум нараства автоматично, което може да доведе до появяване на "блокови" артефакти (както при MPEG-компресия). Във връзка с това се препоръчва да се изключва автоматична донастройка (Auto) веднага след задаване на оптимален праг на шум.

Ако се изключи механизъм за компенсация на движение, работата на плъгина става аналогична на споменатия по-горе BPP_AdvDenoise. При това менютата за изчисляване на отношение сигнал/шум и автоматичното регулиране ще са неактивни.

Плъгинът работи с изображение, което е представено във формат YUV -

  • яркостна съставляваща (Y) и

  • две цветоразликови съставляващи (UV).

Яркостната компонента на телевизионен сигнал е носител на най-голям обем от информация за изображение и всякакви шумове и изкривявания в канал Y са най-забележими. За канал Y не се препоръчва да се завишава праг на шум спрямо автоматично зададената стойност. Това няма да подобри качеството на изображение, я от друга страна би могло да доведе до появяване на артефакти.

Цветоразликовите компоненти на телевизионeн сигнал отговарят за оцветяването на изображение, поради което изкривявания, които възникват в каналите за цветност U/V не са така забележими. При относително ниски стойности на праг на шум, компенсация на движение за такива канали може да бъде изключено, с което могат да се спестят и ресурси на централния процесор.

  • За канал Y прагът на шум, при който компенсация на движение може да бъде пренебрегнат съставлява около 10~5 пункта, а

  • за канали U/V – 30~40 пункта.

Режим Demo, който може да бъде активиран по време на работа (от менюто за настройки на плъгина) позволява да се оцени ефекта при използване на плъгина. При това екранът се разделя на две хоризонтални части, като горната половина на кадър е обработена с плъгина, а долната е оставена без изменения:

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина. | 17.03.2009 |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 16.09.2009 | BPP_MCDenoise_v101.zip (24 kb)


Topic: BPP_UVDenoise

BPP_UVDenoise

- Плъгинът e предназначен за премахване на импулсни смущения, които възникват в UV-канали за цветност на телевизионно изображение.

На скрийншотите са илюстрирани типични примери за смущения от подобен род. Горната половина на кадъра е обработена с плъгина, долната е оставена без изменения:

Индивидуален прозорец за настройки:

  • Група «Канал» - Информационен прозорец с наименование на текущ канал и опции за

    «включване / изключване»,

    «Размер фильтрующего окна»~«Размер на филтриращия прозорец.

  • «Индивидуальные настройки каналов»~«Индивидуални настройки за всеки канал».

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина. | 01.09.2008 |
1.01 |  | 16.09.2009 | BPP_UVDenoise_v101.zip (16 kb)


Topic: BPP_ChromaOffset

BPP_ChromaOffset

- Плъгинът коригира положението на U- и V- компоненти на телевизионно изображение спрямо Y (яркост). Изместването на U- и V- компоненти позволява да се отстранят незначително изоставане или изпреварване на «цветове» в елементите на изображение, каквото може да се забелязва при някои телевизионни канали.

Индивидуален прозорец за настройки:

  • «Смещение»~«Изместване».

  • «Индивидуальные настройки каналов»~«Индивидуални настройки за всеки канал».

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 |  | 15.01.2007 |
1.01 |  | 15.09.2009 | BPP_ChromaOffset_v101.zip (17 kb)


Topic: BPP_LineView

BPP_LineView

- (доп., v.5.17) Измерване на параметри на произволен видим ред на телевизионен кадър. Плъгинът позволява измерване на съотношение сигнал/шум във всеки участък от ТВ-ред, както и да се прегледа спектър и нива на разпределения за всяка отделно взета RGB/YUV компонента на телевизионен сигнал.

Извеждане на диаграми с параметри на телевизионен кадър. Позволява преглед на спектър и ниво на разпределение за всеки отделeн компонент на телевизионния сигнал.

Включване на плъгина в действие:

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.02 |  |  |
1.04 |  | 14.09.2009 | BPP_LineView_v104.zip (30 kb)


Topic: BPP_Sharpn

BPP_Sharpn

- Увеличаване на острота (Sharp~ness англ. [ʃa:p] остър, изострен, ясен, ясно очертан/определен, ярък...) за всеки (избран) канал.

Индивидуален прозорец за настройки:

  • «Четкость»~«Острота»

  • «Запоминать настройки для каждого канала»~«Запомняне на настройки за всеки отделен канал»

Хронология:

Версия | Описание |  | Download
 |  | 06.05.2006 | BPP_Sharpn_v120.zip (4 kb)


Topic: BPP_Denoise

BPP_Denoise

- Малък плъгин за регулиране ниво на шум

Индивидуален прозорец за настройки:

  • «Глубина обработки»~«Дълбочина на обработка»

  • «Запоминать настройки для каждого канала»~«Запомняне на настройки за всеки отделен канал»

Хронология:

Версия | Описание |  | Download
1.20 |  | 06.05.2006 | BPP_Denoise_v120.zip (4 kb)


Topic: BPP_Levels

BPP_Levels

- Плъгин, с който се изобразяват нормирани диаграми за разпределения на нивата на Y, R, G и B компоненти на видеоизображение (бял, червен, зелен и син цвят).

Плъгинът работи във формати YUY2 и RGB24 и позволява обективно да се оценят, контролират и регулират такива параметри изображение, като

яркост,

§ ниво на черното,

§ ниво на бялото и

контраст

в режими на

  • гледане или на

  • запис

За потребители, които са работили с графични редактори като PhotoShop най-вероятно не е необходимо да се обяснява смисълът на показаните диаграми.

§ По хоризонтал на диаграмата е разположена скала за нивата на Y, R, G и B сигналите. Всеки компонент на цвета на всеки пиксел на изображение може да приема стойност от 0 до 255. При това

§ по вертикал се отмерва относително количество точки за всяка от 256 стойности на нивото.

Пример как изглежда диаграма за разпределение на нивото на реална картина:

Следващият скрийншот е тестова таблица от генератор. От диаграмата е видно, че количеството на тъмни точки е приблизително равно на количеството на светли (черни и бели полета). Въпреки това в кадъра няма нито истински бял (ниво «255»), нито истински черен цвят (ниво «0»):

В този случай с регулировки за яркост и контраст динамичният диапазон на сигнала може да се разшири, като се направи черното по-черно, а бялото – по-бяло:

Плъгинът носи чисто информационно натоварване. Всички регулировки на параметри на изображение се изпълняват от допълнителния панел за управление на приложението. Плъгинът не изразходва системни ресурси при неактивен диалогов прозорец, но достатъчно силно натоварва процесора при подготовка и изобразяване на графики, поради което отваряне на прозорец на плъгина по време на процес на запис не се препоръчва. Това води до допълнително натоварване на процесора, което може да предизвика пропадане на кадри.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 |  | 03.06.2005 | BPP_Levels_v100.zip (10 kb)


Topic: BPP_Gamma

BPP_Gamma

- Плъгинът може да се използва за фина настройка на гами независимо от настройките на монитора, което в определени случаи е много полезно.

BPP_Gamma позволява да се регулира гама индивидуално за всеки RGB канал на изображение и индивидуално за произволен TV-канал. На пръв поглед може да изглежда, че регулиране на гама работи аналогично на донастройка на яркост на изображение, но това не е съвсем така. От скрийншота се вижда, че при подадени от генератор изпитателни сигнали с градиентно запълване по три RGB канала характеристиката на АЦП на тунера на практика е линейна, което се доказва от правата на графиката за разпределение на яркост по оста Х.

Въпреки това може да изглежда, че в изображението все пак преобладават тъмни тонове. На практика такива тонове действително понякога може да има при излъчване на някои (особено при стари) филми. Инстинктивна реакция при това е желание да се увеличи яркостта на изображението. Това може да се направи и от стандартните настройки на тунера:

Картината действително става по-ярка и тъмните тонове са по-малко, но от изображението изчезва черният цвят, а най-лошото е, че ярките полутонове се насищат, което в реален кадър ще доведе до преосветяване и загуба на детайлизация на осветени участъци в изображението.

За да не бъде допуснато това, съществува донастройка на още един параметър на изображение – гама (Gamma).

При корекция на гама черните участъци на изображението остават черни, светлите – светли, а междинните стойности на компонентите на цветовете се изменят в логаритмична зависимост.

Точно в такива случаи BPP_Gamma позволява да се настрои гама отделно за всеки от RGB-канали на изображение, както и индивидуално за който и да е TV-канал.

Независимо от това, че гама се донастройва на базата на стойности RGB, плъгинът работи не само във формат RGB24, но и във формат YUY2. Все пак това изисква допълнителни изчислителни ресурси на процесора:

§ Корекция на гама във формат YUY2 заема средно 20% процесорно време (за кадър с размер 768х576). За сравнение -

§ при формат RGB24 допълнителното натоварване на CPU съставлява само 4~5%.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Добавено е автоматично съхранение на настройки отделно за всеки потребителски профил. | 22.07.2005 | BPP_Gamma_v102.zip (18 kb)


Topic: 2. Обработка на логотипи и потоци

2. Обработка на логотипи и потоци

Настройки и филтрация на изображение

В този раздел са поместени плъгини, които могат да бъдат използвани за:

  • премахване (маскиране) на лого;

  • включване на собствено изображение като лого;

  • средства за борба с реклами

  • и други.

The contents of 2. Обработка на логотипи и потоци

BPP_LogoKiller
BPP_MyLogo
BPP_LogoExtractor
BPP_LogoDetector


Topic: BPP_LogoKiller

BPP_LogoKiller

- Плъгинът позволява да се скрие или да се направи по-незабележим на екрана всякакъв логотип (лого), в произволен телевизионен канал.

BPP_LogoKiller е особено полезен при запис от ефир, с което се придава на записа индивидуален и по-професионален вид

Плъгинът ретушира отделена с помощта на маска област от екрана, като я запълва с цветве на пиксели, взети от границите на маската. По подразбиране маската има правоъгълна форма с променливи размери от 4х4 пиксела до размер на цял кадър.

Област, която се заема логотип може да се ограничи по-прецизно, като се зареди т.н. „маска на логотип”. Маската трябва да се съхранява в .BMP файл и сама по себе си представлява силует на логотип, запълнен с еднороден цвят. В плъгина този цвят се избира като цвят на маската. Такава маска може да се направи например с помощта на плъгин BPP_LogoExtractor .

BPP_LogoKiller позволява да се използват като маски шаблони на логотипи, създадени за друг плъгин – BPP_LogoDetector . В шаблоните за детектор на логотипи с прозрачен цвят се запълва всичко освен логотипа, докато за BPP_LogoKiller е необходимо обратното – да се запълни само логотипът.

Настройки:

  • Група за «Обработка на маски, фон, граници и прозрачност»:

    «Цвет маски»~«Цвят на маска» - избор на цвят ца маска

    «Инверсия маски»~«Инвертиране на маска» позволява да се извърши тази процедура лесно, като не се прибягва до обработка с помощта на други графични редактори.

    Тъй като обикновено не може да се изготви маска, която да закрива напълно целия логотип с точност до пиксел, границите на налична маска могат изкуствено да се разтегнат по хоризонтал и вертикал, като се използват бутоните за изменение на размери на правоъгълната маска:

    С настройки «Показать маску»~«Показване на маска» и «Прозрачность» маската се прави видима и се задава степен на прозрачност на същата за удобство при настройка на плъгина.

    При затваряне на диалоговия прозорец за настройки на плъгина маската се скрива автоматично.

    Настройки «Размытие фона»~«Размиване на фон» и «Размытие границ»~«Размиване на граници» позволяват допълнително да се изглади резултатът от работата на плъгина, като се направят границите и фон на ретуш по-слабо контрастни.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина | 18.09.2007 |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 15.09.2009 | BPP_LogoKiller_v101.zip (51 kb)


Topic: BPP_MyLogo

BPP_MyLogo

- Предназначен е за наслагване, подмяна или вграждане на произволно избрано (или собствено) лого върху видеоред при програмен запис във файл или видео излъчване в мрежа, като предварително се маскира логотип на ТВ-канал с BPP_LogoKiller .

Логотип може да бъде с произволен размер и да се разполага във всяка част на екрана.

Плъгинът поддържа качване на графични изображения във формати BMP, JPG, GIF, EMF, WMF, TIFF, PNG, ICO като логотипи, в т.ч. и с прозрачен фон.

(За ОС Win98/ME/2000 е достъпно качване на логотипи само във формат BMP)

Избрано лого може да се избира както индивидуален логотип както за всеки отделен канал («Настройка по каналам»), така и да се зададе еднакво лого за всички канали.

  • BPP_MyLogo поддържа вграждане на анимирани логотипи във формат GIF, включително върху прозрачен фон.

  • При вграждане на статичен логотип е по-добре да се използва файл във формат PNG. Този формат позволява да се съхраняват изображения от алфа-канал. За разлика от формати GIF и ICO, при които може да се избере само един цвят, който при изрисуване на логотип ще се счита напълно прозрачен, алфа-каналът позволява да се зададе степен на прозрачност индивидуално за всеки пиксел.

    С регулируема настройка «Прозрачность» се задава степен на прозрачност на логотип като цяло, в допълнение към това, което може да бъде указано в графичния файл.

    Ако във файлове GIF и ICO не е указан прозрачен цвят, както и ако картината например е във формат BMP и е необходимо да се направят някакви нейни участъци невидими, прозрачен цвят може да се зададе непосредствено в плъгина. За това е необходимо да се включи съответната опция

    «Прозрачный цвет»~«Прозрачен цвят».

    Прозрачен цвят може да се зададе както явно, така и автоматично, като се избере в качество на прозрачен цвят левият горен пиксел на картината.

Логотип може да има произволни размери и да бъде мащабиран по желание от нула до размер на пълен екран. Въпреки това, не си струва увлечението да се зареждат като логотипи фотографии или графики с голям размер, т.к. при превключване на канали зареждането на големи файлове (напр. във формат .jpg) може да отнеме продължително време. При подготовка на логотип е желателно да се подбира неговия размер спрямо максималния размер на кадър – 768х576.

При изменение на формат на поток (размер на кадър при запис), логотипът съхранява своите размери спрямо широчината и височината на видеопрозореца въз основа на разчет 4:3 на неговия аспект.

«Показать логотип»~«Показване на логотип» - Ако не се използва за някой канал, логотип може да не се извежда на екрана или напълно да бъде изключено зареждане на логотип за съответния канал.

Забележка:

За едновременно извеждане на два и повече логотипа на екрана е необходимо в директория ...\Plugins да се създадат няколко копия на плъгина BPP_MyLogo, като се переименува изходния файл BPP_MyLogo.dll например по следния начин:

BPP_MyLogo_1.dll

BPP_MyLogo_2.dll

BPP_MyLogo_3.dll

…………………….

Впоследствие всяко копие на плъгина може да бъде избирано в списъка с плъгини за гледане или запис и отделно да се настрои за съответно лого.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина |  |
1.01 | Отстранена е зависимост при позициониране на логотипи при едновременно отворени прозорци за настройки на няколко екземпляра на плъгина. |  |
1.02 | Реализирано е съхранение на настройки в Windows 7 | 15.09.2009 | BPP_MyLogo_v102.zip (43 kb)


Topic: BPP_LogoExtractor

BPP_LogoExtractor

- Плъгинът е предназначен за отделяне и съхранение на статични елементи на видеоизображение, логотипи на канали и пр.

Получени логотипи в последствие могат да се използват съвместно с плъгин BPP_LogoDetector .

Отделяне на логотип се свежда до оцветяване на участъци от изображение, които не се отнасят (или обратно ~ отнасящи се) към логотипа по някакъв еднороден цвят, който по-нататък може да бъде избран в качество на прозрачен цвят при извеждане на полученото изображение на екран.

За отделяне на логотип е необходимо да се отвори прозорецът за настройки на плъгина. На екрана се появява сива рамка, размерът и положението на която е необходимо да се съвмести с логотипа и да се натисне «Старт».

Участъци от изображението, които не се отнасят към логотипа ще се оцветят автоматично с избрания ключов (прозрачен) цвят. Ако резултатите от работата на плъгина по някаква причина не са удовлетворителни, съдържанието на отделената зона може да се изчисти и да се започне процес на експониране на логотип от началото.

Съхраняване на получения резултат става възможно само след спиране на процеса на експониране.

Принципът на работа на плъгина се основава на това, че диапазонът на изменение на яркост на изображението на фона на логотип никога не превишава строго определена величина, зависеща само от степента на прозрачност на самия логотип и от нивото на шумове в кадър. В настройките на плъгина тази величина се задава с настройка

«Порог»~«Праг». Ако вътре в отделената зона от някаква точка на екрана диапазонът на изменение на яркост превиши зададения праг, то точката ще се оцвети в избрания прозрачен цвят. За напълно непрозрачни логотипи величината на прага се определя само от нивото на шумове в изображение.

6 Времето за експониране на логотип зависи от интензивността на изменение на яркостта в отделената зона и зададения праг. Колкото е по-малко прозрачен даден логотип, толкова по-нисък праг може да се зададе, съответно по-малко да се чака докато измененията по границите на логотипа превишат зададената величина.

Минимално и достатъчно условие за нормална работа на плъгина е наличие на динамика на изменения в кадъра по границите на логотип. Понякога обаче възниква ситуация, при която логотипът е разположен върху напълно неподвижен фон, например в черно поле при широкоекранен филм. В този случай единствен възможен начин остава отделяне на логотип по яркост спрямо нивото на черното. Настройка

«Уровень чёрного»~«Ниво на черното» дава възможност принудително да се запълнят с прозрачен цвят всички елементи на изображение, яркостта на които е под зададената величина.

  • Група «Логотип»:

    Разположение~«Позиция» и размер на логотип се задават в проценти от габаритите на екрана, т.е. не зависят от параметрите на видеопоток.

Логотипи се съхраняват във формат .BMP. Размерът на съхраняемия bitmap се привежда към зададена в проценти стойност по хоризонтал и вертикал спрямо максималния размер на потока – 768х576 (квадратен пиксел).

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина | 26.06.2007 |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 15.09.2009 | BPP_LogoExtractor_v101.zip (23 kb)


Topic: BPP_LogoDetector

BPP_LogoDetector

- Един от най-полезните плъгини при запис!

& Плъгинът сравнява фрагмент от изображението с шаблон на (записан с помощта на BPP_LogoExtractor ) логотип и при изчезване на логотип от екрана позволява да се извършат определени действия (да се намали звук, или ако например в същия момент се извършва запис, да се включи пауза).

По този начин плъгинът може да се използва за ефективна борба с реклами, тъй като по принцип при рекламни заставки най-често логотип на ТВ-канал не се излъчва!

В резултат може да се спести до 30% място при запис на диск, като се изрежат реклами, а обикновеното гледане да се направи значително по-комфортно.

@ Шаблон за логотип трябва да бъде подготвен предварително с външен графичен редактор от предварително направен скрийншот от съответния канал с разрешение 768х576. Изготвен от такъв скрийншот шаблон коректно и автоматично ще се мащабира във всякаква поддържана от тунера разделителна способност.

Настройки:

  • Група «Цвет маски»~«Цвят за маска»: За повишаване на точността на работа на детектора, върху шаблона на логотип се наслагва маска. За целта елементи на изображението, които не влизат в логотипа или представляват негови подвижни части, е необходимо да се запълнят с какъвто и да е еднороден цвят. След избор на логотип и съответен цвят на маска, детекторът ще работи само с незапълнената с този цвят област на шаблона.

    «Левый верхний пиксел»~«Ляв горен пиксел» - Цвят за маска може да се избира автоматично по цвета на левия горен пиксел на заредения шаблон.

  • Ако детекторът е активиран и в настройките е активирана опция [image] «Показать логотип»~«Показване на логотип» с [image] «Прозрачност», различна от нула, при избор на файл с шаблон на логотип неговото изображение ще се появи във видеопрозореца, след което със съответните бутони трябва да се съвмести логотипът с неговото изображение на екрана.

    Ако цвят за маска е избран неправилно, логотипът ще изглежда на екрана като правоъгълник със зададената прозрачност.

    Опция «Показване на логотип» е необходима не само за контрол на положението на шаблона на логотипа при настройка на детектора. Като се настрои детекторът и се остави логотип на екрана, може да се проследи изменението на положението на логотипа на канала по време, като периодично се коригира положението на шаблона.

    Опция «Прозрачност» е необходима изключително за удобство при настройки на положението на шаблона на логотипа.

Детекторът на плъгина има само четири потребителски настройки, които помагат да вземе правилно решение по отношение присъствие на логотип на екрана:

  1. «Допуск на смещение логотипа»~«Допуск за изместване на логотип»

    Логотипите на каналите периодично, от време на време могат да променят своето местоположение на екрана, като се изместват наляво и надясно от нормалното положение с няколко пиксела. Тази настройка позволява детекторът да бъде направен "по-груб" по такъв начин, че неговите показания да не зависят така силно от положението на логотип в кадър. От друга страна обаче, колкото е по-голяма величината на допуск за изместване, толкова по-висока е вероятността от погрешно намиране на логотип, когато такъв няма в кадъра.

  2. «Скорость реакции на пропадание логотипа»~«Скорост на реакция при изчезване на логотип»

    Настройка, която осигурява известна инерция за взимане на решение при изчезване на логотип от екрана. Чувствителността на детектора е крайно висока и твърде малко зависи от яркостта на самия логотип и настройките за яркост и контраст за конкретния канал като цяло. Затова в болшинството случаи стойностите на тази настройка могат да бъдат зададени равни на 5~10, което ще позволи на детектора практически веднага да реагира при изчезване на логотип.

  3. «Скорость реакции на появление логотипа»~«Скорост на реакция при появяване на логотип»

    Настройка, която действа обратно - внася инертност при оценка в момента на появяване на логотип в кадър. Тъй като вероятността за лъжливо намиране на несъществуващ логотип е по-висока, отколкото вероятността за пропускане на съществуващ логотип, то и скоростта за реакция при появяване на логотип трябва да е по-ниска. Нормална стойност в болшинството случаи е 2~3.

  4. «Уровень детектирования»~«Ниво на детекция»

    Ниво, под което детекторът ще счита, че логотип отсъства от кадъра. Съответстващият на настройката индикатор показва текущото състояние на детектора. Скоростта, с която се променя състоянието на детектора се задава от първите два параметъра на настройката.

  • «Уровень соответствия логотипов»~«Ниво на съответствие на логотипи»

    Настройка, която е въведена за да помогне на детектора по-точно да се самоопредели от момента на появяване на логотип, ако такъв отсъства. Съответстващият на настройката индикатор показва абсолютното ниво на съответствие на шаблона на логотип и фрагмент на изображение на екрана. Когато нивото на съответствие на логотипи е под зададеното, детекторът внася поправка в скоростта на реакция за появяване на логотип («Скорост на реакция при появяване на логотип»), с което се намалява вероятността от грешки за лъжливо разпознаване на несъществуващ логотип.

    За почти прозрачни логотипи тази настройка практически е безполезна, т.к. разликата между шаблон и реален логотип може да се променя в твърде широки граници. В този случай нивото на съответствие може да се зададе равно на нула. Това няма да повлияе особено върху работата на детектора. За непрозрачни логотипи нивото на съответствие трябва да бъде зададено по такъв начин, че при наличие на логотип в кадъра индикаторът никога да не спада под червеното ниво.

    По нататък в падащите списъци

    «Просмотр»~«Гледане» и

    «Запись»

    плъгинът позволява да се избере действие, което трябва да се изпълнява при появяване или изчезване на логотип от екрана, съответно в режими на гледане и запис.

  • В режим на гледане е достъпно намаляване на силата на звук с определен процент

  • в режим на запис – включване на пауза при наличие или отсъствие на логотип

    Не трябва да се забравя, че за да работи плъгинът в режим на запис, същият трябва допълнително да бъде въведен в списъка с плъгини за обработка на изображения при видеозахват.

    Опция «Выводить сообщение»~«Извеждане на съобщение» - По време на отсъствие на логотип в кадър, на екран може да се извежда съответно съобщение. Текст, фон, цвят на текст и на фон, както и прозрачност за съобщението се задават индивидуално за всеки канал.

    Опция «Показывать фон»~«Показване на фон» - Ако изцяло се премахне текст за съобщение и се включи запълване с фон, то при отсъствие на логотип екранът просто ще се запълва с цвета на фона, което е удобно да се използва например за намаляване на яркост на изображение.

    Опция «Тест» - При включване на този режим отсъствие на логотип може да се емулира без да се чака реклама. В този случай фрагмент от изображението от центъра на екрана ще се копира на мястото на логотипа и ще го закрие.

P.S. Плъгин BPP_LogoDetector не трябва да се разглежда като панацея в борбата с рекламите. Точно за това плъгинът носи скромното име "Детектор на логотипи", какъвто се явява по същество.

Все пак, на този етап това е най-надеждният и действен известен метод поне някак си да се премахне част от ненужната информация във видеопоток. Всички останали методи (като детектиране на отбивки, заставки, звукови фрагменти и нива) или изискват много сериозни изчислителни ресурси, или просто не са достатъчно надеждни, поради което могат да изпълняват в това занимание само спомагателна роля.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.10 | Добавено е извеждане на потребителско съобщение на екран при изчезване на логотип; Добавена е настройка за допуск на изместване на логотип в кадъра; Реализирано е управление на силата на избраната в приложението линия (само при работа с версия на програмата 4.10 и по-висока); Направено е възстановяване на силата при изход от приложението по време на реклама; Добавена е поддръжка на формат на потока RGB24 в режим на гледане и запис. |  |
1.20 | В прозореца за настройки на детектора е добавена индикация за име на текущия канал; Добавено е изключване на фон на извеждано на екран съобщение; Добавена е опция, позволяваща да се записват само видеофрагменти без логотип (събиране на статистика за рекламите). |  |
1.21 | Добавено е автоматично съхраняване на настройки отделно за всеки потребителски профил. | 24.12.2007 |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 14.09.2009 | BPP_LogoDetector_v122.zip (39 kb)


Topic: 3. Ефекти и полезни допълнения

3. Ефекти и полезни допълнения

Ефекти и полезни допълнения

В този раздел са поместени плъгини, които могат да бъдат използвани за:

  • преработване на "плоско" изображение в 3D "обемно" с анаглифна обработка при гледане в реално време и при запис (от ефир/от външни източници);

  • задаване на рамки около кадър (прозорец) и запълване с предпочитан цвят;

  • задаване на различни действия при отсъствие (пропадане) на сигнал;

  • ефекти при преход между канали;

  • инвертиране на цветове (вкл. в черно-бяло изображение) и на изображение (огледално, обърнато и пр.),

  • изучаване на чужд език,

  • и други.

The contents of 3. Ефекти и полезни допълнения

BPP_Border
BPP_Blank
BPP_CHSwitchingEffects
BPP_Inverse
BPP_BW
BPP_Anaglyph
BPP_25Frame
BPP_Placebo


Topic: BPP_Border

BPP_Border

«Заливка бордюров»~«Запълване на граници»:

Запълване на рамка по границите на кадър с еднороден цвят. Полезно е например при гледане на канали, при които по граница(и) на кадър/видеопрозорец има смущения (шум).

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.20 |  | 06.05.2006 | BPP_Border_v120.zip (5 kb)


Topic: BPP_Blank

BPP_Blank

- Настроика и изпълнение на различни действия при отсъствие на ТВ-сигнал.

Възможни действия:

  • - запълване на екран с избран цвят,

  • - изключване/възстановяване на звук,

  • превключване към следващ канал,

  • свиване на приложението в tray,

  • изход от програмата,

  • изключване на компютъра,

  • преход в „чакащ”/„спящ” режими на Windows.

    ~

Хронология:

Версия | Описание |  | Download
1.40 |  | 24.12.2007 | BPP_Blank_v14.zip (9 kb)


Topic: BPP_CHSwitchingEffects

BPP_CHSwitchingEffects

- Позволява да се визуализира eфектно превключване на телевизионни канали и видеовходове на тунера като плавен преход (примерно като картини в MS Power Point ).

Препоръки: За да бъде направена работата на плъгина по-ефектна се препоръчва в раздел [image] на основната програма Behold TV за режим на възстановяване на вертикална синхронизация да се избере "Бърз tracking" или "Мигновен tracking". В специфичните настройки за режим "Бърз tracking" е необходимо принудително да се зададе тип телевизионна система (PAL/SECAM) за всеки канал в списъка.

@ Настройки:

«Эффект»~«Ефект» - Избор на определен ефект, режим на последователно редуване «Последовательный перебор» на ефекти или по случаен принцип «Случайный выбор эффекта» от "падащо" меню:

«Длительность эффекта»~«Продължителност на ефект» - Избор (чрез преместване на линейния плъзгач) на продължителност на избран ефект.

«Задержка эффекта»~«Закъснение на ефект»

«Предпросмотр»~«Предварителен преглед»~«Preview»

«Использовать Fade-эффект при старте приложения»~«Използване на Fade-ефект при стартиране на приложението»

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание | Дата | Download
1.05 |  | 14.09.2009 | BPP_CHSwitchingEffects_v105.zip (17 kb)


Topic: BPP_Inverse

BPP_Inverse

- Преобразуване на изображение в негатив (пълно инвертиране на всички цветове), огледално обръщане на кадър.

Опции:

  • Група с действия:

    Зеркало по горизонтали~Огледално обръщане по хоризонтал.

    Зеркало по горизонтали~Огледално обръщане по вертикал.

    Инверсия цвета~Инвертиране на цветове.

  • Опция [image] Общие настройки - Ако опцията е активирана, избрано(и) действие(я) се прилага за всички канали. В противен случай се отнася само за канала, за който е(са) зададено(и) действие(я).

    и възможности за огледално обръщане по хоризонтал или вертикал.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
2.01 |  | 14.09.2009 | BPP_Inverse_v201.zip (14 kb)


Topic: BPP_BW

BPP_BW

- Конвертиране на цветно изображение във формат RGB24 или YUY2 в черно-бяло.

Хронология:

Версия | Описание |  | Download
1.00 |  | 17.08.2005 | BPP_bw_v100.zip (7 kb)


Topic: BPP_Anaglyph

BPP_Anaglyph

- Преобразуване в реално време всякакво черно-бяло или цветно изображение в анаглифно (от гръцки anaglyphos-релефен), което позволява да се получи обемен ефект на екран при гледане на обикновени ТВ- и видеопрограми. При това се постига стереоефект не само за сцена като цяло, но и по отношение на отделни подвижни елементи в кадър.

i За гледане на обемни изображения, направени по анаглифен метод, са необходими специални стерео очила, при които светопропускащите (стъклени или пластмасови) елементи са с различни цветове, например едното стъкло е червено, а другото синьо-зелено (циан).

Такива очила понякога се прилагат към различни списания за разглеждане на анаглифни снимки и реклами. Анаглифни очила могат да бъдат направени и самостоятелно. Детайлно описание на процес за самостоятелно изработване на стереоочила с използване на мастило от отработени касети за мастилено-струйни принтери и специалното прозрачно фолио за печат към тях е посочено тук . Подобна методика е описана тук .

& За теорията на стереовъзприятие на образи и стереоизображения, в т.ч. и анаглифни е писано много. Подробна информация има и в специализирани сайтове в Интернет, като www.stereoart.ru и www.really.ru . Материали има и в някои компютърни издания. В тази и в тази статии е описана теория и практика за получаване на стереоизображения, но основно за статични изображения, а тук може да се прочете за цветови корекции, применими към анаглиф.

Ако за получаване на истински стереоефект трябва да се снима обект от две различни токи (от два ракурса), то за получаване на стереоснимка на базата на един отделно взет кадър се изисква сериозен интелектуален подход към задачата и виртуозно владеене на графични редактори. Но ако има не единична снимка, а последователност от кадри във видеоред, може почти автоматично да се получат напълно задоволителни конкретни резултати.

В плъгин BPP_Anaglyph за постигане на стереоефект се прилагат два метода:

  1. изместване на паралакс, което позволява постигане на обща дълбочина на сцената при гледане, и

  2. метод за изместване по време, който позволява да се придаде обем на отделни елементи в кадър.

    Вторият метод осигурява илюзия за обем само за подвижни обекти. Например, за да придобие обем лицето на тв-водещ, е достатъчно да обърне глава настрани. Аналогично, за да изглежда някакъв обект от сцената на първи план, или самият обект трябва да се премества отдясно-наляво спрямо обкръжаващата го обстановка, или като алтернатива самата камера трябва да се премества около обекта, за да може цялата обстановка да се премества спрямо него надясно.

Тези условности не позволяват да се постигне пълен стереоефект. При гледане на видеоред, обработен с плъгин BPP_Anaglyph, стереоефект се постига далеч не за всички кадри, но и това е достатъчно, за да може за останалото време човешкият мозък на база на получената информация и натрупан "житейски опит", в по-голяма или по-малка степен успешно да «доосмисли» обема на сцена самостоятелно.

BPP_Anaglyph е не по-малко интересен и в режим на запис. Записан с плъгина анаглифен видеофайл може без да се бърза да се разгледа по кадри със всеки удобен видеоредактор и по-детайлно да се изследва скритият обем.

По този начин са получени следните скрийншот-и:

Настройки:

v.3.00:

  • Група «Управление»:

    Чекбокс за «включване/изключване». В съседния прозорец може да се зададе комбинация от горещи клавиши, с които в реално време да се включва и изключва стереоефект без да се извиква менюто за избор и настройки на плъгини (по подразбиране Alt-A).

  • Опция «Анализ векторов движения»~«Анализ на вектори за движение» - включва разчет на вектори за движение и корекция на паралакс въз основа на получените резултати, което позволява постигане на правилен стереоефект за значително по-голямо количество видеосюжети.

    Изключване на разчет и анализ на вектори за движение намалява натоварването на централния процесор, но при това силно се съкращава количеството на възможни комбинации от видеопоследователности, при които може да бъде достигнат правилен стереоефект.

  • Група «Анаглифные очки»~«Анаглифни очила» е параметър, който позволява да се настрои изображение за съответен наличен тип анаглифни очила.

  • Регулатор «Глубина сцены»~«Дълбочина на сцена» определя общото положение на сцена спрямо плоскостта на екрана. Ако лявото стъкло на стерео очилата е червено, а дясното синьо-зелено, то при отрицателна стойност на този параметър сцената ще се отдръпва зад плоскостта на екрана, което е най-удобно за възприятие.

  • Регулатор «Глубина эффекта»~«Дълбочина на ефект» определя закъснение по време, което е необходимо за придаване на обем на подвижни обекти.

  • Регулатор «Насыщеность»~«Наситеност» - За комфортно възприемане анаглифно изображение не трябва да съдържа наситени чисти цветове. Чисти цветове в анаглиф създават неприятен ефект на светене и блясък. Така например, ако в кадър присъства червено знаме, то ще бъде видно само през червения светофилтър и само за едното око. Синьо-зеленият светофилтър няма да пропусне червения цвят и за второто око знамето ще изглежда абсолютно черно. Това създава сериозен дискомфорт и пречи за правилно възприятие на стереоизображения:

    Обърнете внимание как на скрийншота «свети» яркият син фон с наситеност 100%. В съседство е същата сцена с наситеност 50%:

    Настройка «Наситеност» "разрежда" всичко с бяло, в това число и чистите цветове. В резултат всички елементи на анаглифно изображение (макар и частично) стават видими през всеки светофилтър.

  • Група «YUY2 - коррекция»:

    & Телевизионно изображение се предава, цифровизира и се обработва във формат YUV. Това означава, че параметри на пиксел се задават по три компонента - яркостна Y и две цветоразликови съставни U и V. При това във формат YUY2 цветност се указва само за половината пиксели. За всеки втори пиксел цветност се изчислява от видеорендерера въз основа на величините на цветност на съседни точки непосредствено при извеждане на изображение на екран. В резултат при несъответствия между реална яркост и изчислена цветност окончателните цветове на четни пиксели ще се различават от очакваните.

    При анаглиф подобен род грешки водят до появяване на лъжливи контури в цветоотделни компоненти на изображение.

    По-долу е показан двукратно увеличен фрагмент от анаглифно изображение на изхода на видеорендерера и неговия червен канал, видим през червения светофилтър. В червения канал е добре забележимо "замърсяване" от грешки при преизчисление на цветност на четни пиксели:

    Съществуват поне две схеми, в съответствие с които видеорендерите преизчисляват междинни стойности на цветност. И двете схеми са взети предвид в настройка «YUY2 - корекция» на плъгина:

    § схема «1» се използва при апаратен овърлей в някои видеокарти,

    § схема «2» - в апаратен овърлей и в EVR (Enhanced Video Renderer). Подходящ вариант за всеки конкретен видеорендерер се подбира по опитен път.

    Същият фрагмент от изображение след YUY2 - корекция:

    Ако в настройките на програма Behold TV е включено извеждане на видео чрез първична повърхнина DirectDraw7, видеопоток ще се предава във формат RGB, който се извежда от видеорендера на екран без каквито и да е изменения и междинни преизчисления. В този случай няма необходимост от корекция на цветове на пикселите и настройка «YUY2 - корекция» не е активна.

  • Група «Ghost - компенсация»:

    & Гоустинг (от англ. ghost - привидение) е общоприет термин за обозначаване на раздвояващи се, разтрояващи се и фантомни изображения, които възникват на екран в резултат на някакви смущения и изкривявания. При анаглиф гоустинг възниква поради това, че червеният светофилтър на анаглифни очила пропуска част от спектъра на излъчване на зеления канал на монитора, в резултат на което окото започва да вижда освен предназначения за него (червен) фрагмент, така и подготвения за другото око фрагмент от синьо-зелено изображение. Същото се отнася и за синьо-зеления светофилтър, но в значително по-малка степен.

    Обикновено потискане на гоустинг се изпълнява само за червения канал.

    В плъгина ghost-компенсация се настройва по две точки - за светъл и тъмен участък от червения слой на изображение. Настройка се осъществява през червения светофилтър на анаглифните очила по изображение на шаблон, който сам по себе си представлява съчетание от всички възможни комбинации на зелени и червени цветове на монитора. През червения светофилтър на анаглифните очила отчетливо е видно как зелените клетки се проявяват на тъмен фон в долния ляв ъгъл на шаблона, а в левия горен ъгъл на шаблона жълтите клетки се открояват по яркост на наситен червен фон.

    @ Чрез настройки на компенсация на гоустинг в тъмни тонове трябва да се постигне резултат, при който червеният фон в левия долен ъгъл на шаблона да бъде сравним по яркост с разположените на него зелени клетки.

    С настройка на ghost-компенсация в светли тонове трябва да се подбере такова максимално ниво на червеното, при което неговата сумарна яркост със зелено (група жълти клетки в левия горен ъгъл на шаблона) да съответства по яркост на чист наситен червени фон.

    Междинните стойности на червения цвят за компенсация на гоустинг се преизчисляват автоматично. Зависимост на видимата яркост от RGB величини на пиксел се описва с нелинейна функция, коефициент на която се подбира индивидуално за всеки отделен монитор («Гама корекция»).

    След настройки на гоустинг-компенсация шаблонът би трябвало да изглежда примерно по следния начин, т.е. зелените и жълти клетки не трябва да изпъкват силно върху червен фон:

    Най-вероятно няма да бъде възможно да се компенсира напълно зеленият канал. Характеристиките на всеки отделен модел монитор са уникални и не винаги са предсказуеми. Това се отнася в пълна сила особено за монитори с LCD матрици. При това обаче зеленият канал, който прониква през червения светофилтър, все пак се възприема от окото именно като зелен, и независимо от подбраната яркост разлики в цветове все пак ще се усещат. Освен това собствено влияние може да оказва и апаратният овърлей на видеокартата като допълнително гама-коригира изображение при извеждане на екран.

  • - Настройки по подразбиране.

Хронология:

Версия | Описание |  | Download
1.00 | Добавена е възможност за задаване на комбинации от горещи клавиши |  |
2.00 | Добавена е възможност за настройки на изображение за тип анаглифни очила Добавен е анализ на вектори за движение |  |
3.00 | Добавено е автоматично съхранение на настройки отделно за всеки потребителски профил. Добавена е настройка за наситеност. Добавена е корекция за YUY2 формат на изображението. Добавена е компенсация на „гоустинг” (от англ.„ghost” - призрак) | 10.04.2009 |
3.01 | Реализирано е съхранение на настройки в Windows 7. | 15.09.2009 | BPP_Anaglyph_v301.zip (23 kb)

The contents of BPP_Anaglyph

BPP_Pseudostereo


Topic: BPP_Pseudostereo

BPP_Pseudostereo

Допълнително (публикувано във форума на официалния сайт)

- Анаглифно обемно изображение в реално време.

Източник - EugeneF:

(цит.) Наконец дописал свою версию плагина конвертации изображения в анаглифное псевдостерео с использованием метода переменного искусственного параллакса В.А. Ежова, и более эффективного метода оценки смещения камеры.

Плагин предназначен для красно-синезеленых очков. (Теперь годится для очков любого цвета).

Параметр "Глубина" определяет положение нижней кромки изображения, параметр "Перспектива" определяет положение верхней кромки относительно нижней. Положительное направление - от наблюдателя (кр.цит.).

Последний раз редактировалось: EugeneF (Сб Янв 23, 2010 23:21), всего редактировалось 5 раз(а)

- Включване на плъгина в действие:

  • Очки~Очила - с клик върху цвят могат да се задават настройки по желание от цветова гама:

    или да се изберат според налични такива от "падащ" списак със стандартни видове:

Хронология:

Версия | Описание |  | Download
 |  | 08.04.2010 | BPP_PseudoStereo.dll
 | За VirtualDub (и AviSynth): | 08.04.2010 | PseudoStereo.vdf


Topic: BPP_25Frame

BPP_25Frame

- Плъгинът илюстрира възможностите на тунера за реализация и практическо приложение на „ефект на 25-я кадър”.

Реализирана е методика, която на теория трябва да помага за бързо запомняне и попълване на речников фонд за всеки чужд език, за който е наличен файл-речник във формат .DIC - по време на гледане на гледане веднъж на секунда в избрана област на екрана може да се види дума или фраза с превод. Този метод се различава от всички аналогични подобни по това, че се използва истински 25-и кадър, който съществува във видеопоток при обикновени телевизионни програми.

Възможно е ефектът на 25-я кадър да разочарова някои потребители. Съществува мнение, че 25-ят кадър е абсолютно незабележим за възприемане и е способен да оказва известно влияние върху човешкото подсъзнание. Това не е точно така. Ако по отношение на влияние върху подсъзнанието въпросът засега остава спорен, то по отношение на «прозрачността» на 25-я кадър илюзии не би трябвало да възникват. Доказателство за това е този плъгин. Нещо повече, че за да бъде направен 25-ят кадър по-малко натрапчив, в плъгина са използвани ред нестандартни решения.

Трудно е да се каже в каква степен влияят технологиите на 25-я кадър. Има много публикации - както потвърждаващи , така и опровергаващи общоизвестните теории. С помощта на този плъгин всеки потребител индивидуално може да изпробва ефекта и да направи съответни изводи за себе си.

Настройки:

  • За да могат да бъдат извеждани думи на екран на два реда, между тях трябва да има разделител с конструкция « - ».

  • Група «Словарь»~«Речник»:

    «Встроенный»~«Вграден» Плъгинът включва вграден, щателно проверен англо-руски речник с 8000 думи и 15000 значения.

    «Альтернативный»~«Алтернативен» Плъгинът позволява да се включват всякакви външни речници, които са базирани на следния формат:

    § Дума1 – Превод1;

    § Дума 2 – Превод2, Превод3;

    .............................

    § Добавяне, поправяне или премахване на думи от използвания речник може да се прави непосредствено в прозореца за настройки на плъгина. Преди попълване и редактиране на речник е необходимо да се създаде файл с разширение .dic и да бъде избран като алтернативен речник в плъгина. Създаден по този начин речник се съхранява на диска при изход от приложението. Вграденият по подразбиране речник не подлежи на редактиране и изменения.

  • Група «Текст» - избор на

    § шрифт,

    § цвят за текст,

    § цвят за фон,

    степен на прозрачност ва дума във видеопрозореца.

  • Група «Положение» - Положението на текст върху екрана от своя страна може да бъде зададено произволно или дори на случаен принцип. Опции - задаване на позиция:

    § по избор за показване на дума във видеопрозореца, или

    по случаен принцип.

  • Група «Фон» - Прозрачност, цвят на извеждания текст и фон се подбират по собствено желание. По подразбиране с фон се запълва само област на екрана непосредствено под текста. Въпреки това плъгинът позволява запълване на целия екран с цвета на фона или обратното – да се извежда текст върху прозрачен фон.

  • Група «Время / Частота показов»~«Време / Честота на показване»:

    Информацията може да се извежда на екран не само с честотата на 25-я кадър. Периодичност на извеждане може да се настройва и изменя в границите от всеки 1-ви до всеки 200 кадъра, т.е. от 25 пъти в секунда до веднъж на 8 секунди. Освен това, честотата на показване може да бъде случайна.

    За задаване на този параметър в плъгина са предвидени две полета. Например, ако в тези полета се зададат стойности 5 и 50, извеждане на екран ще се извършва през случайни интервали от време, но не по-често от всеки пети кадър и не по-рядко от всеки 50-и кадър.

    Същото се отнася и за времето на показване, което може да варира в интервал от един до 100 кадъра, както и на случаен принцип.

  • Група «Перебор слов»~«Извеждане на съдържание на речник» - по избор може да бъде в

    прав, обратен азбучен ред или в случаен ред.

    С двоен клик по ред в списъка се стартира сканиране на речника от посоченото място.

Плъгинът работи във формати YUY2 и RGB24.

- Настройки по подразбиране.

Внимание [image] за инициализация на плъгина при старт на приложението е необходимо допълнително време. Ако плъгинът не се използва често е по-добре да бъде премахнат от списъка! (вж. забележките в началото на раздела)

Хронология:

Версия | Описание |  | Download
1.01 | Първа версия на плъгина |  |
1.02 | Добавено е автоматично съхранение на настройки отделно за всеки потребителски профил. | 25.12.2007 |
1.03 | Реализирано е съхранение на настройки в Windows 7. | 15.09.2009 | BPP_25Frame_v103.zip (133 kb)


Topic: BPP_Placebo

BPP_Placebo

Плъгинът е предназначен за абсолютно подобряване качеството на изображение и звук.

Преди употреба

настоятелно се препоръчва

да се прочете описанието (рус."Справка")!!!

: Плъгинът работи в напълно автоматичен режим и не изисква никакви настройки. Принципът на действие се базира на eфекта на 256-я кадър, при което във видеоред се добавят невидими за окото квазихармонични колебания, стимулиращи механизъм за филтрация на визуална информация непосредствено в човешкия мозък.

В резултат на проведени изследвания е доказано, че 57.9% от всички смущения, шумове и изкривявания на екрана като правило се определят от индивидуалните възприятия на всеки отделен човек. При използване на описания ефект на филтрация може съществено да се подобри възприеманото качество на изображение и звук:

Плъгинът е незаменим за разглеждане на скрити изображения. Често зрителите не знаят (а болшинството дори не се досещат), че в промеждутъците между телевизионните и радиостанции в ефир на фона на шума и атмосферните смущения се предава строго секретна кодирана информация. Плъгинът дава възможност да се видят такива скрити образи:

Плъгинът се справя добре и с деинтерлейсинг на кадъра. В най-голяма степен тези негови свойства се проявяват на максимално разстояние от екрана на монитора.

Точно по този начин плъгинът позволява да се премахнат цял ред други изкривявания, присъщи на аналоговата телевизия.

В режим на запис плъгинът регулира последствията от пропадане на кадри при цифровизация на видео от некачествени носители. При използване на плъгина 5~10 пропаднали кадри стават на практика незабележими, ако времето на запис значително превишава 1,5~2 часа.

BeholdTV не позволява да се използват плъгини за видеопроцесинг за обработка на звук, но принципите на невровизуално програмиране, заложени в BPP_Placebo, позволяват на подсъзнанието със същия успех да се обработва както видео-, така и аудио информация. Въз основа на стотици проведени експерименти с десетки бета-тестери е признато, че след обработка с плъгина звукът става като че ли по-прозрачен, придобива по-богата окраска и панорамност на звучене.

Плъгинът е направен по такъв начин, че при каскадно прилагане на няколко копия качеството се подобрява в геометрична прогресия. За целта е необходимо в директория .../Plugins да се създадат няколко копия на плъгина, като се направи огромен брой копия на изходния файл BPP_Placebo.dll с различни имена, например по следния начин:

BPP_Placebo_1.dll

BPP_Placebo_2.dll

BPP_Placebo_3ххх.dll

............................

Впоследствие всяко копие може да се избира от списъка с плъгини за гледане или запис.

Изменения и допълнения:

Версия 1.00 (1 April 2008) - Първа и последна версия на плъгина.


Topic: 4. Информационни и други ПРОЗОРЦИ

4. Информационни и други ПРОЗОРЦИ

Информационни и други ПРОЗОРЦИ

В този раздел са поместени плъгини, с които в основния видеопрозорец се извеждат

допълнителни информационни и други прозорци с:

  • графична информация;

  • текстова информация;

  • час/дата,

  • прозорец в прозореца ~ картина в картината (режим РІР),

  • и други.

The contents of 4. Информационни и други ПРОЗОРЦИ

BPP_Informer
BPP_PiP
BPP_OSDClock
BPP_CrawlLine


Topic: BPP_Informer

BPP_Informer

- Плъгинът е предназначен за сваляне от мрежата и извеждане на екран на т.н. “информери”

Т.н. “Информери” представляват неголеми, редовно обновявани графични файлове, изобразяващи полезна информация (за времето, валутни курсове, борсови индекси, различни анонси, новини и пр.):

Като “Информери” могат да бъдат всякакви графични файлове във формат BMP, JPG, TIFF, обикновен или анимиран GIF.

  • В плъгина са предвидени два списъка за съхраняване на препратки към “информери” -

    «URL» и

    списък с произволни препратки към страници в Интернет,

    които се отварят в браузър с двоен клик по информер във видеопрозореца.

    По подразбиране и двата списъка са празни. За да се добави URL или препратка е необходимо в падащия списък да се избере и редактира празен ред. След затваряне на прозореца за настройки на плъгина, избраният URL ще бъде активиран.

  • Зареждане на “информер” се извършва по протокол http. В препратка «URL» типът протокол трябва да бъде зададен в явен вид, т.е. всяка препратка трябва да започва с префикс http://

  • Извеждане на екран на “информер” се извършва чрез натискане на комбинация от hotkeys «Показать»~„горещи клавиши” «Показване».

    По подразбиране е зададена комбинация «Ctrl-Shift-Alt-I».

  • Настройка «Индикация (сек.)» – продължителност за индикация на “информер” на екран. Ако тази стойност е нула, информерът ще се изобразява постоянно на екрана, като се обновява периодично през зададено време.

    Премахване на “информер” става с повторно натискане на hotkeys «Показать».

  • Настройка «Автообновление (мин)»~«Автообновяване (мин)» – период за обновяване на “информер” в режим на постоянна индикация. При стойност нула автообновяване е изключено. “Информер” може да бъде принудително обновен по всяко време с натискане на комбинация hotkeys «Обновить»~«Обновяване»

    По подразбиране - комбинация «Ctrl-Shift-Alt-U».

  • При зареждане и обновяване на информер се води протокол за Интернет-съединение. Всички данни се записват във файл, който има точно такова име като плъгина и разширение .log. Log-файлът се съхранява в директорията с плъгини или в съответна потребителска директория, ако в BeholdTV_секция [image] _група «Допълнителни опции» е включена опция

    «Запазване на настройки отделно за всеки профил».

  • Прозорец с “информер” може да се вгражда в различни части на екрана.

  • Могат да се включват няколко „информери” едновременно, като по този начин може например по едно и също време да се гледа ТВ-програма, да се следят валутни курсове, прогноза за времето...

    За едновременно извеждане на два и повече „информери” на екран е необходимо в директория .../Plugins да се направят няколко копия на плъгина, като всяко копие на изходния файл BPP_Informer.dll се преименува, примерно по следния начин:

    BPP_ Informer_1.dll

    BPP_ Informer_2.dll

    BPP_ Informer_3.dll

    …...…………………

    Впоследствие всяко едно копие на плъгина може да бъде избрано в списъка с плъгини за гледане или запис, да се настрои собствен информер и да се определи индивидуална комбинация от hotkeys за управление и препратка.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.01 | Първа версия на плъгина | 28.01.2008 | BPP_Informer_v101.zip (50 kb)


Topic: BPP_PiP

BPP_PiP

- Плъгинът позволява при наличие на втори (или няколко) тунер(а) в системата да се организира режим на работа PiP („кадър в кадъра”) едновременно с две или повече устройства.

PiP-устройства могат да бъдат всякакви инсталирани в компютъра тунери или платки за видеозахват (capture). Поради някои особености при работа изключение правят устройства за видеовход, които са интегрирани с видеоадаптери (видеовходове на видеокарти).

Трябва да се знае, че при работа в режим PiP:

  • в основния прозорец на програмата винаги се изобразява канал, който се приема от основния тунер, а

  • в PiP-прозореца – изображение, получено от другото PiP-устройство.

    По този начин при промяна на съдържанието на прозорците не произтича промяна на размери и положение на прозорците на устройствата (малкият прозорец да стане голям, а големият - малък), а пълна пренастройка на тунерите за съответните канали.

    Ако едно от устройствата е било настроено за композитен или S-Video вход, то обмен между съдържанието на прозорците е невъзможен, т.к. софтуерът на основния тунер не е в състояние да изобрази в своя прозорец изображение, което е получено от нискочестотни входове на PiP-устройство и обратно.

Плъгинът работи с което и да PiP-устройство чрез WDM-драйвер, което налага някои ограничения при управление на устройства. Така например, чрез WDM-драйвер

не може да се зададе режим за автоматично определяне на видеостандарт (вж. по-долу),

не могат да се задават режими за възстановяване на поредова и кадрова синхронизация

и други опции, които са достъпни от основната програма.

При различни хардуерни устройства за видеовход, както и поради различните настройки на съответните драйвери, един и същи канал може да изглежда различно в основния прозорец и в PiP- прозореца.

Интерфейс и настройки на PiP-устройство

За работа в режим «кадър в кадъра» трябва да се избере т.н. PiP-устройство. Под устройство PiP тук се подразбира набор от компоненти на драйвера, всеки от които отговаря за работата на една или друга функция на физическото устройство:

  • «Устройство РІР»

    "TV Тюнер"~"TV Тунер" - компонент на драйвера, който отговаря за управление на високочестотната част на тунера и настройките на тунера за съответни канали. При някои устройства за видеовход, които нямат физически TV-тунер, този компонент на драйвера се явява формален и може да бъде пренебрегнат. Ако PiP-устройството обаче е телевизионен тунер и този компонент не е избран, то превключване на канали в PiP-прозореца ще бъде невъзможно и PiP-устройството ще бъде автоматично настроено за работа с композитен или S-Video вход.

    "TV Аудио" - компонент на драйвера, който формално отговаря за превключване между стереорежими на звуковия съпровод на телевизионните програми.

    "Коммутатор"~"Комутатор"~"Crossbar" е компонент на драйвера, който отговаря за превключване между всякакви входове/изходи, които са налични като устройства за видеозахват (TV, Композитен, S-Video...).

    "Устройство захвата"~"Устройство за захват"~ "Capture device" представлява компонент на драйвера, който отговаря за работата с устройството за декодиране, преобразуване и цифровизация (АЦП) на видео/аудио данни.

    За работа в PiP режим трябва да бъдат избрани минимум Комутатор и Устройство за захват.

    Всички избираеми компоненти на драйвера трябва да принадлежат на едно устройство. Понякога не е лесно да се разбере кой компонент в списъка на кое от устройствата принадлежи. Много производители на тунери като правило подписват със собствено име само основното устройство за захват. При това останалите компоненти на драйвера могат да носят имена, които им е дал референтен производител на драйвери и да не отразяват принадлежност към което и да е устройство. На скрийншота е показан пример за такъв случай:

    Ако в системата са инсталирани два съвършено еднакви тунера, в списъците с устройства ще има по два еднакви реда. В този случай се препоръчва да се съблюдава поредност за избор на устройство. Т.е., ако в списък «TV Тунер» е било избрано първото от двете устройства, то и от останалите компоненти на драйвера при два еднакви също трябва да бъде избрано първото устройство:

    Ако PiP-устройство е било избрано неправилно, то при съхранение на настройки (бутон «Сохранить параметры устройства PiP») ще бъде изведено съответно предупреждение или съобщение за невъзможност за пускане на същото.

    В случай, че като PiP-устройство е избран и пуснат основният тунер, няма да бъдат издадени никакви предупреждения и грешки, но тъй като основният тунер при това е зает от програмата Behold TV, то или в PiP-прозореца, или в основния прозорец няма да има изображение.

Срещу всеки ред с компоненти на PiP-устройство се намира бутон [image], с който се извиква диалогов прозорец за настройки на драйвера. Такива настройки се предоставят от съответните производители на драйвери и позволяват да се регулират такива параметри на изображение, като

яркост,

контраст,

наситеност и пр.

Драйверите на Beholder освен всичко останало позволяват да се настрои АРУ-работата на чипсет Philips и по-фино да се регулират неговите аудио параметри, което обаче не е актуално при работа на устройството в режим PiP.

  • "Формат видеопотока"~"Формат на видеопоток" - списък с поддържани едновременно от плъгина и драйвера на PiP-устройството формати за видеоданни. Списъкът се попълва след избор и съхранение на настройки на PiP-устройство. Ако PiP-устройство не поддържа нито един от YUY, UYVY или RGB24 формати, то в списъка ще се обозначава "Default". По правило това означава, че устройството има собствен формат данни на изхода на драйвера и за работа с него е нужен специален конвертор, който ще се включва автоматично.

  • "Размер видеопотока"~"Размер на видеопоток" – размер на кадър в пиксели, който се изисква от PiP-устройството. За да бъде намалено натоварването на системата в режим PiP и да бъде изключена необходимост от използване на деинтерлейс-филтри, размерът на видеопотока е ограничен до размерите на едно поле (384х288 и по-малко). Въпреки това драйверите на някои устройства не позволяват да се изменя размер на видеопоток и игнорират тази настройка. В този случай размерът на потока се задава от драйвера по собствена преценка и в PiP-прозореца могат да възникнат интерлейсни изкривявания.

  • "Окно PiP"~"Прозорец PiP":

    Тази група настройки позволява да се задават такива параметри на PiP-прозореца, като размер, положение на екрана, прозрачност и атрибути на рамка. С параметър «Размер на кадър»~«Размер кадра» се задава размер на изображение вътре в PiP-прозореца. Размерът и положението на PiP-прозореца се задават в проценти спрямо габаритите на основния прозорец. Цветът на рамката на PiP-прозореца е желателно да бъде подбран от оттенъците на сивото, т.к. чистите цветове на дребните детайли на изображението във формат YUY2 (овърлейна повърхнина) се предават с някои изкривявания.

  • "Видеостандарт PiP":

    При превключване на канали плъгинът е задължен да зададе за PiP-канал един или друг видеостандарт. Плъгинът разчита типа видеостандарт от настройките на канала в програмата на основния тунер. Въпреки това, през WDM-драйвер е невъзможно да се зададе режим за автоматично определяне на видеосистема, който може да бъде зададен за някои канали. Освен това WDM-драйверът на PiP-устройството може принципно да поддържа само ръчен или само автоматичен режим за задаване на телевизионна видеосистема. Също така, някои WDM-драйвери работят в режим Autodetect само до първо превключване към фиксиран стандарт, след което е невъзможно да бъдат върнати в автоматичен режим. Настройка «Видеостандарт PiP» отчасти позволява да бъдат разрешени такива противоречия:

    § Ако в списък «Видеостандарт PiP» е избран режим «Авто», то при превключване от канал на канал плъгинът няма да се опитва да задава видеостандарт. В този случай ще работят настройки, зададени по подразбиране в драйвера на PiP-устройството.

    § Ако в списък «Видеостандарт PiP» е избран който и да е друг тип TV-система (различен от «Авто»), то този видеостандарт ще бъде принудително задаван за всички канали с режим «Autodetect».

    § Ако за PiP-устройство се използва втори тунер Beholder, то настройка «Видеостандарт PiP» става неактивна. Драйвер Behold TV винаги работи в режим на автоматично определяне на видеостандарт и игнорира всички опити за принудителни настройки.

  • Управление:

    Управление на PiP-режим се осъществява

    от менюто на плъгина,

    с мишка - PiP-прозорец може да се „влачи” в границите на основния прозорец на приложението, а с двоен клик в PiP-прозореца - да се сменя съдържанието на прозорците.

    При ръчно изменение на мащаб на овърлей в настройките на видеоадаптера, в режим 16:9 PanScan, както и при съхранение на пропорциите на екрана в режим Full Screen, курсорът на мишката може да не попада във видимите граници на PiP-прозореца.

    от клавиатурата. Част от функциите за управление на PiP са възложени на клавиатурата, за което на всяка команда за управление е зададена комбинация от „горещи клавиши” („hotkeys”).

  • Горещи клавиши (Hotkeys) (Горячие клавиши):

    Нotkeys се използват за управление на режимите на работа PiP непосредствено от клавиатурата.

    За задаване на нова клавишна комбинация е необходимо да се избере ред с команда и

    § с двоен клик на мишката по същия, или

    § с натискане на Enter да се извика прозорец за редактиране на клавишни комбинации. Потвърждение за правилно въвеждане на клавишна комбинация е Enter, отмяна на въвеждане – Esc, изчистване – Delete.

    Hotkey-комбинации, които се задават за управление на PiP не трябва да се припокриват с клавишни комбинации, зададени в основната програма. В противен случай ще се изпълняват едновременно двете зададени действия.

    Таблица с команди и съответни hotkeys:

Команда | hotkeys
Вкл/Изкл PiP | Ctrl + P
Следващ канал | Alt + Up
Предишен канал | Alt + Down
Канал 1 | Alt + Num 1
Канал 2 | Alt + Num 2
Канал 3 | Alt + Num 3
Канал 4 | Alt + Num 4
Канал 5 | Alt + Num 5
Канал 6 | Alt + Num 6
Канал 7 | Alt + Num 7
Канал 8 | Alt + Num 8
Канал 9 | Alt + Num 9
Канал 10 | Ctrl + Alt + Num 0
Канал 11 | Ctrl + Alt + Num 1
Канал 12 | Ctrl + Alt + Num 2
Канал 13 | Ctrl + Alt + Num 3
Канал 14 | Ctrl + Alt + Num 4
Канал 15 | Ctrl + Alt + Num 5
Канал 16 | Ctrl + Alt + Num 6
Канал 17 | Ctrl + Alt + Num 7
Канал 18 | Ctrl + Alt + Num 8
Канал 19 | Ctrl + Alt + Num 9
Режим TV | Ctrl + Page Up
Режим VHS | Ctrl + Insert
Режим S-VHS | Ctrl + Home
Размяна на канали | Ctrl + X
Изместване на прозорец наляво | Ctrl + Left
Изместване на прозорец надясно | Ctrl + Right
Изместване на прозорец нагоре | Ctrl + Up
Изместване на прозорец надолу | Ctrl + Down
Размер на прозорец + | Ctrl + Num +
Размер на прозорец – | Ctrl + Num -
Прозрачност на прозорец + | Ctrl + Num *
Прозрачност на прозорец - | Ctrl + Num /

  • Бързодействие (Быстродействие)

    & При включен плъгин BPP_PiP, по време на пускане на програмата се инициализират едновременно няколко (мин. две, респ. колкото са инсталирани) устройства. В резултат времето за зареждане и разтоварване на програмата се увеличава.

    За повишаване на бързодействието, ако плъгинът не се използва е по-добре да бъде премахнат от списъка с плъгини.

    Плъгинът не извършва обработка на получено изображение, не заема никакви системни ресурси за извеждане на видео на екран и работи непосредствено само с драйвера на PiP-устройството. Натоварването на системата от плъгина е резултат от работата на самия плъгин (2~10% в зависимост от избрания размер и формат на видеопотока) и работата на драйвера на PiP-устройството. Натоварването на системата от драйвери на някои устройства може да достига 15~20% и повече. Като пример, при работа на драйвер Beholder се изразходват по-малко от 1% системни ресурси (процесор P IV 2.4 GHz).

    Особеност на WDM-драйвери за някои устройства е, че твърде продължително се инициализират, а освен това се превключват от канал на канал (особено между собствените входове). Времето за превключване понякога възлиза на 5 и повече секунди. При това натоварването на системата може от време на време да нараства до 100%, което може да доведе до спиране на работа на цялата система и затормозяване при извеждане на видео в основния прозорец на тунера.

  • Допълнение

    След версия 1.20 плъгин BPP_PiP може да поддържа произволно количество тунери, инсталирани в системата.

    За включване на 2 и повече тунера като PiP е необходимо в папка ..\Plugins да се създадат (като предварително се преименуват) няколко копия на файла на плъгина BPP_PiP, например:

    BPP_PiP_1.dll

    BPP_PiP_2.dll

    BPP_PiP_3.dll

    .......................

    След това в прозореца със списък на достъпни плъгини за процесинг е необходимо да бъде избран всеки от създадените екземпляри в списъка с активни плъгини за гледане или запис:

Впоследствие всеки екземпляр на плъгина може да бъде настроен за „собствения” тунер и да се зададе за управление с индивидуален набор от hotkeys.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина |  |
1.20 | Добавена е възможност за работа с два и повече тунера като PiP-устройства. | 28.11.2006 |
1.21 | Реализирано е съхранение на настройки в Windows 7 | 15.09.2009 | BPP_PiP_v121.zip (50 kb)


Topic: BPP_OSDClock

BPP_OSDClock

- Плъгинът позволява да се извеждат върху изображение на екран дата, време, ден от седмицата, име на месец и др. в различни формати.

Удобно е (понякога е необходимо) при запис на някои програми, когато е желателно да се вижда на коя дата и в колко часа е извършен запис.

В настройките са предвидени достатъчно

§ формати,

§ разположение във видеопрозореца и

§ външен вид на дати,

които са подходящи дори за стилизирано оформени предавания.

Необходим формат за визуализация се задава с помощта на макроси, които представляват двойки символи, започващи със знак «%». Списък с макроси:

%a – ден от седмицата съкратено ( Пн, Вт, Ср, Чт, ... )

%A – ден от седмицата изцяло ( понеделник, вторник, ... )

%b – месец съкратено ( яну, фев, мар, апр, ... )

%B – месец изцяло (Януари, Февруари, ... )

%c – дата и време в съответствие с локални установки

%d – ден от месеца ( 01...31 )

%H – часове ( 00...23 )

%I – часове ( 01...12 )

%j – ден от годината ( 001...366 )

%m – месец ( 01...12 )

%M – минути ( 00...59 )

%p – текущ локален индикатор A.M./P.M.

%S –- секунди ( 00...59 )

%U – седмица от годината с първия ден - събота ( 00...53 )

%w – ден от седмицата ( 0...6 )

%W - седмица от годината с първи ден - понеделник ( 00...53 )

%x – дата в съответствие с локални установки

%X – време в съответствие с локални установки

%y – година без столетия ( 00...99 )

%Y – година от столетието

%z – име или абревиатура на часови пояс

%Z – име или абревиатура на часови пояс

%% – символ %

Примери:

%H:%M

%X

%x %X

%d %B %Y година %H час %M мин %S сек

13:2013:20:45

05/06/07

13:20:45

05 Юни 2007 година 13 час 20 мин 45 сек

За по-удобна работа с макроси, същите могат да се избират от меню, което се извиква с 8 десен клик в прозореца за редактиране на формат за показване.

Всякакъв различен от макрос текст, поставен в прозореца за редактиране, ще се изобразява на екран без изменение.

За изменение на шрифт, цвят и фон на извеждания текст трябва да се кликне в съответния прозорец с име на шрифт или текущ цвят.

Невидим фон се задава със стойност за прозрачност „0”. Същото важи и за фон на текст.

При добавяне на плъгина в списъка за обработка на изображения при запис, цялата извеждана на екран информация ще се записва във файл.

Пример за форматиране и разположение на часовник на екран:

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина |  |
2.00 | Добавено е изглаждане на шрифтове. Добавено е отделно регулиране за прозрачност на текст и фон. Добавен e гъвкав избор на формат за реда на извеждане на дата, време и пр. Добавена е възможност за отделно съхранение на настройки за всеки профил. Отстранена е зависимост на размера на шрифта на от размера на видеопотока. | 06.06.2007 |
2.01 | Реализирано е съхранение на настройки в Windows 7 | 14.09.2009 | BPP_OSDClock_v201.zip (27 kb)


Topic: BPP_CrawlLine

BPP_CrawlLine

- Предоставя възможности за извеждане на «бягащ ред» на екран.

Бягащ ред може да бъде всякакъв текст, съдържание на текстов файл или текстова информация, зареждана от новинарски RSS-ленти в Интернет.

Плъгинът може да се използва за

§ извеждане на съобщения при излъчване в мрежа,

§ наслагване на субтитри при запис във файл или при гледане,

§ получаване на актуална информация от новинарски интернет-портали,

и пр.

Пускане и спиране на бягащ ред се осъществява с натискане на комбинация от „горещи клавиши” (hotkeys). При активен прозорец за настройки на плъгина, работата с hotkeys е блокирана и за управление на реда се използва бутон [image].

Редът може да има произволна височина, широчина и да се разполага на произволно място по екрана. Текст и фон на бягащ ред също могат да имат произволен цвят и прозрачност.

За да може бягащ ред да изглежда най-добре на екран, се препоръчва

§ в плъгина да се включва интерлейсен режим за извеждане на ред, а

§ в Behold TV - програмен режим за удвояване честота на кадри и Area Motion или Area Pixel Clopping режими за деинтерлейсинг.

При излъчване в мрежа качеството на бягащ ред ще зависи изцяло от клиентските плейъри и алгоритмите за деинтерлейсинг, използвани в отдалечените компютри. Ако размерът на видеопоток по вертикал е равен на височината на едно поле на пълен кадър (XXXx288 или XXXx240), настройка "Интерлейсная строка"~„Интерлейсен ред” става неактивна.

Плъгинът позволява да се редактират и да се съхраняват отделно списъци с

редове [image],

файлове [image] и

препратки към RSS-ленти [image].

По подразбиране всички (три) списъци са празни.

«+» За добавяне на ред с текст, файл или препратка е необходимо в падащия прозорец със съответния списък да се избере и редактира празен ред. Добавяне на текстов файл в списъка може да се извърши чрез обикновено меню с бутон [image]. Отляво на всеки списък се намира бутон за избор на съответен режим на работа на плъгина.

Настройка "Повтор:"~„Повторение” - При стартиране на бягащ ред плъгинът ще изобразява същия само толкова пъти, колкото е зададено. Ако за повторения е зададено нула, редът ще тече непрекъснато.

Ако в бягащ ред трябва да се изведат поред няколко реда с текст, най-удобно е те да бъдат оформени като текстов файл (файл с разширение .txt ) и в настройка "Строка"~„Ред” да се укаже местоположението на файла. При стартиране на бягащ ред текстов файл ще бъде изцяло показван "кръгово" толкова пъти, колкото е зададено в настройка „Повторение”.

-лента представлява страница в Интернет, на която в кратка форма се публикуват новини, анонси на статии, изменения в блогове, последни съобщения по форуми и пр. оперативна информация.

По-подробно за RSS може да се прочете тук . Най-чeсто RSS-ленти се срещат по страниците на новинарски портали и интернет-издания на новинарски вестници. Дали дадено интернет-издание има RSS-лента, може да се определи по ред признаци. Така например, при намиране на RSS-лента браузерите поместват в определено място в прозореца съответно съобщение. Също така, при превключване към RSS-лента, ако такава се поддържа от браузера на страницата може да се види характерен бутон [image] или [image]. При избиране и превключване към RSS-лента, препратка към същата трябва да се пренесе в плъгина.

Режим на работа с RSS в плъгин BPP_CrawlLine има набор от собствени

Настройки:

  • "Дата" - ако RSS-съобщение съдържа дата/време на публикация, в началото на бягащия ред ще бъдат добавени дата, месец и година на публикуване на съобщението.

  • "Время"~„Време” - ако дадено RSS-съобщение съдържа дата/време на публикация, в бягащия ред ще бъде изобразено времето на публикуване с точност до минута.

  • "Заголовок"~„Заглавие” - в бягащия ред ще се извежда заглавие на RSS-съобщението.

  • "Сообщение"~ „Съобщение” - в бягащия ред ще се извежда непосредственото RSS-съобщение. Ако RSS-съобщение липсва или съдържа само HTML-тагове, вместо съобщението ще се изобрази неговото заглавие.

  • "Автообновление"~„Автообновяване” – задаване честота на обновяване на бягащия ред. През зададения период от време плъгинът ще зарежда RSS-лентата и автоматично ще презарежда съответния ред. Ако е зададена стойност нула, автообновяване е изключено.

  • "Последние новости"~„Последни новини” - в бягащия ред ще бъдат показвани само нови съобщения, публикувани в периода, изтекъл от последното стартиране на бягащия ред. Дата на последно прегледано съобщение се пази от плъгина само за текущата RSS-лента. При смяна на препратка към RSS-лента, датата на публикация на последната новина се нулира. Тази настройка работи само в случай, че съобщенията в лентата съдържат дата на публикация. Ако за изтекъл период няма нови съобщения, плъгинът ще изведе ред "Нет новых сообщений"~„Няма нови съобщения”). Това съобщение се извежда само при ръчно (чрез горещи клавиши) стартиране на ред.

Ако информация в бягащ ред с нещо е привлякла вниманието на потребителя, с двоен клик по реда може да се включи браузер по подразбиране, който ще отвори страница със съответната RSS-лента за да бъде получена по-обширна информация за новината.

При зареждане и обновяване на RSS-лента се води протокол за Интернет-съединения. Всички данни се записват в .log-файл, който има точно такова име като плъгина. Log-файл се съхранява в директорията с плъгини или в съответна потребителска директория, ако в Behold TV е включена опция "Запазване на настройки отделно за всеки профил".

@ За едновременно извеждане на два и повече бягащи реда на екрана е необходимо в директория ...\Plugins да се създадат няколко копия на плъгина BPP_CrawlLine, като се переименува изходния файл BPP_CrawlLine.dll например по следния начин:

BPP_CrawlLine_1.dll

BPP_CrawlLine_2.dll

BPP_CrawlLine_3.dll

……………………....

Впоследствие всяко копие на плъгина може да бъде избирано в списъка с плъгини за гледане или запис, като се зададат съответни атрибути, режим на работа и се определи индивидуална комбинация от горещи клавиши за управление на конкретния ред.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина | 16.12.2008 |
1.02 | Реализирано е съхранение на настройки в Windows 7 | 16.09.2009 | BPP_CrawlLine_v102.zip (47 kb)


Topic: 5. Мащабиране/пропорции на кадър/видеопрозорец

5. Мащабиране/пропорции на кадър/видеопрозорец

Мащабиране, позициониране и отсечка на кадър, пропорции на кадър/видеопрозорец

  • - Плъгин за съхраняване на установени « Пропорции на изображение » в кадър независимо от размери на видеопрозорец или формат на екрана на монитора.

    важно за притежатели на широкоформатни монитори със съотношения на страните 16:9 и 16:10!

  • - Плъгин за [image] «Мащабиране и позициониране на кадър»

    при запис / при гледане ,

  • Допълнително: Съгласно забележките в уводната част, за разширяване на информационното съдържание в контекста на темата е допълнен раздел « Отсечка и мащабиране на кадър » от основното приложение Behold TV.

Вж. също така:

  • Мащабиране на кадър при запис ;

  • Отсечка и мащабиране на кадър в Behold TV .

The contents of 5. Мащабиране/пропорции на кадър/видеопрозорец

BPP_Aspect
BPP_Scaler


Topic: BPP_Aspect

BPP_Aspect

Плъгинът позволява да се съхраняват установени пропорции на изображение в кадър (в пет основни режима на работа), независимо от

  • размери на видеопрозорец или

  • формат на екрана на монитора (на пълен екран).

Плъгинът е особено полезен най-вече за притежатели на масово разпространените широкоформатни монитори със съотношения на страните 16:9 и 16:10.

Интерфейс и настройки:

  • Група «Аспект кадра»~«Аспект на кадър»

    Плъгинът поддържа пет режима на работа:

    Посочените режими осигуряват привързване на аспекта на кадър:

  1. към габаритите на видеопрозорец,

  2. към неговата широчина,

  3. към неговата височина,

  4. нелинейно мащабиране на изображение по хоризонтал (режим «Панорама»),

  5. преобразуване от формат 4:3 към 16:9.

(1) В първия режим плъгинът фактически е изключен и за размерите на изображение в прозорец следи драйверът на видеокартата. Освен това плъгинът се изключва автоматично във всеки режим освен «16:9 Anamorphic» ако пропорциите на видеопрозорец са близки до 4:3, което позволява да се освободят част от ресурсите на централния процесор.

(2~3) Свързване на аспект към широчина или височина на видеопрозорец се осъществява за сметка на

§ отсечка на част от изображението отдолу и отгоре, или чрез

§ допълване на полетата отляво или отдясно:

(4) Режим «Панорама» обезпечава пълно запълване на видеопрозорец с произволна форма чрез нелинейно мащабиране на видеоизображение по хоризонтал. При това пропорциите в центъра на изображение винаги остават неизменни – 4:3.

(5) Режим «16:9 Anamorphic» преобразува изображение в кадър от формат 4:3 във формат 16:9.

i Такъв режим е необходим за по-нормално гледане на филми с оригинален формат 16:9, които някои телевизии привеждат към формат 4:3 по време на показване, в резултат на което изображение при НЕширокоформатни телевизори и монитори изглежда като разтегнато по вертикал.

  • Настройка «Масштабирование по полям»~«Мащабиране по полета»

    В режими «16:9 Anamorphic» и привързване на аспект на кадър към хоризонтални размери «към широчина» на видеопрозорец се извършва мащабиране на реален кадър по вертикал.

    Ако тази опция не е активирана ще бъде нарушена последователност на редуване на четни/нечетни редове на кадър, при което кадър в интерлейсен видеоред в съчетание с някои програмно-апаратни филтри за деинтерлейсинг и удвояване честота на кадрите може да изглежда по подобен начин:

    В същото време мащабиране на кадър без отчитане на полета дава най-добър краен резултат и е оптимален за гледане на прогресивно видео.

Други особености:

  • При използване на плъгина трябва да се отчита, че на преобразуване подлежи реално изображение, а не някакъв формат на извеждане на изображение на екран, както е например при работа на функция за изменение на съотношения на страни [image] в основната програма. Обработен с разглеждания плъгин кадър във всеки от посочените случаи (режими) съхранява собствените пропорции 4:3 и на скрийншот неговото съдържание ще изглежда с изкривявания.

  • Местоположението на плъгин в общия списък с плъгини е пряко свързано с неговия приоритет. Това е много важен фактор особено за разглеждания плъгин, т.к. при неправилно разположение не става въпрос само за натоварване на системата, а ефектите (дефектите) стават видими с просто око и могат да бъдат сериозен дразнител. Поради това конкретната позиция на плъгина задължително трябва да се подбира внимателно, с отчитане на посочените особености на неговата работа.

    Пример: Ако не е желателно показван OSD часовник, PiP-прозорец, и пр. да бъдат с изкривявания както обработено с плъгина изображение, техните плъгини BPP_OSDClock и BPP_PiP трябва да са след плъгин BPP_Aspect.

    В същото време AMP-плъгин и плъгини, отговарящи за изместване („сдвиг”) на цветови компоненти и запълване на рамка работят с изходно изображение и в списъка трябва да са до плъгина, който променя аспекта на кадър.

  • За коректна работа на плъгина, в настройки [image] на основната програма се препоръчва да се задават режими «Свободно на пълен екран» и «4:3».

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание | Дата | Download
1.00 | Първа версия на плъгина. | 26.04.2007 |
1.01 |  | 15.09.2009 | BPP_Aspect_v101.zip (16 kb)
1.02 |  | 01.03.2010 | BPP_Aspect_v102.zip (41 kb)


Topic: BPP_Scaler

BPP_Scaler

- Плъгин за мащабиране и позициониране на кадър при запис

  • Използване на плъгина при гледане:

    Предвид описаните по-нататък функции, BPP_Scaler може да се използва не само при запис, но и при гледане, като мащабиране и позициониране на кадър при използване на апаратни средства на видеокартата, каквото е реализирано непосредствено в програмата Behold TV е лишено от посочените недостатъци.

  • Пълно описание на функции и настройки на плъгина се намира тук .


Topic: При запис

При запис

Видеообработка при запис

В определени случаи настройки за запис в Behold TV пряко или косвено кореспондират с възможности за използване на плъгини.

По-долу са изведени подобни примери на базата на помощната информация към основния пакет Behold TV:

  • «Панел за запис»

    Кадри/сек. - Честота на смяна на кадри в записваното видео. В зависимост от текущия формат (NTSC или PAL/SECAM) честотите на кадрите в дадения списък ще бъдат коригирани автоматично (делителят остава неизменен). Важно е да се знае, че в дадената настройка е актуална не абсолютната честота на кадрите, а делителят от оригиналната честота на кадрите. Делителят за PAL/SECAM/NTSC стандарти ще бъде единен.

    Понижени честоти (1/2 и 1/5) могат да се ползват например за запис с охранителен плъгин за да се намали битрейта и да се пести място на HDD.

    Deinterlace~деинтерлейс - При височина на кадър над 288 (240), кодек InterVideo изисква използване на MPEG деинтерлейс. В противен случай ще се виждат „гребеновидни” артефакти и качеството на компресия ще е по-ниско.

    Режими «Blend» дават по-изгладено изображение с незначително намаляване на контраст.

    Режим «Median» не намалява контраста, но дава артефакт тип „стълбица” по границите на наклонени линии.

    Възможно е да не се използват вградени режими на деинтерлейс на InterVideo кодек, а друг деинтерлейс при видеообработка на базата на включвани плъгини.

  • Група «Операции с видеополета» - WMV кодек има вграден механизъм за деинтерлейсинг, който може да се използва преди кодиране. Ако входящото видео се явява прогресивно или по желание се използват други начини за деинтерлейсинг на базата на допълнителни плъгини, в списъка трябва да се избере «Не се изпълнява (кодиране едно към едно)».

    Също така кодек "Windows Media Video 9 Advanced Profile" от update Microsoft Windows Media Format Runtime 9.5 и 11 поддържа режим за разделно кодиране на интерлейсни полета. Този режим е силно взискателен по отношение ресурси на CPU и е предназначен основно за възпроизвеждане и извеждане на записаното съдържание на интерлейсни устройства (например телевизор). При разделно кодиране на полета се изисква малко по-висок битрейт.

Общи настройки за видео/аудиозапис

секция

подсекция [image] [image] бутони

- вж. по-долу .

- вж. по-долу .

The contents of При запис

Видеообработка на кадър
Мащабиране и отсечка на кадър
Охранителна система с BPP_BTVGuard


Topic: Видеообработка на кадър

Видеообработка на кадър

Включване и Основни действия с плъгини при запис - Видеообработка на кадър

Вж. също така:

Описание на интерфейса [image] [image] Панел за настройки [image] Видео

« Видеообработка на изображение (режим гледане) ».

Описание на интерфейса [image] [image] Панел за запис [image] Видео/Аудио запис

« Видеообработка на кадър (режим запис) ».

  • - Отваряне на основен диалогов прозорец за настройки за обработка на кадър преди компресиране. Позволява да се използва режим за допълнителна видеообработка, настроен въз основа на допълнително включвани плъгини.

    N.B. Включени плъгини за запис се съхраняват отделно и не се пресичат с включени плъгини за гледане. Освен това, включени плъгини за запис могат да съхраняват в пресети.

    ( full screenshot )

    Този прозорец е предназначен за настройки на видеообработка на изображение при запис. Видеообработката се реализира по метода на включване на допълнителни модули-плъгини.

    В случай, че се осъществява запис с ползване на апаратен MPEG енкодер, програмна видеообработка на изображения (шумопотискане, повишаване на острота, гама-корекции и пр.) не е възможна. Въпреки това, при апаратен запис с плъгини може да се контролира паралелния видеопоток, извеждан за гледане и по този начин да се управлява процесът на запис. По този начин плъгини като

    «Детектор на логотипи» и

    «Детектор на движение»

    ще изпълняват своите функции и в нужните моменти от време ще включват, спират и прекъсват на пауза запис.

    В прозореца се намират двете основни групи за настройки на плъгини -

  • Група «Използвани филтри за процесинг» и

  • Група «Използван филтър за деинтирлейсинг».

Разширени описания на Настройки се намират в раздел Описание на интерфейса, както е посочено по-горе.

Програмни инструменти:

  • - вж. по-долу .

The contents of Видеообработка на кадър

Особености в режим Таймшифт


Topic: Особености в режим Таймшифт

Особености в режим Таймшифт

Особености при включване на Таймшифт (Timeshift)

По отношение на видеообработка с плъгини, като специфичен случай на запис

(вж. също «Функции и @ настройки» [image] Функция TimeShift ),

включване (активиране) на Таймшифт оказва пряко влияние върху работа с плъгини в зависимост от зададените индивидуални настройки на функцията в

  • Група за настройки «Параметри за видео запис»:

    Изключване на видеообработка при гледане – Да не се използва видеообработка с плъгини по време на работа на функция «Таймшифт».

(вж. също Описание на интерфейса [image] Панел за настройки [image] Видео [image] TimeShift ).


Topic: Мащабиране и отсечка на кадър

Мащабиране и отсечка на кадър

Мащабиране позициониране и отсечка на кадър при запис

В Behold TV посочените операции могат да бъдат извършвани както с вградени програмни инструменти, така и при използване на плъгини.

Вж. също така:

  • Мащабиране/пропорции на кадър/видеопрозорец ;

  • Отсечка и мащабиране на кадър в Behold TV .

Предвид основното предназначение на тази обособена част от цялостния помощен материал, в раздела следва описание на

  • Плъгин за « [image] Мащабиране и [image] позициониране на кадър »

  • «Отсечка на кадър» с използване на плъгин: Независимо от вградения собствен мощен инструментариум за обработка на видеоизображение в Behold TV, в някои определени случаи за същите цели могат (препоръчва се) да се използват плъгини.

    Подобна ситуация е такава, при която се налага борба само с артефакти по граници на кадър, при което е най-добре е да се използва плъгин за видеообработка «Запълване на граници» -

    ,

    без да се използва отсечка в основната програма.

  • Допълнение: отсечка на кадър в Behold TV: Съгласно забележките в уводната част, за разширяване на информационното съдържание в темата е допълнен раздел « Отсечка и мащабиране на кадър » от основното приложение Behold TV.

    Обща забележка

    При запис в MPEG не се препоръчва да се използват мащабиране или отсечка поради нарушаване на стандартните размери на кадър, приети за MPEG.

The contents of Мащабиране и отсечка на кадър

BPP_Scaler


Topic: BPP_Scaler

BPP_Scaler

- Плъгин за мащабиране и позициониране на кадър при запис

(вж. дъщо така по-долу използване при гледане; Мащабиране на кадър ).

диалогов прозорец за настройки на плъгина [image] :

Със средствата на плъгина могат да се отстраняват ефекти ( [image] дефекти) по краищата на кадър чрез разтягане и позициониране на кадър, без да се прибягва до стандартни процедури за отсечка по границите на кадър с последващо възстановяване на размери до изходни такива.

При използване на плъгина трябва да се помни, че:

~изместване на интерлейсен кадър с нечетно количество редове по вертикал

е еквивалентно на ~

~смяна на ред на последователност на полета във видеоред.

Аналогична ситуация, но не с цял кадър, а с групи редове се получава при мащабиране на кадър по вертикал. Ако такъв видеоред се пусне през някои типове деинтерлейс филтри, то освен трептене на изображение в динамични сцени, на екран може да се наблюдава подобна на следната картина:

Поради това преди мащабиране интерлейсен кадър трябва да бъде обработен предварително с деинтерлейс филтър. Ако все пак се налага да се съхрани интерлейсна структура на кадър, то всички операции с позициониране и мащабиране с плъгина трябва да се извършват при [image] включена настройка «Масштабирование по полям»~«Мащабиране по полета».

«Мащабиране по полета» е универсална настройка, която работи еднакво добре както с прогресивен, така и с интерлейсен кадър. Въпреки това тази настройка може да внася някои изкривявания във вид загуба на острота по вертикал и раздвояване на дребни елементи от изображението. Поради това, ако видеоред е видимо прогресивен, тази настройка е по-добре да бъде изключена.

Деинтерлейсинг и мащабиране по полета се изключват автоматично при разделителна способност под 288 линии по вертикал.

Предвид описаното по-горе, плъгин BPP_Scaler може да се използва не само при запис, но и при гледане, но мащабиране и позициониране на кадър при използване на апаратни средства на видеокартата, каквото е реализирано непосредствено в програмата Behold TV е лишено от посочените недостатъци.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина. | 15.04.2008 |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 16.09.2009 | BPP_Scaler_v101.zip (19 kb)


Topic: Охранителна система с BPP_BTVGuard

Охранителна система с BPP_BTVGuard

На базата на ТВ тунер Beholder и плъгин BTVGuard може да бъде реализирана несложна, но пълноценна охранителна система с възможност за детекция на движение в избрани активни зони и запис на видеофрагменти или отделни кадри за настъпили събития в кадър от съответните зони.

Описанието на плъгина е изведено отделно, доколкото се реализират по-специфични функции от обичайна видеообработка при гледане или запис. Освен това, при съчетание на тунер Beholder+BTVGuard плъгин възможностите се разширяват допълнително чрез реализиране на безплатна охранителна система. Самият плъгин има достатъчно функции и настройки, които дават основание да бъде характеризиран като отделна "програма в програмата".

За въвеждане на плъгина в действие е необходимо само да бъде посочен

  1. източник на видеоданни, които трябва да се анализират за движение (обикновено камера),

    след което трябва просто да се зададе

  2. действие, което да се изпълнява в случай на установено движение.

    Такова действие може да бъде издаване на звуков сигнал, изпълнение на команда или запис на звук/видео/кадри със зададена честота. BPP_BTVGuard може да бъде особено полезен например за наблюдение на район до жилището, зони за достъп и пр.

Интерфейс и настройки:

  • Група «Канал»: Плъгинът се активира и работи само с определен избран ТВ-канал или външен видеовход на тунера.

    Необходим канал се избира от падащия списък в индивидуалния прозорец за настройки на плъгина,

    или се

    приравнява към текущия с натискане на бутона в ляво от списъка с канали.

    По аналогичен начин плъгинът може да бъде изключен, като в списъка се избере ред «Канал не выбран».

  • Група «Маска»:

    «Выделить всю маску»~«Определяне ва цялата маска»

    «Очистить маску»~«Изчистване на маска»

    «Инвертировать маску»~«Инвертиране на маска»

    «Загрузить маску»~«Зареждане на маска»

    «Сохранить маску»~«Съхраняване на маска»

    «Сохранить маску как...»~«Съхраняване на маска като...»

  • Избор на чувствителни към движение активни зони са извършва с [image] клик във видеопрозореца при активен прозорец за настройки на плъгина. Пак там (в прозореца за настройки), с натискане на един бутон могат да се премахнат (или обратно – да се определят) всички активни зони, както и да се инвертират вече съществуващи маркирани елементи. Получената маска трябва да се съхрани във файл. При последващо пускане на приложението, по подразбиране ще бъде заредена последно съхранена маска.

  • Група «Детектор движения»~«Детектор на движение»:

    Настройка «Чувствительность»~«Чувствителност» задава на детектора праг за чувствителност към изменения в кадър. Колкото по-висока е тази стойност, толкова по-чувствителен е детекторът.

    Настройки «Цвет»~«Цвят» позволява да се избере (или обратно – да се изключи) цвят, който няма да участва при работата на детектора за движение. Стандартна настройка е детекция на движение по яркостна съставляваща на изображението, т.е. по черно-бяло изображение.

    «Изменения в (брой кадри)» За предотвратяване на лъжливо сработване, на детектора може да се зададе да реагира на събитие само в този случай, когато е имало активност в определените зони в няколко кадъра поред. В процеса на извършване на обработка на статистиката, определената зона се осветява в син цвят (по подразбиране–цвят «Опасност» в настройките за визуализация). Ако е фиксирано събитие, то определената зона се маркира в червено (цвят «Тревога») и се стартира един от избраните механизми за реакция на събитие.

    С настройка «Длительность»~«Продължителност» се задава в течение на колко време плъгинът да реагира на събитие, т.е. колко време да протича запис и да се издава звуков сигнал след детекция на движение в кадър.

Група параметри «Реакция на событие»~«Тип реакция при събитие»:

  • Подсекция «Запись»:

    «Вкл.»~«Включване» на запис:

    При събитие в кадър са достъпни следните действия в режим на запис:

    ~правене на снимка;

    ~съхранение на серии от снимки;

    ~запис на видеофайл - Ако за реакция на събитие е избран режим «Запись видео»~«Запис на видео», то за работа на детектора за движение плъгинът трябва да бъде добавен в списъка с плъгини за видео запис във всички използвани за запис пресети. В противен случай след стартиране на запис плъгинът няма да може да отброи зададения интервал от време и да спре записа.

    «Запись с паузой»~«Запис на видео с пауза». Режим на запис с използване на пауза дава възможност да се натрупват всички видеофрагменти с «Тревога» в един файл. За работа в този режим програмата трябва да се работи в режим на гледане. След първото събитие плъгинът самостоятелно ще превключи записа на пауза.

  • Подсекция «Звук»:

    «Звуково оповестяване»: При избор на звуков фрагмент за оповестяване, същият може да бъде прослушан и да се настрои за циклично възпроизвеждане, при което звуковият фрагмент ще се възпроизвежда непрекъснато в течение на цялата зададена продължителност за събитието.

    «Вкл.»~«Включване» на оповестяване.

    «Выбрать аудио файл»~«Избор на аудио файл» (отваря стандартен browser-Windows Explorer за избор на файл).

    «Остановить воспроизведение»~«Спиране на възпроизвеждане»

    «Воспроизвести файл»~«Възпроизвеждане на файл»

    «Воспроизведение в цикле»~«Циклично възпроизвеждане»

  • Подсекция «Процесс» - стартиране на външен процес.

    Плъгинът не може да управлява самостоятелно външни устройства, но позволява стартиране на изпълними файлове за външни процеси, на които от своя страна могат да бъдат възлагани функции, например за включване на по-мощна сигнализация, средства за оповестяване и пр. Стартиран външен процес трябва да може самостоятелно да се разтоварва от паметта след изпълнение на своята задача.

    «Выбрать исполняемый файл»~«Избор на изпълним файл» (отваря стандартен browser-Windows Explorer за избор на файл).

    «Запустить внешний процесс»~«Стартиране на външен процес»

    «Разрешить повторный запуск процесса»~«Разрешаване (забраняване) на повторно стартиране на процес» - може да бъде разрешено/забранено повторно пускане на външен процес, ако такъв няма защита от стартиране на свое копие.

Група параметри «Визуализация»:

- настройки на множество елементи:

  • формат за дата/време (допълнителна информация за макроси - вж. по-долу),

  • разположение

  • цвят [image] ,

  • шрифт [image],

  • прозрачност на активните зони и отметки на екрана, както и

    какви елементи на визуализация да се изобразяват на екран в режим на наблюдение и в записания файл.

Плъгинът също така може да изпълнява своите функции при запис* с апаратен енкодер (пускане/спиране на запис при събитие и пр.), но избрани елементи за визуализация на записвано във файл изображение няма да се натрупват.

* Параметри, като

  • формати на видео- и аудиофайлове,

  • ограничения за размер на файл,

  • честота на снимане и формат на снимки, както и

  • други настройки

    се задават непосредствено в секция «Запис» на самата основна програма Behold TV.

Макроси:

Формат за извеждане на дата/време се задава с помощта на макроси, които сами по себе си представляват двойки символи, започващи със знак «%».

Списък с макроси:

%a – ден от седмицата съкратено ( Пн, Вт, Ср, Чт, ... )

%A – ден от седмицата пълно ( понеделник, вторник, ... )

%b – месец съкратено ( яну, фев, мар, апр, ... )

%B – месец пълно ( Януари, Февруари, ... )

%c – дата и време в съответствие с локалните настройки

%d – ден от месеца ( 01...31 )

%H – часове ( 00...23 )

%I – часове ( 01...12 )

%j – ден от годината ( 001...366 )

%m – месец ( 01...12 )

%M – минути ( 00...59 )

%p – текущ локален индикатор A.M./P.M.

%S – секунди ( 00...59 )

%U – седмица от годината с първи ден от седмицата събота ( 00...53 )

%w – ден от седмицата ( 0...6 )

%W – седмица от годината с първи ден от седмицата понеделник ( 00...53 )

%x – дата в съответствие с локалните настройки

%X – време в съответствие с локалните настройки

%y – година без столетие ( 00...99 )

%Y – година със столетие

%z – име или абревиатура на часовия пояс

%Z – име или абревиатура на часовия пояс

%% – символ %

Примери:

%H:%M | 13:20
%X | 13:20:45
%x %X (Северен паркинг) | 05/06/07 13:20:45 (Северен паркинг)
%d %B %Y год %H час %M мин %S сек | 05 Юни 2007 год 13 час 20 мин 45 сек

За по-удобна работа с макроси, същите могат да бъдат избирани от меню, което се извиква с десен клик в прозореца за редактиране на формат за извеждане.

Всякакъв различен от макрос текст, поставен в прозореца за редактиране, се изобразява на екран без изменение.

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
2.00 | Добавено е автоматично съхранение на настройки отделно за всеки потребителски профил; Свалени са ограниченията за формати на видеопоток (YUY2/RGB24); Добавена е настройка за чувствителност по цвят; Добавена е възможност за звуково оповестяване при сработване на детектора; Добавена е възможност за стартиране на външно приложение при сработване на детектора; Добавени са режими за запис при събитие със задаване на пауза; Добавена е настройка на атрибути и формат за извеждане на дата/време; Добавена е настройка за цвят и прозрачност на активните зони. | 22.07.2005 |
2.01 | Реализирано е съхранение на настройки в Windows 7 |  |
2.02 | Поправена е грешка при регулиране на звук след ръчно спиране на запис | 28.10.2009 | BPP_BTVGuard_v202.zip (47 kb)
2.03 |  | 01.03.2011 | BPP_BTVGuard_v203.zip (67 kb)


Topic: Плъгини за Деинтерлейсинг (BPDеinterlace)

Плъгини за Деинтерлейсинг (BPDеinterlace)

Плъгини за Деинтерлейсинг (BPDеinterlace)

  • „Деинтерлейсинг” е алгоритъм за премахване на т.н. "гребеновидни" (рус.”расческа”, англ."comb") артефакти, които се проявяват при извеждане на изображение от междуредов източник на прогресивен дисплей (вж.« Interlace / Progressive изображение »).

Процесите по деинтерлейсинг представляват частен случай на

  • Процесинг - обработка на кадър с цел премахване на интерлейсна (междуредова) структура.

Плъгини за деинтерлейсинг трябва да отчитат ред параметри на видеопотока, които не са задължителни за обичайния процесинг с плъгини, поради което такива деинтерлейс-плъгини са изнесени в отделна група.

Плъгини за деинтерлейсинг (.dll-файлове с префикс BPD_) в Behold TV могат да се използват както в

  • В режим на гледане (Диалогов прозорец в « Панел за настройки » [image] ), така и

  • В режим на запис (Диалогов прозорец в « Панел за запис » [image] )

Интерфейсът на прозорците за настройки и основните действия в същите са еднотипни при различните режими.

Избор на плъгин се осъществява в група «Използван филтър за деинтерлейсинг»

от "падащо" меню с инсталирани в програмата плъгини:

Може да бъде избран само един плъгин, който ще се занимава с деинтерлейсинг. Деинтерлейсинг работи само при извеждане на двете видеополета на кадър, т.е. когато височината на кадър е избрана в размери

  • 576 за PAL/SECAM (напр. 768x576) или

  • 480 за NTSC (напр. 720x480).

    В процеса на работа на Behold TV телевизионен кадър се предава последователно на всеки плъгин по веригата .

    Обработка на кадър се завършва от плъгин за деинтерлейс.

The contents of Плъгини за Деинтерлейсинг (BPDеinterlace)

I / P изображение
BPD_Smart
BPD_Blend2
BPD_Blend3
BPD_BClip
BPD_FieldBob
BPD_Bob
BPD_Motion


Topic: I / P изображение

I / P изображение

Интерлейсно и прогресивно изображение.

Деинтерлейсинг.

Удвояване на честота на кадри.

Телевизионно изображение се предава покадрово, с честота 25 кадъра в секунда.

Всеки кадър се предава на два етапа – първо четни, после нечетни редове на кадър.

Полукадър, съставен от четни или нечетни редове, се нарича поле.

Обикновено се казва, че телевизионно изображение се предава с честота

  • 25 кадъра/сек. или

  • 50 полета/сек.

Две последователни полета могат да са части от един цял кадър. Такива кадри се наричат „прогресивни”.

В същото време, всички полета могат да представляват отделни независими полукадри, заснети с удвоена честота 50 Нz и тогава пълни кадри, сглобени от такива полета се наричат „интерлейсни” (от англ. Interlace – последователност, или в частност редуване на телевизионни редове).

Това, какъв се явява даден кадър - прогресивен или интерлейсен, зависи от изходния видеоматериал и снимачната апаратура на предаващата страна.

Обикновените телевизори приемат и извеждат кадри на екран по реда на постъпване на полетата. Редовете на всяко следващо поле се извеждат в промеждутъците между редовете на преходното поле.

При компютрите видео се изобразява по-различно. Цифровизирани кадри се пренасят на екрана на монитора с честота 25 кадъра/сек. изцяло, т.е. по две полета едновременно.

Ако при това видеоред се явява интерлейсен, то при всяко движение в кадъра ще се вижда неговата междуредова структура. За да се избегне този неприятен ефект при гледане и запис се използват така наречените

Деинтерлейс филтри, които премахват от кадъра част от информацията, с което го правят прогресивен.

Интерлейсен видеоред обаче е характерен именно с това, че за разлика от прогресивно видео е способен да предава два пъти повече фази на движение на подвижни обекти на екрана.

За да бъде съхранена по-голяма част от видеоинформацията и в същото време да се премахне т.н. „гребеновиден” ефект (рус.”расческа”), който възниква поради интерлейсинг, при гледане на видео на компютър се прибягва към удвояване на честотата за извеждане на кадри на екран.

При удвояване на честотата на кадри се обезпечава максимална плавност на движения на екран, което в съчетание с деинтерлейс филтър прави гледане на видео на компютър по-комфортно, отколкото на телевизор.

  • Режим на гледане - Група «Механизъм за удвояване честотата на кадрите» вж. също « Включване и настройки на плъгини »

Избор на деинтерлейс филтър и включване на режим за удвояване на честота на кадри при гледане се осъществява от меню

в настройки [image] на Behold TV.


Topic: BPD_Smart

BPD_Smart

BPD_Smart е плъгин за премахване на "гребеновидни" ефекти, който се отнася към клас деинтерлейс-филтри, осъществяващи филтрация на четни/нечетни редове на кадър само за подвижни участъци в телевизионно изображение.

Индивидуален прозорец за настройки:

  • Чувствителност - Регулиране на интензивност (интензитет) на картата за движение (вж. по-долу) и определяне на дълбочина на филтрация на редовете на изображение:

    При ниска чувствителност ще се забелязва интерлейсна структура на кадър.

    При завишена чувствителност филтърът може да оказва въздействие върху неподвижни участъци на изображение поради аналогови шумове.

  • Инерционност - Въвеждане на закъснение за обновяване на картата за движение. Това позволява да се намали вероятността от появяване на артефакти, възникващи поради еднородност и периодичност на процесите, които протичат в кадър.

  • Карта на движение - В процеса на работа на филтъра се построява т.н. карта на движение, която сама по себе си представлява разновидност на съответните полета на текущ и предходен кадър.

    Построяване на карта за движение се изпълнява по яркостна съставляваща на изображение.

  • Обработка на цвят - При включване на опцията картата за движение се допълва с информация за изменение на цвят, с което се повишава надеждността на работа на филтъра.

    Допълнителна обработка на цвят незначително повишава натоварването на CPU при работа с кадър във формат YUY2 (извеждане на видео чрез овърлейни повърхнини, VMR9, EVR);

    натоварването на CPU значително намалява, ако кадър е във формат RGB24 (режим на извеждане на видео чрез първична повърхнина).

«За плъгина»«About» - прозорец с информация за текущо инсталирана версия.

Хронология:

Версия | Описание |  | Download
1.00 | Първа версия на плъгина. |  |
1.01 | Реализирано е съхранение на настройки в Windows 7 | 16.09.2009 | BPD_Smart_v101.zip (16 kb)
1.02 | Добавлена поддержка инстансов Behold TV. | 01.03.2011 | BPD_Smart_v102.zip (17 kb)


Topic: BPD_Blend2

BPD_Blend2

BPD_Blend2 - Билинейна филтрация на съседни ("смежные") редове с четно и нечетно поле.

Висока скорост на обработка. Добро качество. Понижава острота по вертикала.

Хронология:

Версия | Описание |  | Download
 |  | 08.02.2005 | BPD_Blend2.dll (4 kb)
 |  | 01.03.2011 | BPD_Blend2_v110.zip (2 kb)


Topic: BPD_Blend3

BPD_Blend3

BPD_Blend3 - Трилинейна филтрация на съседни ("смежные") редове с четно и нечетно поле.

Висока скорост на обработка. Добро качество. Понижава острота по вертикала.

Хронология:

Версия | Описание |  | Download
 |  | 08.02.2005 | BPD_Blend3.dll (4 kb)
 |  | 01.03.2011 | BPD_Blend3_v110.zip (2 kb)


Topic: BPD_BClip

BPD_BClip

BPD_BClip - Адаптивно използване на разграничени и неразграничени (рус."отсечённые, не~") пиксели за нечетни редове.

Ниска скорост на обработка. Високо качество.

Хронология:

Версия | Описание |  | Download
 |  | 27.10.2004 | BPD_BClip.dll (5 kb)
 |  | 01,03,2011 | BPD_BClip_v110.zip (3 kb)


Topic: BPD_FieldBob

BPD_FieldBob

BPD_FieldBob - Пресмятане на редове на едно поле по пътя на интерполация на съседни редове на друго поле.

Много висока скорост на обработка. Ниско качество.

Хронология:

Версия | Описание |  | Download
 |  | 27.10.2004 | BPD_FieldBob.dll (4 kb)
 |  | 01.03.2011 | BPD_FieldBob_v110.zip (2 kb)


Topic: BPD_Bob

BPD_Bob

BPD_Bob - Обработка на полета по границите на интерлейс по метод Bob.

Висока скорост на обработка. Добро качество.

Индивидуален прозорец за настройки:

«Порог обнаружения интерлейса»~«Праг (гранична стойност) за детекция (регистриране) на интерлейс».

~

Хронология:

Версия | Описание |  | Download
 |  | 27.10.2004 | BPD_Bob.dll (7 kb)
 |  | 01.03.2011 | BPD_Bob_v130.zip (4 kb)


Topic: BPD_Motion

BPD_Motion

BPD_Motion - Избор на текущ или предходен пиксел с по-малък фактор на интерлейс и допълнителна отсечка.

Средна скорост на обработка. Високо качество.

Индивидуален прозорец за настройки:

«Порог обнаружения интерлейса»~«Праг (гранична стойност) за детекция (регистриране) на интерлейс».

~

Хронология:

Версия | Описание |  | Download
 |  | 08.02.2005 | BPD_Motion.dll (8 kb)
 |  | 01.03.2011 | BPD_Motion_v130.zip (5 kb)


Topic: Други

Други

Други:

Описание | Препратка
Конфигурационни файлове за програми LIRC и WinLIRC . 14.03.08 | lirc.zip (3 kb)
Плъгин с поддръжка на хибриден тунер Behold TV H6 за интернет-прихващане в програми SkyNet и Manna. Версия 1.1 поддържа технология DUAI, която позволява да се избира от кой вход да се осъществява прихващане. 02.07.09 | Streamreader_v11.zip (17 kb)
Покадрова снимка на «оживяващо» растение. Параметри на снимане: камера - SONY Handycam Video 8, TV тунер - Behold TV Columbus, режим – серия снимки с интервал 2 минути в течение на 10 часа. 20.09.06 | Flower.wmv (510 kb)
Примери за захват на видеофрагмент в два различни формата – mpg и wmv. Параметрите на запис са посочени в съответните log-файлове. Видеоизточник – S-Video изход DVD Panasonic S75. 20.09.06 | MPG_Sample.zip (7.2 Mb) WMV_Sample.zip (2.4 Mb)
Примерни екранни снимки от S-VHS вход на тунера. Видеоизточник – S-Video изход DVD Panasonic S75. 20.09.06 | Pictures.zip (1.3 Mb)
Сервизен инструмент за работа с тунери BeholdTV. 18.11.08 | BhDebug_v12.zip (229 kb)
Официален плъгин за поддръжка на пулт за ДУ на телевизионни тунери Behold TV в програма SlyControl 2 ( www.slycontrol.ru ). 20.09.06 | SlyControlRC_v14.zip (39 kb)
Официален плъгин за поддръжка на пулт за ДУ на телевизионни тунери Behold TV в програма Girder ( www.promixis.com ). 20.09.06 | GirderRC_v13.zip (8 kb)
Плъгин за програма Radiator FM ( flesko.cz ). 20.09.06 | RadiatorFM_v13.zip (12 kb)
Допълнения - публикации в официалния форум: |
Плъгин за приемане на амплитудно модулирани (АМ) сигнали (например канали в авиационен диапазон ) BGОписание и настройки - тук . | BPP_AMRc.dll


Topic: За програмисти

За програмисти

За програмисти:

Набор от инструменти за самостоятелно разработване на различни плъгини за Behold TV

API & SDK

За запознати с езици за програмиране C, C++ или Delphi, ако има идеи как да се направи програма Behold TV още по-мощна и функционална, или ако има желание просто да се премерят сили при обработка на видео в реално време, Beholder предоставя такива възможности. В раздел API & SDK може свободно да се свали цялата необходима документация, която е специално разработена за написване на плъгини за Behold TV.

  • API & SDK документация с примери за писане на плъгини Behold TV на C++ и Delphi.

  • API за организиране на поддръжка на пулта за ДУ Behold TV в собствени приложения.

  • Определения на Windows-съобщения, с помощта на които може да се управлява Behold TV.

Необходими файлове могат да се свалят от тук .

Помощ по всички въпроси може да се намери в специализирания раздел на форума в официалния сайт.

Списък с публикувани в официалния сайт материали за download:

Описание | Препратка
API&SDK документация с примери за писане на плъгини за BeholdTV (C++, Delphi) 25.01.05 | PluginsSDK.zip (80 kb)
API, позволяващ да се организира поддръжка на пулта за ДУ BeholdTV в собствени приложения. 19.05.10 | BeholdRC_v22.zip (17 kb)
Заглавен файл с определения на Windows-съобщения, с помощта на които може да се управлява приложението BeholdTV. 11.12.09 | BhMsg_v510.zip (6 kb)


Topic: Описание на интерфейса

Описание на интерфейса

Интерфейс на Вehold TV

? Интерфейсът на софтуерния комплекс Behold TV се развива непрекъснато в съответствие с внедряването на най-съвременна елементна база (чипсети, ВЧ модули, енкодери и пр.), иновационни технологични решения и пр. При всяка нова серия се реализират нови хардуерни възможности и полезни функции, респ. се актуализират и допълват драйверите и софтуерният пакет, разширяват се и опциите за настройки.

Както е посочено в предговора, при инсталиране и тестване на софтуера е използван самостоятелно разработен от автора български интерфейс , който е актуализиран до последната публикувана версия на програмата. При желание ползване на български език е достъпно още на най-ранен етап - в първия диалогов прозорец за конфигуриране на Behold TV след успешно инсталиране на драйвер.

Процедурата за вграждане на български интерфейс представлява елементарна файлова операция и е онагледена подробно в отделен раздел.

За потребители, които не срещат затруднения с английски или руски език тази информация може да бъде пренебрегната - в инсталационния диск и на официалния сайт е поместена обширна информация и Help на тези езици.

The contents of Описание на интерфейса

Панел за настройки
Панел за запис


Topic: Панел за настройки

Панел за настройки

Вehold TV - Панел за настройки

? Основният панел за настройки се извиква

  • с натискане на бутон «Настройки» в основния панел за управление, или

  • 1 от едноименния команден ред [image] в контекстното меню

    (отваря се с 8 десен клик в областта на видеопрозореца на Behold TV при гледане).

The contents of Панел за настройки

5. Видео
8. Интерфейс
9. Таймшифт


Topic: 5. Видео

5. Видео

5. Секция за настройки на видео параметри N при гледане:

...

  • – Извикване на диалогов прозорец за настройки на видеообработка на изображение с използване на допълнителни плъгини за всевъзможни ефекти на обработка.

    (? видеообработка [image] при запис - отделно !)

......

The contents of 5. Видео

5.1. Видеообработка на изображение (режим гледане)


Topic: 5.1. Видеообработка на изображение (режим гледане)

5.1. Видеообработка на изображение (режим гледане)

Описание на интерфейса - Панел за настройки

N в режим на гледане

5.1. Настройки за видеообработка на изображение с използване на плъгини

Вж. също:

Включване и Основни действия с плъгини_Плъгини за Процесинг_При запис_

_« Видеообработка на кадър »;

Описание на интерфейса_Панел за запис_Видео/Аудио запис_

_« Видеообработка на кадър (режим запис) ».

Този диалогов прозорец е предназначен за настройки на видеообработка на изображения при гледане.

: Видеообработка с плъгини е възможна също така и при запис - както от ефирни ТВ предавания, така и от външни източници. Трябва да се помни, че видеообработка в различни режими (запис и гледане) са отделни процеси, респ. настройките при запис са обособени от тези за гледане в отделен раздел на панела за запис .

i Видеообработка се реализира чрез допълнително включване на плъгини.

i Видеообработка не е достъпна в DVB режим на тунера.

2 Диалогов прозорец за настройки - Описание на интерфейса:

  • Група «Използвани филтри за процесинг» - Списък с плъгини за видеообработка и/или наслагване на всевъзможни ефекти.

    В зависимост от включените плъгини може да се сменя тяхната последователност за изпълнение/приоритет.

    Възможно е временно да се деактивира(т) даден(и) плъгин(и), като се свали отметката в съответен "чекбокс".

    @ За да могат да бъдат добавяни в менюто за видеообработка, плъгини за процесинг (файлове с префикс BPP_ и разширение .dll) трябва да бъдат разархивирани и да се намират в директория [image] ...\BeholdTV\Plugins\ ...

    ... ? Информацията е изнесена в раздел « Интегриране в програмата »

    § Поле с «Бутони за управление на списъка с плъгини за процесинг»:

    + Добавяне на плъгин в списъка (при добавяне нов плъгин същият автоматична се подрежда в последната по ред позиция) от меню с достъпни ( инсталирани ) плъгини (? вж. също последователност/приоритет!):

    - Премахване на плъгин от списъка (? различно от активиране/деактивиране!);

    / [image] - бутони за разместване на зададен ред* (респ. в посока към началото или края на същия) за вече налични в списъка плъгини.

    *Важно! При разместване на плъгини не се променя просто тяхното местоположение, а се изменя и редът за инициализиране и изпълнението на същите, респ. се повишава или понижава приоритет на съответен филтър, което от своя страна е пряко свързвано с натоварване на процесора и системата! (*вж. по-долу приоритет на плъгини).

    ? В долната част на списъка се извежда «Информационно поле» с

    кратко описание и версия** на съответния маркиран плъгин:

    ** Плъгините, които се публикуват на официалния сайт могат да имат по няколко различни версии. Както и при различни други приложения, това е свързано с усъвършенстване, доработка(и) и/или отстраняване на грешки на даден плъгин. Актуални версии се предоставят с инсталационния диск в комплекта, но въпреки това се препоръчва периодично да се проверява за актуализации и нови версии.

    ? В диалоговия прозорец могат да са достъпни различни допълнителни настройки, които са специфични за всеки отделен плъгин в зависимост от индивидуалните особености на самите плъгини:

  • Ако при избор на ред [image] от контекстното меню на видеопрозореца за гледане в списъка на подпрозореца вече има включени плъгини,

    при селекция на друго меню освен «Конфигурация» (респ. плъгин за процесинг или за деинтерлейсинг) директно се отваря индивидуален прозорец за настройки на съответния плъгин.

  • Освен по посочения по-горе начин, с

    § десен клик_ [image] върху реда на съответния [image] маркиран като «активен» плъгин, или

    § чрез бутон

    може да се отвори индивидуален диалогов прозорец за допълнителни настройки на маркиран

    плъгин за процесинг от съответен ред в подпрозореца, например [image] :

    и/ или избран

    филтър за деинтерлейсинг, например [image] :

    i Описания на индивидуални диалогови прозорци за допълнителни настройки за различните плъгини се намират в раздел «Включване и настройки на плъгини»_съответните секции « Плъгини за Процесинг (BPProcessing) » и « Плъгини за Деинтерлейсинг (BPDеinterlace) » на всеки отделен плъгин.

  • Група «Използван филтър за деинтерлейсинг» - Избор на достъпен плъгин за деинтерлейсинг.

    & „Деинтерлейсинг” е алгоритъм за премахване на артефакти тип "гребен" (comb), които се проявяват при извеждане на изображение от междуредов източник на прогресивен дисплей.

    i Може да се избере само един плъгин, който ще се занимава с деинтерлейсинг.

    & Деинтерлейсинг работи само при извеждане на двете видеополета на кадър, т.е. когато височината на кадър е избрана 576 за PAL / SECAM (например 768x576) или 480 за NTSC (напр. 720x480).

    ...

    Диалогов прозорец за допълнителни настройки - вж. по-горе.

    «Информационно поле» с кратко описание на избран плъгин - вж. по-горе.

    ...

@ Програмни инструменти:

  • Група «Механизъм за удвояване на честота на кадри» - Опцията позволява да се управлява честотата на кадри при гледане.

    i С удвояване на честотата на кадри се постига по-голяма плавност на видеоизображение и динамика на сцените, т.е. гледане става комфортно както при битовите телевизори.

    Внимание!!! За максимално качество при използване на ефект за удвояване на честота на кадри е необходимо да се настрои опресняване на кадрова честота на монитора (refresh) кратно на 25 (например 75 Hz; 100 Hz).

    При други стойности ще се наблюдава трептене (рус.”биение”), добре забележимо например при "бягащ ред"!

    Изключен – Използва се стандартно прогресивно извеждане на видео с честота на кадрите 25 кадъра/сек. (30 за NTSC).

    @ За отстраняване на „гребеновидни” ефекти в този режим е необходим програмен деинтерлейс.

    Програмен режим за удвояване на честота (Smart Interleave) - Използва се програмен механизъм за двукратно увеличаване на кадровата честота.

    Внимание! При това се повишава натоварването на CPU (~1,5 пъти)!

    @ За отстраняване на „гребеновидни” ефекти в този режим е необходимо да се активира деинтерлейсинг. Този начин за удвояване на честота на кадри работи само при извеждане на двете видеополета на кадър (*x576 или *x480).

    Апаратен режим за удвояване на честота и деинтерлейс (Interleaved Bob) – Използват се апаратните възможности на видеокартата за извеждане на интерлейсни редуващи се видеополета в овърлей.

    i Този способ работи само при видеокарти, които поддържат апаратно дадената възможност (всички ATI Radeon, nVidia GeForce). Този начин не изисква използване на програмен деинтерлейс и на практика не натоварва CPU.

    Режимът е достъпен само при извеждане на видео в Овърлейна или D3D повърхност (вж. настройки в секция «Видео»).

    Внимание! При използване на апаратни функции за деинтерлейс ефектът е виден само в овърлей, но не и при правене на екранни снимки от приложението.

    Този метод се препоръчва за видеокарти ATI Radeon съвместно с включена опция «Използване на VMR». Видеокарти ATI Radeon могат да изпълняват метода Interleaved Bob без тремор (трептене) на редовете и с минимални загуби на контраст по вертикала, тъй като имат блок за апаратен попикселен адаптивен деинтерлейсинг.

    Видеокарти nVidia GeForce с апаратен блок PureVideo също могат да изпълняват апаратен попикселен деинтерлейсинг.

    $ Останалите видеокарти нямат пълноценен апаратен попикселен деинтерлейсинг и изпълняват обикновен BOB, който предизвиква трептене (тремор на редовете), както и намаляване на остротата по вертикал.

Забележка: Допълнителни плъгини могат да бъдат свалени от сайта за техническа поддръжка .


Topic: 8. Интерфейс

8. Интерфейс

8. Секция за настройки на интерфейс:

Основни настройки в секция «Интерфейс» на Behold TV, които имат пряко отношение към видеообработка с плъгини

...

  • Опция «Избор на език» за интерфейс - променя се също интерфейсът на диалогови прозорци за плъгини.

    Ресурсни файлове за поддръжка на езици се намират в папка [image] ...\LangRes (? основна информация за инсталиране на български език вж. тук ).

...

  • Група «Опции за запис»:

    Блокиране на поток за гледане при старт на запис от tray - респ. се блокира видеообработка с плъгини в режим на гледане.

    При включване на опцията, ако програмата се намира в режим на очакване (свита в tray), при команда за предварително зададен запис от вградения модул за планирани задачи, потокът при гледане ще бъде принудително изключен за намаляване натоварването на системата (? вж. също така опция [image] « Да не се извежда записвано видео при гледане »).

    Предполага се, че в случая програмата работи в отсъствие на потребителя. Ако не трябва да се прекъсва гледане на ТВ програма тази опция трябва да се изключи.

    Блокиране смяна на ТV и FM канали в режим на запис – респ. видеообработка с плъгини в режим на запис.

    Опцията забранява превключване на канали ако е активен процес на видео- или аудио запис*,

    (освен за режим на * излъчване в IP-мрежа ).

...

  • Група «Допълнителни опции»:

    Запазване на настройки отделно за всеки профил - отнася се и за настроени опции за плъгини за отделни потребители.

    По подразбиране програмата запазва всички свои настройки в .ini и .cfg файлове в текущата системна папка на приложението. При използване на няколко потребителски профила в една система (само под Windows 2000/XP/2003/Vista/7), може да се използва запазване на индивидуални настройки на програмата за всеки отделен потребителски профил.

    По подразбиране файлове за настройки се съхраняват в папки

    "C:\Documents and Settings\[Потребителско име]\Application Data\BeholdTV\".

    Тази функция също така позволява работа на потребители без административни права съвместно с потребители, които имат такива права. При файлова система NTFS на потребители без административни права по подразбиране е забранен запис на файлове, създадени от потребители с административни права.

    Внимание! Windows Vista / 7 по подразбиране използват UAC (User Account Control), който понижава привилегиите на потребителите и дори за такива с административни права блокира достъп за запис в болшинството системни папки, в т.ч. и в папка Program Files. Поради това за нормална работа под Windows Vista / 7 тази опция трябва да бъде изключена - в противен случай приложението няма да може да съхранява своите настройки.

    Файлове за настройки под Windows Vista се съхраняват в папки

    "C:\Users\[Потребителско име]\Application Data\Roaming\BeholdTV\".

    Приоритет на програмата при гледане - Приоритет на основния процес при гледане (не влияе на приоритет при запис).

...


Topic: 9. Таймшифт

9. Таймшифт

9. Секция за @ настройки на функция Таймшифт

@ Настройки на Таймшифт, които оказват пряко влияние върху видеообработка с плъгини като функция, която представлява специфичен случай на запис (вж. & Функции и @ настройки_ Функция TimeShift ).

? вж. също така

~ Включване и Основни действия с плъгини_Плъгини за Процесинг_При запис_Видеообработка на кадър_ Особености в режим Таймшифт ;

За ТВ тунери без апаратен MPEG енкодер:

ТВ тунери с вграден апаратен MPEG енкодер (screenshot - under construction)

...

  • Група за настройки «Параметри за видео запис»:

    Изключване на видеообработка при гледане – Да не се използва видеообработка с плъгини по време на работа на функция «Таймшифт».

    За тунери с вграден апаратен MPEG енкодер е препоръчително да се изключва видеообработка за да се задейства DXVA - апаратно ускорение на процедура iDCT (обратно дискретно-косинусно преобразуване), което ще бъде изпълнявано от страна на видеокартата, респ. се намалява натоварването на CPU при декодиране на MPEG2 видео и се активира режим на последователност на полета и адаптивен деинтерлейсинг, което осигурява по-комфортно гледане на интерлейсно видео със съвременните видеокарти.

......


Topic: Панел за запис

Панел за запис

Behold TV - Панел за запис

Всички настройки за запис на образ и звук са поместени в отделен панел за запис:

? Основният панел за запис се извиква

  • с натискане на бутон «Панел за запис» в основния панел за управление, или

  • 1 от едноименния команден ред [image] в контекстното меню (същото се отваря с 8 десен клик в областта на видеопрозореца на Behold TV при гледане).

The contents of Панел за запис

Видео/Аудио запис


Topic: Видео/Аудио запис

Видео/Аудио запис

Секция за настройки за ВИДЕО/АУДИО запис

вж. също Аудио запис в Behold TV.

  • Група «Пресети за видео/аудио запис»:

    i С помощта на пресети могат бързо да се зареждат нужни настройки за запис. Пресети могат да бъдат създавани и самостоятелно; да се премахват; да се презаписва съдържанието (настройките) им. Ако файл на пресет е с атрибут «Само за четене» (Read Only), бутонът за премахване на пресет ще е неактивен.

    @ За да се създаде нов пресет трябва да се направят необходимите настройки на текущото меню, да бъдат съхранени текущите настройки и да се избере име за новия пресет.

    - Списък от готови пресети за запис с предварително настроени конфигурации.

    - «Съхраняване на текущите настройки в пресет»;

    - «Премахване на пресет».

  • i «Метод за видеозапис» (BG редакция - аналог. "способ", "начин") - В Behold TV се поддържат няколко метода:

    § "Microsoft AVI",

    § "Microsoft ASF",

    § "Microsoft WMV",

    § "Software MPEG",

    § "Hardware MPEG2 DVD".

    За да може да се записва във формати "Microsoft ASF", "Microsoft WMV" е необходима OS Windows XP SP2 и по-висока или инсталиран ъпдейт Microsoft Windows Media Format Runtime - версия 9 или по-висока.

    За да може да се записва във формат "Software MPEG" е необходимо да се инсталира InterVideo WinDVD Creator от втория диск, приложен в комплекта на тунера.

    Видеозапис "Hardware MPEG2 DVD" е достъпен само за ТВ тунери с апаратен (хардуерен) енкодер.

    @ Всеки метод за запис има собствени настройки.

The contents of Видео/Аудио запис

ОБЩИ настройки за ВИДЕО+АУДИО запис
Видеообработка на кадър (режим запис)
Мащабиране на кадър


Topic: ОБЩИ настройки за ВИДЕО+АУДИО запис

ОБЩИ настройки за ВИДЕО+АУДИО запис

ОБЩИ настройки за Видео + Аудио запис

The contents of ОБЩИ настройки за ВИДЕО+АУДИО запис

Настройки Видео
Настройки Аудио


Topic: Настройки Видео

Настройки Видео

ОБЩИ Видео настройки & обработка с плъгини

Видеообработка на кадър – Настройки за обработка на кадър преди компресиране.

Позволява да се използва режим за допълнителна видеообработка, изграден на база на допълнително включвани плъгини.

Включени плъгини за запис се съхраняват отделно и не се пресичат с включени плъгини за гледане. Освен това, включени плъгини за запис се съхраняват в пресет.

Мащабиране на кадър – Настройки, които позволяват да се включи режим за отсечка по границите на кадър, както и да се измени крайния размер на кадър чрез ресемплиране (? англ. "sample" - "образец", аналог. преобразуване, редактиране) на изображение.

Предвид основната цел за представяне на плъгини в Behold TV, с цел разширяване на информацията и илюстриране на някои по-основни моменти, в този материал са направени паралелни връзки между програмните инструменти и използване на плъгини, в следните раздели:

  • Мащабиране / пропорции на кадър / видеопрозорец ;

  • Мащабиране на кадър при запис ;

  • Отсечка и мащабиране на кадър в Behold TV .

    Да не се показва записвано видео при гледане – При запис да не се показва видеопоток.

    Отнася се и за видеопоток, който се обработва с плъгини

    Включването на опцията позволява допълнително да се намалят натоварването на CPU и вероятността от пропускане на кадри.

    Внимание! Ако вграденият «Модул за планирани задачи» извиква наближаващо по време задание за видеозапис и при това програмата е била свита в системния tray (намира се в режим на изчакване), то възможност за гледане при запис ще зависи от опция « Блокиране на поток за гледане при старт на запис от tray ».


Topic: Настройки Аудио

Настройки Аудио

ОБЩИ Аудио настройки & обработка с плъгини

BeholdTV не позволява да се използват плъгини за видеопроцесинг за обработка на звук.

: За потребители, които имат склонности към експериментиране, няма пречки да се провеждат тестове с единствения плъгин, чието предназначение според описанието (рус."Справка") е за абсолютно подобряване качеството на изображение и звук - BPP_Placebo v.1.00 (©1 April 2008).

: Преди употреба настоятелно се препоръчва да се прочете инструкцията към плъгина!!!


Topic: Видеообработка на кадър (режим запис)

Видеообработка на кадър (режим запис)

Описание на интерфейса - Панел за ВИДЕО/АУДИО запис

Видеообработка на изображение [image] в режим на запис

Вж. също

Включване и Основни действия с плъгини_Плъгини за Процесинг_При запис_

_« Видеообработка на кадър »;

Описание на интерфейса_Панел за настройки_Видео_

_« Видеообработка на изображение (режим гледане) ».

Този диалогов прозорец е предназначен за настройки на видеообработка на изображение при запис. Видео обработка се реализира по метода на включване на допълнителни модули-плъгини.

Ако се осъществява запис с ползване на апаратен МРEG енкодер, програмна видеообработка на изображения (шумопотискане, повишаване на острота, гама-корекции и пр.) не е възможна. Въпреки това, при апаратен запис плъгините могат да контролират паралелния видеопоток, извеждан за гледане и по този начин да се управлява процесът на запис.

По този начин плъгини като « Детектор на логотипи » и « Детектор на движение » ще изпълняват своите функции и в нужните моменти от време ще включват, спират и прекъсват на пауза запис.

? Важно!!! Всеки наличен в списъка плъгин преминава през инициализация при стартиране на Behold TV*, следователно заема ресурси на операционната система (памет) дори когато е изключен от процесинг (т.е. не активен - не е поставена или е свалена отметка в "checkbox", но е наличен е в списъка). Поради това, ако даден плъгин не се използва е по-добре да бъде премахнат от списъка.

@ Настройки:

  • Група «Използвани филтри за процесинг» - Списък с плъгини за видеообработка и/или наслагване на всевъзможни ефекти.

    ( [image] едновременно могат да бъдат използвани няколко/всички плъгини [image] от наличните в системната папка \Plugins)

    @ Добавяне на плъгин(и) към списъка в прозореца за плъгини в готовност за активиране/в процес на използване/за деактивиране от наличните такива в системната папка се извършва с бутон [image]; премахване - по аналогия с бутон [image].

    В зависимост от включените плъгини може да се сменя тяхната последователност за изпълнение * ? съответно с бутони [image] [image] .

    Даден плъгин може временно да бъде деактивиран (? не премахнат*, а оставен в списъка ако се предвижда да бъде използван в по-късен момент), като се свали отметката пред него.

    По време на запис прозорецът за настройки на видеообработка ще бъде достъпен, при което могат да се променят настройки на включени плъгини направо по време на запис (в реално време).

    Внимание! Ако в даден момент не е активен запис, @ настройки на плъгини за процесинг ще са недостъпни, т.к. плъгините се намират в offline режим. С бутон [image] е възможно да се настрои всеки плъгин и за да се види неговата реална работа. С това всички плъгини от списъка автоматично се включват за текущо гледане, при което може визуално да се прецени тяхната работа, както и да се извършват настройки.

    ? Прозорците за настройки са специфични за всеки отделен плъгин. Достъп до съответните менюта с настройки се осъществява с натискане на бутон [image] в долната дясна част на списъка:

  • ? Група за настройки «Използван филтър за деинтерлейсинг» - Избор на достъпен плъгин за деинтерлейсинг.

    Може да се избере само един плъгин, който ще се занимава с деинтерлейсинг.

    ? Филтър за деинтерлейсинг се избира от падащия списък:

    В полето под наименованието на филтъра автоматично се извежда кратка анотация за действието на съответния плъгин:

    Деинтерлейсинг работи само при извеждане на двете видеополета на кадър, т.е. когато височината на кадър е избрана

    § 576 за PAL / SECAM (например 768x576), или

    § 480 за NTSC (например 720x480).

    ? Достъп до съответното меню за настройки на избран плъгин се осъществява с натискане на бутон [image] "Свойства на филтъра":

    @ Програмни инструменти:

    Размяна на ред за последователност на видеополета - Много кодеци поддържат интерлейсна обработка на кадър (разделят кадъра на полета и обработват полетата разделно). Такива например са DV кодеци и някои MPEG кодеци.

    За такива кодеци трябва правилно да се зададе ред на последователност на полета. При неправилен порядък на полета изображението, извеждано на интерлейсно устройство за визуализация (например телевизор) ще „придръпва” характерно при движение на сцени по хоризонтал. В болшинството случаи е необходим следният порядък на полета:

    § PAL / SECAM - Top Field First,

    § NTSC - Bottom Field First.

    BDA драйвер Beholder (изм., v.~5.09 - Чипсет SAA713x) извежда

    § за YUV формати винаги порядък Bottom Field First,

    § за RGB формати - Top Field First.

    Опцията позволява да се определи нужния порядък за последователност на полета при запис в интерлейсен режим. При използване на какъвто и да е алгоритъм за деинтерлейсинг тази настройка губи сила, тъй като деинтерлейсинг превръща интерлейсен кадър в прогресивен, като обработва (рус."смешивает") полета.

  • Група за настройки «Буферизация на видео при запис»:

    Форсиране на видеобуферизация в паметта (кадри) – Указване на

    количество кадри, които ще буферизира конвейер DirectShow по време на запис. Тази настройка позволява да се сведат до нула загуби на кадри по време на запис, предизвикани от кратковременни дискови колизии или от кратковременни пикови натоварвания на CPU. При изключване на тази опция ще се използва буферизация на WDM-драйвера по подразбиране. WDM-драйвер 5.0.0.0 и по-високи версии буферизира по подразбиране 25 кадъра (v.~5.09 - 18 кадъра).

    Препоръчва се да се използва буферизация на видео с дълбочина не по-малко от 1 секунда (25 кадъра).

    1 секунда буферизация за поток 768x576 YUY2 ще отнеме ~22 МВ Nonpaged pool оперативна памет по време на запис.

    Не се препоръчва да се използва буферизация за видео повече от 50 кадъра - това може да доведе до разход на Nonpaged pool памет и да предизвика колапс на Windows при опит да бъдат освободени ресурси.

    Приложение: Малка таблица с препоръчителни стойности за буферизация в зависимост от обема на оперативната памет:

    RAM

    Буферизация видео

    (v.~5.09 - 128 МВ)

    (v.~5.09 - 18 кадъра)

    256 МВ

    25 кадъра

    384 МВ

    32 кадъра

    >= 512 МВ

    40 кадъра


Topic: Мащабиране на кадър

Мащабиране на кадър

Отсечка и мащабиране на кадър при запис в Вehold TV

Вж. също така:

  • Мащабиране/пропорции на кадър/видеопрозорец ;

  • Мащабиране на кадър при запис .

Програмни инструменти на Behold TV за отсечка по границите и мащабиране на кадър при запис се намират в

«Панел за запис»_секция [image] _подсекция [image] _

_функционален бутон

i Този прозорец е предназначен за настройки на изходна геометрия на кадър, която ще се формира след видеообработка и непосредствено преди компресиране.

При запис с използване на апаратен MPEG енкодер този прозорец е недостъпен.

  • ? Група за настройки «Отсечка по границите на кадър» –

    Отсечка – Активиране/деактивиране на опцията, респ. задаване на параметри за отсечка по границите на кадър за отстраняване на нежелателни артефакти, каквито понякога възникват в края на изображение.

  • ? Група за настройки «Мащабиране на кадър» – Изменение на окончателния размер на изображение чрез ресемплиране на изображение:

    Мащабиране – Активиране/деактивиране на опцията, респ. задаване на параметри за мащабиране:

    Окончателен размер на кадър;

    Метод за ресемплиране - Възможност за подбор на подходящ метод за ресемплиране:

    & Мащабиране на кадър е сравнително ресурсоемка процедура и значително увеличава натоварването на CPU.

    Трябва да се помни, че за качествено мащабиране на интерлейсен кадър трябва първо да се изпълни деинтерлейс, в противен случай артефакти след ресемплиране на интерлейс в последствие са неотстраними.

    @ Поради това, че при отсечка на граници и/или мащабиране на кадър изходните размери на кадъра се променят, по същия начин както при избор на първоначален размер на кадър е необходимо да се следи неговите геометрични размери да остават кратни на 8 или на 4. За ориентация в кратността на тези цифри помага подсветка (осветяване) на изходните стойности на размери на кадър в определен цвят:

  • ако цифрата не е кратна дори на 4, подсветката ще бъде в червено;

  • ако цифрата е кратна на 4, но не е кратна на 8, подсветката ще бъде в жълто.

    Идеален вариант е ситуация, при която размерите на кадъра са кратни на 8 по ширина и 4 по височина (цифрите да не са осветени). В този случай никога няма да възникват проблеми с геометрията на кадър при използване на различни кодеци.

    При не кратност на 4 могат да възникнат проблеми както при запис, така и при възпроизвеждане на записан файл, включително до възникване на критични грешки.

Забележки:

За борба само с артефакти по граници на кадър, при което е най-добре е да се използва плъгин за видеообработка «Запълване на граници» -

, без да се използва отсечка в основната програма.

При запис в MPEG не се препоръчва да се използват мащабиране или отсечка поради нарушаване на стандартните размери на кадър, приети за MPEG.


Topic: Въпроси и отговори

Въпроси и отговори

Допълнения от Help-файл към Behold TV - раздел "FAQ";

Материали и дискусии (форуми) в Интернет, други източници

The contents of Въпроси и отговори

При гледане
Запис
Таймшифт
Допълнително / Форум
Полезни връзки


Topic: При гледане

При гледане

N В режим на гледане

  • Въпрос: По края на телевизионно изображение се вижда „шум” във вид на тънки ленти?

  • Отговор: & Телевизионната техника се базира на факта, че при гледане на телевизор около 10% от картината се изрязва от самия апарат (намира се извън пределите на видимата област на кадъра). Затова в първите и последни редове на изображение често се кодира допълнителна служебна информация, кято изглежда като „шум”. В телевизионен стандарт Betacam за маркери се използва първият ред и два първи пиксела от останалите редове – левия край на изображението. Съществуват и ред други промишлени стандарти, които така или иначе използват края на изображението за кодиране на маркери.

    Препоръки:

    @ С помощта на бутони «+» и «-» на допълнителната клавиатура да се мащабира изображението така, че да бъдат скрити тези краища, или

    @ Да се използва плъгин за видеообработка «Запълване на рамка»~«Заливка бордюров»).


Topic: Запис

Запис

В режим на запис


Topic: Таймшифт

Таймшифт

В режим Таймшифт


Topic: Допълнително / Форум

Допълнително / Форум

Въпроси и дискусионни теми от официалния форум и други източници

  • Въпрос: (D.K. - Data.BG /22.09.2010) ~...Като авиолюбител ме интересува могат ли ТВ тунери Beholder да приемат авиочестоти, например 118.100, 123.700, 129.100 и 124.050 MHz?

  • Отговор: & Стандартният диапазон на тунери Beholder е:

    65.50 ~ 158.00 Мнz за тунери с ВЧ блок МК3/МК5;

    60.00 ~ 160.00 Мнz за тунери с ВЧ блок XCeive XC4100 и NXP TDA 18271 HD/C2;

    60.00 ~ 158.00 Мнz за тунери с ВЧ блок XCeive XC5000.

    в които попадат въпросните честоти. Доколкото ми е известно обаче, в случая става въпрос за амплитудна модулация. В такъв случай може да пробва с допълнителен плъгин , който е публикуван в официалния форум :

    Автор: EugeneF Зарегистрирован: 16.04.2008 Сообщения: 679 (23.09.2010)

    Добавлено: Сб Янв 23, 2010 23:48

    Заголовок сообщения: Плагин для приема АМ сигналов

    Превод: - Малък плъгин за приемане на амплитудно модулирани (АМ) сигнали (например канали в авиационния диапазон) през видеосистема на тунера.

    Сигналите се извличат от изображение, филтрират се и се възпроизвеждат чрез звуково устройство по default. Качеството не е високо, доколкото приемане става в широколентов диапазон - по-слаби канали се потискат от по-силни и АДЧ (Автоматична Донастройка на Честота) прескача към по-силен канал, но като цяло се справя както може.

    @ За работа с плъгина трябва да се зададат следните настройки:

    Видеостандарт: PAL/SECAM

    Видеоусилване: Auto

    Вертикална синхронизация: Свободен tracking

    Плъгинът се включва в чекбокс за настройки (отделно за всеки канал).

    Останалите настройки са общи.


Topic: Полезни връзки

Полезни връзки

Обособени / свързани материали

  • Избор на ТВ тунер - Помощна и справочна информация при подбор на ТВ тунер

  • Инсталиране на хардуер, драйвери и софтуер

  • OffLine Behold TV Help (PCI / USB / PCMCIA)

    Български интерфейс Behold TV

    F1 вградена помощ

  • Plugins Review - Многократно разширяване на възможностите при гледане, запис и видеообработка с използване на плъгини;

  • Ефективна борба с реклами:

    Видеообработка с Inter Video Win DVD Creator

    Автоматизиране на борбата с реклами с използване на плъгини (Logo Detector, Logo Killer, Logo Extractor, My Logo)

  • OffLine Behold TV Help (STB)

    Български интерфейс Behold TV INTRO (bh_tvbox_2)

    F1 вградена помощ (STB)

  • Дистанционно управление на компютъра с Behold IR

    Български интерфейс

  • Дистанционно управление на компютъра с Perehvat

    Български интерфейс

  • други материали по темата от същия автор, както и:

    " О компании " Beholder - фирмен сайт

    " Beholder – два года спустя… " Дата: 23.05.2006 | Автор: Reviews.ru

    " Beholder – пять лет на тропе ТВ-тюнеров " Автор: Воевода Денис |

    " ТВ-тюнеры Beholder – что выбрать? Советы покупателю " Автор: Денисов Евгений |

    " Станислав Стельмахов – о Beholder, и не только! " Автор: Воевода Денис |

    Препоръчителни публикации:

  • Статия Beholder Behold TV X7

  • RSS – ленти: Новости в RSS формате

  • ...


Topic: Информация за контакти

Информация за контакти

Информация за контакти:

Официален сайт:

http://www.beholder.ru

Страница за поддръжка:

http://www.beholder.ru/support

Форум:

http://www.beholder.ru/bb

E-mail:

support@beholder.ru

Регионална информация:

Автор и редактор на материали на български език*:

http://www.beholder-europe.com

http://www.beholder-europe.eu

*вж. също пояснителни бележки по превод и редактиране на български език и полезни връзки

The contents of Информация за контакти

Превод и редакция


Topic: Превод и редакция

Превод и редакция

Някои особености в българската редакция на материалите

  • Бележки по превода и редактирането

    Инструкциите за инсталиране на драйвери и софтуерния комплекс са приложими за всички модели PCI / USB / PCIe тунери BeholdTV.

    (доп., v.5.11.) Появата на нови модели тунери (Behold TV серии «7» и «8», тунери с USB и PCIe интерфейс) обективно налагат своевременни промени в програмното осигуряване (драйвери, фирмен софтуер, плъгини), респ. изискват функционален и лесен за употреба потребителски интерфейс с многоезикова поддръжка в съответствие с реализирането на нови технологии и възможности на база на внедряваните чипсети, ВЧ-модули и ред други фактори.

    В съответствие с горното, при редакцията на първоначално публикуваните оригинални материали на български език за v.5.05 своевременно са нанесени всички ключови изменения и допълнения за версии 5.07, 5.09, 5.10 и 5.11, с което се цели да се предостави база за по-пълно сравнение и вникване във възможностите и функционалните/софтуерни промени при новите модели.

    Целта е материалите за последната редактирана версия да съдържат още по-изчерпателна информация, при което да могат да се ползват по желание и за предишни версии* с отчитане на функционалните/хардуерни особености на различните модели/серии и свързаните с това изменения в софтуерната поддръжка, респ. промените във възможностите и интерфейса за управление в новите версии на програмния комплекс.

  • Структуриране на материалите

  1. При превода на интерфейса, помощни инструкции и др. материали по правило са полагани усилия да се следват стриктно постройките на оригиналните текстове и структура с цел избягване на смислови и/или терминологични неточности и при необходимост - предоставяне на възможности за по-лесно сравнение с основните източници.

  2. Така например, разделът за инсталиране на драйвери и софтуер след излизането на версии BeholdTV v.5.07~5.11 е изведен отделно от Help-файла на официалния сайт на производителя.

    За по-пълно придържане към структурата на оригиналната версия, българският превод на този раздел по аналогия също е изведен като самостоятелен раздел в обособен материал . От друга страна в този материал допълнително е включена структурна част за предварителна подготовка и инсталиране на хардуер, при което се обединяват инструкциите на хартиен носител със съответните възможности за по-лесно търсене на различна информация в електронния вариант.

    Материалите за плъгини се публикуват като обособена част - продължение/допълнение на софтуерния комплекс BeholdTV.

  3. Някои относително самостоятелни части в рамките на дадени раздели са допълнително отделени в подраздели с цел обособяване на конкретна терминология, например:

    при което общи особености при използване на плъгини за процесинг са оставени в основния раздел, а специфични настройки за различните плъгини са структурирани в съответни подраздели.

    Пълно (разширено) съдържание на инструкцията е посочено в края .

    *Софтуерът се обновява и развива непрекъснато, като своевременно се усъвършенства, отстраняват се евентуално намерени грешки и забележки, вкл. от форумните дискусии. В официалния форум битуват и мнения, че в някои случаи (например при конфликти) могат да се ползват предишни версии. Без да се изразява лично мнение, това е една от причините в последната редакция на материалите да се оставят текстове от предишни версии, които са съответно обозначени в различен цвят (вж. по-долу).

  • 4 Стилово оформление

    *За ориентиране в промените на софтуера, в българската редакция са използвани различни цветове на шрифт:

  • Изменения и допълнения след v.5.05 (5.07~5.10 вкл.) са във виолетов цвят (“violet”),

  • такива за обновения интерфейс на версия 5.11 - в светло синьо,

  • някои неактивни, отпаднали или редактирани/разместени менюта от версии 5.05~5.10 в сравнение с предишни версии – в светло сиво/сиво (“gray”),

  • авторски коментари, забележки и допълнения/пояснения са в сиво-син цвят,

  • препоръчителни величини, настройки и пр. са подчертани в зелен цвят,

  • забележки, ! предупреждения, %напомняне и други важни моменти са в червено.

    При превода беше забелязано, че части от терминологията принадлежат смислово към отделни групи и има относително обособяване по такъв признак.

    Такива например са различни абзаци (изречения, таблици и пр.) за

    @ настройки и технически параметри/величини,

    теоретични понятия/термини и пр.

    При стиловото оформление в българската редакция пред такава терминология допълнително са използвани символи (Wingdings) или мини-иконки, с които да бъде "подсказано" за какво става въпрос в следващи текстове.

    Таблица с пояснения на използвани символи е поместена тук .

  • @ Терминология, & речник - общи бележки*

    *Речници на използвани термини и съкращения са поместени тук .

  1. При превода и редактирането някои термини (най-вече свързани с менюта на програми, опции и съобщения на операционната система) са възстановени от руски на английски език (без да се превеждат на български език). Това е направено умишлено при редактирането – лично мнение на редактора е, че в ХХІ век не е уместно да се превеждат специфични термини (от сорта на „Recycle Bin” > „Кошче за отпадъци” и пр.), с които масовият потребител би трябвало да борави свободно. Такива термини са представени в курсив (Italic) и са оцветени в тъмно син цвят. В самата програма също така има някои менюта/прозорци, оригиналният интерфейс на които е в англоезичен вариант (например диалогови прозорци за настройки на апаратен декодер, матрица за квантоване и др.). Това не са „недоработки” или пропуски в програмата, a e направено от разработчиците умишлено – в случая става въпрос за вид допълнителна защита срещу непрофесионални действия, доколкото някои фини настройки изискват значително по-задълбочени познания на материята и по-богат практически опит. За болшинството потребители тези настройки са зададени с оптимални стойности по подразбиране и няма необходимост от допълнително експериментиране. Въпреки това за професионалисти в програмата са предвидени и такива настройки.

  2. Някои по-специфични термини и текстове (при превода на които е възникнало съмнение за коректните термини на български език или е необходимо последващо доуточняване и/или редактиране) са оставени непреведени. Такива текстове/термини са оцветени в „orange”. При всяка следваща редакция се полагат усилия проблеми от такъв характер да бъдат окончателно уточнени и преведени (или обяснени), доколкото това е по възможностите на автора/редакцията.

    На този етап интерфейсът на системата от плъгини е на руски език. До пълния превод на български език опциите за настройка са обяснени паралелно с оригиналните руски текстове.

  3. Трябва да се има предвид, че при различните версии на операционната система (по-нататък съкр. "ОС", "OS") някои системни екрани, падащи менюта, прозорци, команди за изпълнение и пр. имат различен интерфейс и транскрипция в сравнение с описаните такива по-долу. Примерите и екранни снимки (screen shots) в материалите са изведени при инсталиране и тестване на драйвери и основна програма на базата на сравнително широко разпространената ОС Windows XP (SP2) в англоезичен вариант.

  4. Преводът на български език на оригинални менюта, подменюта, команди, съобщения, опции и пр. в прозорци/подпрозорци на оригиналния рускоезичен интерфейс са в курсив и тъмно син цвят.

  5. При всяка възможност са правени екранни снимки от българския интерфейс на програмите при инсталиране на софтуер Behold TV v.5.05~5.11; драйвер v.5.2.1.0; хардуерни модули – ТВ тунери:

    - Behold TV М63 с апаратен енкодер и

    - хибриден тунер Behold TV H6 с

    - чипсети SAA7135 и

    - "традиционен" ВЧ-модул МК3

    (поради което някои screen shots за тунери с чипсети, различни от SAA7135 и посочения ВЧ-модул са в непроменен вид - на руски език от оригиналните материали, без български интерфейс/превод).

The contents of Превод и редакция

Източници


Topic: Източници

Източници

Основни източници на информация

Пълен списък с ползвани/свързани с темата източници на информация, които обхващат всички обособени части е публикуван в първия материал (по логическа последователност) - TVTunerChoice_BG.

В отделните части са обособени само източници, които имат връзка със съответната структурна част:

Beholder - официален сайт :

  • Последняя версия справки к программному обеспечению Beholder: Help_v509.zip (947 kb);

  • Плъгини - страница за техническа поддръжка ;

  • Инструкция по установке драйвера и программного обеспечения ;

  • Bulgarian (Болгарский, Български) интерфейс & инструкции ;

  • ...

Публикации в интернет (на руски език):

  • ...

  • Ferra.ru : Особенности нового софта для ТВ-тюнеров Beholder (Timeshift, плъгини - общо ревю към.08.12.2004.)

  • Tom'sHardwareGuide.ru: Обзор ТВ-тюнера BeholdTV 403 ( ВРР_ВТVGuard , BPP_AMPPlugin )

  • HardwarePortal.ru : Видеонаблюдение для дома с помощью ТВ-тюнера Beholder (вж. ВРР_ВТVGuard )

  • ...

Публикации в интернет (на български език):

  • ...


Topic: Reserve

< Previous page

Reserve

Reserved for updates

...С пожелание информацията да е била полезна - до нови срещи!

Created with DrExplain

< Previous page