Application: Behold TV Setup

ТВ тунери Beholder в България
Описание на фирмен софтуерен комплекс Behold TV - актуализация v.5.17.
Next page >
Behold TV Setup
User guide

Created with DrExplain

Next page >
Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията!
© Beholder.ru / Beholder-Europe.com


Application: Behold TV Setup

< Previous page Next page >

Behold TV Setup

www.beholder.ru

www.beholder-europe.com www.beholder-europe.eu

Ръководство, справочна и помощна информация за инсталиране и експлоатация на

ТV тунери Beholder® и софтуерен комплекс Behold ТV©

Сравнителна структура на помощните материали:

Съдържание - оригинал | Съдържание - BG (съкратено)

The contents of Behold TV Setup

Предговор
Инсталиране
Функции и настройки
Описание на интерфейса
Агент BeholdTV
Съвети при видеозапис
Въпроси и отговори
Информация за контакти
Reserve

Created with DrExplain

< Previous page Next page >


Topic: Предговор

Предговор

Встъпителни бележки

От автора на превода и българската редакция

  • Предназначение, обхват и общи условия за ползване

    Материалите се публикуват за улеснение на потребители на ТВ тунери Beholder®, които ползват български език.

    Целта на настоящата публикация е да бъдат преодолени затруднения с интерфейс, настройки и помощна информация на фирмения софтуерен комплекс Behold TV на руски и английски език, които са достъпни при инсталиране по подразбиране. При работата върху материала са полагани усилия редактираният български превод да обхваща всички достъпни теми и раздели от официалните източници на производителя и препратки към други материали, свързани с процесите на инсталиране, настройки и работа с описания хардуер и софтуер.

    Авторът на този материал няма претенции за пълна изчерпателност, както и за налагане на лични мнения и изводи [image] по отношение на коментирания софтуер/хардуер . Материалите и използвани екранни снимки (screenshots), външни препратки (hyperlinks), самостоятелни разработки ( [image] интерфейс) и пр. се публикуват за ползване при условия „As it is“:

    Авторът/редакцията не носят отговорност за възможни вредоносни въздействия върху системите и друг приложен софтуер под влияние на фирмения софтуер на Beholder и съдържанието на цитирани интернет-препратки! Същите могат да бъдат използвани по собствена преценка, при съответните условия за ползване и изключително за своя сметка и риск.

    Споделен личен опит - съвет за спестяване на време и усилия

    Препоръчително е потребителите на софтуерния пакет да се запознаят със следващите бележки – това впоследствие би могло да спести много ценно време при инсталиране на хардуер, драйвери и работа със софтуерните модули. В ръководството се съдържат отговори на ред въпроси (възникнали при затруднения/проблеми от различен характер, но въпреки това основно поради непознаване на описаното в инструкциите), които са подробно разяснени в детайли. Направени са и връзки на общодостъпно ниво с някои други основни теоретични постановки, които имат пряко отношение към определени процеси и/или настройки.

    За потенциални потребители, които все още не са се ориентирали в многообразието от модели TV-тунери* и може би един от най-съществените фактори – перфектен софтуер с безупречната работа и поддръжка в различни версии на операционни системи, в материала се съдържа изчерпателна справочна информация, въз основа на която би могло да се постигане оптимално съотношение цена/качество в съответствие с търсен краен резултат при планиране на определен бюджет за закупуване на съвременен ТV-тунер с лесен за употреба софтуер, драйвери и постоянна поддръжка на същите в реално време.

    * Освен посочената по-долу справочна информация за възможностите на отделните модели, в помощ при избор на конкретен модел, съобразен с желанията и възможностите на потребителите, както и с изискванията към хардуера, софтуера и операционната система, респ. ограниченията на налична (или предстояща за придобиване) компютърна конфигурация със съответна архитектура и свободни слотове/портове, помощна информация за подбор на конкретен тип и модел ТВ тунер е публикувана в отделен материал .

  • **Кратки бележки по превода и редакцията

    Този материал представлява разширен и редактиран превод на оригинални инструкции, Help-файлове и публикации по темата в Мрежата. Използвани са източници и снимки (screen shots), публикувани на официалния сайт на Beholder ®:

    - инсталация на драйвери и софтуер;

    - Help-файлове към програмни пакети btv_v.5.05~v.5.07~v.5.09~v.5.10~v.5.11~v.5.15;

    - Многократно разширяване на възможностите при използване на плъгини;

    - авторски материали, както и

    статии, ревюта, коментари и публикации от други източници в интернет-пространството.

    В последните официални редакции на справочна информация целият раздел за инсталиране на драйвери и софтуер е изведен като отделна препратка в официалния сайт, поради което по аналогия българската версия на тези материали се публикува също отделно от Help-файла към софтуерния пакет за по-пълно съответствие с постройката на оригиналния софтуер и фирмения интернет-сайт. В настоящата инструкция са запазени някои основни моменти от първоначалната редакция за v.5.05, които логически следват следната структура:

    избор на ТВ тунер (желания и обективни възможности/ограничения)

    инсталиране на хардуер

    инсталиране на драйвери/софтуер

    основни настройки

    ползване

    разширени (индивидуални) настройки

    конфигуриране и използване на допълнителни възможности...

    По аналогия са публикувани отделни материали в помощ при избор на ТВ тунер, описание и настройки на плъгини за Behold TV, възможности за борба с реклами и др.

    Материали за SТВ (Set-Тop Вox) тунери и софтуер за управление на такива се публикуват в отделен раздел (материал).

    ** При превода, редактирането и графичното оформление на материалите на български език има някои особености, които са свързани с желанието същите да бъдат по-достъпни, изчерпателни и сравними. Тази информация е изнесена в българската секция към съответните материали.

  • Публикуване на информация

    Цитираните материали (препратки) са преведени и публикувани на официалния сайт на производителя от носителите на авторските права след предварителното съгласуване с Beholder® първоначално за версия Behold TV_v.5.05 въз основа на оригиналния интерфейс и Help към програмата.

  • Условия за ползване, тиражиране и разпространение

    Копиране и разпространение на целия материал и/или части от същия не се допуска без предварително съгласие на авторите и редакцията © Beholder ; The Best / Beholder-Europe . За нарушения се носи отговорност съгласно Закона за авторското право и сродните му права и международните правни норми за закрила на интелектуалната собственост.

  • Обратна връзка

    Авторът на българския интерфейс на софтуерния пакет Behold TV, превода и редакцията на инструкциите и други материали, свързани с представянето на фирмен софтуер и ТВ тунери Beholder на българския и европейския пазар с внимание и благодарност ще очаква всякакви коментари или забележки за установени евентуално допуснати неточности/грешки, както и отзиви във връзка с практическото ползване на тунерите и фирмения софтуер.

The contents of Предговор

Обща информация
Възможности на програмата
Изисквания към системата


Topic: Обща информация

Обща информация

Behold TV

Комплексният софтуерен продукт* Behold TV ( [image] по-нататък за краткост съкр. само Behold TV или „програма/та”) е собствена фирмена разработка на Beholder, който е предназначен за работа с телевизионни PC-тунери Beholder, изградени на базата на (доп., v.5.09~5.11):

PCI чипсети NXP (Philips) SAA713х (9 bit),

PCI Express чипсет NXP SAA7231 (10 bit), както и

USB 2 чипсет Trident TM6010 (10 bit).

Основни технически характеристики на различните модели тунери Behold TV и свързаните с това функционални възможности са изведени в сравнителни таблици **.

*В българската редакция не случайно е употребено определението "софтуерен комплекс", доколкото Behold TV не е само "компютърна програма", а включва:

  • Основно приложение с главен панел, в който са концентрирани най-често използваните функции и модули за управление;

  • В интерфейса на главния панел са интегрирани функционално обособени модули, които имат собствен интерфейс. Модулите се отварят в отделни диалогови прозорци с бързи бутони:

    Панел за настройки;

    Панел за запис;

    Модул за планирани задачи;

    Програма с ТВ-предавания;

  • Комплексът взаимодейства с Агент Вehold TV, който е включен като самостоятелно обособено приложение.

  • Възможностите на системата са многократно разширени чрез специално разработена система от плъгини за тунери Beholder, които работят както в независими режими при гледане и при запис, така и в комбиниран режим на запис с едновременно гледане на видеоматериали;

  • Взаимодействието на софтуерния комплекс със самите тунери като хардуерни модули се осъществява в средата на определена операционна система. Всичко това се извършва с помощта на фирмен, самостоятелно разработен универсален драйвер за всички серии и модели тунери Вeholder. Драйверът и програмата работят еднакво добре както в средата на "древни" операционни системи (като Windows 98 ), така и в най-последните версии на ОС (към момента на последната редакция на този материал - Windows [image] ). При това фирмените тестове и поддръжка осигуряват работоспособност с изпреварващи темпове - дори преди официалните премиери на следващите ОС.

**Някои модели (4-а серия; модели 505RDS/507FM /507RDS; PCMCIA Columbus; 607FM/607RDS/ М6/M63/М6Еxtra/H6) са свалени от производство поради независещи от Beholder обстоятелства (промени в продуктовата спецификация на NXP) или поради пазарните условия.

Въпреки това в материала са предоставени сравнителни технически данни за всички модели и серии, които дават представа за функционалните особености на елементната база (ВЧ-блокове, чипсети, декодери и пр.), внедрени технологии и пр. и свързаните с това възможности на програмното осигуряване. Независимо от това, че посочените модели не се произвеждат, притежателите на такива тунери могат да бъдат напълно спокойни и уверени, че последните версии драйвери и софтуер осигуряват пълна поддръжка, вкл. за операционни системи Windows Vista / [image]. Програмното осигуряване и плъгините за разширяване на функционалните възможности също така са напълно съвместими с всички серии. Някои от тези модели все още могат за бъдат намерени в търговската мрежа, като по функционалност, програмно осигуряване и икономично нискобюджетно решение могат да бъдат полезни както за пълноценно използване за гледане, обработка и запис на ТВ и радио програми, така и за видеообработка на материали от външни източници (вкл. с плъгини) в оставащия преходен период до спирането на аналогово излъчване.

Пример за такава функционалност са наскоро пуснатите (м. Юли~Август 2010 г.) аналогови модели от серия 5 - "501" и "503FM" (дори след най-новите модели от серии 7 / 8 / USB), които съчетават внедряване на най-съвременна схемотехника, технологии и елементна база с функционалност при пълна съвместимост с последните версии на Behold TV, плъгини и драйвери и икономично нискобюджетно решение.

The contents of Обща информация

Сравнителни спецификации


Topic: Сравнителни спецификации

Сравнителни спецификации

Основни технически спецификации на РСІ/РСІе/USB/PCMCIA ТВ тунери Behold TV

  • Сравнителна таблица за ТВ тунери Behold TV с PCMCIA интерфейс**

  • Сравнителна таблица за ТВ тунери Behold TV 4-а серия**

  • Сравнителна таблица за ТВ тунери Behold TV 5-а серия** (PCI interface)

***В публикация за първи тестове на модел Behold TV 501 в специализиран сайт , функция FM тунер при модел Behold TV 501 е активна, въпреки че това не е изрично посочено в спецификацията.

  • Сравнителна таблица за ТВ тунери Behold TV 6-а серия** (PCI interface, Standart profile)

  • Сравнителна таблица за ТВ тунери Behold TV серия x7 (PCI interface, Low profile)

  • Сравнителна таблица за ТВ тунери Behold TV серия x8x (PCI-e interface, Low Profile)

  • Сравнителна таблица на ТВ-тунери Behold TV с USB интерфейс


Topic: Възможности на програмата

Възможности на програмата

Основни възможности на Behold TV

  • (доп.,v.5.17) Едновременна работа на няколко копия на програмата с различни модели тунери Beholder.

  • Приемане на телевизионни програми, излъчвани в диапазон 45.25 - 864.25 MHz

    (+/– в зависимост от ВЧ модул на модела - вж. сравнителната таблица с технически параметри).

  • Прослушване на УКВ / FM радиостанции в стандартен и разширен (65.5-168 MHz) диапазон

    (+/– в зависимост от ВЧ модул на модела - вж. таблицата ).

  • Приемане и декодиране на RDS-поток с последващо визуализиране на RDS данни в режим FM

    (само за модели с RDS декодер - вж. таблицата ).

  • Приемане/обработка/възпроизвеждане/запис ( [image] capture) на видео / аудио сигнали от външни източници през различни видове входове:

    § CVBS (композитен видеовход)

    § S-Video (двукомпонентен видеовход)

    § RGB (четирикомпонентен видеовход)

    § YPbPr (трикомпонентен видеовход)

    (в зависимост от модела - вж. таблицата ).

-T:

  • Приемане на цифрови [image] -T канали

    (само за модели с DVB-T декодер - вж. таблицата ):

    § Отделни режими [image] TV и [image] -T [image] .

    § Бързо сканиране на честотния диапазон 6/7/8 MHz DVB-T канали и за отделно избрани канали.

    § Автоматично определяне на йерархична модулация в DVB-T спектъра с възможност за избор на HP и LP поток.

    § Визуализиране на параметри на [image] -T сигнал :

    Ниво на сигнал,

    Съотношение сигнал/шум на OFDM носеща,

    Претеглено качество на приемания сигнал,

    параметри на модулация.

    § Определяне на всички възможни типове [image] елементарни потоци.

    § Определяне на система за кодиране на затворени (PAY) DVB канали.

    § Запис на цифров DVB поток във формати:

    §§ ISO 13818-1 Transport Stream (пълен поток или избран канал), и

    §§ ISO 13818-1 Program Stream.

    (по-нататък съкратено съответно "TS" и "РS")

    § Запис на цифров [image] поток - една звукова пътека в Elementary Stream.

    Излъчване в мрежа на цифров DVB поток (пълен поток или избран канал) по протоколи

    §§ (ред.,v.5.17) НТТР/SHOUTcast (unicast) и

    §§ (ред.,v.5.17) UDP/RTP (multicast).

    § [image] Режим Timeshift за [image] поток във формат ISO 13818-1 Transport Stream (TS).

    § Поддръжка на [image] EPG (Electronic Program Guide - електронни бази данни с телевизионни- и радиопрограми).

    § Поддръжка на [image] Teletext / Subtitle (ETSI 300 472, ETSI 300 706).

    § Избор на програмен декодер за

    §§ MPEG2 видео;

    §§ H.264 видео;

    §§ MPA / AC3 / DTS аудио;

    §§ AAC аудио.

    § Превключване на [image] аудио в режими Mono LL; Mono RR.

    § RAW-анализатор на пакети в транспортния поток.

Настройки/донастройки на ТV и FM:

  • Гъвкави методи за настройки на ТV и FM радио програми.

  • Поддръжка на профилиране за ТV и FM канали при използване на тунера в различни регионални зони на прием.

  • Приемане на телевизионни програми с формат на звук A2/NICAM Stereo

    (само за модели с чипсет (доп.,v.5.09, 5.11) SAA7134, SAA7135, SAA7231, ТМ6010).

  • Фина настройка на параметри за декодер A2/NICAM

    (само за модели с чипсет SAA7134).

  • Бързо апаратно автоопределяне (Auto detect) на системи за звук - BG/DK/I/L и формати за кодиране на звук - Mono/A2/NICAM

    (само за модели с чипсет (доп.,v.5.11) SAA7135, SAA7231).

  • Индивидуални настройки на тембър за ниски и високи честоти на звук

    за всеки канал, както и

    за всеки НЧ-вход

    (само за модели с чипсет (доп.,v.5.11) SAA7135, SAA7231).

  • Индивидуални настройки на виртуални звукови ефекти - Philips Incredible и Virtual Dolby Surround

    за всеки канал, както и

    за всеки НЧ-вход

    (само за модели с чипсет SAA7135).

  • Индивидуални настройки на

    яркост,

    контраст,

    наситеност,

    оттенък (само PAL),

    острота (рус.”четкость”, англ.”Sharp~ness”),

    ниво на входния сигнал (Gain),

    аудиоформат (BG/DK/I/L, Mono/A2/NICAM),

    видеоформат (Авто/PAL/SECAM),

    сила на звук, баланс на ляв и десен канал,

    размер (Zoom) и

    позиция (рус. „сдвиг”) на кадър

    за всеки ТВ-канал.

  • Индивидуални настройки на

    видеостандарт (Авто/PAL/SECAM/NTSC/PAL60),

    яркост,

    контраст,

    наситеност,

    оттенък (само PAL/NTSC),

    острота,

    ниво на входния сигнал (Gain),

    както и режим за синхронизация на редове

    за всеки НЧ-вход.

  • Интегрирано (вградено) OSD (On-Screen Display) меню.

  • Настройки на стил за визуализация на OSD.

Дистанционно управление:

  • Работа с пулт за дистанционно управление (по-долу съкратено „ДУ”/„ПДУ”/„RC”) и индивидуални настройки на бутони на ДУ за задаване на действия по избор.

  • Едновременна поддръжка и гъвкаво конфигуриране на няколко външни ДУ, работещи по стандарти NEC, JVC, Panasonic, Samsung, Sony SIRC-12/15/20

    (само за модели с технологиr ARPC , (доп.,v.5.15) ARC – вж. таблицата ).

  • (изм.,v.5.11) Включване (изключване - вж. Технология ARPC по-долу) на компютъра от пултове ДУ

    (само за модели с технология ARPC – вж. таблицата ).

  • (изм.,v.5.11) Включване (изключване - вж. Технология ARPC по-долу) на компютъра по вътрешен таймер

    (само за модели с технология ARPC – вж. таблицата ).

Действия с клавиатура/клавишни съчетания:

  • Гъвкави настройки на „горещи клавиши” („hot keys”) за управление на програмата.

  • (доп.,v.5.09) Поддръжка на глобални системни „горещи клавиши”.

  • Поддръжка на бази с ТВ-програми във формат JTV и визуализиране на информация в OSD.

  • Многоезичен интерфейс – [image], [image], [image] ...to be continued...

Модул «Агент» Behold TV («Agent»):

  • Използване на «Агент» за стартиране на програмата от пулт за ДУ;

  • Използване на «Агент» за изпълнение на задания от вградения «Модул за планирани задачи» ( рус.„Планировщик”, англ.”Scheduler”);

  • Използване на «Агент» за автоматично сваляне (download) и обновяване на бази с ТВ-програми.

Обработка на кадри/извеждане на видео/видеообработка:

  • Изменение размери на кадър на извеждан видеопоток при гледане (до 768x576).

  • Изменение на режими за съотношения на страните на кадър - 4:3 / 16:9 PanScan / 16:9 Anamorphic.

  • Поддръжка на VMR-технология (Video Mixing Renderer) за извеждане на видео

    (само за Windows XP / 2003).

  • (доп.,v.5.09) Поддръжка на ЕVR-технология (Enhanced Video Renderer) за извеждане на видео

    (само за Windows Vista / [image] ).

  • Извеждане на видеоизображение в режим на полупрозрачен прозорец.

  • Извеждане на видеоизображение за desktop като Windows Wallpaper.

  • Възможности за видеообработка на изображение с включване на плъгини, при което възможностите на системата се разширяват многократно.

  • Използване на няколко включени в програмния пакет плъгини за подобряване на изображение -

    - няколко плъгина за деинтерлейсинг (за премахване на т.н. „гребеновидни”/рус.„расческа” артефакти);

    - плъгин за премахване на високочестотни шумове;

    - плъгин за подобряване острота на изображение.

  • Използване на програмна (софтуерна) функция Smart Interleave, позволяваща удвояване честотата на кадри при гледане 25 [image] 50 fps (frames per second - кадри в секунда)

  • Използване на апаратни (хардуерни) функции на видеокарти -

    - деинтерлейсинг и

    - механизъм за удвояване честотата на кадри.

Предаване (извеждане) на звук:

  • Извеждане на цифровизиран звук по шина PCI/USB за прослушване с автоматична синхронизация на АЦП от чипсет NXP (Philips) и ЦАП от звукова карта без използване на аналогов аудиокабел за връзка между изход на тунер и вход на аудиокарта.

    (само за модели с чипсет (доп.,v.5.09, 5.11) SAA7134, SAA7135, SAA7231, ТМ6010).

  • Цифровизиране и извеждане на звук по PCI-шина при прослушване в режим Dolby Pro Logic с преразпределение в 4-канален Surround по три възможни схеми -

    § Surround,

    § Phantom Center,

    § X3 Stereo

    (само за тунери с чипсет Philips SAA7135/101).

  • „Сърфинг“ - Многоканален предварителен преглед на канали.

  • Режим „Таймшифт” (отложен преглед) за видео/аудио, както и отделно само за аудио. За модели с апаратен енкодер MPEG режим Таймшифт се изпълнява хардуерно за компресиране и запис на поток.

  • Преглед, отложен преглед (Таймшифт) и запис на програми по разписание с използване на вградения интелектуален модул за планиране на задачи.

  • Предварително възстановяване на системата от режим Hibernate / Suspend при наближаване на задание от модула за планирани задачи (трябва да е активен Агент Behold TV или основното приложение Behold TV).

  • Програмиране на вградения таймер

    за изключване или

    за преминаване в режим Hibernate / Suspend.

  • Заснемане (Screen shot~s/Capture/"прихващане") на отделни кадри във формати BMP и JPEG - както

    - ръчно, така и

    - по таймер [image] .

Аудио запис:

  • Запис на звук във формат WAV с използване на ACM-кодеци по технологии Microsoft ACM и DirectShow.

  • Запис на звук в MPEG1 Layer-2 (с инсталиран енкодер InterVideo MPEG).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

  • Запис на звук във формат Microsoft WMA, както и във всеки достъпен формат в състава на контейнер Microsoft ASF

    (За ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime - v.5.15-версия 9 или по-висока).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

  • Запис на звук във формат MPEG1 Layer-2, AC-3 чрез апаратен MPEG енкодер

    (само за модели с хардуерен енкодер).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

Обработка на аудио – мрежови функции:

  • Излъчване на звук в IP-мрежа

    - във формат Microsoft WMA, както и

    - във всеки достъпен формат в състава на контейнер Microsoft ASF

    (За ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime - v.5.15-версия 9 или по-висока).

  • Излъчване на звук в IP-мрежа по протоколи

    - (ред.,v.5.17) HTTP/SHOUTcast (unicast),

    - (ред.,v.5.17) UDP (multicast).

Видео / [image] аудио запис:

  • Запис на видео/аудио във формат Microsoft AVI (размери на кадър до 768x576) с използване на достъпни VCM- и DirectShow- видео кодеци и ACM аудио кодеци и

    визуализиране на подробна информация за процеса на запис.

  • Запис на видео/аудио във формати MPEG1 и MPEG2

    (с инсталиран енкодер InterVideo MPEG).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

  • (доп.,v.5.09) Запис на видео/аудио във формати MPEG1 и MPEG2 с използване на интегриран MPEG енкодер Ms Windows [image] .

  • Запис на видео/аудио във формат Microsoft WMV, както и във всеки достъпен формат в състава на контейнер ASF

    (За ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime v.5.15-версия 9 или по-висока).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

  • Запис на видео във формат MPEG2 (ISO/IEC13818-2) със звуков поток във формати LPCM, MPEG1 Layer-2 (ISO/IEC13818-3), AC-3 чрез апаратен MPEG енкодер, с гъвкаво конфигуриране на параметрите на енкодера

    (само за модели с вграден хардуерен енкодер).

    Възможен е запис с «Автоматично разделяне на записван файл на сегменти със зададен размер».

Видео/Аудио – мрежови функции:

  • Излъчване на видео/аудио в IP-мрежа във формат Microsoft WMV, както и във всеки достъпен формат в състава на контейнер ASF

    (За ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime v.5.15-версия 9 или по-висока).

  • Излъчване на MPEG поток в IP-мрежа по протоколи

    - (ред.,v.5.17) HTTP/SHOUTcast (unicast),

    - (ред.,v.5.17) UDP (multicast).

Обработка на изображение и кадри при видео запис:

  • Подрязване (cropping) по границите на кадър при видеозапис

    (само за програмен запис).

  • Мащабиране на кадър при видеозапис

    (само за програмен запис).

  • Видеообработка на изображения с плъгини при видеозапис

    (само за програмен запис).

  • Едновременен запис и преглед на записвано видео

    респ. възможност [image] « Да не се показва записвано видео при гледане » при запис.

  • Запис на цифровизиран звук с използване на вградения АЦП чипсет

    (изм. и доп., v.5.09; доп., v.5.11) SAA7134(32 KHz), SAA7135(32/44.1/48 KHz), SAA7231, ТМ6010 по шина PCI/PCIе/USB.

  • Съхраняване на настройки за запис на видео, аудио и екранни снимки (screenshot/s) в пресети с възможности за зареждане на такива по желание.

  • Бърз избор на лимит за време на запис с натискане на един клавиш или бутон на ПДУ.

  • Висококачествен декодер за (доп.,v.5.09) VBI / [image] телетекст/субтитри (ETSI 300 706) с многоезикова поддръжка.

Забележки (Технологии):

The contents of Възможности на програмата

Технологии


Topic: Технологии

Технологии

Забележки / пояснения:

  • DUAI - Dual Universal Antenna Input предоставя възможност за избор на два независими, (изм.и доп.,v.5.17) универсални, програмно управляеми високочестотни антенни входове.

    Технологията позволява:

  1. Произволно избиране на антенен вход за включване на TV/DVB-T/FM антени.

  2. Приемане на аналогови и цифрови програми от две различни независими антени.

    (v.5.09 - Приемане едновременно от две ефирни антени или да се съчетава едновременно приемане на кабелни и ефирни канали.)

  3. Приемане на радиостанции от УКВ/FM диапазон както с телевизионна, така и с радиоантена.

  4. Едновременно използване на DVB-T/FM антена за приемане на цифрово излъчване и аналогови УКВ / FM радиостанции.

  5. Избор на антенен вход индивидуално за всеки канал.

  • GIAI - Galvanic Isolated Antenna Input предпазва антенните входове на тунера от електрически пробив на напрежение, което може да възникне между антенен кабел и незаземен корпус на системния блок на компютъра.

    (v.5.05 …поради конструктивните особености на захранващите блокове в компютрите...)

    Често е особено добре изразено при кабелна телевизия

    GIAI е монтиран непосредствено на платката на тунера и изпълнява функции на т.н. «галваничен разделител» за защита на входните вериги на устройството от пикови напрежения.

    Технологии DUAI и GIAI са нововъведения от излизането на модел Х7 и се прилагат в следващите серии. По разбираеми причини при модели, които имат само един антенен вход (напр. Wander, Voyager, "Lite") и "чисто" аналогови модели технология DUAI не се реализира).

  • ADSS - Analog/Digital Separate Shielding. Технология за пълно и разделно екраниране на цифрови и аналогови области, с което се увеличава шумоустойчивостта на тунера и се намалява нивото на собствени паразитни шумове.

  • ARPC - Advanced Remote & Power Control позволява на тунера:

  1. Да работи с всякакви други пултове за ДУ, работещи по стандарти NEC, JVC, Panasonic, Samsung, Sony SIRC-12/15/20;

  2. Да се включва компютър по вътрешен таймер;

  3. Да се включва компютър от пулта ДУ;

  4. (доп.,v.5.11) Да се изключва компютър от пулта ДУ;

  5. Да се включва компютър по шина PCI при наличие на PME-поддръжка от страна на дънната платка;

  6. Да се включва компютър чрез емулация за натискане на бутон за включване Power (On-Off) при такива системи, които не поддържат PME;

  7. Да се обновява микропрограмния код на блок ARPC.

  • (доп., v.5.15) ARC - Advanced Remote Control ( [image] доп.р. - „олекотена” версия на ARPC - вж. предх.абзац!)

    позволява на тунера да работи с всякакви други пултове ДУ, работещи по стандарти NEC, JVC, Panasonic, Samsung, Sony SIRC-12/15/20.

  • IRC - Internal Remote Connection. Позволява вътрешно (скрито – вътре в корпуса на компютъра) инсталиране на инфрачервения (IR) датчик за пулта ДУ.


Topic: Изисквания към системата

Изисквания към системата

Минимални и оптимални изисквания към системата

по отношение на хардуер и софтуер (OS)

Софтуерни изисквания

  • (доп., v.5.09, 5.11, изм., drv.5.2.1.0. и следв.*) Операционна система Windows 2000/XP up to Professional x64 Edition**/2003 Server x64 Edition/ Vista x86/x64**/ [image] x86/x64

    За модели с USB2 / PCIe интерфейс е необходима операционна система не по-ниска от Windows 2000 SP4 или XP SP1.

    ( [image] Windows 98SЕ* / ME* не се поддържат от drv.5.2.1.0. и следващите версии - вж. забележките под черта)

  • Минимална разделителна способност на Windows desktop – 800x600, 16 bit.

  • Инсталиран DirectX 9.0 или по-висока версия (препоръчително - DirectX 9.0c).

  • Инсталиран универсален BDA драйвер Behold TV - версия 5.0.0.0 и по-висока.

    (доп., v.5.09) Задължително инсталиран пакет драйвери за дънната платка от съответния производител (например за VIA - пакет "4 in 1", за Intel - "Intel Inf Update").

Хардуерни изисквания

  • Процесор – минимум Intel Pentium II 450 или по-мощен

    (Intel Pentium III / 4, Intel Core, AMD Duron/Sempron/Athlon XP/Athlon64 са препоръчителни).

    * За използване на всички функции на видеопроцесинг е необходим процесор, не по-слаб от PIII-1000.

    * За запис на пълен кадър 720x576 с компресия MPEG2, DivX, WMV е необходим процесор, не по-слаб от AMD Athlon XP 2500+ или Intel P4 2400.

    * (доп., v.5.09) За USB2 модели е необходим CPU с тактова честота не по-ниска от 1000 МНz.

  • PCI 2.2 / PCIе слотове за PCI / PCIе тунери,

    PCMCIA-слот Cardbus за тунер Columbus

    USB-порт за тунери Traveler и Voyage.

  • Оперативна памет - min. 128 МB RAM. Препоръчително >= 256 МB.

    * (доп., v.5.09) За USB2 модели е необходима памет минимум 256 МВ.

  • DirectSound- и DirectShow- съвместима аудиокарта.

  • DirectDraw-съвместим AGP или PCI-Express видеоадаптер с поддръжка на овърлей (overlay) във формат YUY2.

    * За комфортна работа с DVB тунери е желателен видеоадаптер с поддръжка на технологии за апаратно ускорение DXVA MPEG2 и DXVA H.264.

  • HDD – min. 5400 RPM (об./мин.).

    * За видеозапис е препоръчителен диск с поддръжка на 7200 RPM или RAID масив.

Забележки:

*От м. Юли 2006 г. официалната поддръжка на [image] 98SE/ME е прекратена от страна на Microsoft®. Забележки по работата на драйвери и програмния продукт Behold TV в средата на тези операционни системи не се разглеждат.

В актуализираната версия на универсалния драйвер v.5.2.1.0. от 16.07.2010 г. е прекратена поддръжка на ОС Windows 98SE/ME за Behold TV. Все пак потребители, които ползват такива ОС могат да работят с тунерите и софтуерния пакет, но с по-ранни версии на драйвера. Разбира се, при такива ситуации е важно да се помни, че при по-стари драйвери и версии на Behold TV не са отстранени някои забелязани бъгове/недостатъци и не са достъпни всички функционални възможности спрямо най-новите издания, поради което въпроси от такъв характер не се разглеждат!

** [image] Media-интерфейс e-Home в операционни системи Windows MCE и Vista се поддържа само от тунери с апаратни (хардуерни) MPEG-енкодери.

The contents of Изисквания към системата

Тестова конфигурация:


Topic: Тестова конфигурация:

Тестова конфигурация:

Примерна процедура за инсталиране на драйвер v.5.2.1.0,

илюстрирана на базата на личен опит с РСІ ТВ тунери в следната РС-конфигурация:

  • Тестови ТВ-тунери : Behold TV M63 (с хардуерен енкодер) и хибриден Н6 (аналогов & [image] -T)

  • Слот - PCI 2.2.

  • Процесор – Core i7 920 Quad Core (2.66GHz, 8MB, LGA1366)

  • Оперативна памет - 6 GВ (3x2 GB DDR3 1600MHz Corsair TW3X4G1600C9DHX, XMS3).

  • МВ/Аудио - Asus P6T SE, X58, LGA1366, DDR3, 3xPCI-E(SLi/CF), SB 7.1

  • Видеокарта - GF 9800GТ, 1GB Gainward PCI-E, 256bit, DDR3

  • Операционна система - Windows XP (SP2) / DirectX 9.0с.

За почитателите на Windows Vista в превода на инструкцията за инсталиране на драйвери са оставени рускоезични илюстрации от оригиналната версия, публикувана на официалния сайт.


Topic: Инсталиране

Инсталиране

Особености при инсталиране на оборудване, драйвери и софтуер

Достигането до етапи «Инсталиране на оборудване», «Инсталиране на драйвер» и «Инсталиране на софтуер» само по себе си предполага, че потребителите вече са направили своя избор за конкретен(и) модел(и) тунер(и) с PCI, РСІе или USB интерфейс.

  • Важно! Добавянето на този раздел към оригиналната инструкция няма за цел да бъдат омаловажавани или пренебрегвани техническите познания и възможности на потребителите.

    Напомнянето за необходимост от спазване на определени мерки за безопасност и ред за работа се прави с цел да бъдат предотвратени възможни злополуки при боравене с електрическо и електронно оборудване, предпазване от повреди на вгражданите модули, компютърните конфигурации и инсталиран софтуер, както и спазване на гаранционните условия за дълготрайна и безпроблемна употреба!

    Повреди поради неспазване на инструкциите за инсталиране и работа с устройствата не попадат в обхвата на гаранционните условия!

Автономни STB (Set-Top Box) модели:

За STB модели, които могат да бъдат управлявани софтуерно от компютър, програмното осигуряване е различно от разглежданото в основния материал и е окомплектовано с отделни собствени пълни инструкции на [image] език.

Подробни материали за управление / flash на STB тунери - инструкции, описание на софтуер и Help на български език са публикувани в обособени материали .

За тунери с USB интерфейс не са необходими никакви действия, свързани с инсталиране на оборудване (отваряне на корпуса на РС/лаптоп/нетбук...). Необходими са основни познания за работа с USB устройства и спазване на правилата за безопасност при работа с такива*.

* Важно! ТВ тунери с USB интерфейс изискват не по-малко внимателно отношение, както и към други устройства с такъв интерфейс. Тези изисквания са свързани основно с процесите за инициализация/деинициализация при присъединяване/изваждане към/от USB порт и предпазване от повреди при такива действия. От една страна мерките са елементарни, изискват минимално време и в програмния пакет не случайно са предвидени съответни команди, а от друга страна при неспазване на тези задължителни условия рисковете от повреда на устройството не заслужават небрежно отношение.

При тунерите за вграждане има повече специфични особености, с които потребителите трябва да се съобразяват!

Освен това (въпреки естественото нетърпение от изпробване на всяка една нова придобивка), за да бъдат пълноценно използвани уникалните възможности, които са реализирани в ТВ тунери Beholder, преди първо включване и инсталиране на драйвери/софтуер е желателно предварително да бъдат изяснени собствените изисквания и желания за последващо управление на системата, свързани като минимум с:

  • възможности за управление, които в ТВ тунери Beholder са реализирани с технология ARPC ;

  • възможности за по-естетичен (скрит) и сигурен (по отношение защита от замърсяване, механични повреди, външни влияния и пр.) монтаж на IR-датчика за дистанционно управление на базата на технология IRC .

При правилно ориентиране в тези особености се избягва необходимост от последващо отваряне/разглобяване на оборудване, преконфигуриране на хардуер / BIOS / ОС и фирмения софтуер на Beholder, респ. могат да бъдат спестени усилия и време, както и да се предотвратят рискове от евентуални повреди по оборудването, които неизбежно се повишават с всяко следващо отваряне на корпуса и преконфигуриране на системата.

PCI / PCIе тунери Beholder са предназначени за вътрешно вграждане в корпуса на компютъра. В зависимост от ограниченията, възможностите на наличното оборудване и желанието на потребителите се предлагат широки варианти за избор:

  • Според пространствените ограничения - с "традиционна"

    или нископрофилна архитектура

  • Според свободните (или предпочитани) слотове - РСІе, РСІ 2.2

    ( [image] РСІ 2.1. - само за налични закупени преди време или "втора употреба" тунери - сериите с такъв интерфейс са с по-ограничени възможности, поради което вече са спрени от производство).

  • Освен комбинациите според архитектурата и РСІ-слотове, възможностите на системата, индивидуалните потребителски желания, предвиден бюджет и други фактори тунерите и програмното осигуряване, които предлага Beholder обхващат почти всички възможните комбинации за конфигуриране -

    § с/без FM тунер, а при наличие на такъв -

    § с/без функция RDS,

    § с/без хардуерен енкодер,

    § с пълна или частична поддръжка на фирмените технологии,

    и други фактори, които оказват влияние върху крайната цена (респ. "...колкото повече - толкова повече...").

The contents of Инсталиране

Предварителна подготовка
Хардуер
Български интерфейс и Help
BDA драйвер
Софтуер


Topic: Предварителна подготовка

Предварителна подготовка

Преди инсталиране на тунер

В зависимост от конкретния модел, тунери Beholder поддържат технологии за

  • управление на системата и програмата - ARPC / ARC (Advanced Remote & Power Control, вж. спецификациите );

  • IRC - избор на начин за монтиране на IR датчик;

  • няколко начина за предаване на звук.

Според индивидуалните предпочитания, като минимум е желателно предварително да бъдат изяснени желанията, конкретните възможности на системата и технологичните въпроси, свързани с предимствата от използване на една и/или друга(и) технология(и). С това ще бъде предотвратена необходимост от последващо отваряне/затваряне на корпуса, включване/изключване/разместване на кабели/връзки, преконфигуриране на BIOS и софтуер, респ. възможни повреди (крайно нежелателни особено за системи в гаранционен срок!) и определено ще бъдат спестени загуби на време, нерви, труд и средства.

Технология ARPC * предоставя допълнителни възможности за дистанционно управление на компютъра и Behold TV.

Забележката, че е необходима предварителна подготовка в този случай е свързана с това, че управление на захранването на компютъра в Behold TV може да се осъществява по два начина*:

  1. Чрез използване на линия «PME», или

  2. Като емулация за натискане на бутон «ATX» за включване на захранване.

Внимание! И двата начина имат свои особености, предимства, недостатъци и някои ограничения, поради което именно е важно предварително да се знае и да се прецени (и изпълни технически) кой от тях (или и двата едновременно*) е желателен (и възможен в зависимост от системата) за реализиране при инсталирането на платката на тунера!

*Вж. подробно описание в раздели «Функции и настройки» [image] « Управление на захранването » и «Панел за настройки» [image] « Пулт за ДУ » в за особености, изисквания, възможности и настройки за управление чрез посочените режими!

IRC ** позволява вътрешно (скрито - в корпуса на компютъра) инсталиране на инфрачервения (IR) датчик за пулта ДУ.

За безпроблемна работа при разполагане на датчика също трябва да се знаят някои особености и да се спазват определени изисквания при подбор на място и самото техническо изпълнение.

Доколкото свързването на датчика също се извършва при монтирането на платката, и в този случай е добре предварително да има яснота по индивидуалните желания, възможностите на системата и посочените особености.

________________________________

**вж. също раздел « FAQ »

Начини за предаване на звук***

Забележката за предварителна подготовка в случая от една страна също е свързана предоставените различни възможности за предаване на звук. От друга страна, много по-важно е да бъдат предотвратени проблеми със

  • закъснение и/ разсинхронизация спрямо видеопоток,

  • появяване на "ехо",

  • и ред други, за които в разделите за функции и настройки на аудио/видео потоци има солиден обем от информация.

В тунери Beholder принципно са предвидени няколко начина за предаване на звук:

  • чрез външен или вътрешен аудио кабел;

  • по шина РСІ / РСІе или USB порт.

При РСІ / РСІе тунери в зависимост от конкретния модел може да се реализира поддръжка на един или друг начин, а в повечето тунери са реализирани и двете възможности.

________________________________

*** Особеностите при предаване , респ. запис на звук и настройки са описани подробно в раздели:

§ « Настройки на звук »

§ Описание на интерфейса > Панел за настройки > « Настройки Аудио »

§ Описание на интерфейса > Панел за запис > « Видео/Аудео запис » и « Аудио запис »


Topic: Хардуер

Хардуер

Инсталиране на хардуер - тунери с РСІ / РСІе интерфейс

Предназначение на допълнителния раздел към оригиналната инструкция:

ТВ тунери Beholder и специализираният фирмен софтуер за тях (драйвери, програмни пакети) не изискват специални познания по хардуерна/софтуерна поддръжка или програмиране. В подробните инструкции и страниците на официалния сайт се съдържа изчерпателна информация, въз основа на която процесите по инсталиране и последващо използване могат да бъдат извършени дори от начинаещи потребители. Въпреки това се препоръчва това да бъде извършено от специалисти на съответните търговски представители или оторизирани от тях лица/сервизни организации.

Както за специалисти, така и при решение за самостоятелно инсталиране е необходимо да бъдат спазвани

Основни мерки за безопасност и ред за работа:

  1. Изключват се компютърът и захранващия кабел от електрическата мрежа

  2. Отваря се корпусът.

  3. Внимателно се поставя(т) платката(ите) на тунера(ите) в свободен(и) PCI / РСІе слот(ове) на дънната платка съгласно специфичните описания за работа със съответните дънни платки.

  4. В зависимост от избрания (ограничения - възможен) начин за предаване на звук* се съединява с външен аудиокабел аудио изход на TV тунера [image] и вход Line-in на звуковата карта

    или вътрешният аудио изход на тунера

    към вътрешен вход на аудиокартата**

IR и ARPC:

  1. Включва се IR-датчикът за приемане на сигнали от ДУ към вътрешния или външен IR-вход на тунера (вж. илюстрации към т.2. "IR" и т.4. "R/C").

  2. *** За използване на технология ARPC като емулация на ATX бутон се включват изходите на бутона за захранване на системния блок към клеми PWR_BTN на тунера, а клеми PWR_MB на тунера се съединяват чрез кабела за включване на захранването със съответния вход на дънната платка (полярността за включване на кабела и бутона е без значение).

    Клеми за кабели (ARPC) [image] [image] [image] Букса за IR-датчик (IRC)

  3. Затваря се корпусът.

  4. Включват се телевизионна- и (само за модели с FM) радио- антени към съответните входове на тунера.

    Важно!!! За модели тунери без поддръжка на технология GIAI настоятелно се препоръчва да се използва(т) галваничен(и) разделител(и) преди съответните антенни входове на тунера! Това е крайно наложително особено при включване на кабелна мрежа и активни антени със собствено ел. захранване, както и за предпазване от токови удари/гръмотевични поражения от външни антени!

  5. Включване на външни устройства към тунера:

    Внимание!!! Всякакви присъединявани устройства трябва да бъдат напълно изключени от захранващата мрежа [image] !

    Включване на външни аудио/видео устройства към тунера се осъществява през съответните входове на тунера** (в зависимост от модела):

    § с А/V кабел-"опашка" в съответствие с предназначението на съответните входове;

    § с комбиниран A/V (S-Video) кабел

    (Доп., v.5.15.) Схеми-разводки закомбинирани А/V входове в зависимост от сериите са посочени по-долу .

Забележка: Пълни инструкции с най-актуална информация са поместени на инсталационните CD и са публикувани в официалния сайт.

* Особеностите при предаване и запис на звук са описани подробно в помощната информация за работа със софтуерния комплекс Behold TV.

** Схема на разположението и описание на функционални входове/изходи на тунера са илюстрирани на кутията и в сайта за поддръжка .

*** За различни производители и модели дънни платки обозначенията могат да бъдат различни - вж. помощна информация за работа със софтуерния комплекс Behold TV.

The contents of Хардуер

Справочна техническа информация


Topic: Справочна техническа информация

Справочна техническа информация

(доп.,v.5.15) Справочна техническа и сервизна информация

  1. Схема на аудиоконектори при ТВ-тунери BeholdTV 401/403/403 FM

  2. Схема-разводка на комбиниран А/V вход за модели тунери Behold TV серии 6 / 7 и STB Behold TV INTRO:

  3. Схема-разводка на комбиниран А/V вход (куплунг MiniDIN 9PIN) за тунери Behold TV серии Н8 / А8:

  4. Схема-разводка на комбиниран А/V вход (куплунг PCMCIA 10PIN) за тунери Behold TV серии Wander/Voyage/Columbus

  5. Сервизна информация за IR-датчици според различните модели - серии 4хх-5хх (датчик TSOP1838 - 38kHz, 5V) и серии 6хх, 7х, 8х (датчик TSOP34838 - 38kHz, 2.5-5.0V):

    Забележки: 1. Дискусия по отношение самостоятелен ремонт/съвместимост се намира тук .

    2. Всякакви самостоятелни действия върху платките/елементите (по отстраняване на неизправности и др.п.) в течение на гаранционния срок водят до отпадане на гаранционните условия!


Topic: Български интерфейс и Help

Български интерфейс и Help

Инсталиране на български интерфейс

За улеснение на потребители, които срещат затруднения при използване на руски или английски език, още при първите стъпки на инсталационния процес е възможно да бъде използван самостоятелно разработен и тестван от автора български интерфейс.

Технология:

  • Внимание! За правилно визуализиране на шрифт е необходимо в Windows - Regional Options («Регионални настройки»): Control PanelRegional and Language Options... да бъде зададена настройка Russian (Bulgarian);

    В секция «Advanced» («Допълнително») за не-Unicode приложения също трябва да бъде зададен «руски» («български») език.

  • За инсталиране на български интерфейс, в основната директория на програмата (по подразбиране C:\Program Files\Behold TV), в папка \LangRes трябва да бъде копиран ресурсният файл Bulgarian.btl

    Внимание! За правилно визуализиране на шрифт е необходимо в Windows - Regional Options («Регионални настройки»): Control PanelRegional and Language Options... да бъде зададена настройка Russian (Bulgarian);

    В секция «Advanced» («Допълнително») за не-Unicode приложения също трябва да бъде зададен «руски» («български») език.

    Български (в перспектива - и други) езикови ресурси се предоставят напълно безплатно като допълнение към оригиналния софтуер в комплекта от оторизирания представител за България. Актуализации се поддържат на страницата за поддръжка - beholder-europe.com и в официалния сайт на производителя -

    раздел «Форум» [image] подраздел «Локализация» [image] тема Bulgarian (Болгарский, Български) интерфейс & инструкции .

    Към момента е актуализиран български интерфейс до версия 5.17 включително.

Действията за инсталиране на български интерфейс са елементарни и отнемат броени минути. Последователните стъпки са подробно описани по-долу в т.1.

Предвид нарасналия обем на помощните материали и за улеснение на процеса за инсталация, интегриране на български езиков интерфейс и незабавен достъп до Help-информация може да бъде извършено по още един начин, описан в т. 2.

  1. Удобно е ресурсни езикови файлове (за български език - Bulgarian.btl) да бъдат копирани в папка /LangRes на основната програма (съответно местоположение, както е посочено по-горе) в процеса на основната инсталация - в момента в който директорията на програмата се "вижда" (или е създадена предварително) в Windows Explorer.

    Ако това е направено, при достигане на етап за конфигуриране на Behоld TV при успешно завършване на процеса на инсталиране на драйвер се отваря диалогов прозорец за съгласие/отказ за отваряне на модул «Behold TV configuration»

    в прозореца за настройки може да се промени използвания до този момент език (руски, английски) с [image] потребителски интерфейс:

    При правилно инсталиран и съответно избран български език, по-нататък може да бъде използван български интерфейс както за

    Behold TV - опция «Избор на език» (панел за Настройки, секция «Управление» меню за настройки «Интерфейс», опция «Избор на език»), така и за

    Agent BeholdTV - респ. опция в собственото меню за настройки на «Agent Behold TV»

    Напомняне: Модул «Agent BeholdTV» използва общ езиков ресурсен файл за целия комплексен софтуер Behold TV.

    Избор на език за интерфейс на модула се извършва отделно от основното приложение - в секцията за собствени «Настройки» на модула.

  2. (Доп., btv_v.5.11.) Интегриране на български езиков интерфейс и помощна информация може да бъде направено по комплексен начин. При закупуване на ТВ тунер Beholder от официалния дистрибутор за България се предоставя безплатно диск с помощна информация и ресурсен файл за интерфейс на български език. Всичко, което е необходимо да бъде направено, е предварително да бъде копирана папка \BeholdTV там, където е избрано да се инсталира програмата:

    § с настройки по подразбиране - в C:\Program Files\BeholdTV, или

    § в потребителска директория по избор.

    В процеса на инсталиране BeholdTV ще запише своите системни папки в съответната директория, при което български интерфейс ще бъде достъпен без да се извършват други действия съгласно описаното тук . При това няма да бъде необходимо да се отварят други прозорци и да се извършват файлови операции по време на инсталационния процес (както е описано по-горе в т.1.), а ресурсния файл и помощната информация остават непрекъснато на разположение в системната директория на BeholdTV:

  • Допълнителна директория, в която се разполагат папки и файлове с помощна информация е

    C:\Program Files\BeholdTV\Bulgaria (файловете могат да бъдат достъпни директно или да бъдат структурирани в съответни подпапки).

  • Ресурсен файл за български интерфейс - Bulgarian.btl се разполага съответно в

    C:\Program Files\BeholdTV\LangRes.


Topic: BDA драйвер

BDA драйвер

(v.5.05~5.11) BDA драйвер

Beholder доработва и актуализира драйверите и софтуерния пакет непрекъснато ( вж. раздел «Поддръжка» ). Въпреки че представляват взаимосвързан и неразделен комплекс от едно цяло със самия тунер, тези компоненти от софтуерната поддръжка са и относително независими доколкото доработки, усъвършенстване, включване на нови възможности и функции или отстраняване на недостатъци могат да бъдат извършвани и поотделно за различните компоненти в зависимост от развитието на хардуера и поддръжката в различни версии на операционната среда. Вероятно това е една от причините разделът за инсталиране на драйвери и софтуер във версии BeholdTV v.5.07~5.11 да бъде променен и изведен в отделен раздел от Help-файла на официалния сайт на производителя.

За по-пълно придържане към структурата на оригиналната Help-версия, българският превод на раздела по аналогия също е изведен като самостоятелен раздел в обособен материал .

(доп., v.5.15~) Особености при инсталиране на BDA драйвер - Help за v.5.17 .

The contents of BDA драйвер

Инсталиране


Topic: Инсталиране

Инсталиране

(v.5.17) Инсталиране на BDA драйвер

Разширена информация за инсталиране на драйвери, софтуер и други материали по темата на български език се публикува в раздел «Поддръжка», «Форум».

За да може Behold TV да работи с тунера (както и различни странични програми на други производители на приложен софтуер) като със стандартно устройство за видеозахват, в операционната система е необхоим инсталиран BDA драйвер за тунера.

(WDM драйвери: вж. забележките за ОС Windows 98/ME )

Beholder® предоставя за всички серии и модификации на своите ТВ тунери, (изм. и доп., v.5.15.) базирани на чипсети NXP (Philips) SAA 7130/7134/7135, PCI-express чипсет NXP SAA 7231 и USB2 чипсет Trident TM 6010

единен висококачествен унифициран BDA драйвер за ОС Microsoft® Windows (изм., drv v.5.2.1.0. 98SЕ* / ME* ) 2000/ XP** /2003/ Vista** / [image], който подържа две платформи - x86 и AMD64 (32/64-битови ОС).

Този драйвер се базира на технология Microsoft® AVStream (изм. и доп., v.5..15.) и е компилиран с помощта на най-новия Microsoft WDK 7600.

За инсталиране на драйвер е задължително да има инсталиран пакет Microsoft® DirectX 9 или по-висока версия. ОС Windows XP/XPMCE2005 включват версия DirectX 9.0c; Windows Vista включва версия DirectX 10, (изм., v.5.15) Windows [image] - версия DirectX 11.

Инсталиране, а впоследствие преинсталиране и/или деинсталиране на драйвери може да бъде изпълнено с помощта на инсталатора от комплекта Behold ТV.

Препоръчва се да се провери в официалния сайт за по-нова версия на драйвера.от наличния такъв в комп Ако е свален архивен файл, същият трябва да бъде разархивиран в отделна папка. Разархивиран файл съдържа следните компоненти (в зависимост от версията на драйвера):

За инсталиране на BDA драйвер е достатъчно да бъде изпълнен файл [image] .exe от съответната папка с компонентите на драйвера.

Забележка: Инсталиране на драйвери в ОС Windows (отп. drv v.5.2.1.0 ~освен под Windows 98SЕ* / ME* ) е възможно само при наличие на Административни права.

Преди инсталиране настоятелно се препоръчва да бъде избрана опция (изм., v.~5.15) «Deinstall Behold TV BDA driver» (v.~5.11 - «Deinstall all previous NXP SAA713x installations»).

След натискане на бутон [image] системата изисква за по-голяма сигурност потвърждение:

Ако опцията за деинсталиране на драйвери не е активна (респ. не са открити предишни инсталации на драйвер), може директно да се премине към инсталиране. Под ОС Windows XP MCE2005, както и под (доп.,v.5.15)Windows Vista / [image] ще бъде изпълнена проверка за работещ сервис Media Center Receiver (ehRecvr) и същият ще бъде автоматично спрян. Това действие е НОРМАЛНО и е необходимо за освобождаване на компонента на драйвера за ТВ тунери Behold TV X7/H6/M6/Extra/ [image] M63 от сервис ehRecvr, чието място се заема от устройство енкодер, устройство за видеозахват и устройство за цифров захват при цифрови ТВ тунери.

След премахване на предишни инсталации на драйвери трябва да бъде избрана първата опция - «Install (Reinstall) Behold TV BDA driver» и да се натисне [image] .

Ако в процеса на инсталиране на драйвер се появи прозорец на системния инсталатор от типа

този прозорец трябва да бъде игнориран, (доп.,v.5.15) тъй като това съобщение е предизвикано от затварянето на стандартния диалогов прозорец за инсталиране на ново оборудване, който принудително се затваря от собствената инсталационната програма на приложението и в резултат се издава такова съобщение. Инсталационната програма [image] .exe не се нуждае от стандартeн [image] процес за инсталиране на ново оборудване и извършва самостоятелно цялата работа.

След успешно инсталиране на драйвера, в Device Manager се появява ново устройство Behold TV (ако са инсталирани няколко тунера - по едно такова за всеки инсталиран PCI тунер Beholder):

Проблеми, които могат да възникнат при инсталиране на драйвери

  • Windows 2000

    В процеса на инсталиране на драйвер под Windows 2000 може да се появи съобщение, че са необходими някои файлове и Windows ще изисква инсталационен диск за ОS, след което ще подмени някои компоненти на ОС с техни по-стари версии (файлове без сервис-пакове)

    За да не бъде допуснато това е необходимо да се провери дали в папка \WinNT\Driver Cache\i386 е наличен файл driver.cab и sp#.cab (където # е версия на сервис-пак, например sp4.cab).

  • (доп.,v.5.15) Windows ХР/2003

    Преди инсталиране на драйвер да се провери дали в папка «\Windows\Driver Cache\i386» е наличен файл driver.cab и sp#.cab (където # е версия на сервис-пак, например sp2.cab). В противен случай по време на инсталация системата ще изисква няколко файла.

  • (доп.,v.5.15) Windows XP Home Edition

    Преди инсталиране на драйвер е необходимо да се клике с [image] десен бутон на мишката върху [image] и в контекстното меню да се избере «Свойства» [image]. В секция [image] се натиска бутон «Подписване на драйвери» [image] и се избира една от опциите

    «Пропускане» [image] или

    «Предупреждаване» [image].


Topic: Софтуер

Софтуер

Инсталиране на софтуер

Инсталирането на софтуерния пакет се свежда до няколко прости стъпки, интерфейсът на които принципно е подобен на стандартна процедура за инсталиране на друг софтуер под Windows.

Доколкото технологично инсталирането на Behold TV предхожда настройки и работа с приложението, подробно описание на примерна процедура за инсталиране на софтуерния пакет е изведено в подраздел на инструкцията за инсталиране на драйвер и софтуер .


Topic: Функции и настройки

Функции и настройки

Описание на основни функции и настройки

The contents of Функции и настройки

Управление
Настройки на аналогови канали
Настройки на DVB-T канали
Включване на външни устройства
Настройки на изображение
Настройки на звук
Видеозапис
Излъчване в мрежа
Режим TimeShift
Декодиране на RDS
Телетекст
Управление на захранването (ARPC)
Включване и настройки на плъгини
Работа с няколко тунера
Ключове за командния ред


Topic: Управление

Управление

Управление на тунера

Управлението на тунера се осъществява посредством:

контекстни менюта на видеопрозореца и икона на приложението в tray;

«Панел за управление» на Behold TV;

пулт за дистанционно управление;

„горещи” клавиши („hot keys”) от клавиатурата;

мишка.

Командите на всички hot keys са изведени непосредствено в прозореца за настройки на програмата – раздели « Управление » и « Пулт ДУ ».

Контекстното меню се извиква с [image] десен клик на мишката в областта на видеопрозореца. Интерфейсът се променя в зависимост от текущия режим на работа на тунера -

  • Обикновено гледане (TV) – разширено меню;

  • Обикновено гледане (TV) – съкратено меню;

  • Обикновено гледане (DVB-T);

  • Режим «Таймшифт»;

  • Активен «Телетекст».

    В зависимост от версията на Behold TV има различия в командните редове на основните прозорци и падащи менюта/подменюта.

    интерфейс-v.5.15:

    Обикновено гледане (TV) – разширено меню

    (ред., v.5.11) Обикновено гледане (TV) –

    съкратено меню

    Обикновено гледане (DVB-T)

    Режим "Таймшифт"

    Активен Телетекст

Описание на командните редове в контекстното меню:

  • Група команди за управление на режими за извеждане на основен видеопрозорец и прозорец на контекстното меню:

    На пълен екран – Превключване между «пълноекранен режим» / режим «в прозорец».

    Видео на desktop – Видеопрозорец като Windows wallpaper.

    (доп., v.5.09) За Windows Vista/ [image] при активен Aero тази функция не е достъпна.

    Връщане към режим «в прозорец» се извършва с команда «Възстановяване на видео»

    от контекстното меню на иконката [image] или на бутон [image] в «Task manadger».

    Прозрачeн прозорец – Превключване към извеждане на видеопрозорец в полупрозрачен режим:

    Този режим е достъпен под Windows Vista, а за други версии на ОС - само в режим за извеждане на видео «Първична повърхнина».

    Съкратено / Разширено меню – Преход между режими за извеждане на контекстното меню.

  • Таймшифт – Включване на функция за отложено гледане « Таймшифт ».

  • Група команди за управление ТV канали:

    ТV канали 4Отваряне на "падащо" меню за бърз достъп до пълния списък с настроени ТВ канали

    ( [image] стават достъпни за гледане и канали, които са маркирани за пропускане):

    Програма с предавания - Извикване на диалогов прозорец за настройки и гледане на ТВ програми и EPG :

    Сърфинг на канали - Мозаичен сърфинг (предварителен преглед) на канали в отделни прозорци (клетки):

    Допълнително меню за настройки на сърфинг ( [image] десен клик в/у видеопрозореца в режим на сърфинг):

    Режим на сърфинг, клетки4задаване брой на клетки от 2х2, 3х3...до 8х8;

    Интервал на сърфинг (секунди)4от 1 до 10;

    Пауза в клетката (секунди)40 (manual), 2, 4, 6, 8, 10.

  • Група команди за настройки, управление и обработка на видеоизображение:

    Съотношение на страните4Съотношение на страните на кадър:

    Размери на видеопрозорец4Геометрични размери на видеопрозорец:

    Най-долният ред с отметка и в по-светъл тон показва текущите размери на видеопрозореца.

    Размери на видеопоток4Размери на кадър във видеопоток:

    Видеообработка4Падащо меню - диалогови прозорци за настройки на видеообработка или на включен(и) плъгин(и).

    или диалогов прозорец за настройки на даден включен плъгин.

    Имената, менютата за настройки и интерфейсът на плъгините за момента са на руски език.

    (ново, v. 5.09) Видео renderer - диалогов прозорец за настройки на параметри на видеорендерер:

  • Група за настройки и управление на видеосигнал:

    Видеовход4Падащо меню за избор на активен вход: TV, A/V

    (~v.5.10: VHS (CVBS); S-VHS (S-Video))

    v.5.11~

    ~v.5.10

    Видео стандарт4Падащо меню за избор на видеостандарт: Авто/PAL/SECAM/NTSC:

    Синхронизация на кадри4Падащо меню за избор на режим за възстановяване на вертикална синхронизация при декодиране на видеосигнал ( вж. описанието ):

  • Група Аудио опции:

    (изм и доп., v.5.09, 5.11~) Аудио система (изм., v.5.09 Аудио стандарт)4

    Падащо меню за избор на ТВ аудиосистема

    (само за модели с чипсети SAA7134, SAA7135, SAA7231, ТМ6010):

    Аудио канал4Падащо меню за избор на аудиоканал за звуков съпровод:

    § В аналогов ТВ режим канали Stereo, Language1 и Language2 работят само при наличие на ТВ-стереоизлъчване A2/NICAM/BTSC/EIAJ на текущия канал.

    (отп., v.5.05 - Канал BTSC SAP е достъпен само за стандарт BTSC и само за тунери с чипсет SAA7135).

    § В режим НЧ входове се избира режим на линия за аудиовход:

    § В режим DVB могат да се избират:

    § Stereo (два фронтални канала);

    § Mono LL (само ляв канал в двата фронтални канала);

    § Mono RR (само десен канал в двата фронтални канала).

    Избран режим се съхранява за всеки аналогов или DVB-T канал.

  • Телетекст - Включване/изключване на режим за преглед на телетекст.

  • Група за основни настройки:

    Настройки – Извикване на диалогов прозорец за настройки

    (бутон [image] от лентата на панела за управление).

    Панел за запис (Видеозахват) – Отваряне на панела за запис

    (бутон [image] от лентата на панела за управление).

    Модул за планирани задачи – Извикване на диалогов прозорец за конфигуриране на модула за планиране на задачи

    (бутон [image] от лентата на панела за управление).

  • Група за управление на видеопрозорец и прозорец на основния панел за управление:

    Прозорец с рамка – Обграждане на видеопрозореца с рамка (бордюр).

    Прозорец върху всички други (също така иконка [image] / [image]) – Разполагане на видеопрозореца (независимо от главния панел) «върху всички останали прозорци» / «зад останалите прозорци».

    Показване на основния панел – Възстановяване на панела за управление от "свито" положение в tray.

    Скриване на видеопрозореца – дословно.

  • Група за управление на програмата Behold TV (описание на управление на модул «Агент Behold TV» е отделно):

    Свиване в tray – Привежда програмата в режим на очакване.

    ( [image] Възстановяване от tray - едноименен команден ред в контекстното меню с [image] десен клик върху иконката в трея):

    Изход – Изход от програмата.

  • РCMCIA (доп., v.5.09) и USB тунери BeholdTV имат допълнителен команден ред в менюто -

    Изваждане на тунера, при изпълнение на който следва изход от програмата и деинициализиране на BDA драйвера за бързо и безопасно изваждане на устройството от слот (порт).

Основен панел за управление на Behold TV -

позволява бърз достъп до основните функции на програмата и настройки на тунера.

Интерфейсът на панела и съдържанието на LCD-дисплея се променят в зависимост от избрания режим на работа на тунера.

  • Намален:

Интерфейсът и функционалните възможности на Behold TV от v.5.11~ са променени както визуално, така и функционално в съответствие с новите възможности, реализирани в тунерите от серия „8” и следващите.

Интерфейс - v. 5.05~5.10:

Интерфейс - v.5.11:

Прецизирани са интерфейсът и функциите на бутони:

§ FM съответно в Radio (респ. аналогови FM и цифрови DVB радиостанции);

§ НЧ-входове, при които от серия „8” се появява нов – компонентен вход, са интегрирани в бутон А/V;

§ бутон DVB е прецизиран в DVB-T.

( [image] В раздел Информация за тунер BeholdTV има интригуваща информация в две полета:

и [image], които до момента не са активни и са свързани с развитието на Behold TV).

  • Разширен:

  • Намален, в режим Таймшифт:

  • Намален, в режим FM с декодиране на RDS:

  • (изм., v.5.11) Превключване в режим «Външен А/V вход»

    (v.~5.10 : / [image] - Превключване в съответен режим «Вход S-Video»/«Вход CVBS»).

    Необходим вход се избира от контекстното меню:

    (Опция «ТV» - активна от v.5.15)

  • (v.~5.10 [image]) (изм., v.5.11) - Превключване в режим «FM тунер»

    (само за модели, които поддържат FM)

    или «DVB-T Radio» (само за модели, които поддържат DVB-T).

  • - Превключване в ТВ-режим аналогов «TV тунер» или «DVB-Т ТV»

    (само за модели, които поддържат DVB-T).

  • (v.5.11~vs~5.10~ [image] ) (изм., v.5.11) - Превключване между режими «DVB тунер» / «Аналогов тунер».

Много от елементите на панела за управление изпълняват по няколко функции, избор на които зависи от предназначението на конкретния елемент и моментният режим на работа на тунера. Така например,

- [image] [image] при двоен клик с левия бутон на мишката по горния ред с номер на канал в LCD-екрана на панела за управление се извиква диалогов прозорец за работа с програма на ТВ-канали по списък, отворен на текущия канал;

- [image] при клик с десен бутон по същия ред на LCD-екрана се извежда контекстно меню със списък на канали, което позволява бързо превключване на друга програма.

Освен това, за удобство при работа с тунера достъп до списъка на канали е възможен от контекстното меню ( [image] десен клик) на бутоните за превключване на канали; от контекстното меню на видеопрозореца и дори от менюто на иконата на приложението в трея.

Допълнителните функции на елементите на панела за управление са, както следва:

(доп., v.5.17) Десен клик с мишката по бутон [image] извиква контекстно меню със списък на достъпни А / V входове (? т.напр. за тунери до серия „8” в контекстното меню няма да се визуализира компонентен вход, т.к. такъв просто не съществува в предишните серии):

Десен клик с мишката по бутони «CH» [image] [image] извиква контекстно меню със списък на настроените TV или Radio канали:

Същото действие може да бъде изпълнено и с

Десен клик с мишката по първия ред на LCD-панела [image] извиква контекстно меню със списък на настроените TV или Radio канали.

Двоен клик с мишката по първия ред на LCD-панела извиква диалогов прозорец «Програма с предавания»

Десен клик с мишката по втория ред на LCD-панела [image] извиква контекстно меню с режими за скролинг на текст:

Ляв клик с мишката по LCD-клетка «часовник» [image] показва в тази клетка информация за оставащо време до сработване на таймера за изключване [image] .

Десен клик с мишката по LCD-клетка «часовник» извиква контекстно меню на таймера за изключване, в което може да се избере време до сработване на таймера и тип на завършващо действие.

Десен клик с мишката по бутони [image] «Фотоапарат», [image] «Микрофон» и [image] «Видеокамера» извиква контекстни менюта с възможности за бързо зареждане на пресети с готови настройки (пресети, англ. preset~s) за запис съответно на Снимки, Аудио и Видео:

Десен клик с мишката по бутон «Фотоапарат» също така дава възможност за избор на режим за работа със скрийншот - «Снимка» или «Серия от снимки»:

Десен клик с мишката по бутоните за превъртане в режим «Таймшифт» [image] извиква контекстно меню с възможности за настройки на стъпка за превъртане. Стъпките се настройват отделно за превъртане назад и напред:

§ Бутони «Stop» [image] , «Pause» [image] и «Play» [image] имат различни функции в зависимост от текущия режим на работа. Тези бутони са предназначени за режим «Таймшифт», но освен това функционират и в режими на запис/възпроизвеждане. В зависимост от текущия режим на работа тези бутони имат различни „изплуващи” подсказки.

Допълнителeн разширен панел за управление

Извикване/скриване се извършва с бутон [image] от лентата в основния панел:

От панела се предоставя директен бърз достъп за настройки (на скрийншота - от ляво на дясно) на:

сила на звук,

яркост,

контраст,

наситеност,

оттенък,

острота,

ниво на видеоусилване

за всеки канал.

В панела могат да се настроят също така

размер (Zoom) и

позиция („Сдвиг”) на изображение вътре във видеопрозореца.

Всички изброени по-горе настройки могат да бъдат както индивидуални за всеки отделен канал, така и глобални - в зависимост от настройките на Behold TV. Към чисто индивидуални настройки на всеки отделен канал се отнасят избор на видео- и аудио стандарти за аналогови телевизионни програми. Всички елементи на разширения панел за управление освен усилване на звук, размер и позициониране на кадър управляват настройките на телевизионния декодер на чипсета на тунера и са достъпни само в режим на гледане на аналогова TV и видео.

При превключване на програми от пулта за ДУ на тунера или от клавиатурата, реакциите на програмата за въвеждани команди зависят от избрания режим (от 4 възможни) за набиране на номер на канал. Предпочитан начин се избира чрез „превъртане” с помощта на

„горещи” клавиши Ctrl+K от клавиатурата (доп, v.5.09) или

с бутон MODE на пулта за ДУ.

Избран начин се визуализира в горния десен ъгъл на OSD или на LCD екрана на панела за управление (в режим FM):

« - » - въвеждане на една цифра и незабавно превключване на канали с номера 1...10. Този режим не предполага въвеждане на двузначни номера и е удобен само ако броят на каналите не превишава 10. (изм., v.5.09) Цифра „0” превключва на канал № 10.

«-/-» - въвеждане на двузначен номер и незабавно превключване на избран канал след набиране на втора цифра. Ако е набрана само една цифра (канал с номер 1...9), превключване към съответния канал ще стане след 1.5 сек. За по-бързо превключване на канали от 1...9, тези номера трябва да се въвеждат във вида 01...09 (изм., v.5.09) или се въвежда цифра, след което се потвърждава с Enter.

«-/-/-» - въвеждане на тризначен номер на канал. Вж. режим «-/-».

«+/+/+» - комбиниран режим за набиране номер на канал. Позволява да се набират едно-, дву- и тризначни номера без да се въвеждат допълнителни нули, при което се минимизират паузите, необходими за изчакване на набиране на пълния номер на канал. При въвеждане на номера на канали 1...9 превключването става веднага. За въвеждане на двузначен номер на канал е необходимо да се натисне и задържи натисната първата цифра в течение на 0.4 сек., след което се появява подсказка, напомняща за възможност за въвеждане на следваща цифра.

Посоченото време 0.4 сек. се задава в секцията за настройки « Пулт ДУ » на тунера - настройка

«Закъснение преди повторение».

За клавиатурата забавянето е фиксирано и се определя от настройките на ОС [image] .

Избраният начин за набиране номер на канал се запомня отделно за режими TV и FM.

Behold TV позволява да се предефинират „горещи” клавиши за управление. Пълен списък на команди за управление с възможност за предефиниране на клавишни съчетания се намира в диалога за настройки - секция « Управление ».

След стартиране Behold TV може да се намира в три състояния:

  1. в активен режим;

  2. в «спящ» режим (свита в трея) - програмата не изразходва ресурси на операционната система и в задълженията й влиза само изчакване за натискане на бутон POWER на пулта ДУ за привеждане в активно състояние и контрол на време за изпълнение на (поредно) планирано задание;

  3. в режим на запис от свито в трей състояние - различава се от обикновения режим по това, че звук от записвано предаване не се подава към акустичната система и ако видеопрозорецът не е необходим в този режим, той може не само да бъде оставен невидим, но и да се изключи напълно, с което се пестят допълнителни ресурси на ОС за сметка на неизвеждане на допълнителен поток на видеорендер.


Topic: Настройки на аналогови канали

Настройки на аналогови канали

(доп., v.5.09~отделно обособен раздел, изм.,v.5.17)

Настройки на аналогови телевизионни- и радио програми

След успешно инсталиране на драйвер и софтуерния пакет Behold TV, тунерът трябва да бъде настроен за приемане на телевизионни- и радиопрограми.

При първо стартиране на програмата се зареждат настройки по подразбиране (със списъци на ТВ- и FM-програми, които се приемат в Русия – регион Москва).

За България и други региони тунерът трябва да бъде пренастроен с ново сканиране.

Настройка на аналогови ТВ- и радио програми се осъществява съответно от секции «ТВ» и «FM радио» в [image] панел за настройки. Автоматична настройка се извършва от съответните менюта «Автосканиране».

Основни характеристики на аналогов телевизионен канал са неговата честота, стандарт за предаване на изображение, цвят и звук.

Телевизионните канали се излъчват в честотен диапазон 48...862 МHz. За всеки ефирен канал е отделена честотна лента 8 МHz. В съответствие с избрания регион за всеки телевизионен канал е определена съответна честота.

При избор на регион се зарежда определена честотна мрежа за съответния регион.

За България чeстотите завършват на ххх.25 МHz.

Телевизионният диапазон се разпределя на групи ефирни и кабелни TВ канали. Това разпределение е донякъде условно – по правило честотите на ефирните канали не бива да се пресичат с честотите на кабелните оператори. Понякога това правило се нарушава и при наличие на кабелна ТВ след сканиране на кабелния диапазон могат да бъдат „препокрити” канали, които се излъчват и ефирно, и по кабел на честотите на ефирния диапазон. Поради това, независимо че в Behold TV има възможност за сканиране на програми по отделни диапазони, по подразбиране се зарежда «Режим на сканиране» по цялата честотна мрежа, включваща както ефирни, така и кабелни честоти.

При търсене на програми «По списък...» на канали тунерът прехвърля честоти за 99 възможни канала и включва съответния канал в списъка в случай, че на дадена честота е намерена носеща на сигнал и самият сигнал е телевизионен, т.е. има редова и кадрова структура. Под това определение могат да попаднат сигнали на телевизионни ефирни ретранслатори, които понякога се „индуцират” в кабелните мрежи. По правило това са много слаби канали с едва различимо изображение, силен шум и без цвят. Тунерът няма как да „пресява” такива канали - те могат впоследствие да бъдат премахнати ръчно.

Behold TV предоставя още един начин за търсене на канали - «По честота (пълен диапазон)». За разлика от търсенето по списък с канали, тунерът сканира целия честотен диапазон със стъпка 0.25 МHz. Този начин може да се използва за търсене на канали, честотите на които по някакви причини могат да не съответстват на стандартната, избрана за дадения регион честотна мрежа (напр.ххх.00; ххх.50; ххх.75 МHz).

При радиостанциите понятието „регионална” честотна мрежа е твърде относително и търсенето винаги се извършва със стъпка 0.05 МHz в УКВ-диапазон и 0.1 МHz в останалия диапазон.

При добавяне на канал в списъка се задават видео- и аудио стандарти в съответствие с настройките по подразбиране за нови намерени канали.

Важно!!! Ако конкретният модел тунер не поддържа автоматични режими за определяне на стандарти за цвят и звук трябва да се има предвид, че при смесено излъчване - едновременно по системи PAL / SECAM със звук BG или DK и пр., зададен стандарт по подразбиране може да не съответства на реалния стандарт:

  • При несъответствие на системи за цветност е възможно както отсъствие на цвят, така и срив в синхронизация на изображението.

  • При несъответствие на стандарт за предаване на звук - пълно отсъствие на звук или шум.

  • В последствие аудио- и видео стандарти винаги могат да бъдат подбрани (коригирани) ръчно, за всеки необходим канал.

Регионална информация: В България болшинството ТВ програми се излъчват по

§ стандарт за предаване на изображения – PAL,

§ аудио стандарт – BG,

§ стерео звук – А2.

Т.к. все още има и смесено излъчване (някои програми се излъчват със звук по стандарт DK), тези параметри трябва да бъдат коригирани ръчно.

Изменения на стандартите се отразяват веднага - без рестарт на програмата.

Освен стандарти за телевизионно излъчване, за всеки отделно взет телевизионен канал могат да бъдат зададени индивидуални параметри, като

яркост,

контраст,

наситеност,

оттенък,

острота,

ниво на видеоусилване

За модели тунери, които поддържат наслагване на аудио ефекти при предаване на звук със средства на DirectSound (вж. сравнителните таблици и възможностите в зависимост от използваните чипсети), за телевизионни- и радиоканали допълнително могат да бъдат зададени също така

§ аудио ефекти и

§ тембър за ниски/високи честоти.

Ако в настройки «Аудио» на Behold TV в качество на режим за управление на силата на звук е избран режим за управление на сила на звук [image], регулаторът за сила на звук в менюто за настройки на канали става активен и с негова помощ може да бъде изравнявана сила на звук поотделно за всеки TV/FM канал, ако звуковите нива се различават осезаемо.

По-детайлна информация за другите елементи на менюто за настройки на канали е дадена в раздела с описание на [image] панел за настройки.


Topic: Настройки на DVB-T канали

Настройки на DVB-T канали

(изм., v.5.09) Настройки на цифрови DVB-T телевизионни- и радиопрограми

Приемане на цифрови ТВ- и радиоканали, предавани по стандарт DVB-T е възможно само за модели тунери Beholdеr, които поддържат такива функции ( вж.таблицата ). Превключване на тунера в режим за приемане на цифрово излъчване се извършва с натискане на бутон [image] на главния панел (доп., v.5.17) или на пулта за ДУ.

При това програмата Behold TV прeминава в режим DVB-T TV или DVB-T Radio в зависимост от това, какъв режим съответно е използван преди превключването - [image] или [image]. При повторно натискане на бутон [image] програмата преминава обратно в Аналогов режим. При първоначално стартиране на приложението в режим DVB, списъкът с DVB-T TV/Radio канали е празен (необходимо е да се изпълни първоначално сканиране).

Настройки на цифрови канали се осъществяват от секции «DVB-T TB» или «DVB-T радио» в [image] панела за настройки на тунера. Автоматична настройка се извършва от меню « Автосканиране ». Достъп до менюто за настройки на канали е възможен само когато тунерът се намира в режим на приемане на цифрово излъчване.

За разлика от аналоговите, цифровите канали имат повече параметри и настройки. Това произтича от свойствата на цифровите телевизия- и радио, които предоставят значително по-големи възможности за предаване и приемане на видео, звук и съпътстваща информация. По аналогия с терминологията, приета за спътниково цифрово излъчване,

цифровите DVB-T канали се излъчват от транспондери. Транспондер представлява единица за предаване на транспортен поток.

(доп., v.5.17) Данните се предават във формат на цифров транспортен поток (TS).

Параметри на транспондер са

  • честота на предавателя, който излъчва цифровия поток,

  • пропускателна ширина на лентата, определена за даден цифров предавател, и

  • тип на модулация

Стандарт за DVB-T модулация OFDM (Orthogonal Frequency Division Multiplex) позволява в една лента на DVB-T спектъра да се предават два независими транспортни потока. Такъв тип модулация се нарича Йерархична (Hierachy). При наличие на йерархична модулация,

първият поток се кодира като HP (High Priority), а

вторият като LP (Low Priority).

При отсъствие на йерархична модулация в DVB-T спектъра, FEC-потокът винаги е един - HP. При автосканиране за канали Behold TV автоматично намира йерархична модулация и изпълнява анализ на двата транспортни потока.

(изм., v.5.17) За превключване на необходимия транспортен поток, към параметъра на транспондера е добавен избор на HP/LP поток (ако има йерархична модулация).

Избор на «регион» в меню «Автосканиране» определя честотна мрежа, в съответствие с която са разположени честотите на ефирните транспондерите. Автоматична настройка се извършва чрез сканиране на всички честоти, заложени в честотната мрежа на избрания регион.

В зависимост от използваната антена - тип, разположение и местни условия на прием, сигналите от транспондерите могат да имат различно ниво (мощност), отношение сигнал/шум и качество. Всички тези параметри са независими един от друг.

Иначе казано, в условията на градска среда с плътно застрояване и изобилие на индустриални смущения, дори при високо ниво на сигнал неговото качество може да се окаже недостатъчно за нормален прием.

  • За приемливо ниво на радиосигнал се счита 35 dB (мкВ) и по-високо.

  • За приемливо отношение сигнал/шум SNR=16 dB и по-високо.

  • За удовлетворително качество на сигнал се счита ниво 70%.

    За комфортно гледане на ТВ програми е необходимо постигане на показател за качество на сигнал 80% и по-високо.

    Качеството на сигнал се определя от количеството грешки, съдържащи се в първичния цифров поток. Впоследствие грешките се подлагат на корекции. Въпреки това, колкото повече са грешките, толкова е по-малка вероятността всички те да бъдат поправени. При качество на сигнал 50% и по-ниско количеството на грешки като правило превишава критичното ниво и те започват масово да проникват в изходящия транспортен поток, като правят неговото декодиране почти невъзможно. При голямо количество грешки видеопотокът започва да преминава с голямо количество пропуснати кадри, а звукът да „заеква”.

Телевизионните и радио програми които се излъчват в състава на транспортния поток при цифрово излъчване се наричат «Сервиси».

Всеки сервис (програма) има свое название и име на провайдер, предоставящ даден сервис (идоп, v.5.17) и три числови идентификатора:

SID (Service ID),

TSID (Transport Stream ID),

ONID (Original Network ID),

които позволяват да се различи един сервис от друг в обема на цялата глобална мрежа на излъчване.

В състава на всеки сервис могат да влизат видео, аудио, групи субтитри и телетекст на различни езици, електронна програма на предаванията (EPG), произволни данни и друга съпътстваща информация. Може да има няколко аудиопътеки (вкл. на различни езици).

Аудио- и видео данните, които се предават в състава на транспортния поток се кодират във формат MPEG и за тяхното възпроизвеждане е необходимо в системата да бъдат инсталирани, а в програмата Behold TV да са избрани съответните MPA/AAC аудио декодери и MPEG2/H.264 видео декодери. Проверка за наличие на такива компоненти може да бъде извършена в секция « DVB поток » на панела за настройки :

(доп., v.5.17) Информация за това, в какъв именно формат се излъчват изображение и звук за текущо избран канал може да бъде видяна в група « Статистика на DVB демултиплексор », както и групи за настройки «Видео потоци» и «Аудио потоци» в раздели « DVB-T TВ » и « DVB-T радио ».

Ако в системата са налични необходимите за декодиране MPEG видео и аудио компоненти (бутони [image] ), те могат да бъдат избирани от падащите списъци с видео- и аудио декодери на DVB-поток.

(доп., v.5.17) Видео- и аудио декодерите са разделени на две групи.

Първата група включва декодери за възпроизвеждане на видео във формат MPEG2 или H.264.

Във втората група влизат декодери за възпроизвеждане на звук, кодиран във формати MPA/AC3/E-AC3/DTS или AAC.

На практика дори в рамките на сервиси на един провайдер могат да се срщат абсолютно произволни съчетания от формати за аудио- и видеоданни. Ако необходим декодер не е избран, или избран декодер не поддържа един или друг аудио/видео формат, това най-вероятно ще доведе до липса на изображене и/или звук при приемане на един или друг канал с цифрово излъчване.

За работа с MPEG2 видео и MPA звук се препоръчват декодери InterVideo. В списъка такива са отбелязани със звездички. Ако такива декодери не са налични в списък, същите могат да бъдат инсталирани от CD "InterVideo WinDVD Creator", който се предоставя като опция в комплект с тунера.

По същия начин е отбелязан и препоръчителен декодер за MPA, AC3, DTS аудио формати - AC3Filter ( http:\\www.ac3filter.net ).

Декодери H.264 и AAC не се включват в комплекта! (доп., v.5.17) Независимо от това, ако се използва MS Windows 7 (редакция Home Premium и по-висока) - необходимите H.264 и ААС декодери са включени в тези ОС. Освен това операционни системи MS Windows Vista / 7 имат вградени висококачествени MPEG2-декодери на Microsoft, които могат да бъдат използвани вместо InterVideo.

ОС MS Windows 7 допълнително поддържа декодиране H.264/AVC и AAC с вградени декодери, като вграденият видеодекодер поддържа модел за апаратно ускорение DXVA2 както за MPEG2, така и H.264.

Освен изброените по-горе, програмата Behold TV позволява да се включват всякакви други аудио- и видео декодери, регистрирани в системата.

(доп., v.5.17) При стабилно приемане качеството на изображение и звук за цифрово излъчване напълно зависи от избрания декодер, неговите характеристики и възможностите на видеокартата. В частност, едно от важните изисквания, които се предявяват към съвременните видеодекодери се явява поддръжка на апаратно ускорение на видео акселератори - DXVA (DirectX Video Acceleration), което позволява съществено да се понижи натоварването на централния процесор при възпроизвеждане на видео с HD-качество. Освен това декодерът трябва правилно да отработва моменти на превключване на канали, разкъсване на поток, адекватно да реагира на смяна на размери на кадър при преход, например от SD на HD каналм коректно да обработва грешки, каквито неизбежно възникват в цифров поток при неуверено приемане на сигнал, както и да "умее" да осъществява деинтерлейсинг и удвояване на честота на кадри с програмни или апаратни способи. При това, ако при възпроизвеждане на видео от файл декодерите практически не се сблъскват с такова явление като грешки в потока данни или смяна на формат на кадър "в реално време", то при работа с реален транспортен поток несъответствие с тези изисквания може да доведе до зависване на изображение и появяване на артефакти в първите секунди след превключване на канал, срив в програмата, забавяне на видео по време на гледане и други нежелателни ефекти.

(доп., v.5.17) Болшинството MPEG аудио/видео декодери имат редица сво собствени настройки, събрани в стандартен DirectShow-конфигурационен диалог, който се извиква с натискане на бутон за свойства (properties) срещу избран декодер в меню "DVB поток". По правило прозорец за конфигурация на декодер позволява да бъдат избрани и настроени такива негови параметри, като тип на деинтерлейсинг и удвояване на честота на кадри, изменение на настройки за декодиране на MPEG-поток, включване или изключване на използване на апаратно ускорение за видео акселератор.

По-детайлна информация за параметри на цифровите канали може да се намери в съответните описания «DVB-T ТВ» или «DVB-T радио» в [image] панела за настройки.


Topic: Включване на външни устройства

Включване на външни устройства

(нов раздел, v.5.11~) Включване на външни устройства

Основните модели тунери Beholder имат допълнителни входове за включване на външна аудио- и видео апаратура.

(доп. р., v.5.11): вж. сравнителните таблици - някои "олекотени" бюджетни модели, напр. серия "Lite" могат да бъдат в изпълнение без такива възможности)

Аудио- и видео входовете могат да бъдат изпълнени като компоненти на A/V кабел (включен в комплекта на тунера) или във вид на съответни куплунги, разположени непосредствено на задната планка на платката на тунера.

В Behold TV необходим видеовход се задава и избира от контекстното меню на видеопрозореца (десен клик по видеопрозореца - команден ред «Видеовход»)

или от контекстното меню на бутон «А/V» на панела за управление.

Натискане на бутон [image] превключва тунера към предварително зададен вход.

В зависимост от модела тунерите могат да имат следните видеовходове:

  • CVBS (Composite Video Baseband Signal) представлява композитен видеовход. Използва се за включване на източник на композитен видеосигнал.

    В състава на CVBS по един единствен екраниран проводник се предава информация за яркост, цвят и синхронизация на телевизионно изображение. Информацията за цвят може за бъде кодирана по стандарт PAL, SECAM или NTSC.

    Такава плътна структура на CVBS сигнала не позволява да се постигне високо качество на телевизионно изображение.

    Във видео апаратурите композитните изходи обикновено са изпълнени във вид на (т.н."Чинч") RCA куплунг с жълт цвят.

  • S-Video представлява двукомпонентен видеовход.

    За предаване на видеосигнал се използват два екранирани проводника,

    § по единия от които се предава информация за яркост и синхронизация на телевизионно изображение, а

    § по втория само информация за цвят, която може да бъде кодирана по стандарт PAL, SECAM или NTSC.

    Разделянето на каналите за яркост и цветност позволява да се постигне значително по-добро качество на телевизионно изображение в сравнение със CVBS, но необходимостта от кодиране на цвят все пак не дава възможност да се съхранят оригиналните цветова острота (рус. ”чёткость”) и цветопредаване на изходящото видео.

    Във видео апаратурите S-Video изходите обикновено са изпълнени във вид на един 4-пинов куплунг MINIDIN.

  • RGB представлява четирикомпонентен видеовход.

    За предаване на синхросигнал и всяка от трите RGB съставни на цветно изображение се използват отделни екранирани проводници.

    Във видео апаратурите RGB видеосигнал присъства на плътно споени куплунги тип SCART. За включване на източник на RGB сигнал се използват същите видеовходове на тунера, както и за включване на компонентен сигнал. При това в режим RGB композитният видеовход на тунера CVBS се използва за включване на синхронизация.

  • YPbPr представлява трикомпонентен видеовход, позволяващ да се предава видео във формат, който е най-близко до физическия формат за съхранение на видео данни. При предаващата и приемаща страна данните се подлагат на минимално преобразуване, което обезпечава качество на изображение максимално близко до оригинала.

    Обикновено YPbPr видеоизходи са изпълнени като три независими RCA куплунга със зелен (Y), син (Pb) и червен (Pr) цвят.

    Трябва обаче да се има предвид, че понякога производителите на видеотехника използват RGB изходи на куплунг SCART за извеждане на YPbPr сигнал. Режим за работа на такива комбинирани изходи (YPbPr / RGB) се избира от менюто на съответната апаратура. Както и за всеки аналогов телевизионен канал, за източник на включено към CVBS и S-Video вход видео, са актуални настройки за избор на тип телевизионна система, която определя стандарт за кодиране на цвят.

При включване към YPbPr / RGB настройките на видео стандарт определят прогресивен или междуредов формат за източник на видео сигнал.

Всички изброени видеовходове са предназначени изключително за предаване на изображение.

За включване на звук към тунера се използва отделен стерео аудиовход, изпълнен в зависимост от модела на тунера във вид на два RCA куплунга в състава на A/V кабел-преходник или един 3.5 мм. мини-жак със син цвят, разположен непосредствено на задната планка на платката на тунера.

Монофонична апаратура се включва към левия или десен аудиовход на тунера. При такова включване, за да може звук да се възпроизвежда и в двата канала е необходимо в меню «НЧ входове» в настройките на тунера да се избере съответен ("Line Mono L" или "Line Mono R") режим на аудио вход.

Внимание [image] За предпазване от повреди на входове/изходи на тунера и присъединявана апаратура, всички свързвани помежду си устройства трябва да бъдат напълно изключени от захранващата мрежа


Topic: Настройки на изображение

Настройки на изображение

(доп. раздел, v.5.09) Настройки на изображение

Извеждане на видео на екран (видеорендеринг)

Размери на кадър

Размери на изображение

Съотношение на страните

Удвояване на честота/Деинтерлейсинг

The contents of Настройки на изображение

Видеорендеринг
Размери на кадър
Размери на изображение
Съотношение на страните
Удвояване на честота. Interlace/Progressive


Topic: Видеорендеринг

Видеорендеринг

Извеждане на видео на екран (видеорендеринг)

Приемано телевизионно изображение се

цифровизира от тунера,

по системната шина попада в оперативната памет на компютъра (където може програмно да се обработва с плъгини), след което

постъпва на разположение на т. нар. "Видеорендерер" – & програмно-апаратен механизъм на операционната система, който обезпечава извеждане на видеоизображения на екрана на компютъра.

„Рендеринг” е термин, приет в компютърната графика за обозначаване на процеси за построяване и изобразяване на графични сцени. По аналогия

„Видеорендеринг” е процес за изобразяване на видео на компютърен екран.

Behold TV поддържа няколко* механизма за извеждане на видео на екран:

  • За операционни системи Windows 2000 / XP / 2003 това са

    два овърлейни режима (DirectDraw7 / VMR7), и

    един режим на първична повърхнина.

  • За ОС Vista / 7 - два режима, използващи овърлейна повърхнина: VMR9 и EVR (Enhanced Video Renderer) рендерери.

Ако в Windows XP е инсталиран пакет Microsoft.NET Framework 3.5, в тази операционна система също ще бъде достъпно извеждане на видео чрез Enhanced Video Renderer (Direct3D DXVA 2.0 повърхнина) както при Vista / 7.

Поддръжка на няколко типа видеорендерери в програмата се обуславя от особеностите при работата на един или друг метод.

  • Овърлейна повърхнина (DirectDraw7) и

  • Овърлейна повърхнина (VMR7) са способи за извеждане на видео на екран,

    използващи овърлей на видеокартата.

    Овърлейно изображение (англ. overlay – нещо лежащо или намиращо се върху друго нещо) представлява само по себе си запазено в отделна област на видеопаметта** изображение, което в нужен момент се смесва в сигнала на видеокартата при формиране и извеждане на образ на екрана на монитора.

    ( [image] **респ. има пряка връзка с използване на системни ресурси - памет!)

По принцип при работа с тунер за потребителите не е задължително да имат задълбочени познания по какъв начин телевизионната картина се извежда на екран, но трябва да се знае, че методите за формиране на овърлейно изображение определят цял ред от неговите свойства и особености, за които е добре да се помни:

  1. Овърлейно изображение физически липсва на desktop-a в прозореца за приложение, използващо овърлей. Т.е., ако се направи снимка на desktop-a (с клавиш Print Screen или с някаква програма), то вместо картина във видеопрозореца на програмата Behold TV ще има черен правоъгълник, запълнен с ключов цвят.

  2. Овърлей извежда изображение върху desktop -a, като използва цветови ключ. Габаритите на видеопрозореца на програмата задават област на наслагване на овърлей, а специално определен за овърлейната повърхност цвят указва, че изображението трябва да се извежда само на посоченото място и никъде повече. Затова, ако върху видеопрозореца се окаже прозорец на друго приложение с рисунка или текст, съвпадащи по цвят с ключовия такъв, видеоизображението ще се извежда върху съдържанието на този прозорец. Такива текстове или рисунки стават като прозрачни за видеоизображението.

  3. Овърлей за видеокартата е винаги един! Едновременно с овърлей може да работи само една програма. Ако овърлеят е зает от някакво приложение, то друга програма под Windows трябва да избере за себе си друг метод на извеждане на изображение на екран, достъпен в текущата версия на операционната система, или да се „довери” на драйвера на видеокартата, който да направи това автоматично.

  4. Овърлей винаги има правоъгълна форма. Каквито и да е геометрични преобразования с изображение вътре в овърлейния прозорец, освен мащабиране по хоризонтал и вертикал са невъзможни.

  5. Овърлей не може да бъде прозрачен. Прозорците на други приложения, покриващи овърлейния прозорец, също така не могат да имат прозрачност.

  6. При по-стари видеокарти овърлей не би могъл да работи с произволно разрешение (разделителна способност) и дълбочина на цвета на desktop -a.

    На по-достъпен език необходимостта от запомняне на такива "досадни" технически детайли могат да бъдат илюстрирани със съвместно използване на овърлей в някакво приложение и на Vista Aero в новите операционни системи...

Някои от изброените свойства на овърлея налагат „идеологически” ограничения за неговото съвместно използване с Vista Aero. Поради това операционната система автоматично изключва Aero при работа с овърлей.

За разлика от овърлейна повърхност VMR7, за овърлей DirectDraw7 не са достъпни апаратни режими за деинтерлейсинг и удвояване на кадри, но при това се обезпечава по-пълна съвместимост с всички категории видеокарти и по-коректна работа в условия, при които овърлеят е зает от други приложения.

При извеждане на овърлейно изображение се използва гама-корекция, в резултат на което картината на екрана на монитора изглежда по-наситена, отколкото при използване на други видеорендерери. Освен това овърлеят на видеокартата има собствени настройки на яркост, контраст, наситеност, цветови оттенък, размери и положение на наслагвано върху видеопрозореца изображение. Всички тези настройки са достъпни от меню „свойства” (Properties) на desktop-a на Windows или чрез специални собствени приложения, които би трябвало да се предоставят от производителите на видеоадаптери в комплект с драйверите за видеокартите.

  • Първична повърхност (DirectDraw7) е метод за извеждане на изображение на екран, при който извежданото изображение се смесва със съдържанието на desktop-a (първичната повърхнина).

    По преценка на драйвера на видеокартата извеждането на изображение се осъществява или програмно, или чрез използване на апаратен акселератор. Съответно натоварването на процесора и качеството на картината в различни случаи може да бъде различно. Особено добре това се забелязва при използване на прозрачен видеопрозорец. Както за Овърлейна повърхнина (DirectDraw7), така и за Първична повърхнина не са достъпни апаратни режими за деинтерлейсинг и удвояване на кадри. Избиране на този метод извеждане на видео на екран се препоръчва само в случай, че видеокартата по някакви причини не поддържа апаратен овърлей или същият работи некоректно.

  • Адаптивна повърхност под Аеро (VMR7/9) е комбиниран метод за извеждане на изображение с използване на овърлей VMR7 или VMR9 рендерер, построен на базата на 3D-акселератора на видеокартата.

    Този режим за извеждане на видео на екран е предназначен за работа при слаби компютри, които трудно се справят с новия графичен интерфейс Vista Aero. За обезпечаване на комфортна работа с програмата Behold TV, в настройките на същата е предвидена опция « Изключване на Windows Vista «Aero» ».

    При изключен Aero извеждането на видео на екран по възможност ще се осъществява чрез използване на овърлея на видеокартата като най-слабо ресурсоемка технология.

    При активен Aero – чрез VMR9.

  • Direct3D DXVA 2.0 повърхност (EVR) – метод за извеждане на изображение на екран с използване на EVR видеорендерер, построен на база на 3D-акселератор и използващ всички най-последни технологии на съвременните видеоадаптери.

    Този видеорендерер се явява основен за операционни системи Windows Vista и Windows 7. При инсталиран пакет Microsoft.NET Framework 3.5, този вид видеорендерер е достъпен и под Windows XP. Трябва обаче да се отбележи, че EVR под Windows XP няма да работи така пълноценно, както в по-новите версии на операционните системи, доколкото моделът на видеодрайвера в Windows XP не поддържа DXVA2 (DirectX Video Acceleration). При това се използва емулация DXVA1>>>DXVA2, която не дава достъп до много функции на видеорендерера.

VMR9 и EVR видеорендерери имат свои собствени независими настройки, които могат да бъдат достъпни от „Свойства на устройство за визуализация” в настройки « Видео » и « DVB поток » на Behold TV.

Настройките на апаратен видеомиксер (яркост, контраст, наситеност, оттенък) са достъпни и за двата типа видеорендерери.

Апаратен филтър за шумопотискане и детайлизация е достъпен само за EVR рендерер и видеокарти nVidia GeForce серии 6/7/8/9 с апаратен блок PureVideo.

Функция за нелинейно разгъване на изображение във видеопрозорец («Панорама») също така е достъпна само за EVR рендерер.

Операционната система и драйверите за видеокартите трябва да поддържат всички изброени по-горе типове видеорендеринг. Това обаче силно усложнява разработката на драйвери за видеокарти води до появяване на грешки, които могат да предизвикат сривове в работата на операционната и видео системи. Един или друг видеорендерер може просто да не се поддържа от драйвера на видеокартата.

*Това по същество е основната причина, поради която Behold TV не се ограничава с един метод за извеждане на видео на екран, а предлага избор от няколко способа.

Всички видеорендерери така или иначе използват апаратни функции на видеокартите. Обаче например в сървърните версии на операционните системи, с цел повишаване на тяхната стабилност апаратното ускорение на видеоадаптерите напълно или частично се изключва по подразбиране, което води до "черен екран" или изкривяване на цветопредаване при работа в различни режими за изобразяване на видео.

В меню "Диагностика" ("Troubleshooting") на допълнителните настройки на видеоадаптера трябва да се провери дали е зададено апаратно ускорение на максимум. Стартира се и инструмента dxdiag.exe (бутон "Start" –> Run... –> dxdiag.exe) и се проверява в настройките "Display" на инструмента дали е напълно включено апаратно ускорение DirectDraw и Direct3D.

Качеството на извежданото на екран телевизионно изображение зависи както от използвания видеорендерер, така и от разрешението (разделителна способност), с което кадър ще бъде цифровизиран от чипсета на тунера.


Topic: Размери на кадър

Размери на кадър

Размери (разрешение) на кадър

В състава на телевизионния сигнал се предават три компонента на изображение –

  • една яркостна, и

  • две цветоразликови съставни (YUV) на изображение.

    В съответствие с препоръките на стандарт ITU-601, яркостната Y-компонента на аналогов телевизионен сигнал се цифровизира от тунера c честота 13.5 МНz, във връзка с което на телевизионен ред, (дължината на който в система PAL/SECAM съставлява 64 мкс.) се падат точно 864 отброявания (рус."отсчет~ов"). В съответствие със същия стандарт, от цифровизиран телевизионен ред се избират 720 отброявания, в които попада цялата негова видима част (52 мкс.-702 отброявания) и по 9 отброявания отляво и отдясно, които на свой ред се падат на полето.

    Телевизионният кадър в стандарт PAL/SECAM се състои от 576 реда.

    ! По такъв начин пълен цифровизиран кадър от страна на тунера има размери 720х576 !

    В оперативната памет за последваща обработка, запис и извеждане на екран може да бъде зареден както пълен кадър във формат ITU-601 (720 отброявания на ред с полета), така и «изрезка» от пълен кадър, която не съдържа странични полета – 704х576. Базовият размер на кадър 704 по хоризонтал се получава с добавяне към 702-я по един пиксел отляво и отдясно за обезпечаване кратност на 32 за удобство при последваща програмно/апаратна обработка на такъв кадър.

    Изложените до тук теоретични моменти са в основата на следващите закономерности и изводи, които от една страна са от съществено значение за настройки и при видеообработка, а от друга са в основата на много често задавани въпроси, свързани с видеоизображение:

    В съответствие с посоченото по-горе се открояват обективни фактори, които не се влияят от субективните желания на потребителите:

максимално качество на телевизионно изображение се достига при разрешение 704х576. Всякакви други размери на кадъра, които могат да се задават в настройки «Видео» на програмата Behold TV, се получават от базовите 704х576 или 720х576 (с полета) чрез мащабиране в по-голяма или по-малка посока.

Намаляване на размера на кадър винаги води до загуба на част от информацията и съответно до влошаване на качеството на изображението. От друга страна, при това се намалява обема на предаваните и обработвани от процесора данни, което е актуално за слаби компютри.

Увеличаване на размера на кадър спрямо базовия по никакъв начин не се отразява на качеството на изображение.


Topic: Размери на изображение

Размери на изображение

Размери на изображение

Компютърните тунери приемат, цифровизират и извеждат на екран телевизионен кадър изцяло - такъв, какъвто е:

точно 576 реда на изображение с продължителност по 52 мкс. всеки. В реалността обаче първите и последни редове на телевизионен кадър рядко се използват за предаване на "служебна" видеоинформация и са запълнени с един вид "отпадъчен" шум , който изглежда на екран като разноцветни изблици (рус."всплох~и") и щрихи по края на изображение. Освен това, ретранслираната видима част на телевизионен ред може да бъде по-малка, отколкото се полага - в този случай отляво и отдясно в кадъра ще присъстват черни или слабо оцветени с неопределен цвят полета.

При обикновените телевизори подобен род изкривявания не се забелязват, т.к. там не се изобразява цял кадър а се мащабира, като се оставя извън пределите на екрана по 5~10% от изображението от всяка страна.

Програмата Behold TV също може да мащабира кадър при извеждане на екран.

Настройки за позициониране и размер на изображение вътре във видеопрозорец са достъпни от допълнителния панел за управление на Behold TV. Тези настройки могат да бъдат съхранявани индивидуално за всеки канал.


Topic: Съотношение на страните

Съотношение на страните

Съотношение на страните

Традиционният телевизионен кадър е с пропорции 4:3. Това създава определени неудобства при гледане на телевизионно изображение на монитори и телевизори със съотношение на страните 16:9 и 16:10. За да бъдат съхранени правилни пропорции на телевизионно изображение при гледане на пълен екран, в Behold TV са предвидени три основни способа:

  • В първия случай изображение с пропорции 4:3 се помества в центъра на широкоформатен монитор и се допълва отдясно и отляво с черни полета. Този режим в програмата носи име «4:3 Letterbox».

  • Във втория случай изображението запълва по хоризонтал целия екран, но при това се губи част от кадъра отгоре и отдолу, т.е. примерно толкова, колкото заемат черните полета при излъчване на широкоформатни филми. Този режим в Behold TV се нарича «16:9 Pan Scan».

    В програмата двата режима се включват от контекстното меню на видеопрозореца - «Съотношение на страните».

  • Третият способ може да бъде достъпен само при поддръжка от страна на операционната система и видеокартата на EVR видеорендерер. Изображение с формат 4:3 се „разтяга” непропорционално при извеждане на екран, като го запълва изцяло при съхраняване на правилни пропорции в центъра на кадъра, с изкривявания по краищата. Този режим, наречен «Панорама» се задава в меню «Свойства на устройство за визуализация» на настройки « Видео » и « DVB поток » в Behold TV.

  • Съществува още един ("обратен") режим - «16:9 Anamorphic», който е предназначен за гледане на филми във формат 4:3, които са подготвени за показване на широкоформатни екрани. В прозорец 4:3 такива филми изглеждат като "разтеглени" по вертикал. Режим «16:9 Anamorphic» възстановява правилни пропорции на такова изображение.


Topic: Удвояване на честота. Interlace/Progressive

Удвояване на честота. Interlace/Progressive

Удвояване честотата на кадри и деинтерлейсинг

Телевизионно изображение се предава покадрово, с честота 25 кадъра в секунда.

Всеки кадър се предава на два етапа – първо нечетни (1,3,5...), после четни (2,4,6...) редове на кадър.

Полукадър, съставен от четни или нечетни редове, се нарича поле.

Обикновено се казва, че телевизионно изображение се предава с честота

§ 25 кадъра/сек. или

§ 50 полета/сек.

Две последователни полета могат да са части от един цял кадър и тогава такива кадри се наричат „прогресивни”.

В същото време, всички полета могат да представляват отделни независими полукадри, заснети с удвоена честота 50 Нz и тогава пълни кадри, сглобени от такива полета се наричат „интерлейсни” (от англ. Interlace – последователност, или в частност редуване на телевизионни редове).

Това, какъв се явява даден кадър - прогресивен или интерлейсен, зависи от изходния видеоматериал и снимачната апаратура на предаващата страна.

Обикновените телевизори приемат и извеждат кадри на екран по реда на постъпване на полетата. Редовете на всяко следващо поле се извеждат в промеждутъците между редовете на преходното поле.

При компютрите видео се изобразява по-различно. Цифровизирани кадри се пренасят на екрана на монитора с честота 25 кадъра/сек. изцяло, т.е. по две полета едновременно. Ако при това видеоред се явява интерлейсен, то при всяко движение в кадъра ще се вижда неговата междуредова структура. За да се избегне този неприятен ефект при гледане и запис се използват така наричаните деинтерлейс филтри, които премахват от кадъра част от информацията, с което го правят прогресивен.

Интерлейсен видеоред обаче е характерен именно с това, че за разлика от прогресивно видео е способен да предава два пъти повече фази на движение на подвижни обекти на екрана.

За да бъде съхранена по-голяма част от видеоинформацията и в същото време да се премахне т.н. „гребеновиден” ефект (рус.”расческа”), който възниква поради интерлейсинг, при гледане на видео на компютър се прибягва към удвояване на честотата за извеждане на кадри на екран. При удвояване на честотата на кадри се обезпечава максимална плавност на движения на екран, което в съчетание с деинтерлейс филтър прави гледане на видео на компютър по-комфортно, отколкото на телевизор. Избор на деинтерлейс филтър и включване на режим за удвояване на кадри при гледане се осъществява от меню « Видеообработка на изображение при гледане » в настройки «Видео» на Behold TV.


Topic: Настройки на звук

Настройки на звук

Настройки на звук

За извеждане на звук тунерите използват звуковата карта на компютъра. Тунерът може да използва аудиокартата както като обикновен усилвател/комутатор на аудиоканали, така и в режим Direct Sound, т.е. както правят това и други програми под Windows.

  1. В първия случай аудиокартата се използва само за управление на силата на възпроизвеждане и включване/изключване на звук (функция MUTE). В този случай тунерът трябва да бъде включен към един от входовете аудиокартата с вътрешен или външен аудио кабел.

    За модели с чипсет SAA7130 това изискване е задължително.

    При такова включване звук не се цифровизира и не се обработва от компютъра, а се предава „едно към едно” от тунера през аудиокартата директно към акустичната система (колонки, слушалки).

    Вътрешно включване на тунера е за предпочитане, т.к. външният вход на аудиокартата може да бъде настроен като изход за задни колонки.

  2. Във втория случай не са необходими никакви кабели за включване към звуковата карта. Звук от телевизионни- и радиопрограми се цифровизира от чипсета на тунера и се предава по системната шина в паметта на компютъра, от където се чете и се възпроизвежда от аудиокартата.

    Цифровизация и предаване на звук по шина е възможно само за модели тунери с чипсети (доп.,v.5.11) SAA7134, SAA7135, ТМ6010, SAA7231 (конкретният чипсет е посочен в техническите характеристики на съответния модел).

И двата способа за извеждане на звук имат свои плюсове и минуси:

  1. + Предаване на звук по кабел на практика изключва забавяне на звук по отношение на „живия” ефир, което например е осезаемо, ако в помещението има работещи едновременно на един и същи канал обикновен телевизор и компютър с тунер.

    - От друга страна, по стерео кабел не може да се предава многоканален звук (5.1~7.1).

  2. + По системна шина могат да се предават и възпроизвeждат толкова звукови канали, колкото може да формира чипсетът на тунера.

    - В този случай обаче, звукът ще се възпроизвежда със забавяне спрямо живия ефир от няколко милисекунди, което при работещ в съседство телевизор създава осезаемо ехо.

    Освен това този начин за предаване на звук изисква най-пълна поддръжка на Microsoft DirectSound интерфейс от страна на драйвера на аудиокартата. В противен случай при възпроизвеждане е възможно „прищракване”, „заекване” и изкривяване на звук.

Всички настройки за управление на звук в програмата Behold TV се намират в диалоговите прозорци за настройки на секция « Аудио ».

За да бъде по-добре разбираем смисълът на тези настройки е добре да се знае как работят класическите компютърни аудио карти:

Всяка аудио карта има определен набор от входове и изходи. Всеки вход/изход има свой собствен регулатор за усилване на звук и баланс. Произволен вход може да бъде включен или изключен от изхода на аудиокартата. Управление на входове/изходи в системата се осъществява софтуерно - чрез аудиомиксер. Ако в компютъра има инсталирани няколко аудио карти, то всяка от тях ще има собствен аудиомиксер, името на който по правило отразява принадлежност към конкретна звукова карта. Освен това, някои аудио карти могат да имат по два аудиомиксера, единият от които осигурява комутация и управление на входове/изходи в режим на възпроизвеждане, а другият - в режим на запис.

По такъв начин, при включване на тунера с кабел към някой от входовете на аудио карта, на Behold TV трябва да се укаже:

  • към кой именно вход и

  • точно на коя аудио карта е включен тунерът.

    Иначе казано, в настройки «Аудио» на тунера е необходимо коректно да се избере

Миксер за възпроизвеждане (от група «Устройство за възпроизвеждане») и

Линия за управление на звук (група «Извеждане на звук»_ [image] Аналогов изход (по аудио кабел) [image] бутон [image] «Конфигурация» [image] «Избор на линия за аудиомиксер» [image] ... ).

Ако това не е направено или е зададено неправилно, няма да може да се регулира звук.

Няма да работи и функция за пълно изключване на звук (Mute).

По-точно всичко това ще работи, но по отношение на някакъв друг вход на аудиокартата, с който тунерът няма нищо общо.

Настройки на Миксер за възпроизвеждане и Линия за управление на звук са актуални и в този случай, при който се използва извежда звук по системна шина (група «Извеждане на звук» > [image] DirectSound PCM аудио (по шина РСІ / USB):

Независимо от това, че управлението на сила и изключване на звук в случая се реализира с чисто програмни средства чрез DirectSound, Behold TV трябва „да знае” към кой вход на аудиокартата е включен тунерът, т.к. при предаване на звук по шина аудиокартата не се управлява и избраният вход трябва да бъде изключен.

(доп., v.5.09) Освен избор на Миксер за възпроизвеждане, при възпроизвеждане на звук със средствата на DirectSound е актуална още една настройка на тунера - Устройство DirectSound (от група «Устройство за възпроизвеждане»):

Ако в компютъра са инсталирани няколко аудиокарти, то на програмата на тунера задължително трябва да се укаже през коя аудиокарта (Устройство DirectSound) да се възпроизвежда звук. Името на аудио картата като правило фигурира в пълното име на Устройство DirectSound от списъка и може да съвпада с името на аудио миксера.

Behold TV управлява само този аудио вход на звуковата карта, който е избран в настройките. Този вход се присвоява вече само на тунера и регулиране на усилване не влияе на работата на други програми и устройства. Въпреки това, звуковите карти имат още една линия, която може да се управлява от програмата Behold TV - това е

  • линия Main, която отговаря за общата сила на всички налични изходи на аудиокартата. Тази линия не е необходимо да се избира от списъка с линии за управление на звука. Тя е известна винаги. Достатъчно е само да се активира настройка

    «Управление чрез обща линия за усилване-от аудиомиксер».

    При това сила на звук в програмата винаги ще се регулира посредством общата линия на миксера на аудиокартата.

Функцията за изключване на звук (Mute) както и преди това ще използва избраната линия за управление на звук или ще се управлява чрез DirectSound.

Способът за управление на обща сила на аудио миксера не е съвсем коректен по отношение на други програми, работещи със звук. В този смисъл е актуална още една настройка на програмата –

«Съхраняване на аудио ниво за обща линия в настройките». При включване на тази опция нивото на сила на общата линия на миксера на аудиокартата се запомня при пускане на програмата и се възстановява при завършване на работа. При това нивото на сила ще се установява в съответствие с настройките на тунера, т.е. такова, каквото е било при завършване на предходния сеанс на работа. Ако тази опция е изключена, при пускане на програмата нивото на сила на общата линия няма да се изменя.

Подобно на звуковите карти, тунерът има свой собствен аудиомиксер. Той управлява линиите на аудио декодера на чипсета на тунера и е необходим за изравняване на сила на звук от различни източници, които могат да бъдат включени към него. В случая под "източници на звук" се подразбират както физически устройства (външна видео/аудио апаратура), така и отделни канали на ТВ програми със звуков съпровод (Mono, A2, NICAM).

Отделните ТВ- и радио канали сами по себе си могат да имат различни нива на сила на звук. Те могат да бъдат изравнявани едни спрямо други в един от режимите за управление на звук.

Индивидуални настройки (и донастройки) на сила на звук за канали/радиостанции се извършва в менюта за настройки TV и FM или в "падащия" допълнителен панел за управление на Behold TV.

Освен настройките за сила на аудиодекодер, избрана линия за управление на звук и линия Main за ниво на усилване, в системата (респ. в програмата Behold TV) оказват влияние и настройки Front, Rear, Center и Wave на системния аудиомиксер. Всички тези линии се отнасят към общите системни ресурси и различни програми в операционната система нямат права да ги управляват. Въпреки това за съществуването на тези линии трябва да се помни.


Topic: Видеозапис

Видеозапис

Запис на видео

  • Кодеци

  • Контейнери и методи за запис

  • Битрейт

  • Формат на кадър

  • Размери на кадър

  • Пропорции (аспект) на кадър

  • Деинтерлейсинг при запис

  • Избор на устройство за запис

Изображения и звук, които се приемат от тунера могат да бъдат записвани (съхранени) във файл.

Файл, в който аудио- и видео- данни следват определен ред се нарича контейнер.

За намаляване на обема на записвани данни се използват кодеци.

The contents of Видеозапис

Кодеци
Контейнери и методи за запис
Битрейт
Формат на кадър
Размери на кадър
Пропорции (аспект) на кадър
Деинтерлейсинг при запис
Избор на устройство за запис


Topic: Кодеци

Кодеци

Кодеци

( [image] вж. също «Съвети при видеозапис» [image] « Кодеци »)

Секунда запис некомпресирано видео заема обем:

720 * 576 * 2 * 25 = 20736000 байта (20 МВ),

където:

720 – размер на кадър по хоризонтал; 576 – размер на кадър по вертикал;

2 – количество байтове, използвани за кодиране на цвят на един пиксел изображение във формат YUY2.

25 – честота на кадри в секунда в системи PAL/SECAM;

_Съответно минута видео ще заеме 1.16 GB, а за половинчасов филм са необходими 104 GB свободно дисково пространство. При излъчване на такова видео по мрежа ще е необходим канал с чиста пропускателна способност над 160 МB/s.

Секунда запис на звук във формат CD-AUDIO заема на диск:

44100 * 2 * 2 = 176400 байта (172 КВ)

където:

44100 – частота на подбор на аудио семпли (честота на цифровизация);

2 – количество байтове на подбор (16 бит);

2 – количество аудио канали (стерео).

Един час аудио запис ще заема 605 МB дисково пространство.

Такива обеми с данни са неудобни за съхранение, а физическата скорост на носителите (рус. "накопители~ей") и пропускателна способност на каналите за връзка може да се окажат недостатъчни за равномерен запис без пропускане на кадри и предаване на видео по мрежа. Поради тези причини при запис и излъчване в мрежа се използват кодеци (англ. codec, от coder/decoder — кодер/декодер или compressor/decompressor) — програми/алгоритми, предназначени за обработка (кодиране) на аудио и видео данни с цел намаляване (свиване, компресиране) на техния първоначален обема.

Компресиране на данни може да бъде извършвано както със загуби на части от информацията, респ. на качество на изображение и звук, така и без такива загуби.

Медиа-данни, към които се отнасят изображение и звук, по принцип са лошо структурирани и да бъдат постигнати високи коефициенти на компресия при свиване без загуби е невъзможно. Типичен представител на lossless (англ. дословно – «без загуби») кодеци се явява кодек Huffyuv 2.2.0 , който обезпечава в зависимост от сложността на изходното изображение коефициент на компресия 2~3. Намаляване на първоначалния обем данни 2~3 пъти съществено понижава натоварването на дисковата система и прави възможен запис на видео на диск в реално време. Въпреки това обемите данни все пак остават внушителни и по тази причина кодеци типа Huffyuv се използват само за промеждутъчен (междинен) запис на изображения с цел последваща обработка с видео редактори.

Да се постигнат високи коефициенти на компресия е възможно с помощта на кодеци, използващи компресиране със загуби. Степента на загуби зависи от особеностите на работа и настройките на конкретния кодек.

Така например кодеци Morgan M-JPEG и PICVideo M-JPEG , които използват алгоритъм за вътрешнокадрово компресиране JPEG, дават добри резултати при компресия 10~15 пъти. В настройките на кодек Morgan M-JPEG това съответства на качество 75, в настройките на PICVideo M-JPEG – качество 16. Кодеци MPEG2, MPEG4 ASP и H.264, които използват алгоритми за вътрешнокадрово и междукадрово компресиране позволяват да се постигнат подобни резултати при компресиране 27, 54 и 65 пъти, което съответства на битрейти 6000, 3000 и 2500 в настройките на тези кодеци.

Трябва да се има предвид обаче, че по правило колкото по-висок е коефициентът на компресия в кодек, на същия се налага да обработва толкова по-големи обеми от информация и толкова по-високи са изискванията на кодека към производителността на централния процесор. Всеки цифровизиран от тунера кадър се предава към кодека за обработка. Приложено към видео - кодекът разполага с точно 40 милисекунди (период на редуване на последователност на пълни кадри в системи PAL/SECAM) за да обработи кадър и да го подготви за запис на диск или предаване по мрежа. Ако кодекът не се справя с тази задача за отделеното за това време, то новопостъпил кадър се помества в специален буфер, където очаква своя ред. Буферът, размерът на който в програмата Behold TV се задава от потребителите, застрахова от единични пикове (рус. "всплеск~ов") в натоварването на компютъра, предизвиквани например от работата на други приложения. От друга страна обаче систематични задръжки на конвейера за обработка на видео бързо могат да предизвикат препълване на буфера, което неминуемо ще доведе до загуба на кадри. С цел оптимизация на натоварването на централния процесор чрез преразпределение (рус. "распаралеливание") на изчислителните процеси, съвременните кодеци позволяват да се задава в собствените им настройки какво количество ядра (потоци) да се използват в процеса на обработка на данни.

Кодеците се правят и се разпространяват от странични производители на програмни продукти и се инсталират в системата от потребителите самостоятелно. Обикновено при инсталиране на кодек в системата се регистрират както енкодер за компресиране на аудио/видео данни, така и декодер за тяхното възпроизвеждане. MPEG енкодери и декодери по правило се разпространяват отделно.

Цялата необходима информация за използвани кодеци програмата Behold TV получава от операционната система. Съответно производителите на кодеци са длъжни да осигурява техните програми да бъдат регистрирани коректно в системата.

Преди да се използва избран кодек е необходимо запознаване с неговите свойства, параметри и настройки. Предоставянето на описание и всички технически характеристики на кодек е задължение на съответните странични производители.

Програмният комплекс Behold TV работи с VCM кодеци в съответствие с правилата и спецификациите, на стандарти Microsoft VfW и предявява към кодеците най-минимални изисквания. Съответният кодек трябва да поддържа формати данни YUY2/RGB24 и да работи със всички възможни разрешения на кадър. В случай, че даден избран кодек не поддържа някакви параметри, които се залагат от програмата или не съответства напълно на спецификации Ms VfW, не се гарантира стабилна работа на Behold TV.

Трябва да се помни, че VCM и DirectShow кодеци могат да имат набор от собствени параметри, достъпни чрез «Свойства на кодека / Properties» в настройките на панела за запис в Behold TV. Настройките на тези параметри определят неговата производителност, качество на кодиране и в някаква степен могат да влияят на стабилността на работа на системата като цяло.

Редица VCM кодеци имат възможности да съхраняват настройките на своите параметри в съответствие със спецификациите на Ms VfW. Програмният продукт Behold TV по възможност използва това свойство, което позволява да се съхраняват настройки на кодеци индивидуално за всеки пресет за запис. Производителите на кодеци могат по свое усмотрение да внасят изменения в блока за съхранявани данни в различните версии. Задължението новите версии на кодеците да бъдат съвместими по тези параметри лежи изцяло върху съответните производители.


Topic: Контейнери и методи за запис

Контейнери и методи за запис

Контейнери и методи за запис

Контейнер (англ. container, от англ. contain — «съдържа..., включва...») представлява файл или поток, в който аудио и видео данни се редуват в определен порядък.

Освен изображения и звук в контейнера се съдържа информация за размера и честотата на следването на кадри, формат на видео и звуков съпровод, както и допълнителни данни, необходими за правилно възпроизвеждане на съдържанието на контейнера.

Болшинството съвременни контейнери се явяват потокови. Това означава, че за преглед на съдържанието на контейнера може да се пристъпи от произволно място в него, като не се изчаква приключване на запис или пълно зареждане на файл от мрежата. Съответно потоковите контейнери не пазят информация за дължина и време за възпроизвеждане на файл. Продължителност на такъв файл се изчислява от плейърите въз основа на съдържащи се във файла времеви отметки, необходими за неговото равномерно възпроизвеждане и синхронизация на видео и звук.

В програмата Behold TV са представени способи (~методи) за запис както с явно указване на тип на контейнер (AVI, ASF, MPEG, WAV), така и с неявно (WMV, WMA). Освен това програмата предоставя възможности за запис и излъчване в мрежа на аудио данни без формиране на контейнери (MPA, AC3, MP3).

Microsoft AVI (Audio Video Interleave)

Microsoft ASF (Advanced Systems Format)

Microsoft WMV (Windows Media Video)

Software MPEG (InterVideo), Software MPEG (Microsoft Windows 7), Hardware MPEG

TS (Transport Stream)

Microsoft ACM , Microsoft ACM чрез DirectShow

Microsoft WMA (Windows Media Audio)

Software MPEG Audio (InterVideo), Software MPEG Audio (Microsoft Windows 7), Hardware MPEG Audio

The contents of Контейнери и методи за запис

AVI
ASF
WMV
Software/Hardware MPEG
TS
ACM
WMA
Software/Hardware MPEG Audio


Topic: AVI

AVI

Microsoft AVI (Audio Video Interleave)

Един от най-популярните формати файлове-контейнери с разширение *.avi. Форматът е разработен от Microsoft в 1992 г. Контейнер AVI може да съдържа видео/аудио данни, компресирани с използване на всякакви комбинации от кодеци, съответстващи на спецификации Microsoft VfW и DirectShow. AVI не се явява потоков контейнер. Цялата информация за неговото съдържание се съхранява във файла до завършване на записа. Съответно файл не може да бъде прочетен (възпроизвежда) до тогава, докато не завърши процесът на неговия запис. При аварийно завършване на запис съдържанието на файла по правило не може да бъде прочетено.

Контейнер AVI не може да бъде използван за излъчване в мрежа. AVI контейнер също така няма средства за синхронизация на изображение и звук при възпроизвеждане на видео файлове. Поради тази причина физически дължините на аудио и видео потоците вътре в контейнера трябва да бъдат строго еднакви по време на възпроизвеждане.


Topic: ASF

ASF

Microsoft ASF (Advanced Systems Format)

Разработен от Microsoft файлов формат, който представлява сам по себе си по-нататъшно развитие на контейнер AVI. ASF се явява част от Windows Media и за работа с него е необходима OS Windows XP SP2.

  • За по-ранни версии OS Windows е необходимо инсталиране на пакет с обновявания Microsoft Windows Media Format Runtime 9.0/9.5/11. Такива обновявания могат да бъдат инсталирани чрез сервис Microsoft Windows Update или с изпълнение на файл wmfdist95.exe от компакт-диск Beholder в комплекта на TV-тунера. Ако такъв пакет обновявания не е инсталиран, запис във формати WMV/WMA/ASF няма да бъде недостъпен.

  • Windows XP SP2 включва Windows Media Format Runtime 9.0.

  • Windows Vista се доставя с Windows Media Format Runtime 11. Както и AVI, контейнер ASF може да съдържа видео/аудио данни, компресирани при използване на всякакви комбинации от кодеци. За ASF файлове-контейнери обикновено се използва разширение *.asf. Освен това файлове, в които аудио и видео данни са компресирани с кодеци Windows Media Audio и Windows Media Video могат да имат разширение *.wma и *.wmv. Разширение *.asf обикновено се използва за файлове, които съдържат данни, кодирани с кодеци на странични (не-Microsoft) разработчици.

Контейнер ASF може да бъде използван за излъчване в мрежа и има допълнителни функции по синхронизация на аудио/видео потоци.


Topic: WMV

WMV

Microsoft WMV (Windows Media Video)

Метод за запис или излъчване в мрежа на видео/аудио с използване на Microsoft кодеци Windows Media Video и Windows Media Audio в състава на контейнер ASF.

  • Формат Windows Media Video (VC-1) представлява сам по себе си по-нататъшно разширение на стандарт MPEG-4 от Microsoft и превъзхожда по качество кодеци DivX и XviD, разработени в съответствие със спецификация MPEG-4 part 2 (ISO/IEC 14496-2).

  • Формат Windows Media Audio е разработен и се позиционира от Microsoft като алтернатива на формат MPEG Layer-3 и в някои случаи го превъзхожда по съотношение качество/размер на файл. По всичко останало способ за запис WMV е аналогичен на запис в контейнер ASF и към него се предявяват всички изброени системни изисквания.


Topic: Software/Hardware MPEG

Software/Hardware MPEG

Software MPEG (InterVideo), Software MPEG (Microsoft Windows 7),

Hardware MPEG

Способи за видеозапис и излъчване в мрежа в състава на контейнер ISO13818-1 Program Stream, или по-просто - в MPEG.

MPEG е наименование на група стандарти за цифрово кодиране на видео и аудио сигнали, разработвани от специалисти на Motion Picture Experts Group и одобрени от ISO - Международна Организация по стандартизация.

Файлове-контейнери Program Stream имат разширение *.mpg.

Като контейнер, MPEG-файл се състои от елементарни аудио- и видео- потоци, кодирани по строго определен начин, благодарение на което се спазва пълна съвместимост между програмно/апаратни MPEG енкодери и декодери на различни производители. В частност програмата Behold TV поддържа способи за запис с използване на програмни енкодери InterVideo - «Software MPEG (InterVideo)» и Microsoft - «Software MPEG (Microsoft Windows 7)», а също така способи за запис с помощта на апаратни енкодери производство на NXP и NEC.

  • Апаратен запис (Hardware MPEG) е достъпен само за притежатели на тунери с вграден апаратен MPEG-енкодер.

  • За програмен запис (Software MPEG) е необходимо в операционната система да има инсталирани съответни кодеци.

Кодеци InterVideo се регистрират в операционната система при инсталиране на програма WinDVD Creator от допълнителния компакт-диск в комплекта на тунера.

Кодеци Microsoft са включени в състава на операционна система Windows 7 (редакция над Home Basic).

Контейнер Program Stream също така се използва в програмата Behold TV за запис на текуща телевизионна- или радио- програма при приемане на цифрови DVB канали.


Topic: TS

TS

TS (Transport Stream)

Контейнер ISO13818-1 Transport Stream. Във формат именно на този контейнер се осъществява излъчване на цифрови спътникови, ефирни и кабелни канали.

Този контейнер е универсален и освен всичко друго позволява да се излъчват H.264 видео потоци, AAC аудио потоци, няколко аудио пътеки, субтитри, телетекст и друга сервизна информация. В програмата Behold TV контейнер Transport Stream се използва при приемане на цифрови канали за запис и излъчване в мрежа както на целия излъчван транспортен потока, така и на текуща телевизионна- или радио- програма, заедно или без съпътстващи сервиси. Файлове-контейнери Transport Stream има разширение *.ts.


Topic: ACM

ACM

Microsoft ACM, Microsoft ACM чрез DirectShow

Способи за запис на звук, основани на технология ACM (Audio Compression Manager) на операционна система Windows. Запис на звук се осъществява във формата на контейнер WAV (Waveform Audio File Format) във файлове с разширение *.wav.

Контейнер WAV може да съдържа аудио данни, кодирани с всякакъв ACM-кодек. За категории MPEG Layer-3 кодеци в програмата Behold TV е предвидено изключение и аудио данни, компресирани с тези кодеци се записват без формиране на WAV-контейнер във файлове с разширение *.mp3.

Способ за запис «Microsoft ACM» работи само със звук, цифровизиран от звуковата платка (~аудио карта). За целта аудио изходът на тунера трябва да бъде включен с кабел към входа на звуковата карта. За модели тунери, които нямат аналогови аудио изходи, този метод за запис не е достъпен.

Способ «Microsoft ACM чрез DirectShow» в програмата Behold TV поддържа запис на звук, цифровизиран както от аудио карта, така и непосредствено от чипсета на тунера (звук по шина PCI/USB).


Topic: WMA

WMA

Microsoft WMА (Windows Media Audio)

Способ за запис и излъчване в мрежа на аудио във формат Microsoft Windows Media, в състава на контейнер ASF. При това контейнерът съдържа само аудио данни, кодирани с кодек Windows Media Audio, който се позиционира от Microsoft като алтернатива на формат MPEG Layer-3 и в някои случаи го превъзхожда по съотношение качество/размер на файл.


Topic: Software/Hardware MPEG Audio

Software/Hardware MPEG Audio

Software MPEG Audio (InterVideo), Software MPEG Audio (Microsoft Windows 7),

Hardware MPEG Audio

Способи за излъчване в мрежа и запис на аудио -

- или без формиране на какъвто и да е контейнер (файлове с разширение *.mpa и *.ac3),

- или в състава на контейнер ISO13818-1 Program Stream (файлове с разширение *.mpg). При това контейнер Program Stream съдържа само аудио данни, кодирани във формат MPEG-1 Layer II или Dolby AC3.

  • Способ «Hardware MPEG Audio» е достъпен само за притежателите на ТВ тунери с интегриран апаратен MPEG енкодер.

  • Способ «Software MPEG Audio (Microsoft Windows 7)» е достъпен за потребители с операционна система Windows 7 (редакция над Home Basic).

  • Способ «Software MPEG Audio (InterVideo)» е достъпен само при наличие на инсталирани в системата MPEG кодеци InterVideo. Кодеци InterVideo се регистрират в операционната система при инсталиране на програма WinDVD Creator от допълнителния компакт-диск в комплекта на тунера.


Topic: Битрейт

Битрейт

Битрейт

Битрейт (от англ. bitrate – bit rate, скорост на потока в битове) е един от основните параметри, използвани при запис.

Битрейт се задава в настройките на кодека и най-често се измерва в количество килобит~ове, необходими за съхранение на секунда цифровизирани данни (kbps, kBit/s). Практически за всички кодеци се отнася правилото - колкото по-висок е битрейтът, толкова по-добро е качеството на цифровизирано видео и звук. Поради това в настройките на някои кодеци понятието «битрейт» понякога се подменя с относителното понятие «качество» (quality), което от своя страна зависи от цял ред други настройки на конкретния кодек, алгоритми, заложени в основата на неговата работа и сложността на цифровизирания материал (количество малки детайли и шумност на изображение и звук, интензивност на изменения в последователността на кадри и пр.).

Такива кодеци като DivX и XviD имат в своите настройки вградени калкулатори за разчет на битрейт. При разчет се указва необходим размер на файла, продължителност на запис, честота на кадри, както (по желание) да се отчита битрейт на аудио и обем на служебната информация (overhead), добавяна от контейнера при опаковане на аудио и видео данни.

Като се знае битрейтът може без труд да се изчислят размерите на бъдещ файл. Опростено общият размер на файл при запис се изчислява по следната формула:

Размер_на_файл=(Битрейт_видео + Битрейт_аудио) * Време_на_запис / 8

Ако битрейт е зададен в килобита/сек, а времето е указано в секунди, размерът на файла ще бъде изчислен в килобайтове. За преизчисляване на килобайтове в битове, мегабайтове и гигабайтове се използват следните съотношения:

1 байт = 8 бита

1 килобайт = 1024 байта

1 мегабайт = 1024 килобайта

1 гигабайт = 1024 мегабайта

Разчет за размера на файл ще бъде справедлив само в този случай, при който величината на битрейт не се променя в процеса на запис. Такъв битрейт се нарича постоянен - CBR (Constant Bit Rate). При постоянен битрейт качеството на цифровизирано видео и звук ще зависи от сложността на цифровизирания материал. Т.к. шумове и изобилие на малки детайли в кадър изискват голям битрейт, за съхранение на неговата постоянна стойност кодекът ще жертва качество на изображение или звук.

Алтернатива на постоянния битрейт се явява променлив битрейт – VBR (Variable Bit Rate). При променлив битрейт кодекът самостоятелно оценява сложността ня сцена и автоматично, в рамките на зададени стойности увеличава битрейта за поддържане на оптимално качество на изображение или звук.


Topic: Формат на кадър

Формат на кадър

Формат на кадър

Телевизионно изображение е прието да се предава, съхранява и обработва във формат YUV, т.е. във вид на 3 компонента – яркостна и две негови цветоразликови съставни.

Яркостната компонента на телевизионния сигнала Y представлява сама по себе си пълноценно черно-бяло изображение, което направо се извежда на екраните на черно-бели телевизори.

Цветоразликовите компоненти получават своето наименование благодарение на способа за тяхното формиране като разлики между B, R компоненти на цветно изображение и неговата яркост Y. U и V компоненти се смесват в телевизионния сигнал и носят информация за цвят. Ако се знае яркостната компонента и две цветоразликови, може да бъде извършено обратно преобразуване и да се изчислят по-привични за разбиране и приети като основни за болшинството устройства за изобразяване на информация три RGB компоненти на изображение.

YUV-формат за представяне на цветно телевизионно изображение е бил приет на първо място от съображения за съвместимост с черно-белите телевизионни приемници, за работа на които яркостната компонента на телевизионния сигнала е трябвало да бъде оставена неизменно. При това въвеждането на цветоразликови компоненти, които също така се наричат цветност, се е оказало точно навреме за компресиране и съхранение на видео. Т.к. човешкото око е значително по-слабо чувствително към окраската на изображение, отколкото към неговата яркост, то обемът на данни, кодиращи цвят може без особени последствия да бъде съкратен два или даже четири пъти. Така се появява формат YUY2, където цветност U и V се указват едновременно за два съседни пиксела на изображение, като в същото време яркостта Y при всеки пиксел остава своята. По такъв начин, за да се зададе цвят на два пиксела във формат YUY2 са необходими само 4 байта, или условно казано 2 байта (16 бита) на пиксел. Това е двукратно по-малко по сравнение с формат RGB24, където за указване на цвят за всеки пиксел са необходими 3 байта (24 бита).

Тунерът във всеки случай цифровизира кадър веднага във формат YUY2, но по желание може апаратно да го преобразува към RGB24. Трябва да се помни обаче, че формат RGB24 е крайно неефективен от гледна точка на обработка на данни със съвременните процесори. Формат RGB24 е съхранен в програмата Behold TV изключително за съвместимост с кодеци, които умеят да работят само с RGB представяне на цвят в кадър.

Ако даден кодек поддържа и двата формата на кадър, то избор на RGB24 в настройките за запис по-скоро ще доведе до това, че преди компресиране кадър ще бъде преобразуван от кодека обратно към формат YUY2 или негов подобен, за което ще бъде пожертвано допълнително процесорно време.


Topic: Размери на кадър

Размери на кадър

Размери на кадър

В съответствие с препоръките на стандарт ITU-601, яркостната Y-компонента на аналогов телевизионен сигнал се цифровизира от тунера c честота 13.5 МHz, във връзка с което на телевизионен ред, продължителност на който в система PAL/SECAM съставлява 64 мкс, се падат точно 864 отброявания (рус. "отсчёт"). Част от телевизионния ред се заема от служебна информация и поради това, в съответствие със същия стандарт, от цифровизиран телевизионен ред се подбират 720 отброявания, в които попада цялата видима част от реда (52мкс-702 отброявания) и по 9 отброявания на поле. Телевизионен кадър в стандарт PAL/SECAM се състои от 576 реда. По такъв начин, пълен цифровизиран кадър от страна на тунера има размер 720х576. В оперативната памет за по-нататъшна обработка, запис и извеждане на екран може да бъде зареден както пълен кадър във формат ITU-601 (720 отброявания на ред с полета), така и фрагмент от поле на кадър, не съдържащ полета от страни – 704х576. Базовият размер на кадър 704 по хоризонтал се получава с добавяне към 702-я по един пиксел от ляво и от дясно за обезпечаване на кратност на 32 за удобство за последваща програмно/апаратна обработка на такъв кадър.

Моделите тунери, които имат вграден скалер (апаратен модул, управляващ мащабиране), могат да формират кадър в по-широк диапазон на разрешения, които се предлагат за задаване в настройките за запис на видео/аудио в панела за запис [image] . Всички допълнителни разрешения се формират от базовите разрешения 704х576 или 720х576 (с полета). Ако необходим размер на кадър отсъства от списъка, предлаган от тунера, такъв винаги може да бъде получен чрез програмно мащабиране или отсечка на краищата на изходното изображение.

Отсечка на излишни краища често се използва при цифровизиране на широкоформатни филми, които имат черни полета отгоре и отдолу на изображението. Към намаляване на размери на кадър се прибягва случай, че централният процесор не се справя с обработката на пълен кадър или когато е необходимо да се прибегне до икономии в размера на записан файл.

При програмно изменение на размерите на кадър е желателно да се следи за това, размерите на неговите страни да остават кратни минимум на четири или на осем, т.е. да се делят на тези числа без остатък. В голяма степен това изискване е свързано с особеностите на работа на програмно/апаратните алгоритми за обработка на изображение при запис и възпроизвеждане на записан файл. Нарушение на тези правила може да доведе до възникване на критични грешки, способни да предизвикат сривове в работата на операционната система.

Също така, произволно мащабиране по вертикал не може да се прилага по отношение на интерлейсен кадър. Това ще доведе до разрушаване на неговата междуредова структура и изкривявания при възпроизвеждане. Ако все пак възниква такава необходимост, то интерлейсен кадър трябва предварително да бъде обработен с деинтерлейс-филтър. Това изискване обаче не е приложимо в тези случаи, когато размери на кадър се избират от списъка с фиксирани разрешения, предлагани от драйвера на тунера. При намаляване на размерите на кадър по вертикал с четно количество пъти, драйверът на тунера автоматично изключва от видео последователността едно поле, като фактически превръща кадъра в прогресивен.

Намаляване на размерите на кадър винаги води до загуба на част от информацията, следователно до влошаване на качеството на изображението. Съществува обаче определена зависимост между клас/формат на източника на видео, качество на изходния видеоматериал и оптимални размери на кадър, при които такива загуби могат да бъдат пренебрегнати. Взимайки предвид това под внимание, може да бъде икономисан битрейт, следователно и размер на крайния файл, или като се съхрани битрейт даже да бъде повишено качеството на цифровизирано видео. По-долу са приведени съответствия на размерите на кадър за най-често разпространените формати видео:

Запис на ефирно предаване PAL: 720х576, 480х576

Запис на ефирно предаване SECAM: 480х576

Запис на ефирно предаване NTSC: 720х480, 640х480

Цифровизиране на S-VHS запис PAL: 720х576

Цифровизиране на S-VHS запис NTSC: 720х480

Цифровизиране на VHS запис PAL: 480х576, 352х576, 352х288

Цифровизиране на VHS запис NTSC: 480х480, 352х480, 352х240


Topic: Пропорции (аспект) на кадър

Пропорции (аспект) на кадър

Пропорции (аспект) на кадър

Исторически телевизионното изображение е имало предназначение за показване на екрани на телевизори със съотношение на страните 4:3. Съответно, за спазване на правилни пропорции цифровизиран на компютър телевизионен кадър също така трябва да се изобразява в прозорец 4:3. Обаче, ако се вземе например базов размер на кадър 704х576, то не е сложно да се разбере, че отношението на неговите страни 704:576=1.22 е далече от необходимото 4:3=1.33. Т.е., ако даден плейър изобразява такъв кадър на екрана на монитор такъв, какъвто е, в правоъгълен прозорец със страни 704х576, то изображението ще се окаже свито по хоризонтал.

За задаване на реално съотношение на страните на прозорец в плейър за извеждане на цифрово видео се използва т.н. аспект на кадър – коефициент, който се задава в настройките на кодек и съхранява във видео поток. При извеждане на екран кадър се разтяга от плейъра до необходими пропорции.

Ако размерите на кадър са равни на неговия аспект се казва, че такъв кадър има квадратен пиксел. Ако избраният кодек не позволява да се задава аспект на кадър, то за неговото правилно изобразяване на екран наличие на квадратен пиксел е задължително.


Topic: Деинтерлейсинг при запис

Деинтерлейсинг при запис

Деинтерлейсинг при запис

Телевизионно изображение се предава покадрово, с честота 25 кадъра в секунда.

Всеки кадър се предава на два етапа – първо нечетни (1,3,5...), после четни (2,4,6...) редове на кадър.

Полукадър, съставен от четни или нечетни редове, се нарича поле.

Обикновено се казва, че телевизионно изображение се предава с честота

§ 25 кадъра/сек. или

§ 50 полета/сек.

Две последователни полета могат да са части от един цял кадър и тогава такива кадри се наричат „прогресивни”.

(доп., v.5.15) Прогресивно видео се заснема с честота 25 кадъра/сек.

В същото време, всички полета могат да представляват отделни независими полукадри, заснети с удвоена честота 50 Нz и тогава пълни кадри, сглобени от такива полета се наричат „интерлейсни” (от англ. Interlace – последователност, или в частност редуване на телевизионни редове).

(доп., v.5.15) При запис на видео трябва да се отчита не само това, какъв се явява видеоред - прогресивен или интерлейсен, но и това - къде и как ще се възпроизвежда записано видео – на екрана на компютър, или чрез стационарен DVD-плейър на телевизор.

Обикновените телевизори приемат и извеждат кадри на екран по реда на постъпване на полетата (доп., v.5.15) с честота 50 полета/сек. Редовете на всяко следващо поле се извеждат в промеждутъците между редовете на преходното поле (доп., v.5.15) и това, какъв се явява видеоред за телевизора няма никакво значение.

При компютрите видео се изобразява по-различно. (изм. и доп., v.5.15) В най-простия случай, цифровизирани кадри се пренасят на екрана на монитора с честота 25 кадъра/сек. изцяло, т.е. по две полета едновременно. Ако при това видеоред се явява интерлейсен, то при всяко движение в кадъра ще се вижда неговата междуредова структура. За да се избегне този неприятен ефект и да бъде съхранена плавност при движение, присъща на интерлейсно видео, при гледане (v.~5.11 - и запис) се използват така наричаните деинтерлейс филтри, които премахват от кадъра част от информацията, с което го правят прогресивен.

(доп., v.5.15) Дали обаче ще има деинтерлейс и ще се прилага ли удвояване на честотата на кадри при възпроизвеждане на видео или не, зависи от твърде много фактори – от настройките на програмния плейър, декодера, формат на видеопотока и даже от апаратните възможности и драйвера на видеоадаптера. Така например, ако даден плейър няма свои собствени деинтерлейс-филтри то видео, записано с кодецио DivX или WMV ще се изобразява с изкривявания. В същото време файлове, записани във формат MPEG2 по-скоро ще бъдат възпроизвеждани без проблеми. Цялата информация за структурата на кадър, необходима за правилно възпроизвеждане на MPEG файл се пази в MPEG потока и всеки видео декодер или медиаплейър при желание може да се възползва от същата.

За да бъде направен процесът на възпроизвеждане на видео на компютър по-предсказуем и независещ от настройките на програмните плейъри е необходимо да бъде преобразуван междуредов видеоред към прогресивен. При това такова може да бъде направено непосредствено в процеса на запис. За това в настройките за видеообработка на кадър в панела за запис на програмата Behold TV е предвиден избор на деинтерлейс филтър. Освен това, да бъде изпълнен деинтерлейсинг преди компресиране също такт се предлага в настройките на някои кодеци. При това обаче кадър остава междуредов чак до момента на предаването на същия към кодека и да бъдат прилагани към него програмни методи за мащабиране не е възможно.

Ако видео се цифровизира с цел последваща обработка във видео редактори или за запис на DVD и гледане изключително на екран на телевизор, то в този случай обратно, задачата се свежда до това, както може по-точно да бъде повторена оригиналната структура на кадър. Работата е в това, че при компресиране на интерлейсен кадър като едно цяло отчасти произтича разрушаване на неговата междуредова структура, т.е. редовете на полетата като че ли да се смесват между себе си. За да не се случва това, в настройките на съвременните кодеци може да бъде указвано кадър да се свива по полета. При това четните и нечетни редове на интерлейсен кадър ще бъдат групирани в два независими полукадъра и свити поотделно. Апаратни енкодери NEC и NXP винаги цифровизират видео само по полета. При декодиране на видео, компресирано по подобен начин интерлейсната структура на кадър напълно се възстановява.


Topic: Избор на устройство за запис

Избор на устройство за запис

Избор на устройство за запис

Ако цифровизиране на видео може да се изпълнява само от едно устройство - тунер, то запис на звук в програмата Behold TV може да се осъществява по два начина – от самия тунер или с помощта на системната аудио карта.

За модели тунери, които не поддържат цифровизиране на звук от чипсета на тунера е достъпен само вторият вариант.

За тунери, които нямат аудио изходи за включване към звукова платка е достъпен само първият вариант.

Всеки способ за цифровизиране на звук има свои плюсове и минуси. Така например, звуковата платка предоставя по-широк честотен спектър и формати за запис, докато при цифровизиране от чипсета на тунера се обезпечава най-добра синхронизация на изображение и звук, а също така позволява да бъдат изключени от веригата за обработка на аудио поток допълнително цифрово-аналогово и аналогово-цифрово преобразуване.

Цифровизиране на звук от чипсета на тунера се включва чрез задаване на флаг [image] (изм. и доп., v.5.15) «Запис на аудио поток по шина РСІ/PCI-E/USB» в настройките за запис на програмата Behold TV. Съответно, ако тази настройка е изключена, звук автоматично ще се записва от аудиокартата, за което външният или вътрешен аудиоизход на тунера трябва да бъде включен с кабел съответно към външен или вътрешен вход на звуковата карта. В програмата Behold TV трябва задължително да бъде указано точно към коя звукова карта (устройство за аудио запис) е включен телевизионният тунер. Ако това не се направи, то по подразбиране като устройство за запис на звук може да се окаже Bluetooth-гарнитура, гласов модем или микрофон на web-камера, които нямат никакво отношение към тунера и не могат да бъдат използвани за запис на звуков съпровод на телевизионни- и радио програми.

Избор на устройство за запис на звук се осъществява в настройките за аудио запис в панела за запис на програмата Behold TV – меню « Устройство за аудио запис (общи настройки) ». Същото може да бъде извършено в отделния пакет с инструменти за конфигурация Behold TV config, който се предлага д бъде отворен веднага след инсталиране на програмата Behold TV:

Звуковата карта се представя в операционната система като устройство, в наименованието на което най-често е отразена марката на производителя или чипсета на аудио картата, например «Realtek HD Audio Input».

Всяка звукова платка има определен набор от входове (линии). Всеки вход има свой собствен регулатор за сила на звук и баланс, при изменение на които програмата може да управлява нивото на запис. Всеки вход може да бъде включен или изключен от аналогово-цифровия преобразувател на звуковата платка, която непосредствено се занимава с цифровизиране на звук.

Управление на входовете на аудиокартите се осъществява чрез програмни аудиомиксери, които за звуковата платка могат да бъдат няколко. При смяна на миксер се сменя достъпният набор от линии за запис. Освен това, в Windows Vista/Seven избор на миксер подменя сам устройството за запис, настройки на което в тези операционни системи е недостъпни. При избор на устройство за запис на звук и/или аудиомиксер, на програмата Behold TV е необходимо да се укаже към кой вход на звуковата платка е включен тунерът, т.е. допълнително да се избере активна линия за запис.

Ако наименованието на аудиомиксер по правило отразява принадлежност към конкретна звукова платка, то обозначението на входовете на аудиокартата може да бъде произволно.

Външен вход на звуковата платка се нарича «линеен» и се обозначава като Line-In.

Вътрешен вход по-рано се използваше за включване на устройства CD-ROM и поради това към тях исторически се е закрепило наименование «Лазерно устройство» или CD-In.

При аудиоплатки Audigy производство на Creative всички външни входове са групирани в едно цяло и носят общо наименование Analog Mix.


Topic: Излъчване в мрежа

Излъчване в мрежа

Излъчване (ретранслиране) на аудио/видео потоци в мрежа

Излъчване (ретранслиране) на видео/аудио по мрежа е еквивалент на процес на запис, само че не във файл, а в IP-мрежа. Респективно настройки за ретранслиране в мрежа се осъществяват също в «Панел за запис» [image] .

За целта в настройките за запис е достатъчно да се зададе направление на поток [image] «Излъчване в IP-мрежа». Настройките на формати за запис (~v.5.09 - Microsoft WMV / WMA / ASF или MPEG) са описани подробно в раздел « Панел за запис ». След настройка на всички параметри на кодек, излъчване в мрежа се стартира като обикновен запис [image] с натискане на бутон [image] за стартиране / респ. за спиране на излъчване. Видима контролна индикация за излъчване в мрежа е промяната на иконката в трея - [image] и надписът в LCD дисплея на основния панел:

При посочване с мишката върху иконката се извежда разширена информация:

(доп., v.5.09) Съществуват 2 основни транспорта за предаване на данни в IP-мрежа - TCP и UDP:

  1. TCP транспорт се използва за обезпечаване на съединение тип клиент-сървър, при което в процеса на съединение между два хоста (клиент и сървър) произтича ”handshake” („ръкостискане”) и в случай на успех се установява надеждно съединение, гарантиращо доставката на пакети между хостовете. На базата на TCP транспорт работят протоколи на по-високо ниво като HTTP, FTP и пр. Ако със сървъра установяват съединение няколко хоста-клиенти, които поискват постоянно едни и същи данни, на всеки клиент поред ще бъде изпратено копие на един и същи пакет. Това влошава пропускателната способност и създава ефект на „гърловина”. От друга страна TCP пакетите ще бъдат гарантирано доставяни от маршрутизаторите от една подмрежа в друга без нарушаване целостта на данните.

    Протоколите на база TCP позволяват да се създават съединения от произволни точки вътре в глобалната мрежа.

  2. UDP транспорт се използва за изпращане на големи пакети (датаграми) на определени адресати или група от адресати. След изпращане на UDP пакет хостът, който го е изпратил напълно губи контрол над този пакет. Вътре в една подмрежа обикновено UDP пакетите достигат своята точка на предназначение и редът на тяхното получаване съответства на реда на изпращане. Болшинството маршрутизатори обаче са настроени така, че не пропускат UDP датаграми или могат да нарушат тяхната последователност.

    Транспорт UDP е много удобен за предаване на мултимедия-съдържание вътре в една подмрежа, тъй като може да адресира пакети към мултикаст-групата и всеки хост, членуващ в тази група ще получава дадения пакет. Това води до икономия на пропускателна способност на мрежата при голям брой клиенти.

(доп., v.5.09) Behold TV позволява да се излъчват:

  • Windows Media потоци (WMV/WMA/ASF) през HTTP протокол по unicast схема.

  • MPEG потоци (MPEG2 PS, MPEG2 TS (DVB), MPA аудио) през HTTP протокол по unicast схема.

  • MPEG потоци (MPEG2 PS, MPEG2 TS (DVB), MPA аудио) през UDP протокол по multicast схема.

  • MP3 аудио поток през HTTP и SHOUTcast протокол по unicast схема.

  • MP3 аудио поток през UDP протокол по multicast схема.

Компютърът, на който е(са) инсталиран(и) тунер(и) и е настроен за излъчване в мрежа условно се нарича излъчващ сървър.

(доп., v.5.09) Всеки клиент, който желае да се включи през HTTP протокол, установява съединение с IP-адреса на избрания мрежов интерфейс (който "вижда" в нужната подмрежа) на хоста–излъчващ сървър. Ако на дадения клиент е разрешено включване се установява HTTP съединение и започва предаване на данни от сървъра Behold TV към всеки клиент. В статусния ред на излъчващия сървър може да се види количеството на включени клиенти и информация за всеки клиент.

(доп., v.5.09) Всеки клиент, който желае да получава пакети от излъчващия сървър през UDP протокол, установява членство (MEMBERSHIP) в multicast-групата, на multicast-ip адреса на която хостът Behold TV изпраща UDP-пакети.

(доп., v.5.09) Препоръки за включване на клиенти към излъчващия сървър Behold TV:

За преглед/прослушване на излъчван в мрежа видео/аудиопоток не могат да се използват всички програми-плейъри. Списък на основни поддържани плейъри:

  • Microsoft Windows Media Player. Приема по мрежа (през HTTP) само потоци Windows Media, както и MP3 аудио.

    Не приема от мрежата потоци MPEG2 PS, MPEG2 TS, MPA аудио.

  • Nullsoft Winamp ( http://www.winamp.com ). Приема по мрежа (през HTTP и SHOUTcast протоколи) потоци MP3 аудио, MPA аудио, AAC аудио, WMA аудио.

  • VideoLAN VLC Media Player ( http://www.videolan.org ). Приема по мрежа всички известни потоци по протоколи HTTP и UDP.

  • Media Player Classic Home Cinema ( http://mpc-hc.sourceforge.net ). Приема по мрежа Windows Media и MPEG потоци, както и MP3 аудио по протоколи HTTP и UDP.

HTTP протокол

UDP протокол

The contents of Излъчване в мрежа

HTTP
UDP


Topic: HTTP

HTTP

(доп., v.5.09) HTTP протокол:

След стартиране на излъчване в мрежа, URL за включване на клиенти към сървъра ще се визуализира в десния долен ред за URL-статус на панела за запис (секция «Запис»). Този адрес, както и други адреси (например външен адрес в Интернет) за текущия излъчващ сървър може да се копира в буфера за обмен (clipboard) от контекстното меню на мишката над лентата на статуса.

(доп., v.5.09) При натискане на мини-бутона над числото на свързаните клиенти може да се види детайлна информация за всеки включен клиент.

(v.5.05 - Текущият ретранслиращ сървър може да се включи „към себе си” чрез т.н. "loopback" - http://127.0.0.1:порт или http://localhost:порт, което е едно и също.)

  • Windows Media Player

    За включване (v.5.05 ...към излъчващия сървър от отдалечен компютър) клиентът трябва да стартира Windows Media Player, в менюто да се избере «File», отваря се адрес «Оpen URL...» и в появилия се диалог трябва да се внесе URL на сървъра във вид:

    http://адрес:порт

    например: http://192.168.3.150:8080

  • WinAmp

    За включване клиентът трябва да стартира WinAmp (http://www.winamp.com), в менюто на WinAmp да се избере «File», «Play URL» и в диалоговия прозорец да се внесе по посочения по-горе начин URL.

    Ако сървърът излъчва WMA или ASF поток трябва допълнително да се добави разширение със звездичка (*.wma или *.asf),

    например: http://192.168.3.150:8080/*.wma

  • (доп., v.5.09) Media Player Classic Home Cinema (съкр. МРС).

    За включване клиентът трябва да стартира MPC, в менюто да се избере «File», «Оpen File...» и в ред „Open” да се набере URL на сървъра във вид http://адрес:порт (вж. по-горе).

    Понякога MPC некоректно разпознава MPEG поток и не определя в него видео (само аудио). Препоръчва се отново да се повтори процедурата за включване.

  • Екранни снимки от тест с VLC Media Player:


Topic: UDP

UDP

(доп., v.5.09) UDP протокол:

След стартиране на излъчване в мрежа ІР адресът на multicast групата, както и портът ще се визуализират в ред за URL-статус на панела за запис.

  • (доп., v.5.09) VLC Media Player

    За включване клиентът трябва да стартира VLC, в меню «File» да се избере команда «Оpen URL...», да се избере UDP/RTP Multicast, да се въведе IP адрес на Multicast групата и номер на порт. Също така във VLC може да се отвори плейлист-а и да се включи източник «SAP» (б.р. > разширени настройки > Show settings > отметка all). След 1~3 секунди там ще се появи анонсен ред, който разпраща Behold TV по SAP протокол. С двукратен клик по реда VLC сам ще определи URL и ще се включи.

  • (доп., v.5.09) Media Player Classic Home Cinema

    За включване клиентът трябва да стартира MPC, в менюто да се избере «File», «Оpen File...» и в ред „Open” да се набере URL на сървъра във вид:

    udp://multicastaddress:порт

    например: udp://224.0.1.1:10200


Topic: Режим TimeShift

Режим TimeShift

TimeShift / Таймшифт

вж. също така описание на интертейса - настройки TimeShift ; Въпроси и отговори (FAQ) .

Работата на режим Таймшифт може да бъде илюстрирана като аналогия при работа с мултимедийни файлове, но в реално време. По същия начин, както при гледане на такива материали с обикновен видеокасетофон, DVD плейър или на компютър, във всеки един момент гледането може например да бъде спряно на пауза (примерно докато се отговаря на телефонно повикване), както и да бъде върнато до необходим момент или от самото начало и отново да бъде възобновено.

За онагледяване на полезните страни на функцията може да се посочи например гледане на футболен мач в реално време, в който пред гол е имало съмнение за засада - изображението може да бъде върнато до момента на подаване към играча "в засада" и да се разглежда колкото пъти има желание, кадър по кадър...

Функция Таймшифт работи по аналогия с пауза при гледане/слушане на обикновени видео/аудиозаписи. Съответно режимът се включва

  • с бутон «Pause» на основния панел за управление, или

  • чрез избор на команда [image] от контекстното меню на видеопрозореца.

В режим Таймшифт се включва запис на аудио/видео във временен файл.

( [image] респ. е необходимо да бъде предвидено достатъчно място на диска за временния файл).

Файлът се създава в директория, пътят до която и други параметри на този режим на работа могат да бъдат променяни в меню «Таймшифт» от [image] «Панел за настройки» на Behold TV.

По време на рботата на режима някои функционални прозорци са недостъпни. При избиране на такива прозорци Behold TV напомня за това с

"балонно" съобщение над иконата в трея.

Важно! По време на работа в режим Таймшифт програмата Behold TV изключва основния канал на работа с аудиокартата и извежда звук от записвания файл.

Внимание! ( [image] Често задаван въпрос):

Ако по време на Таймшифт се прослушват едновременно два аудиоканала, изместени по време един спрямо друг, това означава, че в настройките в секция « Аудио » на тунера е

  • неправилно избран «Миксер за възпроизвеждане»,

  • или «Линия за управление на звук», с които работи тунерът,

  • или тунерът е включен към звуковата карта едновременно с два аудиокабела – вътрешен и външен.

Препоръки: Да се проверят настройките и да се изключи излишният аудио кабел.

(доп., v.5.09) При запис на временен файл таймшифт, звук може да се цифровизира както

  • от самия тунер, така и

  • от аудиокартата.

    Във втория случай избор и настройки на аудиокартата се извършват в « Настройки за аудиозапис » от [image] «панел за запис».

    Важно! Дори ако има инсталирана само една аудиокарта, задължително е необходимо да се провери дали именно тя е избрана като «Устройство за аудиозапис», а не например гласов модем, който по дефиниция също се явява стандартно устройство за звукозапис в компютъра.

За активиране на режим Таймшифт са необходими няколко секунди. Това време е необходимо за да може записваният файл да достигне определен размер преди да може да бъде възпроизвеждан.

След изтичане на времето за подготовка стават достъпни бутони [image] «Play» и [image] «Stop», с които съответно може да се пусне отложен по време с изместване (рус."смещение") преглед, респ. да се излезе от режим Таймшифт. Ако в процеса на възпроизвеждане е необходимо отново за някакво време да се преустанови гледане или прослушване на текущата програма, това винаги може да се направи с повторно натискане на бутон [image] «Pause».

В режим Таймшифт винаги може да се премине към гледане/прослушване на който и да е фрагмент от предаването, като се започне от момента на стартиране на Таймшифт и се завърши с текущото време. Избор на произволен фрагмент се осъществява с помощта на хоризонталния плъзгач (слайдер) или с бутони [image], които позволяват придвижване по времевата скала със зададена стъпка назад и напред. Величина на стъпката се задава в контекстното меню на тези бутони. При преместване на плъзгача с мишка се изобразява справочна информация за

  1. Текуща позиция спрямо началото на работа на функция Таймшифт.

  2. Обща продължителност на работа на функция Таймшифт.

  3. Разчетно оставащо време за работа на функция Таймшифт (в зависимост от оставащото свободно място на носителя~диска).

При преместване на плъзгача с мишка, текущата позиция на възпроизвеждане се запомня само след отпускане на бутона на мишката. В процеса на работа на функция Таймшифт е недостъпно превключване на канали и са блокирани много функции и някои прозорци на програмата.

Таймшифт в Behold TV работи при приемане както на аналогови, така и на цифрови DVB телевизионни- и радио програми.

  • В аналогов режим на работа запис на временен файл Таймшифт е възможен само в MPEG2 формат. За целта в системата е необходимо да има инсталирани два компонента - програмен MPEG2 енкодер и MPEG2 декодер. Ако някой от тези компоненти липсва или е с остаряла версия, функция Таймшифт няма да е достъпна. И двата компонента - InterVideo MPEG2 Encoder и Decoder се регистрират в системата при инсталиране на програма InterVideo WinDVD Creator от приложения диск в комплекта.

  • За тунери с вграден апаратен (хардуерен) MPEG енкодер е необходим само един компонент - MPEG2 декодер.

Behold TV може да използва различни инсталирани MPEG2 декодери. В Windows Vista са включени нови висококачествени MPEG2 декодери от Microsoft, които могат да бъдат използвани чрез избиране от списъка вместо InterVideo декодери.

За тунери с апаратен (хардуерен) MPEG2 енкодер под Windows Vista е достатъчно използване на декодери Microsoft, при което отпада необходимостта от инсталиране на InterVideo WinDVD Creator (ако не се ползва по желание като отделна програма). Ако MPEG2 аудио/видео декодер има стандартен DirectShow диалогов прозорец за конфигурация, той може да бъде извикан с натискане на бутона за свойства срещу декодера, който съответно да бъде настроен по свое усмотрение.

Всеки декодер има свой собствен диалогов прозорец за настройки, характерен само за съответния декодер.

Предназначението на всички елементи за управление на диалоговия прозорец за настройки на Таймшифт могат да бъдат намерени в съответния раздел « Панел за настройки » на настоящото описание.


Topic: Декодиране на RDS

Декодиране на RDS

Декодиране на RDS поток

RDS (Radio Data System) представлява текстова информация и данни, предавани в състава на радиосигнала на честотите на FM-радиостанциите.

Декодиране на RDS поток е възможно само за модели с поддръжка на RDS (вж. таблиците ).

Процесът на RDS декодиране се включва автоматично в режим на тунера FM и неговата работа зависи от качеството на предаващата радиостанция.

При намиране на RDS-поток, на LCD екрана на панела за управление на програмата светва индикатор [image] и след 1~2 секунди се появява ред PSN (Program Service Name) - име на съответната настроена радиостанция [image]. Обикновено в ред PSN се предава и друга допълнителна информация - за времето, валутни курсове и пр. Ако предаващата радиостанция излъчва в RDS-потока код на страна/регион на излъчване, той също ще се визуализира на LCD екрана.

Радиостанциите могат да предават 64-символен текстов ред, който обикновено съдържа име на песен, име на изпълнител... Тази информация се показва като „бягащ текст” на втория ред на LCD екрана. От контекстното меню с [image] десен бутон на мишката текст от този ред може да се копира в буфера.


Topic: Телетекст

Телетекст

Телетекст

Телетекст представлява текстова информация, предавана в състава на телевизионния сигнал в „невидими” служебни (VBI) редове на всеки кадър, или при DVB излъчване - в състава на цифровия транспортен поток. Такава информация може да бъде отделена, декодирана и изведена в отделен прозорец или вътре във видеопрозореца на Behold TV, във вид на страници и подстраници телетекст.

Режим Телетекст в Behold TV се включва/изключва чрез

  • избор на съответния ред от контекстното меню на видеопрозореца;

  • с натискане на зададена в настройките клавишна комбинация, или

  • от пулта за ДУ.

Ако избран канал излъчва телетекст, в горния ляв ъгъл на екрана (на черен или на полупрозрачен фон) ще се появи номер на текущата избрана страница и брояч на страниците, които се декодират в дадения момент:

Избраната страница ще се визуализира на екрана веднага, след като информацията за нея бъде предадена в състава на телевизионния сигнал и декодирана. Ако при включване на режим телетекст не се появява брояч и екранът остава празен, с голяма степен на вероятност избраният канал не предава телетекст (или тази функция временно е изключeна).

В аналогов режим на работа на тунера, при канали с нестабилен прием декодерът за телетекст може да има проблеми с декодиране на страници, което се изразява в появяване на грешки и загуби на символи в текста.

Страници с телетекст се предават в кръгов цикъл през интервал 1~2 минути. При следващо зареждане на страница декодерът ще се постарае да поправи допуснати грешки. Въпреки това, тъй като телетекст-данни и самото телевизионно изображение се предават в аналогов вид и не са защитени от стандартни телевизионни смущения, успешно декодиране е възможно само при много добро качество на прием. Всякакви внесени изкривявания, например приемане на отразени сигнали (т.н. „многолъчев прием” – ефект на „раздвояване~разтрояване” на образ на екрана) могат съществено да затруднят декодирането на телетекст.

В състава на телетекст могат да се предават до 800 страници.

Всички страници телетекст имат тризначни номера. Първата страница започва от номер 100 и се нарича „домашна”, последната - номер 899.

Всяка страница може за има до 80 показвани вмъкнати подстраници.

Количеството подстраници се изобразява с наклонена черта заедно с номер в заглавието на страницата.

Страница се състои от 24 реда текст по 40 символа на всеки ред.

Първият ред е заглавие на страницата, в което се изобразява нейния номер, име и друга допълнителна информация (дата/време).

В страницата също така може да има 25-ти ред със стилизирано изображение на четири бутона с червен, зелен, жълт и син цвят. Така оцветени бутони има и в някои модели ДУ Beholder. Това са бутони-препратки за бърз преход към свързани страници.

Освен стандартни страници в телетекст-пакетите може да има новинарски ленти и скрити субтитри. Това са специфични страници с невидими заглавия, които по принцип съдържат само 3~4 реда текст като субтитри, извеждани върху видео на напълно прозрачен фон. Информация за програми, които се излъчват със скрити субтитри може да се намери на страниците с телетекст на съответните канали.

Телетекст в Behold TV може да се визуализира както

  • в отделен прозорец и да се управлява подобно на интернет-browser, така и

  • във видеопрозорец върху телевизионното изображение, на полупрозрачен или с напълно непрозрачен фон.

  • Комбиниран режим позволява до се визуализира телетекст върху външен прозорец и преход в режим на изобразяване върху видео, ако видеото е разгънато на цял екран.

Настройки за режими на работа и визуализиране на телетекст се намират в диалоговия прозорец за настройки, секция « Интерфейс ».

За разлика от режим на извеждане на телетекст върху видео, режим на работа във външен прозорец на телетекст-браузера предоставя допълнителни възможности и удобство.

Ако в съответния канал се излъчва телетекст, символът (буква) [image] в статусния ред на прозореца се оцветява в зелен цвят,

в съседство се изобразяват

  • ред на текст, като правило отразяващ принадлежност на телетекст към конкретния канал,

  • номер на текущо декодирана страница (TTX),

  • номер на страница със субтитри (TTS),

  • количество декодирани страници, и

  • номер на текущата страница.

Навигация в прозорец с телетекст може да се осъществява по няколко начина:

  • от клавиатурата,

  • с мишка,

  • от пулта за Дистанционно Управление,

  • от контекстното меню на видеопрозореца (в режим „върху видео”) или

  • от панела с инструменти на външния прозорец на браузъра.

Курсорът на мишката в прозореца на браузъра, както и във видеопрозореца при някои режими на извеждане на видео е чувствителен към тризначни номера на страница с телетекст. По подразбиране това са номера на страници, към които може да се премине с клик върху този номер.

Номерът на последно избрана страница се запомня индивидуално за всеки канал.

При необходимост бутоните на ДУ могат да се настроят по желание за управление на телетекст. От пулта за ДУ телетекст се управлява само в режим на наслагване върху видео.

Във всеки от режимите на работа с телетекст текущата страница може да се изпрати за печат, да се съхрани във файл с формат *.bmp,*.gif, *.png, *.tif или *.btd (формат данни на телетекст, който позволява да се съхрани както отделна страница, така и целият списък с декодирани страници), както и да се променят някои параметри на телетекста, като:

  • шрифт и атрибути на шрифта;

  • тип кодиране на телетекст;

  • да се зададе/отмени автономен режим на работа;

  • да се зададе полупрозрачен или напълно непрозрачен фон;

  • да се включи или изключи изобразяване на скрит текст.

Типът на кодиране на телетекст инсталира кодова страница на изобразявания шрифт. По спецификация телетекст поддържа до 20 различни кодови страници, разделени на 8 различни региона за удобство при автоматично определяне. Някои канали предават телетекст на по-високо ниво 2,5 и 3,5, при което кодовата страница се определя еднозначно. В този случай избор на автоматично кодиране в пределите на избрания регион няма да е в сила и кодовата страница се определя в напълно автоматичен режим. За коректно изобразяване избран шрифт трябва да поддържа Unicode и да съдържа набор символи за избраната кодова страница. Най-пълен набор от символи имат шрифтове Arial, Courier New, Tahoma, Times New Roman.

Автономен режим на работа позволява да се зареждат в телетекст-декодера съхранени отделни страници или пълен списък със страници от файлове във формат .btd.

Скрит текст се използва например за скриване на отговори на кръстословици или въпроси, които могат да се публикуват на страниците с телетекст.


Topic: Управление на захранването (ARPC)

Управление на захранването (ARPC)

Управление на захранването на компютъра (ARPC)

вж. също така Описание на интерфейса: Пулт за ДУ ; Въпроси и отговори: ДУ .

Технология ARPC (Advanced Remote & Power Control)

( [image] ARC - вж. спецификации за тунери Behold TV 501/503/Н75/А85/А85).

Технологията предоставя допълнителни възможности за управление на компютъра и програмата Behold TV:

  • включване на компютъра от напълно изключено състояние - от пулта за ДУ или по разписание;

  • изключване на компютъра от пулта за ДУ;

  • управление на програмата от различни пултове за ДУ на други производители;

  • независим таймер за изпълнение на планирани задания;

  • обновяване на микропрограмата на ARPC контролера ( [image] firmware).

    Наличието на технология ARPC за различните модели тунери е отбелязано в техническите характеристики на всеки конкретен модел (вж. таблиците ).

Управление на захранването на компютъра може да се осъществява по два начина:

  1. Първият начин е чрез използване на линия PME, при което тунерът прави контакт по PCI-шина за включване на компютъра.

    При този начин на управление не е необходимо включване на никакви допълнителни кабели към тунера, но може да се наложи да бъде включена поддръжка на такава функция в BIOS на дънната платка.

    В зависимост от производителя на BIOS и на дънната платка (МВ - Main Board), тази опция може да се намира в раздел (или някой подраздел) Power Management на BIOS и да има различно (произволно) име, например:

    «Power On by PCI Card»;

    «Resume On PME»;

    «Resume on PCI Event»;

    «Wake up on PME»;

    «Wake up on PCI».

    В някои случаи управление на захранването при използване на линия PME може да се окаже проблематично или невъзможно по принцип. Причини за това могат да бъдат:

    § Независимо от абсолютно правилни настройки, поради грешки в BIOS някои дънни платки може да не реагират на активност на линия PME.

    § След подаване на захранване към системния блок, някои дънни платки не реагират на сигнал от PME, докато компютърът не бъде поне веднъж включен и пуснат ръчно от бутона за включване на захранването. В такива случаи причината е в особености на чипсета на дънната платка.

    § При някои по-стари дънни платки на PCI-слотовете не се подава „дежурно” захранване, което е необходимо за работа на ARPC-контролера. В подобни случаи не е възможно да се използва тази функция за включване на компютъра.

    § В компютъра може да са инсталирани други устройства, които също използват линия PME за аналогични цели. Такива устройства са например гласови модеми, които позволяват компютърът да се включва при телефонно позвъняване за приемане на факсове. Ако след активиране на линия PME в BIOS компютърът започва да се включва всеки път при телефонно позвъняване, а тази функция не може да бъде изключена от настройките на модема, за съжаление този начин за управление на захранване не е възможно да бъде използван.

    § Последно, по сигнал PME компютър може да се включва, но не може да се изключва.

  2. Вторият начин за управление на компютъра е по-универсален и се реализира като емулация на натискане на бутона за включване на захранване от системния блок ATX.

    Единствено изискване за работа на ARPC в този случай е наличие на дежурно захранващо напрежение на PCI-шината в компютъра, който може да бъде управляван както

    от изключен (Standby) режим, така и ако е в

    един от енергоспестяващите режими на Windows.

    За реализиране на този метод тунерът се включва като прекъсвач във веригата между бутона за включване на захранване на системния блок и съответния конектор на дънната платка. За целта в описанието на дънната платка е необходимо да се намери този раздел, в който cе описва начинът на включване на платката към системния блок на дънната платка, да се локализира съответната клема (конектор), към която се включва бутонът от лицевия панел на компютъра. В зависимост от производителя и модела на дънната платка, клемата може да бъде обозначена различно («PWRSW», «PWR_ON» или просто «PW») и обикновено се описва в англоезични инструкции като «ATX power button/soft-off button (2-pin PWRSW). This connector is for the system power button...».

    Кабелът на бутона за включване се изключва от дънната платка и се включва към клема «BTN» на платката на тунера;

    Така освободената клема за включване на захранването на дънната платка се свързва към клема «MB» на платката на тунера с приложения в комплекта кабел.

    Спазване на полярност за включваните кабели е без значение.

    Към дънната платка (МВ) [image] [image] [image] (ВТN) Към бутона за включване АТХ

    Важно! При такъв начин на свързване на тунера се реализира възможност не само да се включва, но и да се изключва компютър по команда от пулта ДУ.

За управление на захранването на компютъра, в настройки «Пулт ДУ» - [image] може да се наложи да се активира един от посочените по-горе режими или двата режима едновременно. Също така, за включване/изключване на компютъра е необходимо да бъде конфигуриран поне един от 4-те възможни бутона на ДУ. Като външен пулт ДУ може да се използва всякакъв друг модел от списъка с поддържани стандарти: NEC, JVC, Panasonic, Samsung, Sony SIRC-12/15/20.

Оригиналните пултове за ДУ в комплекта на тунера са с кодиране по стандарт NEC. Техните настройки по подразбиране са включени в програмата Behold TV.

За управление на програмата от пултове на други производители е необходимо да бъде създаден профил на новия ПДУ и всеки бутон да бъде конфигуриран за изпълнение на съответна команда (извършва се с бутон [image] «Обучаване/Редактиране»).

Описание на елементите за управление на диалогови прозорци за работа с пултове ДУ се намира в раздел « Панел за настройки » на това упътване.

Обновяване на микропрограмата на ARPC-контролера се извършва автоматично при всяка нова версия на софтуерния комплекс Behold TV.


Topic: Включване и настройки на плъгини

Включване и настройки на плъгини

Включване и настройки на плъгини

Допълнителни плъгини към програма Behold TV се намират в папка \Plugins на инсталационния компакт-диск или могат да бъдат изтеглени от официалния сайт http://www.beholder.ru/support

Отделно е публикуван подробен материал с пълно описание на плъгини , инсталиране, настройки и др. въпроси на български език.

  • За да може да се използва даден плъгин съответният файл трябва да бъде разархивиран (ако е свален като архивен файл от сайта за поддръжка) и да се копира в папка \Plugins в директорията, в която е инсталирана основната програма Behold TV (по подразбиране C:\Program Files\BeholdTV\Plugins\).

  • След това от контекстното меню ( [image] или от «Панел за настройки» > секция «Видеообработка» > бутон «Видеообработка на изображение при гледане») се избира «Видеообработка» и от видеопрозореца се избира необходимият плъгин за видеопроцесинг или деинтерлейс.

  • Същите плъгини могат да се използват и при видеозапис.

    Избират се от «Панел за запис» - раздел «Настройки за видео/аудиозапис».

Плъгините за Behold TV са два вида:

  • плъгини за процесинг (файлове с префикс BPP_ и разширение .dll) и

  • плъгини за деинтерлейсинг (dll-файлове с префикс BPD_).

    Важно:

    ! В процеса на работа на програма Behold TV телевизионният кадър се предава последователно на всеки плъгин по веригата. ( [image] Свързано е с инициализация на плъгини, респ. с използване на ресурси и натоварване на системата - вж. по-долу!)

    ! Обработка на кадър се завършва от плъгин за деинтерлейсинг.

Процесите по деинтерлейсинг представляват частен случай на процесинг - обработка на кадър с цел премахване на интерлейсна (междуредова) структура. Плъгините за деинтерлейс трябва да отчитат ред параметри на видеопотока, които не са задължителни за обичайния процесинг с плъгини, затова такива деинтерлейсинг плъгини са изнесени в отделна група.

Важно! Всеки наличен в списъка плъгин преминава през инициализация при стартиране на програмата Behold TV, следователно заема ресурси на операционната система (памет), дори когато е изключен от процесинг ( [image] дори ако не активен - не е поставена или е свалена отметка в "checkbox", но е наличен е в списъка)

Поради това, ако даден плъгин не се използва (често) е по-добре да бъде премахнат от списъка.

Описание на настройки в диалогови прозорци за работа с плъгини се намират в съответните раздели:

  • в режим на гледане - « Панел за настройки »

  • в режим на запис - « Панел за запис »

на това упътване.


Topic: Работа с няколко тунера

Работа с няколко тунера

(нов раздел, v.5.17) Работа с няколко тунера

Behold TV може да работи едновременно с няколко ТВ-тунера Beholder, инсталирани на един компютър.

Работа на допълнителни тунери се осъществява под управлението на копия (т.н. „инстанс~и”, англ. INSTANCE ['instəns] I. 1. пример, отделен случай, илюстрация) на програмата Behold TV, които се стартират от името на един потребител и от една папка (директория) с първоначално инсталирана програма Behold TV. При това за всеки тунер се създава свой уникален профил, основното предназначение на който е разрешаване на възможни конфликти между настройки на функционално различни и независими едно от друго устройства за Capture (~видеозахват). Наличието на основен профил (профил по подразбиране за работа с един тунер) и възможност за създаване на 10 допълнителни профила в крайна сметка позволява едновременно да работят едновременно 11 тунера Beholder.

За стартиране на копие на приложение с необходим профил е необходимо в командния ред на програмата BeholdTV.exe да се укаже ключ -inst:x, където x - номер на профил от 0 до 9. Стартиране на копие на приложението под основния профил не изисква указване на ключ. За удобство при стартиране на копие на програмата може да се създаде shortcut (рус. „ярлык”) на приложението и да се укаже необходим ключ за команден ред в поле “Target” (рус. "Объект") в Properties (рус. „свойства”) на създадения shortcut.

От всеки профил се допуска стартиране само на едно копие на приложението.

Опит за стартиране на няколко копия на програмата от различни профили, настроени на един тунер ще доведе до липса на изображение в прозореца на едно от копията и конфликт между настройките на програмата.

За бързи настройки и свързване на ТВ-тунер към „свой” профил може да се използва инструмента BhConfig.exe. За целта:

  • стартира се "Behold TV config" (вж. група програми "Behold TV" /Start>Programs>…/),

  • от "падащия" списък "Конфигурация" се избира един от 11-те възможни профила в програмата, а

  • в списък "Устройство за capture~видеозахват" - необходимият тунер.

    Еднакви модели тунери се различават в списъка по номер на PCI/PCI-E/USB слот или порт. Също там за допълнителен тунер може да се избира устройство за аудиозахват, аудиомиксер и линия за управление на звук. Направени изменения е необходимо да бъдат съхранени. В резултат на такава операция се създава допълнителен профил с първоначални настройки за съответния избран тунер.

Всички профили запазват своите настройки независимо един от друг и от основния профил на приложението. За всеки тунер се съхраняват индивидуални настройки за

  • клавиатура,

  • пулт за ДУ,

  • плъгини,

  • пресети за запис и

  • списъци на канали.

За да се облекчи настройка на допълнителен тунер, при първо стартиране на копие на приложението с профил, различен от основния, се изпълнява копиране на всички настройки и списъци с канали от основния в новосъздадения профил.

В зависимост от параметър "Запазване на настройки за всеки потребител" на програмата Behold TV, настройките за профили се съхраняват или

  • в поддиректории ..\Instances\x\ на самата програма Behold TV, или

  • под Windows XP - в потребителски директории C:\Documents and Settings\{User}\Application Data\BeholdTV\Instances\x\

  • под Windows Vista/Seven - C:\Потребители\{User}\AppData\Roaming\BeholdTV\Instances\x\, където {User} е име на потребител.


Topic: Ключове за командния ред

Ключове за командния ред

Ключове за командния ред

За активиране на програмата в зададено време може да се използва програма за планиране на събития в Windows или друга такава, с която се управляват параметри от командния ред. Допустими префикси на ключове са «-» и «/»:

Ключ | Команда
-inst:x | (доп.,v.5.17) Стартиране на ново копие (инстанс) под профил х (0~9)
-m:tv | Включване на режим TV
-m:fm | Включване на режим FM (за модели с FM Radio)
-m:cp -m:svbs | (изм. и доп., v.5.11) (~v.5.09 Включване на режим VHS) Включване на режим външен вход SVBS
-m:sv -m:yc | (изм. и доп., v.5.11) (~v.5.09 Включване на режим S-VHS) Включване на режим външен вход S-Video
-m:yuv | (доп., v.5.11) Включване на режим външен вход YPbPr (за модели с компонентен вход)
-m:rgb | (доп., v.5.11) Включване на режим външен вход RGB (за модели с компонентен вход)
-m:dvbttv | Включване на режим DVB-T TV (за модели с DVB-T)
-m:dvbtrd | Включване на режим DVB-T Radio (за модели с DVB-T)
-fs | Превключване в пълноекранен режим
-ch:xxx | Превключване на xxx канал (xxx - номерация от 1)
-mute | Изключване на общия звук (не влияе на запис на звук)
-lnmute | Изключване на звука на линейния вход на миксера (не е приложимо за режим на запис)
-vol:xxx | Задаване на сила на звук xxx (xxx 0~255)
-tr | Стартиране на програмата свита в трея (suspend to tray)
-wu | Активиране на програмата от tray (wake up)
-r:video | Начало на запис видео/аудио
-r:audio | Начало на запис само на аудио
-r:stillxxx | Начало на запис на screenshot-ове с интервал xxx секунди
-d:xxx | Продължителност на запис xxx минути
-fn:"име" | Задаване на име на файл при запис. Ако не е зададено име се използва времева отметка (рус.“таймштамп”) (задължително в кавички)
-nv | Форсиране запис на видео без преглед (само с ключ -r:video)
-ps:"име.pst" | Посочване на име на пресет за изчитане на настройки (задължително в кавички)
-exit | След завършване на запис - излизане от програмата
-shut | След завършване на запис - излизане от програмата и изключване на компютъра

Забележки:

  • Ключове -lnmute, -tr, -fs не са съвместими с режим на запис, извикан от командния ред посредством ключ -r:

  • Ключ -fn:"име" може да бъде указан във вид на шаблон с използване на макроси.

    Подробно описание на макроси има в раздел « Модул за планирани задачи ».

    Пример:

    Да се стартира програмата,

    да се избере 8-ми канал,

    да се включи видеозапис

    за 25 минути

    във файл "tom and jerry.avi"

    и след края на записа да се изключи компютъра:

    c:\beholdtv\beholdtv.exe -m:tv -ch:8 -r:video -fn:"tom and jerry" -d:25 -shut

Забележка: Изход от програмата (-exit) или изключване (-shut) се извършва 3 секунди след спиране на запис с ключ -d:xxx.


Topic: Описание на интерфейса

Описание на интерфейса

Вehold TV - Описание на интерфейса; актуални промени и нововъведения.

(доп.р.,v.5.15) Интерфейсът на софтуерния комплекс Behold TV се развива непрекъснато в съответствие с внедряването на най-съвременна елементна база (чипсети, ВЧ модули, енкодери и пр.), иновационни технологични решения и пр. При всяка нова серия се реализират нови хардуерни възможности и полезни функции, респ. се актуализират и допълват драйверите и софтуерният пакет, разширяват се и опциите за настройки.

Появата на нови серии и модели тунери обективно налага изменения в интерфейса на програмата. Пример за това е версия 5.11, която се различава от предшестващите версии (5.00~5.10). Същата е обогатена с поддръжка на (в зависимост от модел тунер - вж. технически спецификации по-горе):

  • допълнителен компонентен НЧ вход;

  • 2D шумопотискане;

  • нови аудио опции -

    5-канален графичен equalizer;

    усилване на ниски честоти (Bass Booster);

  • и други.

В съответствие с функционалните изменения и нововъведения, интерфейсът на програмата е променен и прецизиран, което създава определени удобства при ориентиране в опциите за настройка, респ. при работа с програмата:

При елементарно добавяне дори само на посочените по-горе нови аудио опции интерфейсът неизбежно трябва да бъде допълнително сбит, усложнен и претрупан. От версия 5.11 това е избегнато - опции за новите и част от съществуващите в предишните версии настройки, които принадлежат към функционално обособени групи (Аудио- Видео- Честотни настройки и пр.) са обособени в три секции със собствен интерфейс, респ. параметри за настройки за съответните групи:

  • «ТВ» (аналогова ТВ);

  • «FM радио»;

  • «АV входове» («НЧ входове»).

В тези секции са активни за настройки групирани сходни регулируеми параметри в обособени подсекции «Тунер», «Видео» и «Аудио»:

«ТВ» (аналогова ТВ) - подсекции |  |
«FM радио» - подсекции |  | -
«АV входове» - подсекции | - |

Както е посочено в предговора, при инсталиране и тестване на софтуера е използван самостоятелно разработен от автора български интерфейс . При желание това е достъпно за всички потребители веднага след инсталиране на драйвер - в следващия диалогов прозорец за конфигуриране на Behold TV.

Процедурата за вграждане на български интерфейс представлява елементарна файлова операция и е онагледена подробно в обособен раздел . За потребители, които не срещат затруднения с английски или руски език тази информация може да бъде пренебрегната - в инсталационния диск и на официалния сайт е поместена обширна информация и Help на тези езици.

The contents of Описание на интерфейса

Панел за настройки
Панел за запис
Модул за планирани задачи
Електронна програма на предавания


Topic: Панел за настройки

Панел за настройки

Вehold TV - Панел за настройки

Панелът за настройки се извиква

  • с натискане на бутон «Настройки» на основния панел за управление, или

  • от едноименния команден ред «Настройки» в контекстното меню (десен клик в областта на видеопрозореца на Behold TV при гледане).

Основни секции с инструменти за настройки - подробно описание:

The contents of Панел за настройки

1. ТВ канали
2. FM канали
3. DVB-T ТВ/Радио канали
4. A/V входове
5. Видео
6. Аудио
7. DVB поток
8. Интерфейс
9. Таймшифт
10. Пулт за ДУ
11. Управление
12. LCD и OSD
13. Информация за тунера
Информация за програмата


Topic: 1. ТВ канали

1. ТВ канали

1. Секция за настройки на ТВ канали:

Интерфейс ~v.5.10:

Интерфейсът от v.5.11~ е съществено променен в съответствие с функционалните изменения в новите модели тунери:

Интерфейс - настройки на параметри в секция «ТВ», подсекция «Тунер»:

  • Група «Задаване» на основни параметри

    ( [image] до v.~5.10 - Група Аудио+Видео настройки «Основни параметри на TV канал» – въвеждане на наименования и честоти, задаване на видео- и аудио стандарти за телевизионни канали):

    (доп.,v.5.09) ТВ антена (Антенен вход) - За тунери с реализирана технология DUAI се задава поканално свързване (принадлежност) към антенен вход – източник на TV сигнал.

    (доп.,v.5.15) В контекстното меню над списъка с входове меже да се избере редактиране на наименованията на входовете DUAI.

    ( [image] За тунери без поддръжка на технология DUAI опцията не е активна)

    Честота (MHz) - [image] Група за ръчно изменение на честота във възходяща или низходяща посока, с желана стъпка - от стотици до 0,25 МНz

    При натискане на бутон [image] се извежда таблица със зададени честоти, от С1 до S310

    >...>...>

    От таблицата лесно (с един клик) може да бъде избрана конкретна желана честота.

  • Група «Допълнително» регулиране:

    Праг АРУ – За ТВ тунери с ВЧ блок MK3/MK5 ( [image] „традиционен”, "не-силиконов" ВЧ блок) е възможно настройване на праг за сработване на АРУ. Регулиране на този праг помага да се донастроят канали с повишено ниво на радиосигнал и да се отстраняват дефекти като трептене (рус.”рябь”) на образа и „плуващи” широки бледи хоризонтални ленти.

  • Информационно поле - «Статус» на

    - Носеща честота и

    - Отклонение (КНz)

Интерфейс - настройки на параметри в секция «ТВ», подсекция «Аудио»:

  • Група за настройки «Аудио декодер»:

    (доп.,v.5.09, изм. и доп., v.5.17) Аудио стандарт (v.~5.11 - Аудио система) - Настройки на аудиостандарт за избран канал.

    Достъпно само за ТВ тунери с чипсети SAA7134, SAA7135, SAA7231, ТМ6010.

    За ТВ тунери с чипсет SAA7134 също така е достъпен бутон за фина ръчна донастройка на звуковата носеща.

    В някои страни (! и в България за някои аналогови канали - вж. по-долу!) се използва система за ТВ звук D/K.

    Някои канали се предават със стерео звук по цифров стандарт NICAM 728.

    Стандарт A2 (DualFM) представлява аналогов стандарт за предаване на стерео звук (по подобие на FM), който се използва основно в Европа, както и в системите за кабелни ТВ.

    За тунери с чипсети SAA7135, SAA7231 е достатъчно да се избере стандарт BG/DK auto и чипсетът ще извърши пълен автодетект на система за звук - BG/DK и формат на кодиране - Mono/A2/NICAM.

    В информационната рамка се изобразява определен и декодиран от чипсета стандарт.

    За чипсет ТМ6010 е необходимо ръчно да се зададе аудиостандарт.

    Внимание [image] Ако е зададен неправилен стандарт, при такива канали няма да има звук, а само шум!

    Регионална информация: В България болшинството ТВ програми се излъчват по

    стандарт за предаване на изображения – PAL,

    аудио стандарт – BG,

    стерео звук – А2.

    ! Въпреки това все още се използват едновременно два стандарта за ТВ-звук: B/G и D/K !

    Препоръчва се при автосканиране да се зададе преобладаващ стандарт B/G и впоследствие да се промени стандарт само за тези канали, при които вместо звук има шум (към момента на подготовката на материалите по стандарт D/K се излъчват ефирно и по някои от кабелните мрежи БНТ-1, bTV, НоваТВ).

    (доп.,v.5.09) Аудио канал - Избор на аудио канал за звуков съпровод.

    Опции:

    «Stereo»,

    «Language1» и

    «Language2».

    са актуални само при наличие на ТВ-стереоизлъчване A2/NICAM/BTSC/EIAJ на текущия канал.

  • Група регулатори - линейни плъзгачи «Усилване»:

    Усилване и

    Баланс на линейния вход за избран канал.

    Тези настройки могат да са недостъпни, ако в секция « Аудио » (група настройки «Параметри за управление на звук») е зададен [image] «Режим за управление - сила на звук» като [image] .

  • Група регулатори - линейни плъзгачи [image] «Тембър»:

    (изм. и доп.,v.5.11) Апаратен филтър (~v.5.10 - Донастройка) за ВЧ- и НЧ тембър за избран канал.

    Достъпно само за тунери с чипсети SAA7135, SAA7231.

  • (ново - v.5.11) Група регулатори - линейни плъзгачи [image] «Equalizer»:

    Апаратен пет лентов стерео Equalizer за избран канал.

    Достъпно само за чипсет SAA7231.

  • Група опции за допълнителни аудио ефекти «Аудио разширения»:

    Аудио ефект – Избор на виртуален звуков ефект за избран канал.

    Достъпно само за тунери с чипсет (доп.,v.5.11) SAA7135, SAA7231.

    (ново, v.5.11) Bass - усилване - Апаратен филтър за динамично усилване на бас (Dynamic Bass Boost) за избран канал.

    Достъпно само за чипсет SAA7231.

Интерфейс - настройки на параметри в секция «ТВ», подсекция «Видео»:

  • Група настройки «Видео декодер»:

    Видео стандарт - Настройка на видеостандарт за избран канал.

    По подразбиране е Auto (Autodetect) (рус.”Автоопределение”). Може принудително ръчно да бъде изменен по желание стандарт (PAL/SECAM). В долната част - в информационната рамка се визуализират данни за реално декодиран стандарт към момента.

    (доп.,v.5.09) Autodetect не е достъпен за чипсет ТМ6010.

    Синхронизация на редове -

    (изм.,v.5.11) - активно в настройки « ТВ » и « АV входове » ( v.5.09 «Настройки на НЧ входове») - секция «Видео»:

    - Донастройка на хоризонтална синхронизация (HPLL) на видеодекодер SAA713х (v.5.09-за избран канал).

    Режим VCR е предназначен за синхронизация на сигнал, подаван от VHS видеомагнетофон.

    За (v.5.09-повечето канали) останалите случаи се препоръчва режим Fast track.

    (v.5.09-За някои канали с лошо качество на образа може да се наложи използване на режим Poor signal).

    Недостъпно за чипсети SAA7231, ТМ6010 (авто).

  • (доп.,v.5.09, изм. и доп., v.5.11) Група регулатори - линейни плъзгачи [image] «Видеомиксер» -

    Група елементи за изменение на

    яркост,

    контраст,

    наситеност,

    оттенък (само за PAL),

    острота,

    ниво на видеоусилване (Gain) (v.5.09-ниво на входния канал)

    за избран канал.

    В съседство е разположен чекбокс [image] за задаване на стойности по подразбиране за всички регулатори на видеомиксера и бутони [image] , с които може да се присвоява всяка настройка за целия списък с канали.

    Регулатор «Видеоусилване (Gain)» е достъпен само в режим на ръчно регулиране на видеоусилване. В противен случай работи видео АРУ (Aвтоматично Регулиране на Усилване / AGC - Automatical Gain Control).

    Регулатор «Видеоусилване (Gain)» не е достъпен за чипсет ТМ6010.

    Допълнителни параметри за донастройки на видео АРУ са посочени в секция « Видео ».

  • Група опции за допълнителни аудио ефекти «Видео разширения»:

    (ново, v.5.11) «2D шумопотискане» - Апаратен филтър за шумопотискане SWAN/LORE за избран канал.

    Достъпно само за чипсет SAA7231.

  • Бутон [image] – Извежда диалогов прозорец за търсене на ТВ канали .

С отметка срещу всеки канал се избира дали да се разреши или да се прескочи дадена програма при гледане на екран и преминаване по списъка с канали ( [image] би могло да се използва и като елементарно средство за „родителски контрол”).

Бутони [image], [image] и [image] позволяват съответно добавяне, вмъкване и премахване избран канал в/от списъка.

За създаване, избор или премахване на профил за канали е необходимо да се кликне върху бутон [image] и да се изпълни необходимото действие.

Забележка: При първоначално пускане на програмата по подразбиране е зареден списък на ТV станции за Русия (профил Moscow).

За други страни/региони е най-удобно този списък да се изчисти изцяло и да се попълни с ново сканиране, като се създаде и съхрани нов профил (напр. "София", "Ефир", "Кабелни канали" и пр.).

Всеки списък може да бъде редактиран, запазен, както и да бъдат създавани отделни профили в нов списък.

Списъкът по подразбиране може периодично да се изменя и допълва.

The contents of 1. ТВ канали

1.1. Автосканиране за ТВ канали


Topic: 1.1. Автосканиране за ТВ канали

1.1. Автосканиране за ТВ канали

1.1. Диалогов прозорец за автосканиране на ТВ канали:

Автосканиране за ТВ-канали може да се осъществи по два начина:

  1. Да се сканира предварително определен честотен ТВ диапазон по региони (бързо сканиране).

    Недостатък - в някои региони излъчването на канали може да е в нестандартен честотен диапазон, при което такива канали няма да бъдат намерени при автосканиране.

  2. Да се сканира целия честотен ТВ диапазон със стъпка 0.25 MHz (бавно сканиране).

    Позволява да се намерят всички канали без изключение (в зона на удовлетворително приемане [image] респ. в зависимост от качеството на приемания сигнал), но е малко по-бавен.

  • Опция* за избор на антенен вход «ТV антена»:

    (ново от v.5.09) Източник – За ТВ тунери *с реализирана технология DUAI се задава антенен вход – източник на TV сигнал при сканиране

    ( [image] За тунери без поддръжка на технология DUAI опцията не е активна).

  • Група за задаване на «Стандарти по подразбиране за нови канали»

    (v.5.09 ~ Стойности по подразбиране за нови канали»):

    Видео стандарт по подразбиране - Видеостандарт, който се задава за всеки намерен канал при добавяне в списъка след сканиране:

    Аудио стандарт (v.5.11 ~ Аудио система) по подразбиране - Аудиостандарт, който се задава за всеки намерен канал при добавяне в списъка след сканиране:

  • Група «Параметри на сканиране»

    Изчистване на списък с канали – Изчистване на списъка преди добавяне на намерени канали.

    Да се добавят само нови - Изпълнява се „избирателно” автосканиране. В списъка се добавят само нови намерени канали (при автоматично или полуавтоматично сканиране).

  • Група «Сканиране»:

    Режим на сканиране – Определяне на диапазон и стъпка на сканиране:

    По списък на ефирни канали - сканиране на предварително зададена честотна мрежа на ефирни канали за даден регион (бързо сканиране).

    По списък на кабелни канали - сканиране на предварително зададена честотна мрежа на кабелни канали за даден регион (бързо сканиране).

    По целия списък с канали - сканиране на предварително зададена честотна мрежа на ефирни+кабелни канали за даден регион (бързо сканиране).

    По честота (пълен диапазон) - сканиране на пълния диапазон ТВ честоти със стъпка 0.25 Mhz (бавно сканиране). Позволява да бъдат намерени всички предавани канали в даден регион, в т.ч. ако има такива, които се излъчват на нестандартни честоти и не попадат в стандартните регионални мрежи.

    Регион – Избор на регион, за който е определена честотна ТВ мрежа.

    Достъпно е само за режими на сканиране

    «По списък на ефирни канали»,

    «По списък на кабелни канали» и

    «По целия списък с канали».

    Датчици [image] показват текущия статус на радио блока.

    За „намерена” се счита такава ТВ честота, при която и двата датчика са активни.

    В мини-прозореца отдясно на датчиците се изписва точната честота в MНz.

    Бутон [image] – стартиране на избрания режим за сканиране по пълен диапазон, от начало до край, с внасяне на намерени канали в списъка (автоматично сканиране).

    Стрелки [image] - Пускане на избран режим на сканиране от текущото място в честотния диапазон, в право или обратно направление (полуавтоматично сканиране).

    Ако е поставена отметка в чекбокс [image] «Автосъхранение», при намиране на канал същият ще бъде добавен в списъка и сканирането ще продължи по-нататък.

    Ако отметката в чекбокс [image] «Автосъхранение» е свалена, при намиране на канал търсенето ще спре и на потребителя се предоставя избор – да добави канала в списъка с бутон [image] и/или да продължи сканирането (без добавяне).

    Стрелки [image] - Ръчно изменение на честотата с една стъпка в право или обратно направление.

    Движението на плъзгача [image] онагледява местоположението на съответната честота/процеса на сканиране спрямо избрания честотен спектър.


Topic: 2. FM канали

2. FM канали

2. Секция за настройки на FM канали (само за модели с FM):

Интерфейс ~v.5.10:

Интерфейсът при v.5.11 е съществено променен в съответствие с функционалните изменения в новите модели тунери:

(ново, v.5.15) - За тунери с поддръжка на Equalizer и Dynsmic Bass Booster са активни съответни показатели в колони Equalizer и DBB.

Интерфейс - настройки на параметри в секция «FM радио», подсекция «Тунер»:

  • Група «Задаване» на основни параметри

    (v.~5.10 - Група Аудио+Видео настройки «Основни параметри на FM станция» - Група за ръчно изменение на параметрите на избрана радиостанция)

    (ново, v.5.09) FM Антена - За тунери с реализирана технология DUAI се задава поканално свързване (принадлежност) към антенен вход – източник на FM сигнал.

    (доп., v.5.15) В контекстното меню над списъка с входове може да бъде избрано редактиране на наименованията на входове DUAI.

    (доп., v.5.11) ТВ тунери Behold TV A7/A8 също така позволяват да се избере вход (букса) TV или FM за включване на източник на FM сигнал.

    (отп., v.5.11) Име - Име на текущата станция. редактира се директно в списък (поле) «Име на станция».

    (изм. и доп., v.5.09) Честота (MHz) - [image] Група стрелки за ръчно изменение на честота (или директно въвеждане на стойност) във възходяща или низходяща посока, с желана стъпка - от стотици до 0,10 МНz:

    Честота на FM радиостанции. За тунери с ВЧ блок MK3, MK5, ХС5000, TDA18271 е достъпен диапазон за настройки от 60 до 800 Mhz.

  • Опция «Допълнително» регулиране:

    Предусилване по МЧ - Включва усилване по междинна честота (рус.„Промежуточная частота”/„ПЧ”) на радио блока, което позволява да се подобри приемането на някои станции, работещи в гранични условия на прием и да се намали „пищене” при евентуално самовъзбуждане на приемника.

    Страничен ефект на тази опция е усилване на шумове.

    За мощни станции се препоръчва опцията да се изключва. При настройки на честоти над 108 МHz предусилването трябва да е включено задължително, в противен случай чувствителността е много ниска.

    Опцията е достъпна само за тунери с ВЧ блок MK3/MK5.

    RDS име - Текст на сервис PSN за RDS станции. Обикновено в този сервис се предава име на радиостанцията.

    Достъпно само за ТВ тунери с функция RDS.

    (ново, v.5.11) RDS текст - Текст на сервис RADIOTEXT за RDS станции.

    Достъпно само за ТВ тунери с функция RDS.

  • Информационно поле «Статус» -

    Носеща честота и

    Отклонение (КНz)

Интерфейс - настройки на параметри в секция «FM радио», подсекция «Аудио»:

  • Група настройки «Аудио декодер»:

    FM аудио (v.5.05.~ „Моно”) – Принудително задаване на режим на приемане FM Mono.

    Позволява намаляване на шум при стерео станции с нестабилно приемане. За тунери с ВЧ блокове MK2 и MK3 режим Моnо също така подобрява качеството на приемане. В статусната лента се изобразява текущ реален режим на приемане.

    За тунери с поддръжка на RDS и ВЧ блок MK5 не се препоръчва принудително превключване в режим Mono - това може да доведе до влошаване на приемането на потока данни RDS.

  • Група регулатори - линейни плъзгачи «Усилване»:

    Усилване и [image] Баланс на линейния вход за избран канал.

    Тези настройки могат да са недостъпни, ако в секция «Аудио», група настройки «Параметри за управление на звук» е зададен «Режим за управление - сила на звук» като «Обща сила на звук за всички канали».

  • Група регулатори - линейни плъзгачи [image] «Тембър»:

    (изм. и доп., v.5.11) Апаратен филтър (v.~5.10 - Донастройка) за ВЧ- и НЧ тембър за избрана станция.

    Достъпно само за тунери с чипсети SAA7135, SAA7231.

  • (ново, v.5.11) Група регулатори - линейни плъзгачи [image] «Equalizer»:

    Апаратен пет лентов стерео Equalizer за избран канал.

    Достъпно само за чипсет SAA7231.

  • Група опции за допълнителни аудио ефекти «Аудио разширения»:

    Аудио ефект – Избор на виртуален звуков ефект за избрана станция.

    Достъпно само за тунери с чипсет (доп., v.5.11) SAA7135, SAA7231.

    (ново, v.5.11) Bass - усилване - Апаратен филтър за динамично усилване на бас (Dynamic Bass Boost) за избрана станция.

    Достъпно само за чипсет SAA7231.

Забележка: При първоначално пускане на програмата по подразбиране е зареден списък на радиостанции за Русия (профил Moscow).

За други страни/региони е най-удобно този списък да се изчисти изцяло и да се попълни с ново сканиране, като се създаде и съхрани нов профил (напр. "София", "FM..." и пр.).

Всеки списък може да бъде редактиран, запазен, както и да бъдат създавани отделни профили в нов списък.

Списъкът със заредени радиостанции по подразбиране може периодично да се изменя и допълва.

  • Бутон [image] – Извежда диалогов прозорец за търсене на FM канали .

С отметка срещу всеки канал се избира дали да се разреши или да се прескочи дадена станция при слушане и преминаване по списъка с канали.

Бутони [image], [image] и [image] позволяват съответно добавяне, вмъкване и премахване на избран канал в/от списъка.

За създаване, избор или премахване на профил за канали е необходимо да се кликне върху бутон [image] и да се изпълни необходимото действие.

The contents of 2. FM канали

2.1. Автосканиране за FM канали


Topic: 2.1. Автосканиране за FM канали

2.1. Автосканиране за FM канали

2.1. Диалогов прозорец за автосканиране на FM канали:

  • Група «Сканиране»:

    За начало на автосканиране трябва да се натисне съответен бутон със

    Стрелки [image] - Сканиране от текущото място в честотния диапазон, във възходящо или низходящо направление.

    Ако отметката в чекбокс Автосъхранение е свалена, при намиране на работеща станция търсенето ще спре (полуавтоматично сканиране). Възможностите са:

    – да се добави намерената станция в списъка с бутон [image], и/или

    – сканирането да продължи без добавяне с повторно натискане на бутон [image] / [image].

    Стрелки [image] - Ръчно изменение на честотата с една стъпка (0,05 МНz) в право или обратно направление.

    Движението на плъзгач [image] онагледява местоположението на съответната честота/процеса на сканиране спрямо избрания честотен спектър.

    Автоматично добавяне на намерени станции в списъка без да спира търсенето - Ако е поставена отметка в чекбокс Автосъхранение, при намиране на станция същата ще бъде добавена в списъка и сканирането ще продължи по-нататък.

За коректно сканиране задължително трябва да се използва FM антена.

  • Опция* за избор на антенен вход «FM антена»:

    (ново от v.5.09) Източник – За ТВ тунери *с реализирана технология DUAI се задава свързване (принадлежност) към антенен вход за FM сигнал при сканиране ( [image] За тунери без поддръжка на технология DUAI опцията не е активна).

  • Група настройки за «Режим на сканиране FM радио»:

    Висока чувствителност при търсене на сигнал – Позволява намиране на станции, при които нивото на сигнал е по-ниско от номиналното. Страничен ефект при ползване на тази опция е намиране на повече "фантомни" канали.

    Сканиране на широк диапазон - Сканиране в разширен диапазон (изм., v.5.09) 64~160 MHz.

  • Група «Параметри на сканиране»

    Изчистване на списък със станции – Изчистване на списъка преди добавяне на намерени станции.

    Да се добавят само нови - Изпълнява се „избирателно” автосканиране. В списъка се добавят само нови намерени станции (при автоматично или полуавтоматично сканиране).

  • Бутони [image] / [image] – стартиране/спиране на сканиране по пълен диапазон, от начало до край, с включване на намерени станции в списъка (автоматично сканиране).


Topic: 3. DVB-T ТВ/Радио канали

3. DVB-T ТВ/Радио канали

3. Секция за настройки на DVB-T ТВ/Радио канали (само за модели с DVB-T):

интерфейс - v.5.11:

  • Група «Транспондер» - Задаване на параметри за DVB-T транспондер:

    Транспондер представлява единица за излъчване на транспортен поток, (изм., v.5.09) състояща се от:

    - Честота - Централна радиочестота на DVB-T спектъра.

    - Диапазон („Полоса”) - Ширина на лентата на DVB-T спектъра (8, 7, 6 MHz).

    - FEC поток - [image] Стандарт за DVB-T модулация OFDM (Orthogonal Frequency Division Multiplex) позволява в една лента на DVB-T спектъра да се излъчват два независими транспортни потока. Такъв тип модулация се нарича Йерархична (Hierachy). При наличие на йерархична модулация, първият поток се кодира като FEC HP (High Priority), а вторият - като FEC LP (Low Priority). Ако няма йерархична модулация в DVB-T спектъра, FEC потокът винаги е един - FEC HP.

    При автотърсене на канали Behold TV автоматично намира йерархична модулация и изпълнява сканиране на двата транспортни потока

  • (ново, v.5.09) DVB-T антена - За ТВ тунери с реализирана технология DUAI позволява да се зададе антенен вход за приемане на DVB-T сигнал Т.к. в състава на транспортния поток могат да се предават няколко канала, присвояване на антенен вход се изпълнява за всички канали на текущия транспондер.

  • (изм. и доп., v.5.09) DVB-T спектър – блок от автоматично получавани величини, определящи формат на текущо приемания DVB-T спектър:

    - FFT – Количество носещи в DVB-T спектъра (доп., v.5.11) (2К / 4К / 8К).

    - GUARD (GI) – Защитен интервал (1/32 – ¼).

    - Constellation (Modulation) – Тип модулация (QPSK, 16QAM, 64QAM).

    - FEC HP / LP – Количество излишни данни за всеки тип FEC поток (7/8 - 1/2).

    - Hierarchy – Наличие и тип на йерархична модулация.

  • Група лентови индикатори «Статус на сигнал» (изм., v.5.09:v.5.05 – Сигнал от транспондера) – Изобразява текущ статус на приемания цифров сигнал:

    L - Ниво на сигнал - Ниво на прием на радиосигнал, измерим в dB (мкВ). Показва амплитудата (мощността) на радиосигнал в точката на приемане. Нивото на сигнала се изобразява за която и да е носеща (включително аналогова), но точна стойност се определя само за OFDM-носеща.

    За приемливо се счита ниво на радиосигнал от 35 dB (мкВ) и по-високо.

    Оказва слабо влияние върху качеството на приемане и позволява да се прецени само отдалеченост от предавателя. (изм., v.5.09-при v.5.05 e в следващото меню)

    SNR - Съотношение сигнал/шум на носеща - Показва ниво на полезен сигнал вътре в OFDM-носещата. SNR е активен само при наличие на OFDM-носеща.

    Q - (изм., v.5.09 - Претеглено) Качество на сигнал - Основен показател при прием на цифрово излъчване.

    Този параметър се изобразява в % и определя количеството предварителни грешки, постъпващи на вход Viterbi на декодера.

    «« Гранична стойност е приблизително 50%. При показател за качество на сигнал <= 50% във видеопотока ще има много пропуснати кадри, а звукът ще "заеква".

    »« Удовлетворително качество на сигнал е показател >= 70%.

    »» За комфортно гледане на предаване е необходимо достигане на качество >= 80%.

    Параметърът за качество на сигнал е активен само след прихващане на OFDM-носеща и отделяне от нея на FEC-поток (FEC Lock). Показателят за качество на сигнал осезаемо корелира с показател SNR на носещата.

  • Информационна група «Идентификация на сервис» – Параметри на DVB-сервис:

    - име на сервис,

    - име на провайдер,

    - SID (Service ID),

    - TSID (Transport Stream ID),

    - ONID (Original Network ID) получени непосредствено от транспортния поток при сканиране.

    Връзката ONID + TSID + SID задава уникален идентификатор на сервис.

  • Групи «Видео потоци» и «Аудио потоци» (v.5.09 - Елементарни потоци / избор на PID):

    За идентификатор на всеки пакет, който носи полезно натоварване (Payload) вътре в транспортния поток служат PID (Packet ID).

    Всеки елементарен поток носи пакети с уникални PID вътре в даден транспортен поток.

    За отделяне на елементарен от транспортен поток е необходимо да се знаят PID на пакетите, носещи необходимия елементарен поток.

    В процеса на сканиране на транспортния поток от сервизните таблици се отделят сервиси,

    вътре във всеки сервис се отделят елементарни потоци - видео, аудио, субтитри, телетекст и прочее потоци.

    В един сервис може да има няколко аудио потока (например съпровод на различни езици), няколко потока със субтитри и т.н. В дадена група може да се избере необходим поток от всеки тип (в случай, че те са повече от един), както и да се види типа на елементарния поток MPEG2 / H.264; MPA / AC3 / DTS / AAC и т.н.

    (изм., v.5.09) В случай, че звук се предава само по един канал, той може да бъде разпределен в два аудио канала, като се избере режим Mono L/L или Mono R/R.

  • Усилване и [image] баланс на линейния вход за избрания канал.

    Тези настройки могат да са недостъпни, ако в секция «Аудио» е зададен «Режим за управление - сила на звук» като «Обща сила на звук за всички канали».

  • – Извикване на диалогов прозорец за търсене на DVB-T канали .

  • Бутон «Информация за сервис» - При необходимост може по-детайлно да се разгледат параметрите на DVB-сервис в диалогов прозорец с детайлна информация:

    В случай, че даден сервис е затворен (кодиран) [image], в прозореца може да се види тип на системата за условен достъп и нейните атрибути - ECM и EMM PID-ове, по които се предава информация в CAM-модул за дешифриране на CSA-ключ.

    С течение на времето параметрите на сервис на предаващата страна могат да се изменят или даден сервис може да бъде премахнат.

    За проверка за изменения е достатъчно да се натисне бутон [image].

    Ако в транспортния поток са настъпили изменения за даден сервис, намерени промени трябва да бъдат съхранени -

The contents of 3. DVB-T ТВ/Радио канали

3.1. Автосканиране за DVB-T канали


Topic: 3.1. Автосканиране за DVB-T канали

3.1. Автосканиране за DVB-T канали

3.1. Диалогов прозорец за автосканиране на DVB-T канали:

  • (доп., v.5.09) Група «DVB-T антена»:

    Източник – За ТВ тунери с реализирана технология DUAI се избира свързване към антенен вход – източник на DVB-T сигнал при сканиране.

    Ниво на сигнал (L) - вж. по-горе .

  • (изм., v.5.09) Група «Статус на сигнал»~«Сигнал от транспондера»~«Транспондер» –

    – Сигнал от транспондера:

    - вж. по-горе .

    - вж. по-горе .

(ново, v.5.09) Секция «Параметри» – задаване на допълнителни параметри за сканиране:

  • Група «Зона на неуверен прием» на сигнал:

    Увеличаване на време за прихващане на носеща - в зона на неуверен прием може да се увеличи времето за очакване за захват на OFDM-носеща от цифровия демодулатор.

    Увеличаване на време за анализ на "нечист" TS поток - в зона на неуверен прием може да се увеличи времето за очакване за подбор от TS-поток на сервисни таблици без наличие на грешки пакетите.

  • Група «Предпочитан език за нов сервис» - При сканиране на нови канали програмата позволява по подразбиране да се избере предпочитан език, ако сервисът съдържа няколко аудио пътеки и/или няколко пътеки със субтитри.

  • «Съхраняване на канали»:

    Премахване на отбелязаните изгубени канали - Параметърът определя вид на действие при натискане на бутон «Съхраняване на канали» – да се премахват или оставят канали, попаднали в списък «Изгубени» в резултат на сканиране.

  • Група «Сканиране»:

    Автосканиране за DVB-T канали може да се осъществи по два начина:

  1. да се сканира предварително зададена DVB-T честотна мрежа за регион:

    При сканиране на пълен диапазон става активна опция за задаване на съответен «Регион»

  2. да се въведе ръчно нужен транспондер и да се сканира неговия транспортен поток.

    След успешно сканиране таблицата се запълва с намерени канали.

    В долната част на групата - под съответните опции се визуализират информационни прозорци:

При нужда може да се разгледа детайлна информация за сервис на канал с изпълнение на команда «Информация за сервис» от контекстното меню в избран ред (v.5.05 - с двоен клик по избран ред):

Ако намерени канали не са налични във вече съществуващ списък ще бъдат показани в списък [image].

Канали, при които има изменения на сервиса ще бъдат в списък [image].

Канали, които са отпаднали от транспортния(те) поток(ци) ще бъдат показани в списък [image] .

След натискане на бутон «Съхраняване на канали», в зависимост от ситуацията:

  • нови канали се добавят в списъците DVB-T ТВ/ Радио;

  • канали с изменения ще бъдат пресъхранени;

  • изгубени канали или ще останат, или ще бъдат премахнати в зависимост от маркираното в «Премахване на отбелязаните изгубени канали».

    За всеки списък с резултати от сканиране може ръчно да се маркират канали, които подлежат на съхранение. От контекстното меню могат да се извикват макрокоманди за сваляне и слагане на отметки срещу всеки канал.

В секция [image] се изобразява log за процеса на сканиране.

(доп., v.5.09) Внимание! При ниско качество на сигнал (под 40%) поради голямо количество грешки в потока могат да възникнат проблеми при анализа на транспортния поток, които ще бъдат изобразени в дневника във вид на редове „PAT секция не е намерена” и т.н.. Това не е грешка на програмата и съобщава, че модулът за анализ не е могъл да получи от потока необходимите данни за извличане на сервисна информация.

Препоръките са две:

да се подобри показателят за качество чрез донастройка на антената, или

усилване на сигнала и активиране на параметър «Увеличаване време за анализ на "нечист" TS поток» в група «Зона на неуверен прием».

  • (доп., v.5.09) Група «Tранспондер»:

    С бутон [image] се извиква диалогов прозорец, в който се изпълнява (изм., v.5.09) отделен пълен анализ на ниско ниво на пакетите на транспортния поток (състав на всички негови пакети и техния тип).

    (v.5.05 -Този бутон е достъпен само когато е избран режим на сканиране «Избран транспондер»).

В реално време се извеждат:

  • PID на пакета;

  • моментен Битрейт на пакета;

  • тип Данни (които носи пакета);

  • Общ битрейт на транспондера.


Topic: 4. A/V входове

4. A/V входове

4. Секция за настройки на НЧ входове

(изм. и доп., v.5.11) Менюто е предназначено за настройки на параметри за А/V входове CVBS, S-Video, YPbPr, RGB (v.~5.10 - VHS (Композитен) и S-VHS (S-Video) входове).

Компонентни входове YPbPr / RGB са достъпни само за модели с чипсет SAA7231.

Интерфейс ~v.5.10:

Интерфейсът при v.5.11 е съществено променен в съответствие с функционалните изменения в новите модели тунери:

(вж. също Описание на интерфейса и интерфейс - v.5.11, подсекция «Видео» ):

(ново, v.5.11) А/V входове при тунери с компонентен вход:

Преведени съкращения:

§ Яр/Ярк=яркост (рус.„Ярк");

§ Кт/Контр=контраст (рус.„Контр”);

§ Цв/Цветн=цветност (рус.„Цветн”);

§ Нс/Насит=наситеност (рус.„Насыщ”);

§ От/Отт=оттенък;

§ NR/Отт=Noice Reduction~шумопотискане (рус.„Ш/под”~"Шумоподавление");

§ Sh/Остр=Sharp~ness ~острота (рус.„Рк”~„Резк”~"Резкость");

§ Lev/Ниво=Level~ниво (рус.„Нв”~„Уров”).

Интерфейс - настройки на параметри в секция «A/V входове», подсекция «Видео»:

  • Група настройки «Видео декодер»:

    Видео стандарт - Настройка на видеостандарт за избран вход.

    По подразбиране е Auto (Autodetect) (рус.”Автоопределение”). Може принудително ръчно да бъде изменен по желание стандарт (PAL/SECAM/NTSC/PAL60). В долната част - в информационната рамка се визуализират данни за декодиран стандарт в реално време.

    (доп., v.5.09) Autodetect не е достъпен за чипсет ТМ6010.

    (доп., v.5.09,5.11) Синхронизация на редове –

    Донастройка на хоризонтална синхронизация (HPLL) на видеодекодер SAA713x за избран вход (v.5.09-избран канал):

    § Режим Poor signal - при слаб сигнал

    § Режим VCR е предназначен за синхронизация на сигнали от VHS видео.

    § Режим Fast track се препоръчва за останалите случаи.

    Недостъпно за чипсети SAA7231, ТМ6010 (авто).

  • (доп., v.5.09,изм. и доп., v.5.11) Група регулатори - линейни плъзгачи [image] «Видеомиксер» - Група елементи за изменение на

    яркост,

    контраст,

    наситеност,

    оттенък (само за PAL / NTSC),

    острота,

    ниво на видеоусилване (Gain) (v.5.09-ниво на входния канал)

    за избран вход.

    В съседство е разположен чекбокс [image] за връщане на всички регулатори на видеомиксера в стойности по подразбиране.

    С бутони [image] «Прилагане за всички канали» всяка отделна настройка може да се присвоява за целия списък с канали.

    Регулатор «Видеоусилване (Gain)» е достъпен само в режим на ръчно регулиране на видеоусилване. В противен случай работи видео АРУ (Aвтоматично Регулиране на Усилване~AGC - Automatical Gain Control).

    Регулатор «Видеоусилване (Gain)» не е достъпен за чипсет ТМ6010.

    Допълнителни параметри за донастройки на видео АРУ са посочени в секция « Видео ».

  • Група опции за допълнителни аудио ефекти «Видео разширения»:

    (ново, v.5.11) 2D шумопотискане - Апаратен филтър за шумопотискане SWAN/LORE за избран канал.

    Достъпно само за чипсет SAA7231.

    Интерфейс - настройки на параметри в секция «A/V входове», подсекция «Аудио»:

  • Група за настройки «Аудио декодер»:

    Режим Аудио вход - Настройки на параметри на аудио линия за избран вход.

    Ако аудио входът се включва само с един моно вход (например обикновен видеокасетофон), трябва да се зададе режим Line Mono (L) или Line Mono (R) в зависимост от начина на включване.

    (доп., v.5.09) Не е достъпно за чипсет ТМ6010.

  • Група регулатори - линейни плъзгачи «Усилване»: Усилване и [image] Баланс на линейния вход за избран вход.

    Тези настройки могат да са недостъпни, ако в секция «Аудио» (група настройки «Параметри за управление на звук») е зададен [image] «Режим за управление - сила на звук» като «Обща сила на звук за всички канали».

  • Група регулатори - линейни плъзгачи [image] «Тембър»: - (изм. и доп., v.5.11) Апаратен филтър (v.~5.09 - Настройки) за ВЧ- и НЧ тембър за избран канал.

    Достъпно само за тунери с чипсети SAA7135, SAA7231.

    (ново, v.5.11) Група регулатори - линейни плъзгачи [image] «Equalizer» - Апаратен пет лентов стерео Equalizer за избран канал.

    Достъпно само за чипсет SAA7231.

  • Група опции за допълнителни аудио ефекти «Аудио разширения»:

    Аудио ефект – Избор на виртуален звуков ефект за избран канал.

    Достъпно само за тунери с чипсет (доп., v.5.11) SAA7135, SAA7231.

    (ново, v.5.11) Bass - усилване - Апаратен филтър за динамично усилване на бас (Dynamic Bass Boost) за избран вход.

    Достъпно само за чипсет SAA7231.

    (доп., v.5.09) С отметка срещу всеки НЧ вход се задава дали да се разреши или да се пропусне съответен вход при преминаване през различни източници с команди от ПДУ или от клавиатурата.


Topic: 5. Видео

5. Видео

5. Секция за настройки на видео параметри:

  • Група «Извеждане на видео» - Режим на извеждане и показване на изображение при гледане.

    Ако видеокартата поддържа наслагване на овърлей във формат YUY2, оптимален режим е «Овърлейна повърхнина» (болшинството съвременни видеокарти поддържат овърлей YUY2).

    Ако има проблеми с изображението или такова изобщо липсва, може да се зададе режим «Първична повърхнина».

    Внимание! Режим «Първична повърхнина» увеличава натоварването на процесора!

    Под Windows XP*/2003 се препоръчва «Овърлейна повърхнина (VMR7)».

    *Ако под Windows XP е инсталиран пакет Microsoft.NET Framework 3.5, ще бъде достъпно извеждане през «Enhanced Video Renderer» («Direct3D DXVA 2.0 повърхнина»). Рендерер EVR се появи в Windows Vista и използва последни технологии на съвременните видеокарти за извеждане на видео през Direct3D.

    Под Windows Vista списъкът ще се състои от два режима:

    «Адаптивна повърхнина под Аеро (VMR 7 / 9)» и

    «Direct3D DXVA 2.0 повърхнина (EVR)».

    За слаби системи под Windows Vista/7 се препоръчва да се изключва Vista Aero и да се използва извеждане на видео като «Адаптивна повърхнина...», при това се ползва «Video Mixing Renderer7 (VMR7)», който по възможност ще извършва извеждане в овърлей.

    В останалите случаи се препоръчва да се използва «Direct3D DXVA 2.0 повърхнина».

    При натискане на бутон [image] «Свойства на устройство за визуализация» се отваря диалогов прозорец за настройки на видеорендерер .

  • Група «Размери на видеопоток»:

    (доп., v.5.09) Режим „в прозорец” [image] [image] [image] Пълноекранен режим - Размер за формиране на кадър от WDM-драйвера при гледане.

    Колкото е по-висока разделителната способност, толкова по-високо е качеството на образ.

    Предвидени са отделни настройки на изображение за

    режим „в прозорец” и

    пълноекранен режим.

    Ако разделителната способност на кадър не съвпада за тези режими, при превключване между пълноекранен режим и режим „в прозорец” ще има „прищракване”.

    Препоръчва се величините на режим „в прозорец” и пълноекранен режим да са еднакви.

    при натискане на бутон «<>» / «=» се асоциират респ. еднакви или задаване на различни разрешения.

    Препоръчителни режими: 704x576, 720х576, 768x576 за PAL / SECAM и 640х480, 704x480, 720x480 за NTSC.

    Дължина на активния видеоред – Задаване на количество отброявания (рус.”отсчет~ов”) в ред, което се прихваща от видеодекодера след цифровизиране на видео.

    За по-комфортно гледане на PC монитор се препоръчва да се зададе 704.

    За гледане на телевизор трябва да се зададе 720 (ITU-601).

    (изм., v.5.09, доп., v.5.11) За чипсети SAA7231 и ТМ6010 дължината на активния ред се задава от разрешението на кадър, където 704 отброявания се формират при разрешения, кратни на 704.

  • – С този бутон се извиква диалогов прозорец за настройки на видеообработка на изображение [image] при гледане с използване на допълнителни плъгини за всевъзможни ефекти на обработка.

    (видеообработка [image] при запис - отделно !)

  • Група «Параметри ва видеопрозорец»:

    Прозрачност [image] - В режими на извеждане

    «Първична повърхнина» (само под Windows 2000/2003/XP) и

    «Direct3D DXVA 2.0 повърхнина» (само под Windows Vista / 7)

    е достъпна функция за използване на полупрозрачен видеопрозорец. Регулиране на степен на прозрачност може да се извършва и със скрола на мишката над видеопрозореца (вж. « Настройки на управление » - Прозрачeн прозорец).

    Внимание! Включване на прозрачност силно увеличава натоварването на CPU в зависимост от размерите на видеопрозореца и видеопотока!

    За използване на функция «Прозрачност» се препоръчва видеопоток с размер, не по-голям от 384 x 288.

    При преход на пълен екран функция „Прозрачност” автоматично се блокира.

  • Група «Извеждане на видео»:

    (редактирано, v.5.11) Съхраняване ниво на видеомиксер за всеки канал - При превключване на канали стойностите на видеомиксера ще се прилагат индивидуално към всеки канал в съответствие с настройките на всеки ТВ канал. В противен случай стойностите на видеомиксера ще бъдат общи за всички канали.

    Съхраняване на Zoom и позиция на кадър за всеки канал - При превключване на канали величините за [image] «Zoom» и [image] «Позиция на кадър», настроени за изображение във видеопрозореца, ще се съхраняват поотделно за всеки ТВ канал. В противен случай тези стойности ще бъдат общи за всички канали.

  • Група «Разширени параметри на аналогово видео»:

    (доп., v.5.09,5.11) Синхронизация на кадри - Режим за възстановяване на вертикална синхронизация при декодиране на видеосигнал. Задава режим, при който чипсети SAA713x, SAA7231 възстановяват вертикална синхронизация при загуба на синхросигнал (напр. при превключване на канали).

    Режим «Нормален tracking» е препоръчителна настройка.

    Режим «Бърз tracking» позволява максимално бързо да се възстанови синхронизацията на кадри, но трябва да се прилага само при качествен видеосигнал с чисти синхроимулси. В противен случай е възможно „придърпване” на изображение и изместване на кадри по вертикал.

    Режим «Свободен tracking» изключва принудителната синхронизация на кадри и може да бъзе полезен при гледане на кодирани канали с криптирани синхроимпулси. Този режим може да помогне и при запис от нискокачествени VHS касети с повредени отметки на синхроимпулси. Режим «Свободен tracking» не се препоръчва за ежедневно използване, т.к. предизвиква изместване на кадър по вертикал при преминаване през ТВ канали.

    Не е достъпно за чипсет ТМ6010.

  • Подгрупа «Авторегулиране на видеоусилване» - Набор от опции за настройки на видео АРУ.

    Видеоусилване има 2 режима на работа - ръчен и автоматичен (АРУ). АРУ не се препоръчва да се използва за ефирни ТВ канали, тъй като при силни изменения на нивото на входящия видеосигнал са възможни скокообразни изменения на яркостта. За всеки отделен ТВ канал може да се зададе ръчен или АРУ (Авто) режим на видеоусилване:

    Контролиране праг на яркост - Режим, при който видео АРУ ще сработва при превишаване на номиналната стойност (0 dB) на яркостната съставляваща на видеосигнала. При изключен параметър е възможно „избледняване” на изображението.

    (доп., v.5.09) Не е достъпно за чипсет ТМ6010.

    Контролиране праг на цветност - Режим, при който видео АРУ сработва само тогава, когато нивото на цветоразликовата съставляваща на видеосигнала превишава динамичния диапазон на АЦП-декодера.

    Препоръчително е да бъде включен.

    (доп., v.5.09) Не е достъпно за чипсет ТМ6010.

    Дълга пауза на АРУ (изм... в течение на VBI) (Корекция Macrovision) - Дълга или кратка пауза преди сработване на АРУ. Дълга пауза се препоръчва ако видеосигналът е защитен Macrovision.

    (доп., v.5.09) Не е достъпно за чипсет ТМ6010.

  • «Предпочитан стандарт за Autodetect» - При включване на режим за автоматично определяне на видеостандарт, чипът на декодера преминава през стандартите, като започва от зададения като предпочита:

    Ако болшинството ТВ канали се излъчват по стандарт PAL се препоръчва да се зададе предпочитан PAL, аналогично – за стандарт SECAM. Това позволява да се ускори автоопределяне и да се избегнат „цветни изблици~отблясъци” (рус.”цветовые всплески”) при превключване на канали. Също така, при SECAM канали предпочитан стандарт SECAM позволява да се избегне лъжливо NTSC-определяне, което изглежда като цветови „муар” (вълнообразни отблясъци) по целия екран.

    (доп., v.5.09) Не е достъпно за чипсет ТМ6010.

  • Аnti-Alias филтър за SECAM - при декодиране на видеостандарт SECAM чипсети SAA713x издават неголям артефакт във вид на „мрежа” по границите с рязка смяна на цветовете. Артефактът е особено забележим, когато плъзгачът за острота е близко до максималната стойност. Тази опция позволява да се намали подобна „мрежа”, но като страничен ефект се забелязва незначително намаляване на остротата на изображение.

    (доп., v.5.09,5.11) Не е достъпно за чипсети ТМ6010, SAA7231.

  • Група «Параметри на Windows desktop»:

    Размер (разделителна способност) в пълноекранен режим – Задаване на параметри на Windows desktop при преход на програмата в пълноекранен режим.

    Някои по-стари видеокарти не поддържат наслагване на овърлей при високи разделителни способности на Windows desktop.

    Този проблем може да бъде решен, като се зададе разделителна способност например 800x600, в която да работи Windows desktop при преминаване в пълноекранен режим.

    В менюто може да се зададе и честота на обновяване на кадри за монитора в Hz (само под Windows 2000/XP/2003).

    Честота на обновяване (Hz) –

    (доп., v.5.11) Изключване на Windows Vista / 7 «Аerо» - Позволява при стартиране на Behold TV да се изключва Vista Aero и да се работи в овърлеен режим. След затваряне на приложението Aero ще бъде автоматично възстановен.

    Препоръчва се за по-слаби системи.

    Опцията е достъпна само под Windows Vista / 7.

The contents of 5. Видео

Настройки на видеорендерер
5.1. Плъгини за видеообработка


Topic: Настройки на видеорендерер

Настройки на видеорендерер

Настройки на видеорендерер

Диалогов прозорец за настройки на видеорендер се отваря при натискане на бутон [image] «Свойства на устройство за визуализация» в група « Извеждане на видео »:

  • «Входящ тип медиа»:

    - обновяване (refresh)

  • «DXVA декодиране MPEG2/H.264/VC-1»

  • Група «DXVA видеомиксер»:

    яркост

    контраст

    наситеност

    оттенък

    Апаратен видеомиксер е достъпен само за VMR9 и EVR рендерери.

  • Група «DXVA видеопроцесор»:

    Апаратен деинтерлейс,

    Апаратен филтър за шумопотискане

    Luma denoice

    Chroma denoice

    и Апаратен филтър за детайлизация

    Luma detail

    Chroma detail

    са достъпни само за EVR рендер и видеокарти nVidia GeForce - серии 6/7/8 с апаратен блок PureVideo.

  • «Параметри на аспект»

    Нелинейно разширяване (разгъване) - «Панорама» е достъпно само за EVR рендерер.

    Трябва да се отбележи, че EVR рендерер под Windows XP няма да бъде пълноценен както при Windows Vista/7, доколкото моделът на видеодрайвер при XP не поддържа DXVA2, при което се използва емуляция DXVA1 [image] DXVA2 и достъп до много функции е ограничен.


Topic: 5.1. Плъгини за видеообработка

5.1. Плъгини за видеообработка

5.1. Настройки за видеообработка на изображение с използване на плъгини:

Този диалогов прозорец е предназначен за настройки на видеообработка на изображения при гледане.

Напомняне: Видеообработка с плъгини е възможна също така и при запис - както от ефирни ТВ предавания, така и от външни източници. Трябва да се помни, че видеообработка в различни режими (запис / гледане) са отделни процеси, респ. настройките при запис са обособени от тези за гледане в отделен раздел на панела за запис .

Видеообработка се реализира чрез допълнително включване на плъгини.

В зависимост от самите плъгини, различните такива могат да имат допълнителни диалогови прозорци за настройки.

Видеообработка не е достъпна в DVB-режим на тунера.

  • Група «Използвани филтри за процесинг» -

    Списък с плъгини за видеообработка и/или наслагване на всевъзможни ефекти. В зависимост от включените плъгини може да се сменя тяхната последователност за изпълнение.

    Възможно е временно да се деактивира(т) даден(и) плъгин(и), като се свали отметката в съответен "чекбокс".

    За да могат да бъдат добавяни в списъка с достъпни плъгини за видеообработка, плъгини за процесинг (файлове с префикс BPP_ и разширение .dll) трябва да бъдат разархивирани и да се намират в директория [image] ...\BeholdTV\Plugins\

    Бутони за управление на списъка с плъгини за процесинг:

    + Добавяне на плъгин в списъка от меню с достъпни плъгини ( [image] вж. предходния абзац!):

    - премахване на плъгин от списъка;

    и [image] - разместване* на плъгини по ред списъка, респ. в посока към началото или края на същия.

    *Важно [image] При разместване на плъгини не се променя просто тяхното местоположение, а се изменя и редът за инициализиране и изпълнение на същите, респ. се повишава или понижава приоритет на съответен филтър, което от своя страна е свързвано с натоварване на процесора и системата!

В зависимост от особеностите на самите плъгини, същите могат да имат допълнителни настройки, до които се стига

  • с деесен клик > [image] върху ред на съответния маркиран като «активен» плъгин, или

  • чрез бутон «свойства»:

    В диалоговия прозорец могат да са достъпни различни настройки, които са специфични за всеки отделен плъгин.

    В долната част на списъка се извежда информационно поле с кратко описание [image] и версия* на съответния маркиран плъгин:

    * Плъгините могат да имат няколко различни версии, които се публикуват на официалния сайт. Както и при различни други приложения, това е свързано с усъвършенстване, доработка(и) и/или отстраняване на грешки на даден плъгин. Актуални версии се предоставят с инсталационния диск в комплекта, но въпреки това се препоръчва периодично да се проверява за актуализации и нови версии.

  • Група «Използван филтър за деинтерлейсинг» - Избор на достъпен плъгин за деинтерлейсинг.

    „Деинтерлейсинг” е алгоритъм за премахване на артефакти тип "гребен" (comb), които се проявяват при извеждане на изображение от междуредов източник на прогресивен дисплей.

    Може да се избере само един плъгин, който ще се занимава с деинтерлейсинг.

    Деинтерлейсинг работи само при извеждане на двете видеополета на кадър, т.е. когато височината на кадър е избрана 576 за PAL/SECAM (например 768x576) или 480 за NTSC (напр. 720x480).

    Свойства на филтъра - вж. по-горе.

    Информационно поле с кратко описание [image] на избран плъгин - вж. по-горе.

  • Група «Механизъм за удвояване на честота на кадри» -

    Опцията позволява да се управлява честотата на кадри при гледане.

    С удвояване на честотата на кадри се постига по-голяма плавност на видеоизображение и динамика на сцените, т.е. гледане става комфортно - както при битовите телевизори.

    Внимание [image] За максимално качество при използване на ефект за удвояване на честота на кадри е необходимо да се настрои опресняване на кадрова честота на монитора (refresh) кратно на 25 (например 75 Hz; 100 Hz). При други стойности ще се наблюдава трептене (рус.”биение”), добре забележимо например при "бягащ ред"!

    Изключен – Използва се стандартно прогресивно извеждане на видео с честота на кадрите 25 кадъра/сек. (30 за NTSC).

    За отстраняване на „гребеновидни” ефекти в този режим е необходим програмен деинтерлейс.

    Програмен режим за удвояване на честота (Smart Interleave) - Използва се програмен механизъм за двукратно увеличаване на кадровата честота.

    Внимание [image] При това се повишава натоварването на CPU (~1,5 пъти)!

    За отстраняване на „гребеновидни” ефекти в този режим е необходимо да се активира деинтерлейсинг. Този начин за удвояване на честота на кадри работи само при извеждане на двете видеополета на кадър (*x576 или *x480).

    Апаратен режим за удвояване и деинтерлейс (Interleaved Bob) – Използват се апаратните възможности на видеокартата за извеждане на интерлейсни редуващи се видеополета в овърлей.

    Този метод работи само при видеокарти, които поддържат апаратно дадената възможност (всички ATI Radeon, nVidia GeForce). Този начин не изисква използване на програмен деинтерлейс и на практика не натоварва CPU.

    (доп., v.5.11) Режимът е достъпен само при извеждане на видео в Овърлейна или D3D повърхност (вж. настройки в секция «Видео»).

    Внимание [image] При използване на апаратни функции за деинтерлейс ефектът е виден само в овърлея, но не и при правене на скрийншот-ове от приложението.

    Този метод се препоръчва за видеокарти ATI Radeon съвместно с включена опция «Използване на VMR». Видеокарти ATI Radeon могат да изпълняват метода Interleaved Bob без тремор (трептене) на редовете и с минимални загуби на контраст по вертикала, тъй като имат блок за апаратен попикселен адаптивен деинтерлейсинг.

    Видеокарти nVidia GeForce с апаратен блок PureVideo също могат да изпълняват апаратен попикселен деинтерлейсинг.

    Останалите видеокарти нямат пълноценен апаратен попикселен деинтерлейсинг и изпълняват обикновен BOB, който предизвиква трептене (тремор на редове), както и намаляване на остротата по вертикал.

Забележка: Допълнителни плъгини могат да бъдат свалени от сайта за техническа поддръжка .


Topic: 6. Аудио

6. Аудио

6. Секция за Аудио настройки:

интерфейс - v.5.11:

  • (изм., v.5.09) Група «Устройство за възпроизвеждане»

    (v.5.05 - «Настройки на аудиомиксер» – Параметри за работа съвместно със звуков миксер) –

    Група за избор на устройство за обработка и извеждане на звук:

    Миксер за възпроизвеждане –

    Избор на системен аудиомиксер (ако в системата има няколко подобни устройства).

    Трябва да се избира само звукова карта, към която е включен аудио кабелът от тунера.

    ! Някои аудио карти (например Realtek HD Audio) имат по 2 миксера -

    § за запис и

    § за възпроизвеждане.

    Трябва да се избере миксер за възпроизвеждане (Output).

    ! При смяна на миксер се сменят достъпните линии за възпроизвеждане!

    (v.5.05 - Забележка: За PCMCIA тунер BeholdTV Columbus избор на миксер е недостъпен).

    (изм. и доп., v.5.09) Устройство DirectSound

    (v.5.05 - DirectSound устройство за извеждане на звук) –

    Избор на Direct Sound устройство за извеждане на цифров звук. Звук във формат PCM се извежда чрез даденото устройство в режим «Таймшифт», както и при предаване на звук по шина PCI / USB.

    Ако в системата има само едно устройство за извеждане на звук е достатъчно да се избере «Първичен звуков драйвер».

  • (изм., v.5.09) Група настройки за «Извеждане на звук»

    (v.5.05 - «Извеждане на звук от чипсет SAA7134/35 през PCI-шина») –

    Режим за извеждане и управление на звук при прослушване:

    v.5.11: ( сравнителни данни да интерфейс v.5.05 са приложени тук )

    (изм., v.5.09) [image] – Предаване на аналогов звук от изхода на ТВ тунера чрез аудио кабел към външен вход на аудиокартата.

    (доп., v.5.09) Не е достъпно за PCMCIA и USB модели ( [image] поради миниатюризирания интерфейс на подобни устройства и спецификациите на използваните шини за трансфер на информация съществуват както чисто физически, така и функционални ограничения за вграждане на някои изходи, вкл. за аналогов аудио кабел*).

    В този режим е много важно да бъдат избрани коректно

    § «Миксер за възпроизвеждане» и

    § «Линия за управление на звук» от допълнителния диалогов прозорец за свойства

    Диалоговият прозорец за конфигуриране на «Параметри за извеждане на звук» се извиква с натискане на бутон [image] «Конфигурация» в дясната част на информационната лента за формат на предавания поток.

    (доп., v.5.09) Линия за управление на звук – Избор на линия на миксера за регулиране ниво на звук.

    Избира се тази линия, към която е включен аудио кабелът на тунера. Обикновено това е Line-In.

    ! В случай на активирано извеждане на звук по шина PCI / USB, тази линия може да бъде потисната (Mute), за да се избегне извеждане на звук от два източника и появяване на ехо!

    Внимание! Ако «Миксер за възпроизвеждане» или «Линия за управление на звук» са избрани неправилно, функциите за потискане (Mute) и управление на усилване на звук няма да работят!!

    (v.5.05 - Забележка: За PCMCIA тунер BeholdTV Columbus избор на миксер е недостъпен - обща забележка в началото на опцията).

    Изключване на линията за управление на звук при изход от програмата – Изключване на избраната линия за управление на звук на миксера при изход от програмата.

    Избягва се настройване на линия при неактивен тунер.

    (v.5.05... Опцията е недостъпна ако е зададен режим на извеждане на звук по PCI).

    Fader - компенсация при затихване на линия (ms) - Аудио карти Creative от серии SB Live!/Audigy/Audigy2/Audigy4 имат ефект на затихване (Fade) при затихване на линията на миксера. Опцията отчита този аспект и компенсира ефекта на затихване с допълнително закъснение от 150 ms. Величината на закъснение може да се регулира. Ако тази опция е изключена, за посочените звукови карти ще се чува щракане при превключване на канали (особено при тунери с чипсет SAA7130).

    За други звукови карти опцията може да се изключи.

    (v.5.05 - Компенсация на затихване (Fader) при гасене на линия (ms) ... Опцията е недостъпна ако е зададен режим на извеждане на звук през шина PCI).

    (доп., v.5.09) [image] (по шина PCI / USB) –

    (v.5.05 - Извеждане на звук от чипсет SAA7134/35 по шина PCI)

    Включване на цифровизиране и извеждане на звук от чипсета по шина (доп., v.5.11) PCI / PCIе / USB. При това звукът се цифровизира от чипсета на тунера и се предава по шината директно в буфера на звуковата карта.

    В този случай не е необходим аналогов аудио кабел за съединяване на тунера със звуковата карта.

    Не е достъпно за модели, базирани на чипсет SAA7130.

    (v.5.05...Забележка: PCMCIA тунер BeholdTVColumbus винаги цифровизира и извежда звук от чипсета по шина PCMCIA)

    В този режим е много важно да бъдат избрани коректно

    § «Миксер за възпроизвеждане» и

    § «Устройство DirectSound» от допълнителния диалогов прозорец за свойства ( [image] вж. по-горе група «Устройство за възпроизвеждане»).

    Диалоговият прозорец за конфигуриране на «Параметри за извеждане на звук» се извиква с натискане на бутон [image] «Конфигурация» в дясната част на информационната лента за формат на предавания поток.

    В допълнителния диалогов прозорец за свойства са достъпни следните параметри):

  • Група за настройки «Общи параметри»:

    (изм., v.5.09) Честота на дискретизация за декодера (Hz) ( [image] Честота на подбор на семпли за декодера (Hz)) -

    Избор на честота за дискретизация на звуковия РСМ поток при цифровизиране и предаване по шина PCI / USB.

    Препоръчителна честота - 48000 Hz.

    ( [image] в зависимост от възможностите на чипсета!)

    (изм., v.5.09) Изключване на линия миксер за затихване на звук по кабел - Ако по време на предаване на звук по шина е включен и аналогов аудио кабел, ще се чуват едновременно 2 звукови потока с изместване по време.

    За да може предаван по кабел звук да се изключва автоматично, тази опция трябва да е активирана.

    Забележка: За PCMCIA и USB тунери Behold TV тази опция не е достъпна.

  • Група за настройки на «Обемен звук»:

    Текущи настройки на устройства в Windows

    Извеждане на обемeн звук (NXP SAA7135 Dolby Pro Logic) - Задействане на процесор DPL в чипсет SAA7135. Тази възможност е достъпна при изпълнение едновременно на всички изброени по-долу условия:

    + само за SAA7135

    + наличие на аудио карта, поддържаща изходни формати 5.1 / 6.1 / 7.1

    + активиран режим 5.1 / 6.1 / 7.1

    Процесор DPL апаратно разделя стерео сигнала на 4 канала:

    X Front Left,

    X Front Right,

    X Front Center,

    W Back Surround,

    като използва патентования алгоритъм DPL.

    ! За коректно извеждане на звук по схема Dolby Pro Logic собственият Surround режим на работа на аудиокартата (обикновено е програмен) трябва да бъде изключен, иначе ще подменя Dolby Pro Logic със собствен алгоритъм!

    Ограничения:

    § Чипсет SAA7135 е построен така, че при активация на процесор Dolby Pro Logic, сигналът вътре в DSP не се подава на блока за регулиране на Общо ниво, Тембър ВЧ и НЧ, Виртуални ефекти, звуково АРУ.

    § Също така при запис на звук по шина PCI процесор DPL се изключва за коректен запис на стерео канали във файл.

    Режим на извеждане Dolby Pro Logic:

    Full surround (Left - Right - Center - Back Surround) - Пълен режим на работа DPL.

    Ако изходният сигнал е Моnо, след обработка ще работи само централният канал Front Center.

    Phantom Center (Left - Right - Back Surround ) - Канал Front Center е изключен и разпределение на аудио панорама се извършва в канали Front Left, Front Right, Back Surround.

    Ако изходният сигнал е Моnо, след обработка ще работят само канали Front Left и Front Right.

    X3 Stereo (Left - Right - Center) - Канал Back Surround е изключен и разпределение на аудио панорама се извършва в канали Front Left, Front Right, Front Center.

    Ако изходният сигнал е Моnо, след обработка ще работи само централният канал Front Center.

  • Група за настройки на «Параметри за управление сила на звук» – Група настройки, които позволяват да се зададе оптимален режим за управление на сила на звук в приложението.

    Режим за управление - сила на звук -

    Избор на режим за регулиране на общата сила на звука в приложението.

    Внимание! Върху нивото на сила на звук на тунера в режим на гледане оказват влияние общите настройки за сила на звук в системата, т.е.

    § величините на линии Main и Wave на системния аудиомиксер, както и

    § нивата на декодера (v.5.05 - на чипсет Philips SAA7134/35) в настройките на секция «Аудио»:

    – Задавана сила на звук става обща за всички TV / FM канали и A/V (VHS / S-VHS) входове.

    – Текущата сила на звук се пресмята въз основа на общата сила на звук за приложението, с поправка (в проценти) индивидуално за всеки TV / FM / DVB канал или A/V (VHS / S-VHS) вход.

    Относително ниво за сила на звука за избран канал или вход се задава в менюто за настройки на канали или чрез допълнителния панел за управление на програмата.

    Управление чрез обща линия за усилване-от аудиомиксер

    ( [image] предишна BG редакция - Управление на аудиомиксер - обща сила)

    При включване на тази опция, силата на звук в програмата винаги ще се регулира посредством общата линия (Main) на миксера на аудио картата.

    Функция „изключване на звук” (Mute) както и преди това ще се използва в зависимост от избраната линия за управление на звук (или чрез DirectSound).

    Съхраняване на аудио ниво за обща линия в настройките -

    § При включване на тази опция, нивото на звук в общата линия (Main) на миксера на аудио картата ще се запомня при стартиране на програмата и ще се възстановява при завършване на нейната работа. При това нивото на звук ще бъде установено в съответствие с настройките на тунера, т.е. каквото е било при завършване на предишен сеанс на работа с програмата.

    § Ако опция «Съхраняване на аудио ниво за обща линия в настройките» е изключена, при пускане на програмата нивото на сила на общата линия няма да се променя.

    Тази настройка е достъпна само при включена опция «Управление чрез обща линия за усилване-от аудиомиксер» ( [image] вж. предходната опция)

    (доп., v.5.09) Нелинейна скала на главното ниво за сила на звук в Behold TV - Активира нелинейно изменение на стъпката за общо ниво на сила на звук в приложението в зависимост от текущото ниво.

    (доп., v.5.09) Стъпка за усилване (за сила на звук) (%) – Величина в проценти за дискретно регулиране на общата сила на звук.

    Не е активно при активирана нелинейна скала.

    Затихване на звук (ms) – Време за затихване на звук при превключване на канали.

  • (изм., v.5.09) Група «Разширени параметри на аналогово аудио»

    (v.5.05: Philips SAA713x - опции Аудио) -

    Допълнителни апаратни настройки на аудио декодера на чипсета:

  • Подгрупа «Междинна честота на TV звук (SIF)» -

    Блок за настройки, позволяващи да се зададе оптимално ниво на сигнала по междинна честота (МЧ) (рус. ”Помежуточная Частота” - ”ПЧ”) на ТВ звук за последващо декодиране (само за SAA7134/35).

    Тези настройки влияят върху последващото качество на декодиране на аудио сигнал от чипсет SAA7134/35. Претоварване или ниско ниво на сигнала от изход SIF води до характерни неприятни припуквания на звука, особено забележими при декодиране NICAM. Декодер NICAM е много чувствителен към входното ниво SIF.

    Входно усилване - Три режима на предварително усилване за задаване на номинално ниво на сигнала от SIF изхода на ВЧ блок:

    Автониво - Включва автоматично регулиране на нивото на сигнала, постъпващ от изход SIF (препоръчително).

    При изключена опция може да се зададе ниво на SIF-сигнал ръчно:

  • (изм., v.5.09) Подгрупа «Ниво на усилване за декодер» - Задаване на ниво за аудио декодер за различни линии:

За SAA7134:

Линия Main регулира общата сила на звук на изхода,

Линия A2/Mono - нивото на сила на звук в система Dual l FM,

Линия NICAM - нивото на сила на звук в система NICAM. Ако в текущия момент няма NICAM излъчване, този плъзгач е неактивен. Аналогично и за A2/Mono.

Линия PCI позволява да се регулира нивото на звук при запис на звук от чипсета по шина PCI.

линия FM - n.a.*

линия LINE - n.a.*

*Всички тези регулировки работят само в ТВ-режим (ограничения на SAA7134).

(доп., v.5.11) За SAA7135, SAA7231:

Линия Main регулира общата сила на звук. Това регулиране работи във всички режими.

Линия A2/Mono и

Линия NICAM работят само в ТВ-режим за съответните стандарти.

Линия FM регулира силата на звук от FM тунера в режим FM Radio,

Линия Line регулира силата на звук от линейния вход (изм., v.5.11) (А / V входове) (v.5.05 - режими VHS, S-VHS).

Всички регулировки също така са в сила при запис на звук от чипсета по шина PCI.

(доп., v.5.09) За ТМ6010:

Линия TV регулира нивото в режим ТВ,

линия FM регулира нивото в режим FM Radio,

линия Line регулира нивото на външния вход.

АРУ на звук - Автоматично регулиране на изходната сила на звука.

Само за SAA7134 / SAA7135.

Чувствителност - Чувствителност на аналоговия вход за различни режими*.

Ако силата на звук е недостатъчна, трябва да се зададе 1 Vrms.

*За чипсети SAA7134/35 тази опция е недостъпна в ТВ режим.

(доп., v.5.09) Не е достъпно за чипсет ТМ6010.

  • (изм., v.5.09) Група «ВЧ радиомодул - Аудио опции» – Този блок за настройки е достъпен само

    за ТВ тунери с ВЧ-селектор от клас MK3 или MK5, както и

    за PCMCIA тунер Behold TV Columbus в режим FM:

    Автозатихване на звук при слаб сигнал (FM) - При включване на тази опция ВЧ-модулът потиска изходния звуков сигнал, ако входното IF ниво е под критична стойност. Това позволява да се потиска неприятния шум при отсъствие на сигнал.

    Опцията е достъпна само в FM режим за тунери с ВЧ модули MK3/MK5.

    Намаляване на ВЧ-шум при слаб сигнал (FM) – Опцията е приложима само за Behold TV Columbus в режим FM и задава параметър HCC (High Cut Control) за FM-декодер Philips TEA5767. При включена опция се изрязват високите звукови честоти за FM станции с лошо ниво на сигнал за намаляване на шумови ефекти.

    Автозатихване на звук при слаб сигнал (ТV) - Аналогична опция, само за TV режим.

    Опцията е достъпна само за ТВ тунери с чипсет SAA7130+ВЧ блок MK3/MK5+само в ТВ режим.

    Корекция на високи честоти на звук (TV)- При включване на тази опция се потискат ВЧ-съставни на аудио сигнал.

    Опцията е достъпна само за ТВ тунери с чипсет SAA7130+ВЧ блок MK3/MK5+само в ТВ режим.

The contents of 6. Аудио

v.5.05/SAA7134


Topic: v.5.05/SAA7134

v.5.05/SAA7134

СРАВНИТЕЛНА информация - Интерфейс v.5.07~v.5.09 - Секция за настройки «Аудио»

С пускането на нови серии тунери базирани на различни от NXP SAA 7130 / 34 / 35 чипсети (с USB интерфейс, серии 7, 8, ...) след v.5.05 интерфейсът на тази основна секция се променя и развива динамично. В този подраздел е оставена информация със сравнителен характер за развитието на Behold TV от v.5.05 до v.5.11 включително (може да бъде от полза при евентуално ползване на по-стари версии на Behold TV).

  • интерфейс ~ v.5.05, чипсет SAA7134

  • Група настройки за «Извеждане на звук»

    (v.5.05 «Извеждане на звук от чипсет SAA7134/35 през PCI-шина»)

    v.5.05 -

    v.5.11 -

    ...


Topic: 7. DVB поток

7. DVB поток

7. Секция за настройки на DVB поток:

Управляващите елементи в тази секция са достъпни само в режим DVB на тунера.

  • Групи «Видео декодери за DVB поток»; «Аудио декодери за DVB поток»:

    В полетата се визуализира [image] информация с данни за наличие и статус на необходими компоненти за декодиране на DVB поток.

    Коректно инсталирани компоненти се отбелязват с отметка [image] и имат активни опции [image] за

  • избор на Видео декодери

  • избор на Аудио декодери

    от съответните списъци с инсталирани и достъпни такива, както и

  • отделни прозорци за информация/настройки (свойства/"properties") респ. за

    § Видео декодери:

    § Аудио декодери:

  • (доп., v.5.09) Видео декодери за DVB поток; Аудио декодери за DVB поток - За декодиране на DVB видео/аудио поток е необходимо да са инсталирани

    § MPEG2 / H.264 видео декодери и

    § MPA / AAC аудио декодери.

    MPEG2 / MPA декодери InterVideo се зареждат в програмата при инсталиране на приложението InterVideo WinDVD Creator, включено в комплекта на тунери Behold TV на отделен диск.

    Декодери H.264 видео и AAC аудио не влизат в комплекта (Използване на конкретен вид е по индивидуална преценка и не е задължително за всички потребители).

    При превключване на Behold TV на DVB канал нужният декодер за формат MPEG2 или H.264 (MPA или AAC) ще бъде включен автоматично в зависимост от параметрите на DVB-сервиса. Behold TV може да използва различни инсталирани в системата MPEG декодери.

    В Windows Vista / 7 са интегрирани нови висококачествени MPEG2 (под Windows 7 също така H.264 и AAC) декодери от Microsoft, които могат се използват при избиране от списъка вместо InterVideo декодери. Под Windows Vista / 7 е достатъчно използване на декодери Microsoft, при което отпада необходимостта за инсталиране на InterVideo WinDVD Creator като приложение (ако не се ползва като отделна програма за видеообработка). Видеодекодер MPEG2/Н.264 на Microsoft също така поддържа интерфейс за DXVA 2.0 ускорение. Ако MPEG аудио/видео декодер има стандартен DirectShow диалог за конфигурация, същият може да бъде извикан с натискане на бутон [image] «Свойства» («Properties») срещу декодера и да бъде настроен по свое усмотрение. Трябва да се знае, че всеки декодер има свой собствен диалог за настройки, свойствен само за дадения декодер. Болшинството видео декодери имат в диалога за настройки опция за включване на DXVA ускорение. Препоръчва се да се включва DXVA, тъй като това позволява на видео адаптера да изпълнява болшинството функции по декодиране на MPEG потока, което води до намаляване на натоварването на CPU и повишаване на качеството на изображение за сметка на качествено декодиране, апаратен деинтерлейс и включване на апаратен интерливинг на полетата.

  • Група настройки за «Извеждане на DVB видео» - Извеждане на видеоизображение при гледане след декодиране на видеопоток.

    Препоръчва се да се избира овърлейна повърхност VMR7 с поддръжка на DXVA за получаване на по-качествено изображение и по-ниско натоварване на CPU. За целта видео адаптерът трябва да поддържа DXVA ускорение за декодиране на MPEG2 / H.264. В противен случай видео декодиране ще се осъществява изцяло програмно.

    Под Windows Vista / 7 списъкът ще се състои от два режима:

    «Адаптивна повърхнина под Аеро (VMR7/9)» и

    «Direct3D DXVA 2.0 повърхнина (EVR)».

    За слаби системи под Windows Vista / 7 се препоръчва да се изключва Vista Aero и да се използва извеждане на видео като «Адаптивна повърхнина...», при това се използва Video Mixing Renderer7 (VMR7), който ще използва по възможност извеждане в овърлей. В останалите случаи се препоръчва използване на Direct3D DXVA 2.0 повърхност посредством DXVA2 Enhanced Video Renderer. Апаратно ускорение за декодиране H.264 под Windows Vista / 7 е достъпно само в този режим.

    С бутон [image] «Свойства на устройство за визуализация» се отваря прозорец за настройки на съответния режим.

    ?

  • Група настройки за «Извеждане на DVB аудио» - Извеждане на звук при гледане след декодиране на аудио поток.

    Ако в системата има няколко DirectSound от списъка трябва да се избере конкретно такова устройство.

    Под Windows Vista / 7 също така може отделно да се избере SPDIF устройство ако е необходимо да се изведе звук към външен ресивър (?приемник).

  • Група за настройки «Параметри на DVB демултиплексор»:

    Цифровият транспортен поток, получен от цифровия тунер, преди декодиране постъпва в демултиплексор, който разделя потока на елементарни видео/аудио (и други) потоци и изпълнява PID филтрация на транспортните пакети.

    (изм., v.5.09) Закъснение и буферизация на А/V потоци (ms) (v.5.05 - Закъснение на медиасемпли в режим ТВ/Радио) – позволява да се управлява латентност на изходните потоци. Колкото по-малка е латентността, толкова по-бързо потокът се визуализира (v.5.05 - постъпва за декодиране) и толкова по-бързо се изпълнява превключване на канали.

    (доп., v.5.09) При твърде малко закъснение (рус.”задержка”) е възможно появяване на разриви в звука. При твърде голямо закъснение е възможно препълване на буфера на демултиплексора, както и бавно превключване на канали.

    Препоръчителна величина на закъснение е 200~300 мс.

    (доп., v.5.09, изм., v,5,11) Използване на референтен часовник PCR от TS поток

    (v.~5.09 - Използване на часовник в реално време от TS поток) –

    Коригиране на системния часовник за реално време въз основа на часовник-препратка (рус. „ссылочные часы”) PCR (Program Clock Reference), предавани в съдържанието на транспортния поток. Тази функция позволява да се избегне препълване на буфера на демултиплексора при твърде продължително гледане на един канал без превключване (над денонощие).

    Препълване на буфера се предизвиква от бавно нарастващ дрифт (разсъгласуване) на часовника за реално време на предаващата страна и часовника за реално време, намиращ се на самата звукова карта на приемащата страна. Тъй като опорните честоти, формиращи часовниците за реално време на предаващата и приемащата страна са различни (с различни кварцови осцилатори и наличие на грешки в тях), при продължително време на гледане се натрупва времева грешка, която може да доведе до препълване на буфера, което от своя страна ще предизвиква постоянни сривове в данните.

    При активна корекция часовниците за реално време се формират въз основа на мултимедийните системни часовници, които постоянно се коригират по PCR часовниците за реално време на предаващата страна.

    Отхвърляне на медиасемпли с грешки в TS пакети -

    При лошо качество на прием цифровият демодулатор не може да възстанови всички грешни битове за получаване на оригинален цифров транспортен поток и някои пакети ще съдържат грешки. Такива пакети демодулаторът отбелязва със специален флаг. При демултиплексиране на транспортния поток пакети с грешки могат да се отхвърлят, при което се губи целият изходен медиасемпъл. Това позволява да се избегнат артефакти във видеоизображението и звукови артефакти като „пищене” и „пукане”. От друга страна, това води до пропадане на видеокадри, а също така при наличие на голямо количество грешки – до пропадане на фрагменти от звука.

    При необходимост отхвърляне на грешни пакети може да се изключи, но това трябва да се прави внимателно, тъй като медиасемплите ще съдържат изкривени данни и това може да доведе до зависване или недопустима операция при някои MPEG декодери.

    Вмъкване на черен екран при превключване на канали - При активиране на тази опция се добавя черен кадър в момента на превключване на канали за избягване на „застинал” кадър от останало от предходен канал видеоизображение.

    ! Може да предизвика проблеми при някои видеокарти в режим на активно DXVA декодиране.

    (изм., v.5.11) Показване на видеозаставка за закрити канали

    (v.~5.09 - Показване на видеозаставка за канали без сигнал) -

    При превключване на закрити (кодирани) канали вместо черен екран да се показва видеозаставка.

    Показване на видеозаставка при отсъствие на сигнал - При отсъствие на сигнал (липсва цифров поток) да се показва видеозаставка.

  • (доп., v.5.09) Поле «Статистика на DVB демултиплексор»:

    Информационен блок, предоставящ възможност да се оценят и анализират текущите елементарни аудио- и видео потоци, постъпващи от DVB-демултиплексора. За елементарния поток се изобразяват няколко информационни полета:

  • Формат на потока и профил, извлечени от заглавията на потока.

  • Основни характеристики на потока, извлечени от заглавията на потока.

  • Реален моментен битрейт (разчетни откъси от 2 секунди).

  • Запълване на буфера на демултиплексора (buffer fullness) – позволява да се види дълбочината на задръжка на потока спрямо реалното време и да се намерят проблеми при препълване на буфера.

  • Количество грешки в транспортните пакети, носещи даден елементарен поток.


Topic: 8. Интерфейс

8. Интерфейс

8. Секция за настройки на интерфейс:

  • Опция «Избор на език» за интерфейса. Ресурсни файлове за поддръжка на езици се намират в папка [image] \LangRes ( [image] подробна информация за инсталиране на български език вж. тук ).

  • Група «Опции за интерфейса»:

    Изключване на Screen saver при активeн видеопрозорец – Изключване на Screen saver и енергоспестяващ режим (power safe) на монитора в режими TV, CVBS (Composite), S-Video при активен видеопрозорец.

    Показване на рамка около видеопрозореца – Показване на видеопрозорец с рамка.

    Блокиране извеждане на видеопрозорец извън екрана - Ограничава позицията на видеопрозореца в границите на видимата област на екрана.

    Прилепване на прозорци към границите на desktop-a – Включва ефект на „прилепване” на видеопрозореца и главния панел към границите на desktop-а.

    Показване бутон на приложението в панела за задачи – Показване на бутона на приложението в панела за задачи. Опцията разрешава и превключване с Alt+Tab.

    Бутон [x] на главния панел за свиване в tray - При натискане на бутон "[x]" (затваряне) на главния панел се изпълнява команда „свиване в tray” (режим на очакване).

  • Група «Опции за автозареждане/изключване»:

    Зареждане на Behold TV в tray при старт на Windows - Автоматично зареждане на Behold TV при старт на Windows и свиване в tray (режим на очакване).

    Зареждане на Аgent при старт на Windows - Автоматично зареждане на Агент Behold TV при стартиране на Windows. Вж . описание на Agent-а.

    Изключване на компютъра при изход от програмата - Автоматично изключване на компютъра при изход от програмата. Ако опцията е включена, 15 секунди предварително преди изход от програмата таймерът издава съобщение с предупреждение за предстоящо изключване на компютъра. На този етап може да се откаже изключване или да се премахне опцията за изключване при изход.

  • Група «Опции за запис»:

    Блокиране на поток за гледане при старт на запис от tray - При включване на опцията, ако програмата се намира в режим на очакване (свита в tray), при команда за предварително зададен запис от вградения модул за планирани задачи, потокът при гледане ще бъде принудително изключен за намаляване натоварването на системата ( [image] вж. също така опция [image] « Да не се извежда записвано видео при гледане »).

    Предполага се, че в случая програмата работи в отсъствие на потребителя. Ако не трябва да се прекъсва гледане на ТВ програма тази опция трябва да се изключи.

    Блокиране смяна на ТV и FM канали в режим на запис – Опцията забранява превключване на канали ако е активен процес на видео- или аудио запис*

    (освен за режим на * излъчване в IP-мрежа ).

  • Група «Опции за телетекст»:

    Декодиране на телетекст във фонов режим – при потвърждение с отметка процесите на приемане и декодиране на телетекст ще работят във фонов режим (т.е. непрекъснато). Ако след превключване на канал към момента на извикване на функция Телетекст нужната страница е била приета и декодирана, същата веднага ще бъде изобразена на екрана. При превключване на друг канал базата данни със страници телетекст се занулява. Ако е изключен фонов режим, процесът на декодиране на телетекст се активира само по време на работа на функция Телетекст. При това за визуализиране на избрана страница може да е необходимо известно време на изчакване докато страницата не бъде предадена от канала, приета и обработена от декодера. Също така, при включване на опцията в аналогов ТВ режим пин VBI на драйвера ще бъде винаги зает. Това означава, че никаква външна програма за работа с телетекст няма да може да работи с тунера докато работи Behold TV.

    Извеждане на телетекст - избор на механизъм за показване на телетекст страници:

    Върху видео – наслагване на страниците върху видеото. В този режим е достъпно управление от пулта ДУ.

    Във външен прозорец - отваря отделен прозорец-browser [image] за преглед на страници.

    Във външен прозорец (пълен екран - върху видео) - комбиниран режим, позволяващ визуализиране на телетекст във външен прозорец, а при превключване на видеопрозореца на пълен екран телетекстът се визуализира върху видеото.

  • Група настройки за «Сърфинг на канали»:

    Режим на сърфинг (брой клетки) - Количество на клетки в мозайката при сърфинг на канали.

    Интервал на сърфинг (s) - Време в секунди, което да бъде отделено за показване на всяка клетка.

    Закъснение за избрана клетка (s) - Време в секунди, отделено за повторно показване на изображение в клетка, в която е кликнато с мишката.

    Стойност „0” е ръчен режим - сърфинг няма да продължава, докато не се кликне повторно по съответната клетка.

    Изключване на звук при сърфинг ?

    Започване на сърфинг от първия канал - При старт на сърфинг да се започва от първия канал в списъка.

    Показване на всеки канал в своя клетка - При сърфинг всеки канал ще се изобразява точно в своята клетка. В този режим е желателно да бъде осигурено количество клетки не по-малко от броя на каналите.

    Превключване в пълноекранен режим ?

  • Група «Допълнителни опции»:

    Запазване на настройки отделно за всеки профил - По подразбиране програмата запазва всички свои настройки в .ini и .cfg файлове в текущата системна папка на приложението. При използване на няколко потребителски профила в една система (само под Windows 2000/XP/2003/Vista/7), може да се използва запазване на индивидуални настройки на програмата за всеки отделен потребителски профил.

    Файловете за настройки ще се съхраняват в папки "C:\Documents and Settings\[Потребителско име]\Application Data\BeholdTV\".

    Тази функция също така позволява работа на потребители без административни права съвместно с потребители, които имат такива права. При файлова система NTFS на потребители без административни права по подразбиране е забранен запис на файлове, създадени от потребители с административни права.

    Внимание! Windows Vista / 7 по подразбиране използват User Account Control (UAC), който понижава привилегиите на потребителите и дори за такива с административни права блокира достъп за запис в болшинството системни папки, в т.ч. и в папка Program Files. Поради това за нормална работа под Windows Vista / 7 тази опция трябва да бъде изключена - в противен случай приложението няма да може да съхранява своите настройки.

    Файловете за настройки под Windows Vista ще се съхраняват в папки

    "C:\Users\[Потребителско име]\Application Data\Roaming\BeholdTV\".

    Приоритет на програмата при гледане - Приоритет на основния процес при гледане (не влияе на приоритет при запис).


Topic: 9. Таймшифт

9. Таймшифт

9. Секция за настройки на функция Таймшифт:

вж. също така описание на функция TimeShift ; Въпроси и отговори (FAQ) .

За ТВ тунери без апаратен MPEG енкодер

За ТВ тунери с вграден апаратен MPEG енкодер (screenshot - under construction)

Таймшифт е функция, която по аналогия с пауза при гледане/слушане на обикновен видео/аудио запис позволява временно спиране на възпроизвежданите телевизионни или радио програми, излъчвани в реално време. При използване на Таймшифт за отложено гледане/слушане за известно време не е необходимо да се прибягва до запис, както обикновено се прави за такива цели.

  • Поле «Статус за готовност на «Таймшифт» (Аналогов тунер)»:

    Полето носи i информационно съдържание - извеждат се резултати от диагностика за наличие и статус на необходими компоненти (минималните изисквания са различни при тунери с/без вграден хардуерен енкодер - вж. по-долу) за работа на функцията. Коректно инсталирани компоненти се отбелязват с отметка [image] и имат активни опции [image] за:

  • избор на енкодер,

  • избор на Видео/Аудио декодер

    от съответните списъци с инсталирани и достъпни такива, както и

  • отделни прозорци за информация/настройки (свойства/"properties"):

    За работа на функция «Таймшифт» в аналогов режим е необходимо в системата да има инсталирани два компонента*:

    - MPEG2 енкодер и

    - MPEG2 декодер.

    Таймшифт няма да работи, ако някой от компонентите не е инсталиран или е с остаряла версия!

    И двата компонента - InterVideo MPEG2 Encoder и Decoder се регистрират в системата при инсталиране на приложението InterVideo WinDVD Creator от приложения диск в комплекта.

    (доп., v.5.09) Под операционна система MS Windows 7 се препоръчва да се използва интегрирания програмен MPEG2 енкодер от Microsoft.

    *За тунери с вграден апаратен (хардуерен) MPEG енкодер е необходим само един компонент - MPEG2 декодер.

    Behold TV може да използва различни инсталирани в системата MPEG2 декодери. В ОС Windows Vista / 7 са интегрирани нови висококачествени MPEG2 декодери от Microsoft, които могат да се използват при избиране от списъка вместо InterVideo декодери.

    За тунери с вграден апаратен MPEG енкодер под Windows Vista е достатъчно да се използват декодери Microsoft, при което отпада необходимостта от инсталиране на InterVideo WinDVD Creator като приложение (ако не се ползва като самостоятелна програма за видеообработка [image] вж. например материала за борба с реклами ).

    Ако MPEG2 аудио/видео декодер има стандартен DirectShow диалогов прозорец за конфигурация, той може да бъде извикан с натискане на бутон „свойства” ( [image] "Рroperties") срещу декодера и да бъде настроен по своя преценка. Трябва да се знае, че всеки декодер има свой собствен диалог за настройки.

    (доп., v.5.09) За тунери с вграден апаратен MPEG енкодер също така са достъпни за избор програмни MPEG2 енкодери.

  • Група за настройки на «Общи параметри»:

    Папка за запазване на временен файл - Избор на папка, в която да се записва временeн файл при работа на функция «Таймшифт». За работа на «Таймшифт» на диска трябва да има достатъчно свободно място, желателно не по-малко от 4 GB.

    Оставяне на временен файл таймшифт – След завършване на работа на «Таймшифт» временният файл да се съхранява на диска за последващо отваряне при необходимост.

    Отделни процеси за запис и възпроизвеждане - Параметър, който позволява в система, която изпълнява много задачи да се зададат запис и възпроизвеждане на файл в режим «Таймшифт» като два независими процеса. При това за сметка на по-гъвкавото разпределение на ресурси на процесора(ите) се постига по-голяма плавност при гледане по време на «Таймшифт».

    Забележка: Този параметър не е активен за тунери с вграден апаратен MPEG енкодер, както и в режим DVB на тунера.

    Автоматично стартиране на възпроизвеждане - След натискане на бутон [image] «Таймшифт» възпроизвеждане ще започва автоматично.

  • Група за настройки на «Параметри за видео запис» -

    – Настройки на видео (изм., v.5.09) енкодера при кодиране и запис на видеопоток на диск. Предвидени са готови балансирани пресети, но по желание може да се настрои и собствена схема (вж. по-долу [image] Настройки по избор).

    Пресет за видеозапис

    Минимален CPU Intel

    Минимален CPU AMD

    (v.5.05) Лошо качество

    PIII 550-600

    Duron 600-700

    Ниско качество

    PIII 600

    Duron 750

    Средно качество

    PIII 1000

    Duron 1200

    (v.5.05) Добро качество

    PIII 1000, P4 1600

    Duron 1600, Athlon XP 1700+

    Високо качество

    P4 2400

    Athlon XP 2500+

    Забележка: Тунери с вграден апаратен MPEG енкодер имат свои собствени настройки, различни от програмния енкодер.

    Зададените параметрите за отделните пресети (Размер на кадър, Битрейт (kBit/s), Търсене-движение) се визуализират в дясната част на групата. При избран готов пресет зададените величини са информативни (полето не е активно). Изменения са възможни при избор на следващата опция -

    Настройки по избор:

    Размер на кадър - Избор на размер за кадър преди кодиране и запис на диск.

    Колкото размерът на кадър е по-голям, толкова по-мощен CPU е необходим за кодиране.

    (изм., v.5.09) Видео Битрейт (kBit/s) – Скорост на запис на кодиран видеопоток.

    Колкото по-висок е битрейтът, толкова по-високо е качеството на изображение, но при съответно по-голям размер на записвания файл.

    Търсене-движение (изм., v.5.05 - Вектори за движение) – Колкото величината за търсене на движение е по-висока (v.5.05 - колкото повече са векторите за движение), толкова по-малко блокови артефакти ще има при бързо движещи се сцени, но съответно нараства натоварването на CPU.

    Изключване на видеообработка при гледане – Да не се използва видеообработка с плъгини по време на работа на функция «Таймшифт».

    За тунери с вграден апаратен MPEG енкодер е препоръчително да се изключва видеообработка за да се задейства DXVA - апаратно ускорение на процедура iDCT (обратно дискретно-косинусно преобразуване), което ще бъде изпълнявано от страна на видеокартата, респ. се намалява натоварването на CPU при декодиране на MPEG2 видео и се активира режим на последователност на полета и адаптивен деинтерлейсинг, което осигурява по-комфортно гледане на интерлейсно видео със съвременните видеокарти.

  • Група за настройки на «Параметри за аудио запис» -

    - Настройки на аудио (изм., v.5.09) енкодер при запис на поток на диск. И тук са предвидени са готови балансирани пресети, но по желание също може да се настрои собствена схема. Кодирането на аудио поток не изисква големи изчислителни ресурси.

    (v.5.05 - Забележка: Тези параметри не са актуални за тунери с апаратен MPEG енкодер)

    Честота на подбор (Hz) - Колкото по-висока е честота на подбор, толкова повече високи честоти ще има в кодирания файл.

    ( [image] В зависимост от възможностите на чипсета!)

    Кодиране на канали (v.5.05 - „Режим на кодиране”):

    Dual Channel - режим, при който левият и десен канал се кодират отделно, като два различни записа. На всеки от каналите се отделя точно половината от размера на резултативния файл. Използва се много рядко - например, когато в единия канал върви дикторски текст, а в другия - музика.

    За този режим е необходим битрейт не по-нисък от 320 Кbit/s.

    Stereo - в този режим каналите също се кодират отделно, но в процеса на работа кодерът може да варира (променя) с разпределението на потока и в зависимост от ситуацията да увеличава или намалява пропускателната способност на един от каналите за сметка на другия. Това предотвратява например кодиране на „тишина” в отделен канал, докато в същото време в съседния има сигнал.

    Joint Stereo - в този режим левият и десен канал се кодират заедно, а в резултативния файл се записва информация за разликите в двата канала (напр. ляв канал и разлики на десния канал от левия). Joint Stereo позволява по-качествено кодиране на поток с нисък битрейт (ще има повече високи честоти), но се влошава предаването на стереоефекти.

    Mono - в този режим се кодира само средна стойност на двата канала.

    Битрейт (kBit/s) – Скорост на запис на кодирания аудио поток.

    Колкото по-висок е битрейтът, толкова по-високо е качеството на звук.

    За режим на кодиране „Mono” максималният битрейт (изм., v.5.09) е ограничен до 192 КBit/s.

    Запис на звук от A/V декодер по шина PCI доп., v.5.09 (USB)

    (v.5.05 - ...от чипсет SAA7134/35 през PCI):

    Тази опция разрешава цифровизация и запис на звук от чипсета вместо използване на звуковата карта. Опцията може да се използва, ако аудиокартата не може да извършва едновременно запис и възпроизвеждане на звук (не поддържа Full Duplex) или драйверите на аудиокартата не позволяват коректно да се изключи линията за възпроизвеждане по време на запис.

    Забележка: Този параметър не е актуален за тунери с вграден апаратен MPEG енкодер

    (изм., v.5.09) както и за PCMCIA и USB модели тунери Behold TV.

В долната част на панелите се изобразява справочна информация за предполагаемата (по разчет) продължителност на режим «Таймшифт» в зависимост от свободното място на диска и използван битрейт.

! Трябва да се помни, че във файлова система FAT32 размерът на файл не може да превишава 4 GB, поради което продължителност се пресмята на база максимална големина 4 GB!

За по-продължителна работа (по-големи файлове) е необходима файлова система NTFS (само под Windows 2000/XP/2003).

Внимание! При работа на функция «Таймшифт» приложението изключва основния канал на работа с аудиокартата и извежда звук от записвания файл. Ако при работа на «Таймшифт» се прослушват два аудио канала, изместени един спрямо друг във времето, това означава, че в настройките на секция «Аудио» е избран неправилно «Миксер за възпроизвеждане» или «Линия за управление на звук», с които работи приложението.


Topic: 10. Пулт за ДУ

10. Пулт за ДУ

10. Секция за настройки на пулта за дистанционно управление (ПДУ):

вж. също така Функции: Управлевие на захранването (ARPC) ; Въпроси и отговори: ДУ .

Диалоговите прозорци в секцията са предназначени за настройки на команди, изпълнявани при натискане на определен бутон на пулта за ДУ, както и за конфигуриране на параметри на пултове за ДУ.

  • Група «Списък на включени пултове за ДУ»

    Моделите тунери, които поддържат технология ARPC , ARC позволяват:

    § да се добавят в списъка всякакви странични ПДУ по стандарти NEC, JVC, Panasonic, Samsung, Sony SIRC-12/15/20,

    § да бъдат обучавани на нови команди,

    § да се редактират наименования на бутони,

    § да се променя тяхната последователност в списъка,

    § да им бъдат присвоявани съответни действия.

    Първи в списъка е оригиналният пулт ДУ на тунера – за него не се допускат никакви изменения освен задаване на действия за бутони.

    Обучение на нов ПДУ се извършва по следния начин:

  1. Натиска се бутон [image] «Включване на нов ПДУ» и се въвежда желано име за новия пулт. Името не трябва да съвпада с вече налично такова в списъка.

  2. Натиска се бутон [image] «Обучаване/Редактиране». В този режим приложението очаква натискане на бутони от обучавания ПДУ.

    Обучаване/Редактиране се извършва отделно за различните възможни режими на работа.

    При приемане на клавишен код от ПДУ в списъка се добавя нов ред. По желание може да се измени наименованието на бутона с двоен клик на мишката върху клетката с името на бутона. На този етап също така може да се присвои действие на текущо обучаван бутон или това да се остави за по-късно. По аналогичен начин се повтаря обучението на всички необходими бутони на новия ПДУ. При необходимост може да се премахне вече обучен бутон, като се маркира (освети) съответния ред и се натисне клавиш Delete.

  3. Отпуска се бутон [image] «Обучаване/Редактиране». Приложението преминава в нормален режим. Бутоните в таблицата могат да бъдат сортирани чрез влачене с мишката до нужна позиция на избран ред от първата колона.

  4. Присвояват се действия за изпълнение на всеки бутон (ако това вече не е направено).

  5. Активира се ПДУ с отметка [image] «Активен».

  6. Съхранява се конфигурацията [image].

    По желание може да се включи собствено изображение за новия ПДУ. За целта е необходимо да се нарисува или снима ПДУ и с графичен редактор да се намали изображението. Максимално допустими размери на картинка са ширина 160 х височина 206 пиксела. Границите около пулта се запълват с достъпен ключов цвят и файлът се съхранява във формат «.Вmp». След това е необходимо да се кликне с десен бутон на мишката върху областта за рисунка в ПДУ и в контекстното меню да се избере команда [image]. При избиране на нужния файл, същият ще бъде копиран в съответната системна папка на приложението и автоматично ще бъде включен към текущата конфигурация на ПДУ.

  • Група «Команди на текущия пулт ДУ»

    Приложението реагира на команди само от тези ПДУ, които са маркирани като «Активен».

    За режими «Действия в режим на активно меню», «Таймшифт», «Сърфинг на канали», и «Телетекст» са предвидени отделни настройки за действия.

    При натискане на бутон от пулта за ДУ маркерът автоматично ще се премести към съответния бутон в таблицата.

    В реда срещу съответния бутон може да се избере съответно желано действие

    Възможните действия се визуализират в падащ списък:

    Действия:

    § «Изход от програмата»

    § «Свиване/ разгъване в/от системния tray»

    очакват кратковременно натискане на бутон от пулта за ДУ.

    Действия:

    § «Изключване на компютъра»

    § «Режим «Заспиване»»

    очакват двойно потвърждение с натискане на бутон от пулта за ДУ.

  • Група «Общи настройки» е актуална за всички включени ПДУ:

    Използване на пулт ДУ - Позволява разрешаване или забраняване поддръжка на всички пултове ДУ в приложението.

    Закъснение преди повторение - Време в ms, в течение на което произтича закъснение преди автоповторение при натискане на който и да е бутон от ДУ.

    Интервал на автоповторение - Време в ms, в интервал на което при натиснат бутон на пулта ДУ се изпълнява автоповторение на команда.

    Бутон [image] отваря диалогов прозорец за управление на захранването на компютъра от пулта ДУ (само за тунери с поддръжка на технология ARPC ).

При натискане на бутон [image] се възстановяват зададени по подразбиране настройки на команди за пулта ДУ (само за оригиналния пулт ДУ от комплекта).

The contents of 10. Пулт за ДУ

10.1. Управление на захранване


Topic: 10.1. Управление на захранване

10.1. Управление на захранване

10.1. Диалогов прозорец за конфигуриране на захранване в компютъра:

Този диалогов прозорец е предназначен за програмиране на микроконтролера ARPC за възможност за включване/изключване на компютъра.

  • Група «Режим за включване на захранване» - Определя режим за включване на захранването на компютъра по вътрешен таймер, както и от пулта за ДУ:

    Използване на линия PME по шина PCI – Компютърът се включва по начина за подаване на сигнал по шина PCI. Тази функция работи при поддръжка на PME от страна на дънната платка. В болшинството съвременни дънни платки функция PME се поддържа.

    Емулиране на бутон АТХ за включване на захранване - Компютърът се включва чрез емулиране на натискане на бутон АТХ ( [image] Power; On/Off).

  • Група «Режим за изключване на захранване» - Определя възможност за изключване на захранването на компютъра от пулта ДУ:

    Разрешаване изключване на захранване-емулация на бутон АТХ – Компютърът може да се изключва по команда от пулта ДУ чрез емулация на бутон ATX при задържане на зададен бутон от ПДУ в течение на 2.5 секунди.

  • Група «Зададени бутони от ПДУ за включване/изключване на захранване» -

    Програмиране на до 4 бутона от различни ПДУ, при натискане на които се включва или изключва компютър.

    Бутоните, които са определени за включване/ изключване на компютъра се изобразяват в таблицата за команди на ПДУ с червен шрифт.

    За задаване (програмиране) на бутон трябва да се натисне бутон [image] в избрана клетка и да се прехвърли кодът на бутона чрез натискане на избрания такъв от съответния пулт за ДУ.

    Ако трябва да се премахне (изтрие) бутон от някоя клетка е достатъчно да се „отпусне” съответния бутон в клетката, в която е зададен.

Всякакви направени изменения се съхраняват само след натискане на бутон [image].

Важно: Настройките от този диалогов прозорец се съхраняват в самия тунер и не се губят дори след пълно изключване на компютъра от захранващата мрежа (спиране на ток и пр.).


Topic: 11. Управление

11. Управление

11. Секция за настройки на управление:

The contents of 11. Управление

11.1. Клавиатура
11.2. Мишка


Topic: 11.1. Клавиатура

11.1. Клавиатура

Настройки на клавиши за управление

  • (изм. и доп., v.5.09) Панел «Настройки на клавиши за управление» е предназначен за настройки на команди, които да се изпълняват при натискане на клавишни съчетания. Предвидени са две групи клавиши за управление:

    § Обикновени клавиши за управление;

    § Глобални системни „горещи” клавиши.

    Обикновените клавиши за управление работят, когато прозорецът на приложението се намира във фокуса на въвеждане. Това е основен начин за управление.

    Глобалните системни „горещи” клавиши се явяват спомагателен начин за управление на Behold TV. Глобални „горещи” клавиши могат да изпълняват команда от програмата, дори ако тя не е активна (намира се извън фокуса на въвеждане, напълно или частично закрита от прозорци на други приложения).

    Към регистрация на глобални „горещи” клавиши е необходимо да се подхожда с много внимание - докато работи Behold TV избрана комбинация престава да бъде достъпна от други приложения в системата. Изключение прави режим на очакване в tray - в този случай приложението сваля регистрацията на клавиши с изключение единствено на команда за управление «Свиване в /Възстановяване от/ tray (режим на очакване)» (? Раздел * Друго управление *). Поради блокировката на системата за „горещи” клавиши за всички останали приложения, в този диалогов прозорец не е разрешено да се въвеждат „горещи” клавиши без модификатори Ctrl или Alt или Shift.

    В случай, че дадена комбинация от „горещи” клавиши вече е заета от някакво друго приложение в системата, същата ще бъде изобразена в таблицата с червен шрифт. Това означава, че дадената комбинация не е могла да премине регистрация, респ. командата няма да бъде изпълнена.

    За да бъдат въведени изменения в дадена клетка е необходимо да се кликне двукратно върху клетката или в контекстното меню на същата да се изпълни команда «Разрешаване на изменения» («Разрешаване на промяна»). След това трябва да се набере желано съчетание. Прието от програмата клавишно съчетание ще се изобрази в клетката. за да бъдат записани всички настройки във файл

    След евентуални изменения трябва да се натисне бутон [image].

    Ако това не бъде направено, програмата извежда напомнително съобщение:

    (доп., v.5.09) С натискане на бутон «По подразбиране» се възстановяват всички първоначално зададени клавишни настройки ( [image] след повторно потвърждение в предупредителния прозорец):


Topic: 11.2. Мишка

11.2. Мишка

Конфигурация на действия с мишка

  • Панел «Конфигурация на мишката» е предназначено за настройки на команди, които се изпълняват с мишка.

    С бутон [image] във всяко меню ще бъдат възстановени всички зададени по подразбиране настройки.


Topic: 12. LCD и OSD

12. LCD и OSD

12. Секция за настройки на LCD и OSD:

  • Група «Настройки на OSD»:

    Включване на OSD – Разрешава извеждане на OSD с опции за избор на позиция за

    Тип фон за OSD - Режим на визуализиране на фон под текста на OSD:

    Ако е избран прозрачен или полупрозрачен режим на фон, за коректно изобразяване на фона е необходимо да е активен режим на извеждане на видео в овърлей. Ако това не е направено, фон ще бъде включен принудително.

    Закъснение на OSD-текст (s) – Време за изобразяване на обикновен OSD текст в секунди.

    Закъснение на OSD-меню (s) - Време за изобразяване на разширен OSD (меню „видеомиксер”, меню „списък на ТВ канали”, меню „списък на ТВ програми") в секунди.

    Изключване изглаждане на шрифт - Изключва изглаждане на TrueType шрифтове при изобразяване на OSD.

    Функцията работи само при включен режим за изглаждане на шрифтове в Windows.

    Изключване на статистика при запис - в пълноекранен режим да не се извежда информация за процеса на запис в OSD.

  • Група настройки «OSD за ТВ програма» за отделно конфигуриране на извеждане на OSD при показване на блокова информация за ТВ програми:

    Закъснение на ТВ програма (s) - Време за изобразяване на блок с ТВ програми в OSD.

    Максимум редове с текст - Лимит за брой на извеждани редове с текстово описание на ТВ предаване.

    Извеждане на информация за канал - Извеждане на наименование на ТВ канал и процент на изминало време от текущо предаване в първия ред.

  • Група «Настройки на LCD» за конфигуриране на LCD-дисплея.

    Интервал за скролинг (ms) – Периодичност за скролиране на ред с текст в LCD дисплея.

    (доп. р.) - Избор на цветове за основни и допълнителни светещи точки, светещи точки при запис и фонови точки.

    Файл на шрифт за поддръжка на език - За правилно изобразяване на шрифт в LCD-дисплея е необходима поддръжка на езици, различни от английски.

    Забележка:

    За изменение на шрифт в OSD трябва да се кликне с мишката по съответния надпис "OSD".

    За изменение на цвят на избран параметър е необходимо да се кликне с мишката по съответния цветен квадрат (pattern).


Topic: 13. Информация за тунера

13. Информация за тунера

13. Основна информация за инсталирания модел тунер;

настройки BDA устройство / «Параметри на устройство»

  • BDA устройство – Позволява да се избере BDA устройство за видеозахват (използва се, ако в системата има няколко устройства за видеозапис, например видеокарти с VIVO или Web-камери). Трябва да се избира устройство Behold TV. При изменение на този параметър програмата трябва да бъде рестартирана.

  • Група «Параметри на устройството» - настройки, позволяващи да се настрои коректна работа на чипсета при предаване на потоци по шина PCI:

    PCI latency timer - Позволява при захват да се управлява латентност на арбитраж на слота PCI, в който е инсталирана платката на ТВ тунера.

    BIOS и драйверите на някои дънни платки некоректно задават стойности на PCI Latency timer, което води до появяване на артефакти във вид на вертикални цветни ленти и „шум” на екрана на монитора. Препоръчителни стойности са от 16 до 64 clock. Зададената стойност се съхранява в (изм., v.5.09. v.5.05 -WDM) BDA драйвера.

    PCI DMA burst length - Дължина на пакет DMA транзакции.

    Препоръчва се Unlimited burst length, но не всички дънни платки работят коректно с този параметър, което се проявява като изкривяване на данни при предаване на пакети чрез DMA (corrupted buffers).

    Особено важно е да няма corrupted buffers при предаване на цифров MPEG поток (работа на тунера в режим DVB, апаратно кодиране MPEG2).

    (ново, v.5.11) USB bandwidth utilization - Режим на използване на пропускателна способност на шина USB при работа на USB тунер.

    Reserve max bandwidth - Устройството предварително резервира 48% от пропускателната способност на USB2 хост контролера и постоянно поддържа тази величина.

    + Преимущества - по-бързо стартиране на Audio / Video / TS потоци.

    - Недостатъци - при включване на допълнителни високоскоростни устройства USB2 HiSpeed е възможен недостиг на пропускателна способност.

    Dynamic save bandwidth - Устройството заявява 48% от пропускателната способност на USB2 хост контролера само преди пускане на Audio / Video / TS потоци. При спиране на всички Audio / Video / TS потоци устройство заявява 1% от пропускателната способност на USB2 хост контролера.

    + Преимущества - икономично използване на пропускателната лента на USB.

    - Недостатъци - по-бавно стартиране на Audio / Video / TS потоци. Ако към текущия USB2 хост контролер вече е включено високоскоростно устройство, което резервира повече от 50% от лентата, стартиране на Audio / Video / TS поток не е възможно.


Topic: Информация за програмата

Информация за програмата

14. Прозорец с актуална информация:

  • Версия на Behold TV;

  • Версия на BDA драйвер;

  • Поддържани модели тунери:

  • Поддържани * операционни системи:


Topic: Панел за запис

Панел за запис

Behold TV - Панел за запис

Всички настройки за запис на образ и звук са поместени в отделен панел за запис:

Панелът се отваря от основния панел на Behold TV - бутон

The contents of Панел за запис

Основна секция
Видео/Аудио запис
Аудио запис
Екранни снимки


Topic: Основна секция

Основна секция

Основен интерфейс за настройки на запис

Тази секция е предназначена за управление на режимите за запис, както и за визуализиране на статистики в процеса на видео/аудио или само аудио запис.

  • Група «Индикатор за ниво на аудио запис»:

    (изм. и доп., v.5.09~5.11) Индикатор за ниво на аудио сигнал, който позволява визуално да се контролират процесите на звукозапис. Индикаторът показва пикова стойност на амплитудата на сигнал за текущото аудио устройство.

    За текущо се счита това устройство, което в дадения момент работи със звук, т.е.

    Ако при гледане се използва предаване на звук по аудио кабел чрез звукова карта

    (режим «Direct sound PCM аудио по шина РСІ(USB)» (v.~5.09 - «Предаване на Аудио поток по шина PCI(USB)») в настройки « Аудио »>«Извеждане на звук» на тунера е изключен),

    то до започване на запис за текущо устройство се счита звуковата карта.

    След стартиране на запис с активна опция (изм., v.5.09)«Запис на аудио поток по шина PCI(USB)» («Панел за запис»>«Аудио запис»>« Общи настройки ») текущото устройство ще се смени на (доп., v.5.11)«SAA7231», «SAA7135HL», «SAA7134HL» (доп., v.5.09) или «ТМ6010». При това нивото на запис най-вероятно ще бъде вече друго.

    По този начин, ако за запис и за гледане се използват различни устройства, то коректна настройка на ниво на запис ще бъде възможна само в процеса на запис.

    Индикатор On/Off - индикаторът за ниво на аудио запис може да се изключи за намаляване натоварването на процесора и за избягване на проблеми с някои аудио карти (отп., v.5.11. v.~5.09 ...които могат да работят некоректно в режим на двупоточност при индикация на нивото по време на запис).

    Отделни плъзгачи - дословно.

  • Група «~ Информационни полета и графика»:

    В долната лява лента за статус се визуализира текущото устройство за запис на звук;

    В долната дясна лента за статус - текущо пълно име и път на записван файл:

    Графиката показва натоварването на процесора в реално време:

Режим на излъчване (ретранслиране) в мрежа

The contents of Основна секция

Излъчване в мрежа


Topic: Излъчване в мрежа

Излъчване в мрежа

Режим на излъчване (ретранслиране) в мрежа

Опция «Излъчване в IP-мрежа» не е активна при настройка за метод на видео/аудиозапис Microsoft AVI.

В случай на запис на видео или аудио в режим на излъчване (ретранслиране) в IP-мрежа, в долната дясна лента за статус ще бъде изобразен URL адрес за включване на клиенти. Този адрес, както и други адреси за текущия хост може да бъде копиран в буфера за обмен (clipboard) от контекстното меню на мишката над лентата на статуса. При натискане на мини-бутона над брояча за включени клиенти [image] може да се види детайлна информация за всеки включен клиент.


Topic: Видео/Аудио запис

Видео/Аудио запис

Секция за настройки за ВИДЕО/АУДИО запис

вж. също Аудио запис .

  • Следващите подробни описания на основни групи/настройки/опции в този раздел имат принципно общи транскрипции при характерни индивидуални особености (в зависимост от тип/метод на запис) за още няколдо раздела.

    Описанията в такива раздели са в съкратен вид, но с препратки към разширените описания по-долу.

    Секции с принципно общи транскрипции са:

    - Настройки за АУДИО запис ;

    - Настройки за екранни снимки (Screenshots)

  • Група «Пресети за видео/аудио запис»:

    С помощта на пресети могат бързо да се зареждат нужни настройки за запис. Пресети могат да бъдат създавани и самостоятелно; да се премахват; да се презаписва съдържанието (настройките) им. Ако файл на пресет е с атрибут «Само за четене» (Read Only), бутонът за премахване на пресет ще е неактивен.

    За да се създаде нов пресет трябва да се направят необходимите настройки на текущото меню, текущите настройки да бъдат съхранени и да се избере име за новия пресет.

    Списък от готови пресети за запис с предварително настроени конфигурации.

    «Съхраняване на текущите настройки в пресет»;

    «Премахване на пресет».

  • «Метод за видеозапис» (BG редакция - аналог. "способ", "начин") - Формат за видеозапис.

    Поддържат се няколко метода -

    "Microsoft AVI",

    "Microsoft ASF",

    "Microsoft WMV",

    "Software MPEG",

    "Hardware MPEG2 DVD".

    За да може да се записва във формати "Microsoft ASF", "Microsoft WMV" е необходима OS Windows XP SP2 и по-висока или инсталиран ъпдейт Microsoft Windows Media Format Runtime - версия 9 или по-висока.

    За да може да се записва във формат "Software MPEG" е необходимо да се инсталира InterVideo WinDVD Creator от втория диск, приложен в комплекта на тунера.

    Видеозапис "Hardware MPEG2 DVD" е достъпен само за ТВ тунери с апаратен (хардуерен) енкодер.

Всеки метод за запис има собствени настройки :

The contents of Видео/Аудио запис

Методи за запис
ОБЩИ настройки за ВИДЕО+АУДИО запис
Видеообработка на кадър (режим запис)
Мащабиране на кадър


Topic: Методи за запис

Методи за запис

Настройки на методи за запис

Предпочитан метод за видеозапис се избира от падащо меню в прозорец с еднотипен интерфейс за всички методи:

«Microsoft AVI»

«Microsoft ASF»

«Microsoft WMV»

«Software MPEG»

«Hardware MPEG2 DVD»

Диалогов прозорец за настройки на различни методи / формати за запис:

Различните методи за запис са достъпни (респ. неактивни) за избор в зависимост от инсталираната ОС, кодеци и конкретния модел тунер (с/без хардуерен енкодер).

The contents of Методи за запис

Microsoft AVI
Software/* Hardware MPEG
Microsoft WMV
Microsoft ASF
Digital Video Broadcating (DVB)


Topic: Microsoft AVI

Microsoft AVI

Широко разпространен универсален формат за запис на видео/аудио. Има следните настройки:

Размер на кадър – Размер на видеокадър при запис.

Внимание! Размерите на кадър не могат да бъдат произволни!

При избор на разделителна способност трябва да се имат предвид следните ръководни правила:

  1. Височината на кадър трябва да е кратна на размера на видеополето.

    За PAL/SECAM едно поле заема 288 реда, за NTSC - 240. По такъв начин височината може да има само няколко стойности - 144, 288, 576 за PAL/SECAM и 120, 240, 480 за NTSC.

  2. Широчината на кадър трябва да е кратна минимум на 4, желателно на 8.

    Списък с най-разпространените размери на кадър се извежда с десен клик на мишката.

Кадри/sec - Честота на смяна на кадри в записваното видео:

(изм.-отп., v.5.09 ...В зависимост от текущия формат (NTSC или PAL/SECAM) честотите на кадрите в дадения списък ще бъдат коригирани автоматично (делителят остава неизменен). Важно е да се знае, че в дадената настройка е актуална не абсолютната честота на кадрите, а делителят от оригиналната честота на кадрите. Делителят за PAL/SECAM/NTSC стандарти ще бъде единен.)

Понижени честоти (1/2 и 1/5) могат да се ползват например за запис с охранителен плъгин за да се понижи битрейта и да се пести място на диска.

Формат:

Най-предпочитан формат за запис е YUY2, но

за максимално качество на изображение може да се ползва формат RGB24. Трябва да се има предвид обаче, че при това натоварването на процесора ще е по-високо и крайният файл ще бъде с по-голям размер (обем). Трябва също така да се отчита, че някои кодеци не поддържат формат RGB24.

Компресиране на видео поток - Позволява за компресиране на видео да се избере всеки регистриран в системата VCM или DirectShow видео кодек от "падащия" списък:

Такива кодеци се разработват и разпространяват от разлнични производители на програмни продукти и се инсталират в системата по индивидуално желание, самостоятелно от потребителите.

Преди да се използва избран кодек е необходимо запознаване с неговите настройки, параметри и свойства. Описание и технически характеристики на различните кодеци следва да се предоставят от съответните производители.

Behold TV работи с VCM кодеци в съответствие с правилата и спецификациите, отговарящи на стандарти Microsoft VfW и предявява към кодеците най-минимални изисквания:

За да бъде използван в Behold TV, даден кодек трябва да поддържа формат на данни YUY2 / RGB24 и да работи с всички възможни разделителни способности на кадър. В случай, че избран кодек не поддържа някои параметри, задавани от програмата или не съответства напълно на спецификация MS VfW, не се гарантира стабилна работа на Behold TV.

Трябва е да се помни, че VCM и DirectShow кодеци могат да имат набор за настройки на собствени параметри, достъпни от меню за свойства «Properties» на съответния видео кодек.

Връзка към диалогов прозорец за избор/ конфигурация на видео кодек се осъществява при натискане на бутон [image] «Свойства на кодек»:

Различните фирмени прозорци имат свой специфичен интерфейс, които се разработва от отделните производители.

Правилни индивидуални настройки на параметри за всеки отделен кодек определят неговата производителност и качество на кодиране, но също така могат да влияят в определена степен и на стабилната работа на системата като цяло.

Ред VCM кодеци имат възможност да съхраняват настройките на своите параметри в съответствие със спецификация MS VfW. Behold TV по възможност използва това свойство, което позволява да се съхраняват настройки на кодеци индивидуално за всеки пресет за запис.

Производителите на кодеци внасят промени в блока на съхраняеми данни в следващи версии по свое усмотрение, поради което трябва да се проверява дали новите версии са съвместими по тези параметри.

Препоръчителни кодеци:

  1. Ниска степен на компресия без загуби - Huffyuv, PICVideo Lossless JPEG.

  2. Средна степен на компресия - PICVideo MJPEG, Morgan MJPEG v3, MainConcept DV.

  3. Висока степен на компресия - XviD 1.x.x, DivX 5/6, WMV9 VCM, On2 TrueCast VP6/7.

Формат/компресиране на аудио поток - Избор на формат и тип на компресия за аудио поток .

Връзка към диалогов прозорец за избор/конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на аудио кодек и формат»;

От така отворен прозорец [image] е достъпен следващ диалог за избор/индивидуални фирмени настройки за всеки отделен кодек при натискане на аналогича икона - бутон [image] «Свойства на кодек»:

Различните фирмени прозорци имат свой специфичен интерфейс, които се разработва от отделните производители.

Препоръчителен формат - PCM. Компресиране на звук в различни от PCM формати може да доведе до разсинхронизация на аудио- и видео потоци

(отп., v.5.11. v.5.09 - При зададена отметка «Запис на звук от чипсет SAA7134/35 през PCI», списъкът с достъпни формати без ползване на конвертиране ще бъде ограничен до честоти 32/44.1/48 кHz за чипсет SAA7135 и 32 кHz за чипсет SAA7134)

Режим~последователност (редуване) – Избран режим на последователност посочва на модул AVI Mux DirectX по какъв начин да се разполагат аудио- и видео данните в записван файл.

По подразбиране е зададен «None»:

  • None – Аудио- и видео данните ще се записват във файл по реда на тяхното постъпване от аудио- и видео кодеците. Поради особеностите на работа и настройките на някои аудио- и видео кодеци данните могат да се забавят и да постъпват в AVI Mux неравномерно. В резултат на това структурата на видеофайла се получава доста хаотична и непредсказуема, което може да създаде усложнения при гледане и редактиране на такъв файл.

  • Full – AVI Mux ще следи строго аудио- и видео фрагментите да се редуват във файла равномерно в съответствие с техния размер и поредност. Това обаче се постига по метод на изчакване за постъпване на поредни порции данни, което може да предизвика препълване на изходния видео буфер на драйвера ( вж. по-долу «Видеообработка на кадър (режим запис)» [image] «Буферизация на видео при запис» [image] «Форсиране на видеобуферизация в паметта (кадри)») и да доведе до загуба на кадри при запис.

  • Buffered (XP>) – режим, който е еквивалентен на режим «None» с тази разлика, че данните при запис във файл предварително се буферизират в паметта. Това намалява натоварването на дисковата система за сметка на намаляване на количеството обръщания към буфера. Режимът е достъпен за XP и по-нови версии на операционната система.

Главен поток - Настройка на модул AVI Mux DirectX, който също така отговаря за синхронизацията на аудио- и видео данни при запис в AVI:

  • При цифровизиране на звук от аудиокартата за настройки на главния поток е желателно да се избира режим «Audio», т.к. поради незначителни отклонения на честотата на цифровизация от номиналните значения теоретично е възможна разсинхронизация на аудио- и видео потоци в записвания файл. В режим «Audio» AVI Mux ще форсира скоростта на възпроизвеждане на видео към скоростта на аудиото, в резултат на което е възможно незначително отклонение на средната стойност на честота на кадри в една или друга посока. Това може да доведе до проблеми при последващо редактиране и сглобяване на AVI файлове.

  • При цифровизиране на звук от чипсета на тунера, входните аудио- и видео потоци са абсолютно синхронни и в настройките на главния поток AVI Mux може да се зададе режим «None». Въпреки това, поради особеностите на работа на някои кодеци синхронът на потоците на входа на мултиплексора AVI Mux може да бъде нарушен. Това води до разсинхронизация на звук и видео в записвания файл. В такива случаи може да помогне задаване «Audio» на главния поток или избор на друг кодек.

Избор и конфигурация на ACM кодек :

The contents of Microsoft AVI

ACM кодек


Topic: ACM кодек

ACM кодек

Избор и конфигурация на ACM кодек:

Връзка към диалогов прозорец за избор/конфигурация на кодек се осъществява при натискане на бутон [image] «Избор на аудио кодек и формат»

  • Група «Кодек АСМ»

Избор на инсталиран в системата ACM кодек, конфигуриране и избор на достъпен формат.

Ако е включена опция «Запис на аудио поток по шина РСІ (USB)» (изм.,v.5.11. v.5.09 - от чипсет SAA7134/35), то в списъка част от форматите ще бъдат оцветени в друг цвят. Това означава, че при запис в такива формати ще се изпълнява програмно конвертиране на честотата на дискретизация от изходния PCM формат на чипсета в изисквания формат, при което ще се наблюдава слабо влошаване на качеството.

Препоръчва се да се използват само нативни формати, изобразявани с черен цвят.

(изм.-отп., v.5.09: Това са 32 КНz Стерео за чипсет SAA7134 и 32/44.1/48 КНz Моно/Стерео за чипсет SAA7135. Честота на дискретизация 44.1 КНz за чипсет SAA7135 не е достъпна нативна в режим ТВ)

От така отворен прозорец [image] е достъпен следващ диалог с индивидуални фирмени настройки за всеки отделен кодек при натискане на аналогича икона - бутон [image] «Свойства на кодек».

Различните фирмени прозорци имат свой специфичен интерфейс, които се разработва от отделните производители:

  • «Формат на АСМ кодек» - Избор на достъпен формат


Topic: Software/* Hardware MPEG

Software/* Hardware MPEG

(изм. и доп.,v.5.17)

  • *

  • Software MPEG (Microsoft Windows 7) **

  • Hardware MPEG *** -

    - Методи за запис на видео/аудио в широко разпространения стандарт MPEG1/2.

Стандарт MPEG2 се използва в DVD плейъри, спътникова DVB-S и наземна DVB-T/C цифрова телевизия.

*** Hardware MPEG е достъпен само за ТВ тунери с апаратен MPEG енкодер.

** Software MPEG (Microsoft Windows 7) е достъпен за операционна система Windows 7 (редакции по-високи от Home Basic).

* Software MPEG (InterVideo) е достъпен след инсталиране на приложение WinDVD Creator от допълнителния диск в комплекта.

ОБЩИ параметри:

Software MPEG InterVideo (shot v.5.11) | Software MPEG InterVideo (shot v.5.09)

Hardware NEC µPD61151 (shot v.5.11) | Hardware NXP SAA6752 (shot v.5.07)

(изм.,v.5.07) Профил на енкодер

(v. 5.05 - "Режим MPEG" / "Режим мултиплексор" – Режим на работа на MPEG кодера). -

- Избор на стандарт и контейнер за мултиплексиране на елементарни MPEG2 аудио/видео потоци:

  • Оптимален избор на профил в болшинството случаи е MPEG2 Program Stream (файл с разширение .mpg).

  • (изм. и доп., v.5.11) MPEG1 System е стар стандарт (формат) (ISO/IEC 11172), който използва за запис само едно видеополе.

    Максимална разделителна способност на кадър – 384x288.

  • MPEG1 System (VCD) е MPEG1 (изм. и доп., v.5.09) стандарт, който има допълнителна структура на индексиране (v. 5.05 ...и режим за мултиплексиране на аудио- и видеопоток) и нестандартен размер на PS-pack. Този формат се използва изключително за създаване на VCD дискове.

    (v. 5.05 ...Не поддържа запис без аудио поток.) Форматът има ограничения!

  • (изм. и доп., v.5.09) MPEG2 Program Stream е по-нов стандарт (ISO/IEC 13818), поддържа запис на двете видеополета, има по-висок битрейт има по-нови алгоритми на кодиране.

    (v. 5.05 Максимална разделителна способност на кадър - 720x576 (720x480)).

  • (изм. и доп., v.5.09) MPEG2 Program Stream (SVCD) – MPEG2 стандарт, който има допълнителна структура на индексиране и нестандартен размер на PS-pack. Предназначен е за запис на SuperVCD дискове (CD 650~800МВ) с добро качество.

    Разрешение на кадър - 480x576 (480x480)

    Максимален битрейт - 2600 kBit/s.

  • (изм. и доп., v.5.09) MPEG2 Program Stream (DVD) е MPEG2 стандарт за запис на DVD дискове

    (v. 5.05 ...със собствена структура на индексиране).

    Максимален битрейт – 9000 kBit/s.

  • (изм. и доп., v.5.09) MPEG2 Transport Stream е MPEG2 стандарт, мултиплексиран в TS-пакети по 188 байта.

    Файлове са е с разширение .ts.

    Препоръчва се за излъчване в мрежа.

Размери на кадър - Разрешение на видеокадър при запис.

(изм., v.5.09. v. 5.05 - За всеки формат MPEG има собствен набор от достъпни разделителни способности на кадъра.)

(доп., v.5.09) За максимално качество се препоръчва да се използва D1 кадър - 720x576 за PAL / SECAM (720x480 за NTSC). При задаване размер на кадър ***x288 (x240) (v. 5.05 - 352x288 (SIF)) ще се формира прогресивен MPEG2 видеопоток, състоящ се от едно видеополе.

Аспект на кадър - Съотношение на страните на кадър при отваряне на MPEG2 файлове. Това съотношение се чете от болшинството програмни MPEG2 плейъри (и от стационарни DVD плейъри) за задаване на необходимото съотношение на страните на кадър при извеждане на изображение.

(изм., v.5.09) Аудио формат – Избор на формат на аудио поток за кодиране. Достъпни формати:

  • LPCM bypass. (Linear Pulse Code Modulation). Некомпресиран поток с линейно квантоване. LPCM е понятен за болшинството стационарни DVD плейъри. Записва се във формат 48000 Hz 16 Bit Stereo с постоянен битрейт 1536 kBit/s.

    (доп., v.5.07) Само за модели с енкодер NXP SAA6752.

  • (изм., v.5.09~5.11) MPEG1 Layer-2. Компресиран поток по стандарт ISO/IEC13818-3 (Кодира се с честота на дискретизация 48000 Hz)

    MPEG1 Layer-2 получава широко разпространение и е основен формат за MPEG2 потоци (...но не се поддържа от някои стационарни DVD). Някои програми за DVD-авторинг изискват формат за формиране на DVD проект формат Dolby Digital AC3 (Dolby DigitalConsumer - DDC).

  • Dolby AC3. Стандарт „де факто” за DVD Video дискове. Форматът е разработен, патентован и е собственост на компания Dolby Laboratories Inc. По начало формат AC3 поддържа от един до шест независими звукови канала. Апаратният енкодер на ТВ тунера кодира 2-канален AC3 с честота на дискретизация 48000 Hz. Този формат е достъпен само за ТВ тунери Behold TV M6 Extra.

    Формат AC3 се препоръчва в случай, че се планира последващ запис на файлове на DVD диск. Ако се предвижда да се гледат MPEG2 записи с AC3 звук на компютър, при инсталиране на програмата трябва да се избере опция «AC3 филтър».

Честота на подбор (Hz) – Избор на (изм., v.5.09) честота на подбор на аудиосемпли при аналогово-цифрово преобразуване (АЦП).

Честота 48000 Hz позволява максимално точно цифровизиране без загуби на високи честоти на звук.

(изм., v.5.09. v.505 - При маркиран «Запис на звук от чипсет SAA7134/35 по PCI», списъкът на достъпни честоти е 32000, 44100, 48000 Hz за чипсет SAA7135 и 32000 Hz за чипсет SAA7134.)

– Отваряне на диалогов прозорец за по-пълно конфигуриране на енкодера:

Software InterVideo (shot v.5.11) | Software MS Windows 7 (shot v.5.11)

Hardware NXP SAA6752 (shot v.5.05)

Hardware NXP SAA6752 (shot v.5.11) | Hardware NEC µPD61151 (shot v.5.11)

ОСНОВНИ параметри:

  • Група (изм., v.5.10) «Video bitrate» (Битрейт видео) – Скорост на запис на поток видеоданни във файл.

    Колкото е по-висок битрейтът, толкова е по-добро качеството на изображение, но съответно и размерът на крайния файл е по-голям.

    Битрейтът може да бъде както постоянен (CBR), така и променлив (VBR):

    (v.~5.09 - Всеки формат MPEG има собствен диапазон от достъпни битрейтове. Среден битрейт е 3500-4500 kBit/s, висок битрейт е 6000-9000 kBit/s.)

    - Постоянен битрейт (ConstantBitRate) се използва в тези случаи, при които е необходимо да се получи ясно зададена, постоянна скорост на потока данни, например за използване в системи за предаване на данни. При сложни, наситени с малки детайли или динамични сцени, битрейтът се съхранява постоянен за сметка на влошаване качеството на изображението. За да се избегне това, при компресиране на видеоданни може да се използва

    - Променлив битрейт (VariableBitRate), който се увеличава динамично при сложни сцени но запазва постоянно качеството на изображението.

    Bitrate mode:

    § Constant (CBR) – скоростта на видеопотока е постоянна величина, която се задава с настройка Bitrate.

    § Variable (VBR average) – величината на битрейта може да се изменя в диапазон, зададен в Bitrate +/- 40% от Bitrate.

    § Variable (VBR peak) - в процеса на запис битрейтът ще се изменя от базовия Bitrate само в пределите на пикова стойност Bitrate peak.

    Ако се планира записван файл впоследствие да се използва за подготовка на DVD и гледане на стационарен плейър, не се препоръчва да се задава пиков битрейт (изм., v.5.11) над 9000, т.к. някои стационарни плейъри не се справят с декодиране на висок битрейт. Също така, в стандарт MPEG2 DVD е заложен максимален битрейт=9800 при максимален пиков MuxRate=10080.

    Препоръчителни стойности на битрейт: Bitrate (Kbit/s)=6500, Bitrate peak (kBit/s)=9000.

  • Група «Video GOP structure» (GOP / SubGOP) –

    Структурата на видеоданни в MPEG поток включва:

    § GOP - последователност от т.н. групови кадри (Group Of Pictures) - структури, които от своя страна се състоят от

    § SubGOP - последователност от кадри от различен тип (I, P, B).

    Всеки кадър в структура GOP се кодира (компресира) в съответствие с определени правила:

    §§ Първият кадър в GOP структура като правило е I-кадър (Intracoded), който се компресира без да се отчита съдържимото на съседните (предходен и последващ) кадри.

    §§ P-кадри (Predicted - кодиране с предсказване) се кодират с отчитане съдържимото на предходен I или P кадър.

    §§ B-кадри се кодират с отчитане на двупосочни (Bidirectional) предсказания въз основа на информацията в предходните и последващи I или P кадри.

    GOP (~lenght, ~size) - задава обща дължина на GOP-последователност.

    (v.5.хх ~ количество кадри между I-фреймове в MPEG-поток)

    SubGOP - определя периодичност за разположение на P и B кадри в GOP структурата. При SubGOP=1 цялата последователност от кадри (с изключение на първия I-кадър) ще се състои от P-кадри.

    (v.5.хх ~ количество на B-фреймове в подгрупа)

    (v.5.хх ~ Колкото са по-високи стойностите на GOP и SubGOP, толкова по-малък поток може да се зададе при същото качество, съответно качеството на картина ще бъде по-високо, но при това нараства натоварването на процесора. Най-качествени резултати се получават при GOP=15, SubGOP=3.)

    Closed GOP (Force close GOP)

    ...

    (доп.,v.5.07.~v.5.10) Scene change detection (SCD) - Изменение на GOP последователност при рязка смяна на сцени в изображението. „B” кадрите ще се заменят с „P”, за да бъдат намалени артефакти. Енкодер Microsoft Windows 7 винаги използва SCD и автоматично добавя „I” кадри при рязка смяна на сцени в изображение.

    Препоръчителната величина GOP (Recommended GOP) ще се променя в зависимост от зададения битрейт (Bitrate (kBit/s). При кодиране взаимовръзката може да се отчита както между кадри само от една GOP, така и между кадри от съседни групи. Във втория случай последователността GOP започва не от I-, а от B-кадър. Такава последователност осигурява по-високо качество на кодиране и се нарича отворена, т.к. данните от нея се използват за кодиране на B-кадър в началото на следващата група. Отворена последователност се счита за нередактируема (Non-editable GOP).

    Ако се зададе флаг Force close GOP, енкодерът ще поставя отметки «Closed» на отворените последователности, а B-кадрите ще се разчитат в обратен порядък (Backward predicted closed GOP). Последователности GOP, които са първоначално затворени, винаги започват от I-кадри (Real closed GOP) и флаг Force close GOP не оказва никакво влияние върху тях.

  • Група «Video sequence»:

    ( [image] англ. SEQUENCE ['si:kwəns] - 1. ред, редица, серия, поредица, цикъл, редуване; 2. последователност)

    (доп., v.5.10) Scan type – Определяне тип на входящ видеоред за кодиране.

    Препоръчва се тип Interlace за обезпечаване на разделно кодиране на полета.

    Енкодер InterVideo не поддържа интерлейсен източник, затова е необходимо използване на вътрешен или външен деинтерлейс;

    Енкодер Microsoft Windows 7 поддържа интерлейсен източник, а също така автоматично намира кадри тип Film (3:2 Pulldown за NTSC и 2:2 Pulldown за PAL/SECAM), затова тип Interlace е за предпочитане.

    Deinterlace

    (v.5.05: Деинтерлейс - При височина на кадър над 288 (240) кодек InterVideo изисква използване на MPEG деинтерлейс. В противен случай ще се вижда „гребеновиден” артефакт и качеството на компресия ще е по-ниско.

    Режими «Blend» дават по-изгладено изображение с незначително намаляване на контраста.

    Режим «Median» не намалява контраста, но дава "стъпаловиден" артефакт (тип „Стълбица”) по границите на наклонени линии.

    Възможно е да не се използват вградените режими на деинтерлейс на кодек InterVideo, а друг деинтерлейс при видеообработка на базата на включвани плъгини.)

  • «Video quantization»:

    (доп.,v.5.07) Intra DC precision - Точност на изчисление на DC коефициенти в целочислена аритметика.

    § При ниски битрейти под 4000 кBit/s се препоръчва да се използва 8 Bit.

    § За високи битрейти над 7000 кBit/s се препоръчва да се използва 10 Bit.

    § В останалите случаи по-добро качество дава 9 Bit.

    § Избор "Auto" автоматично донастройва DC precision под използвания битрейт.

  • Motion search - Ниво на сложност (в %) за търсене на вектори за движение. Колкото по-висако е нивото на сложност, толкова по-малко артефакти ще се виждат при бързодвижещи се обекти и при динамични смени на сцени. При увеличение на нивото се повишава натоварването на процесора.

  • Група «Static denoise»:

    Filter – Метод за намаляване на шум въз основа на анализ на отделно взет кадър от видеоред.

    § Off - Cтатично шумопотискане не се използва.

    § Median - Aлгоритъм, който ефективно отстранява ярко изразени пикови шумове, като при това се съхранява контраст на отделни яркостни и тонови преходи.

    § Average - Aлгоритъм, основан на използване на филтър за ниски честоти.

    Denoise - Величината задава честота на срез на филтъра. При високи стойности на срез се понижава остротата.

  • «Motion compensated denoise»:

    Метод за намаляване на шум въз основа на анализ на последователност от кадри във видеоред с използване на вектори за движение.

    Този начин дава най-добро качество без понижаване на остротата на изображение като цяло, но при високи стойности на коефициент Denoise е възможно появяване на артефакти тип „горещ въздух”.

    (доп.,v.5.07) Препоръчителна величина: 6...8.

    Denoise - (v.5.05: Denoise – задаване на коефициент за определяне на наличие на шум по вектор за движение. Препоръчителна величина 6...8.).

    (v.5.05: Вектори движ. – Вектори за движение. Колкото повече са векторите, толкова по-малко артефакти ще се виждат при бързодвижещи са обекти и при динамична смяна на сцените. При увеличаване на количеството вектори се повишава натоварването на процесора.

    Препоръчителна величина: не по-малко от 8.)

  • Група «Audio encoder»:

    Bitrate (Audio bitrate) (Битрейт аудио) – Позволява да се зададе битрейт на аудиопоток за формати MPEG1 Layer-II (доп.,v.5.07) и Dolby АС3.

    (v.5.05: Аудиобирейтът определя скоростта на запис на аудиопоток във файл.)

    Колкото по-висок битрейт - толкова по-високо качество на звук.

    Като оптимален битрейт за MPEG Layer-II се приема (изм.,v.5.07. v.5.05: 224~256 kBit/s.) 192-256 kBit/s.

    Channels mode (изм., v.5.10 Audio channels mode) (Кодиране) - Режим на кодиране на аудиоканали.

    Препоръчителни режими - Stereo и Joint Stereo.

    (В режим Joint Stereo левият и десен канали се кодират заедно, а в резултативния файл се записва информация за разликите в двата канала, например: ляв канал и разлики на десния канал от левия. Joint Stereo позволява по-качествено кодиране на поток с нисък битрейт (ще има повече високи честоти), но се влошава предаването на стереоефекти.)

  • «Multiplexer»:

    (изм., v.5.10) Multiplexer SCR/PCR clock - System Clock Reference / Program Clock Reference - базови времеви отметки в MPEG-поток:

    (v.~5.09: Multiplexer settings - Параметри ISO/IEC13818-1 (MPEG2 Program/Transport Stream) на мултиплексора):

    § SCR/PCR clock):

    §§ Locked to video - тактовият генератор SCR/PCR се привързва към скоростта на потока на кодирано видео.

    Този режим се препоръчва при директен видеозапис във файл, т.к. осигурява максимално ефективна синхронизация на видео- и аудио потоци.

    §§ Fixed clock - препоръчва се за гледане на кодирано видео в реално време чрез програмния декодер. В случай, че се губи видео синхронизация (пропада синхросигнал), няма да се забелязва забавяне на изображението.

    § (v.~5.09 - NAV PACK time slots - Настройка, позволяваща при запис да се резервира в MPEG-потока известно количество временни слотове за използване по-нататък от навигационни пакети (NAV PACK). Навигационни пакети се използват за достъпа до данни DVD. Минималната единица данни на DVD-потока се нарича VOBU и съдържа от 0.4 до 1.2 сек. видео. В зависимост от дължината на GOP размера VOBU съставлява от 1 до 4 GOP. NAV PACK се записва преди началото на всеки VOBU и се използва при подготовка на DVD за указания на препратки. Достъпна е само за режим на мултиплексора Program Stream.)

    § (v.~5.09 - Program end code – указва във файла да се записва или не (в съответствие с ISO/IEC 13818-1) код за край на потока (00 00 01 B9). Достъпно само за режим на мултиплексора Program Stream.)

РАЗШИРЕНИ параметри:

  • Група «Quantizer matrix»:

    В процеса на MPEG-кодиране кадърът се разбива на блокове с размер 8х8 пиксела и всеки блок се подлага на дискретно косинусно преобразуване (DCT), в резултат на което се формира масив от данни с 8х8 стойности, представляващи сами по себе си матрица от DCT коефициенти.

    Величините и положението на коефициентите в матрицата определят честотните характеристики на изходното изображение:

    § Коефициенти, които са по-близо до десния долен ъгъл на матрицата характеризират количество, острота и рисунък на дребни детайли от изображение.

    § Коефициентите, които са по-близо до левия горен ъгъл на матрицата задават как да изглеждат големи елементи от сцената. Най-крайният коефициент в левия горен ъгъл определя средна яркост на квадрата от 8х8 пиксела.

    Ако е налична матрица с DCT коефициенти може да се възстанови изходното изображение (квадрат 8х8 пиксела). Ако в изображението напълно отсъстват дребни детайли, стойностите на коефициентите в десния долен ъгъл на матрицата ще бъдат близки до нула. Такива стойности могат да бъдат пренебрегнати, като се занулят напълно. Колкото повече еднакви коефициенти има в една матрица (например нули), в толкова по-голяма степен същата може да бъде компресирана. Стойностите на другите коефициенти DCT също така може да се коригират, като с това се установява компромис между качество на изображение и степен на компресия (размера на файл).

    Процесът на нормиране и корекции на DCT коефициенти се нарича квантоване.

    Това, колко пъти ще бъде намален един или друг коефициент DCT, се определя от квантовата матрица. Всеки елемент от квантовата матрица се явява делител за коефициента, който се намира в същата позиция на DCT-матрицата. Коефициентът-делител може да има стойност от 8 до 255. В зависимост от различните изисквания към качеството на I-, B- и P- кадри, за тяхното квантоване се използват две различни матрици:

    Matrix for intra block - матрица с коефициенти за квантоване на I- фреймове.

    Matrix for inter block - матрица с коефициенти за квантоване на B- и P- фреймове. Коефициентите на тази матрица по правило имат големи стойности (коефициенти на делене) и не са така честотно зависими.

    Select quantizer matrix – набор от предварително зададени квантови матрици:

    §§ MPEG standard - стойностите на коефициентите на матрицата се задават от стандарт MPEG. Тъй като матриците са стандартни, стойностите на техните коефициенти не се записват в MPEG-файл и при отваряне на такъв се зареждат от декодера по подразбиране (автоматично).

    §§ Low interframe compression, Philips default и High interframe compression матрици се различават от MPEG standard само по матрицата за квантоване на B- и P- кадри (интер-блокове). По реда на преизчисляване тези матрици осигуряват по-висока компресия на B- и P- кадрите.

    §§ CG/Animation - матрицата за квантоване на I-кадри се различава от стандартната с равномерност на разпределение на коефициенти в цялата честотна област. Използва се за компресия на съдържанието на анимация или компютърна графика.

    §§ User defined - Потребителска матрица за квантоване. Коефициентите на матрицата се редактират непосредствено в нейните клетки. По стандарт стойностите на коефициента в позиция (0, 0) не подлежат на изменение и винаги трябва да остават равни на 8. Стойностите на матрицата за квантоване се съхраняват в пресети за запис.

  • «DCT block»:

    Получените след квантоване коефициенти на DCT-матрица се компресират допълнително с помощта на алгоритъм RLE. По този метод най-плътно се „опаковат” числови редици с периодично повтарящи се последователности от еднакви числа. След квантоване матрица с DCT коефициенти представлява сама по себе си масив от такива числа, величините на които намаляват и завършват със серия от нули, ако се разглежда матрицата започвайки от горния ляв ъгъл към долния при движение по диагонал (на зиг-заг). За междуредови (интерлейсни) кадри е по-ефективен леко модифицираният начин на алтернативно сканиране.

    Block scan order - указва начин на сканиране на матрица с DCT коефициенти:

    § Alternate (interlace) – препоръчва се при компресиране на интерлейсно видео (студийни програми, сериали и пр.).

    § Zigzag (progressive) - препоръчва се при компресиране на прогресивно видео (анимация, стари филми). Метод Zigzag също така се включва принудително при задаване размер на кадър 352x288 (352x240).

  • «B-frames quantization»:

    B-frames weighting factor - Допълнителен тегловен коефициент, който усилва квантоването на B-кадри, намалявайки с това битрейта при компресиране на B-кадри. При нисък общ битрейт на потока (CBR 3000) увеличаването на този коефициент (например до 32) позволява да се подобри качеството на изображението за сметка на преразпределение на битрейта между I- и B-кадрите. Ако се използва само IP-последователност GOP, то при квантоване тегловният коефициент се прилага за всеки втори P-кадър, които в дадения случай се явяват като виртуални B-кадри.

The contents of Software/* Hardware MPEG

* (Hardware MPEG2 DVD)


Topic: * (Hardware MPEG2 DVD)

* (Hardware MPEG2 DVD)

«Hardware MPEG2 DVD» - вж. по-горе .

От v.5.10 описанието на метода се намира в обединен подраздел «Software/* Hardware MPEG»:

«Software MPEG (InterVideo)»,

«Software MPEG (Microsoft Windows 7)»,

«Hardware MPEG»

В българската редакция на раздела са оставени екранни снимки от предишни версии (v.5.05~v.5.09) като сравнителна информация за измененията в интерфейса.


Topic: Microsoft WMV

Microsoft WMV

& Метод за запис или излъчване на видео/аудио в по-новия формат Microsoft Windows Media в състава на контейнер ASF.

Контейнер ASF от своя страна е продължение на развитието на контейнер AVI.

Контейнер ASF има допълнителни функции по синхронизация на аудио/видео потоци. Файл в контейнер ASF, в който видеопоток е компресиран с кодек WMV обикновено има разширение ".wmv".

Формат WMV (Windows Media Video) сам по себе си представлява продължение на развитието на Microsoft MPEG4.

Формат WMА (Windows Media Audio) е разработен като достоен конкурент на формат MPEG Layer-3 и в някои случаи превъзхожда MPEG Layer-3 по съотношение качество/размер на файл.

За кодиране на файлове в Windows Media формат, както и за излъчване на Windows Media поток в IP мрежа е необходима OS Windows XP SP2, по-висока или инсталирано обновяване Microsoft Windows Media Format Runtime - версия 9 или по-висока.

За запис и излъчване на поток във формат WMV са достъпни следните настройки:

Размери на кадър – Размери на видеокадър при запис. Препоръки - вж. по-горе .

Кадри/sec - вж. по-горе .

Аспект - Съотношение на страните на кадър при гледане на WMV файлове. Това съотношение се възприема от плейъра при извеждане на изображение за настройки на необходимо съотношение на страните на кадър.

Компресиране на видео поток - Избор на достъпен WMV кодек и настройки на основни параметри на кодека.

Връзка към диалогов прозорец за конфигурация на видео кодек се осъществява при натискане на бутон [image] «Избор на видео кодек и формат» - отваря се прозорец за настройки

Формат / компресиране на аудио поток - Избор достъпен WMA кодек и настройки* на основни параметри на кодека.

Връзка към диалогов прозорец за конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на аудио кодек и формат» - отваря се прозорец за настройки

Използване на предбуферизация при запис - Тази опция се препоръчва при резултативни битрейти > 1500 Кbit/s. При това ASF-мултиплексор използва достъпната оперативна памет и формира в паметта поток от големи блокове, след което блоковете се записват във файл. В противен случай се формира поток от малки блокове.

Файл-име (Собствено име за файл): По желание - използване на собствено потребителско име в описанието на медиа-файл.

Конфигурация на WMV кодек

Конфигурация на WMA кодек

The contents of Microsoft WMV

WMV кодек
WMА кодек


Topic: WMV кодек

WMV кодек

Конфигурация на WMVideo кодек:

Връзка към диалогов прозорец за конфигурация на видео кодек се осъществява при натискане на бутон [image] «Избор на видео кодек и формат» - отваря се прозорец за настройки

  • «Кодек WMV»

    Избор на WMV кодек. Съдържанието на този списък зависи от версията на инсталирано обновяване Microsoft Windows Media Format Runtime:

    § За системи с честота на CPU >= 2000 Mhz се препоръчва кодек «Windows Media Video 9».

    § За системи с честота на CPU < 2000 Mhz се препоръчва кодек «Windows Media Video V8».

  • Група «Формат на WMV кодек» - Базова конфигурация на избрания кодек:

    Постоянен битрейт, променливо качество (CBR) – Режим на кодиране с постоянен битрейт. Препоръчително.

    Битрейт (кBit/s) - Задава базов битрейт за видеопотока. Колкото по-висок е битрейтът, толкова по-високо е качеството на кодиране, но и размерът на получения файл ще бъде съответно по-голям.

    За запис на пълен кадър 768x576 се препоръчва битрейт не по-нисък от 1200 Кbit/s.

    Острота (%) - Този параметър определя претеглено качество на изображение при зададен битрейт.

    Не се препоръчва да се задава острота над 85%, тъй като е възможно пропускане на кадри от WMV кодека дори при слабо натоварване на CPU.

    По същата причина не се препоръчва да се задава острота над 50% при ниски битрейти (< 500 Кbit/s), т.к. ще има пропускане на кадри.

    Този параметър не оказва влияние върху натоварването на CPU.

    Променлив битрейт, постоянно качество (VBR Quality) - Режим на кодиране с променлив битрейт въз основа на показател качество. Този режим не се поддържа от всички WMV кодеци. Ако кодекът не поддържа VBR Quality избор на този режим няма да бъде достъпен.

    Качество (%) – Задаване на базово ниво на качество за режим на кодиране VBR Quality. Колкото по-високо е качеството, толкова по-висок е резултативният битрейт.

  • Група «Допълнителни параметри на WMV кодек»:

    Ключов кадър (s) - Задава интервал на ключови кадри в потока. Колкото по-голям е интервалът, толкова по-малко битрейт ще загуби кодекът за кодиране на разлики в информацията между ключови кадри, но ако видео съдържанието е с много бързо сменящи се динамични сцени, качеството на компресия ще се получи ниско.

    Общи препоръки:

    за видео съдържание с малко динамични сцени - интервал 4 ~ 6 s,

    в останалите случаи - 3 ~ 4 s.

    Сложност - Всеки WMV кодек има свой диапазон за регулиране на сложност на кодиране. Сложността на кодиране определя резултативното качество на изображение. Колкото по-висока е сложността, толкова по-високо е качеството, но едновременно с това нелинейно нараства натоварването на CPU. За поток в реално време е предназначено ниво на сложност на кодиране Live и по-ниско. Всички нива на сложност над Live изискват най-мощни CPU (каквито засега няма) и затова са определени от Microsoft за прекодиране на файлове (Offline съдържание). За поток в реално време такива нива са приложими само за кодиране на малки фреймове (например 160x120).

  • Група «Операции с видеополета»:

    «Не се изпълнява (кодиране едно към едно)» - Ако входящото видео се явява прогресивно или има желание да се използват други начини за деинтерлесинг на база допълнителни плъгини.

    «Използване на вградения WMV деинтерлейс» - WMV кодек има вграден механизъм за деинтерлейсинг, който може да се използва преди кодиране.

    «Отделно кодиране на полета (интерлейсно извеждане)» - кодек «Windows Media Video 9 Advanced Profile» от ъпдейт Microsoft Windows Media Format Runtime 9.5 и 11 поддържа режим за разделно кодиране на интерлейсни полета. Този режим е силно взискателен по отношение ресурси на CPU и е предназначен основно за възпроизвеждане и извеждане на записаното съдържание на интерлейсни устройства (например телевизор). При разделно кодиране на полета се изисква малко по-висок битрейт.


Topic: WMА кодек

WMА кодек

Конфигурация на WMAudio кодек:

Връзка към диалогов прозорец за конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на аудио кодек и формат» - отваря се прозорец за настройки

  • «Кодек WMА»

    Избор на WMА кодек. Съдържанието на този списък зависи от версията на инсталирания ъпдейт Microsoft Windows Media Format Runtime.

    (v.~5.11) [image] За системи с честота на CPU >= 2000 Mhz се препоръчва кодек «Windows Media Video 9».

    (v.~5.11) [image] За системи с честота на CPU < 2000 Mhz се препоръчва кодек «Windows Media Video V8».

  • Група «Формат на WMV кодек» - Основна конфигурация на избрания кодек:

    Постоянен битрейт, променливо качество (CBR) – Режим на кодиране с постоянен битрейт. Препоръчително.

    За видеозапис съвместно с аудио в списъка са достъпни формати, отбелязани с абревиатура (A / V).

    За качествено аудио кодиране е желателно да се избират формати с битрейт не по-нисък от 128 Кbit/s.

    Променлив битрейт, постоянно качество (VBR Quality) - Режим на кодиране с променлив битрейт въз основа на показател качество. Този режим не се поддържа от всички WMА кодеци. Ако кодекът не поддържа VBR Quality избор на този режим няма да бъде достъпен.

Забележка: Формати, които изискват ресемплиране или конвертиране на изходния PCM поток ще се показват в списъка с друг цвят.

(отп.,v.5.10. v.~5.09: Windows Media Format има функция за качествено ресемплиране на аудио, затова при запис на звук с чипсет SAA7134/35 са достъпни всички възможни честоти на дискретизация за избрания WMA кодек. При избор на формат, например «192 kbps, 48 kHz, stereo (A/V) CBR» за чипсет SAA7134 ще се извърши автоматично конвертиране на честотата на дискретизация от 32 kHz на 48 kHz без осезаема загуба на качество. За чипсет SAA7135 също ще бъде избирана най-близката поддържана честота на дискретизация, която при необходимост ще бъде автоматично ресемплирана в крайното значение.)


Topic: Microsoft ASF

Microsoft ASF

Метод за запис или излъчване на видео/аудио в състава на контейнер ASF посредством кодиране на видео- и аудио потоци със странични кодеци (не-Windows Media).

Контейнер ASF представлява продължение на развитието на контейнер AVI и има допълнителни функции по синхронизация на аудио/видео потоци.

За кодиране на файлове във формат ASF, както и за излъчване на ASF поток в IP мрежа е необходима OS Windows XP SP2, по-висока или инсталирано обновяване Microsoft Windows Media Format Runtime - версия 9 или по-висока.

За запис и излъчване на поток във формат ASF са достъпни следните настройки:

Размери на кадър – Размери на видеокадър при запис. Препоръки - вж. по-горе .

Кадри/sec - вж. по-горе .

Формат - вж. по-горе .

Компресиране на видео поток - Позволява за компресиране на видео да се избере всеки регистриран в системата VCM или DirectShow видео кодек от падащия списък. Препоръки - вж. по-горе .

«Свойства на кодек» - вж. по-горе .

Формат/компресиране на аудио поток - Избор на формат и тип на компресия за аудио поток .

«Избор на аудио кодек и формат» - вж. по-горе .

Използване на предбуферизация при запис - вж. по-горе .

Файл-име (Собствено име за файл): - вж. по-горе .


Topic: Digital Video Broadcating (DVB)

Digital Video Broadcating (DVB)

Метод за запис или излъчване на видео/аудио за DVB режими на тунера.

вж. също Аудио запис .

След превключване на тунера в DVB режим този начин на запис е единствено достъпен. Запис се извършва без прекодиране на съдържанието на цифровия поток, поради което качеството на видео и звук остава неизменно.

Формат за запис на поток - Текущият DVB поток може да се записва в няколко формата на контейнер MPEG:

«Transport Stream Transponder» - Изпълнява се запис на ЦЕЛИЯ транспортен поток в контейнер ISO13818-1 Transport Stream с ВСИЧКИ сервиси без изменения.

Фактически този режим изпълнява "на сляпо" транспондер [image] поради което допълнителни опции за избор в чекбокс (група Transport Stream) не са достъпни (активни).

Тъй като се записват всички сервиси, които се предават в излъчван поток, съответно записваният битрейт е достатъчно висок.

Разширение на файл «*.ts».

  • Група «Transport Stream» - Текущият сервис (канал) се записва в контейнер ISO13818-1 Transport Stream.

    Този контейнер е универсален и позволява също така да се записват

    -- H.264 видео потоци,

    -- AAC аудио потоци,

    -- няколко аудио пътеки,,,

    «Всички аудио потоци»,

    «Субтитри»,

    «Телетекст»,

    «Всички останали потоци» - Ако в текущия записван сервис има и други потоци освен видео и един аудио поток, те също могат да се записват във файл при активиране на опцията.

    -- друга сервисна информация.

    Разширение на файл «*.ts».

    «Program Stream» - Текущият сервис (канал) се записва като една аудио пътека в контейнер ISO13818-1 Program Stream.

    Това е най-популярният MPEG контейнер, който се използва в случай, че е необходимо просто да се запише текуща телевизионна или радио програма. За разчитане (доп. р. - прослушване, гледане) на данни от контейнер Program Stream не е необходимо в системата да се инсталират допълнителни програмни сплитери.

    Записва се текущ видео поток и текущ аудио поток.

    Този контейнер има ограничения за типове съхранявани в него елементарни потоци, поради което ако текущият сервис представлява H.264 видео поток или AAC аудио поток, приложението автоматично ще започне да записва във формат на контейнера Transport Stream.

    Разширение на файл «*.mpg».

    Размер на PS-pack ("пак")

    „Рack”/„Пак” е минимален фрагмент на поток Program Stream, който носи в себе си PES-пакети (Packetized Elementary Stream).

    Избор на размер на pack в контейнер ISO13818-1 Program Stream:

    2048 (DVD compatible) - За запис на видео се препоръчва фиксиран размер на pack - 2048 байта, равен на DVD сектор като установен (рус."устоявшийся") стандарт.

    Variable pack - При избор на Variable pac сумарният битрейт на контейнера ще бъде по-нисък поради по-плътно разположени пак~ове в потока, тъй като няма да се използва запълване (Padding) за изравняване на пакове. Във всеки случай, ако се планира запис да се пренесе на DVD, всяка програма за DVD авторинг ще изпълнява перемуксиране на файла в DVD проект и ще заготви пак~ове с размер 2048 байта.


Topic: ОБЩИ настройки за ВИДЕО+АУДИО запис

ОБЩИ настройки за ВИДЕО+АУДИО запис

ОБЩИ настройки за ВИДЕО + АУДИО запис

The contents of ОБЩИ настройки за ВИДЕО+АУДИО запис

Настройки-Поток
Настройки Видео
Настройки Аудио


Topic: Настройки-Поток

Настройки-Поток

ОБЩИ настройки за видео/аудио: поток

  • «Общи настройки»:

    Спиране на запис при липса на сигнал – При пропадане на видео-синхросигнал (например пауза в тв програма) записът автоматично ще спре, като събитието се записва в log-файл.

    Висок приоритет на процеса при запис – Програмата ще задава висок приоритет за своя процес по време на видеозапис. При висок приоритет вероятност от пропускане на кадри е по-малка.

    Подробните описания на основни групи/настройки/опции в този раздел имат принципно общи транскрипции при характерни индивидуални особености (в зависимост от тип/метод на запис) за още няколдо раздела. Описанията в такива раздели са в съкратен вид, но с препратки към разширени описания, които се намират в:

    Режим «Запис във файл» *

    Режим «Излъчване в IP-мрежа» **

The contents of Настройки-Поток

Режим «Запис във файл»
Режим «Излъчване в IP-мрежа»


Topic: Режим «Запис във файл»

Режим «Запис във файл»

Задаване на режим (направление) на поток за запис във файл:

Излъчване в IP-мрежа – вж. следв. абзац .

Запис във файл – Насочване на крайния поток за запис във файл:

Следващите подробни описания на основни групи/настройки/опции в този раздел имат принципно общи транскрипции при характерни индивидуални особености (в зависимост от тип/метод на запис) за още няколдо раздела.

Описанията в такива раздели са в съкратен вид, но с препратки към разширените описания по-долу.

Секции с принципно общи транскрипции са:

  • Настройки-Поток ;

  • ...

Път за записвани файлове – Избор на папка за разполагане файлове с видеозаписи.

Отваря се Вehold TV browser за избор на папка за разполагане на:

видео/аудио файлове при видео+аудио запис

аудио файлове при аудио запис

файлове със снимки при екранни снимки (screehshot~s)

файлове за отложено гледане при Таймшифт

Внимание [image] Път за записвани файлове не се съхранява в пресети!

Шаблон за име на файл – Шаблонът за име на файл може да включва всякакви допустими символи за име на файл, както и макроси , вместо които в името на файл се вмъква дата, време, име на канал, име на TV-програма и др. предопределени от макросите елементи.

Шаблонът трябва да съдържа само име на файл БЕЗ указания за път и БЕЗ разширение. За удобство при въвеждане на макроси може да се извика диалогов прозорец-подсказка, с помощта на който да се формира необходим шаблон:

Бутон [image] - отваряне на прозорец за избор на макрос.

Log – При започване на запис програмата ще създава log-файл (*.log), в който се записва допълнителна информация при процеса на запис. Предназначението на log-файла е да помага при възникване на различни по вид проблеми при запис. В log-файла също така се съдържа информация за параметрите на текущия запис.

log-файл може да се отваря с всякакъв текстов редактор.

Разрешаване презапис на съществуващ файл - При свалена отметка и в случай, че генерирано от програмата текущо име на файл съвпада с вече съществуващ файл, програмата допълнително ще добави няколко символа за да се избегне презапис и загуба на съществуващия файл.

Разделяне на Файл на сегменти по – «Автоматично разделяне на записван файл на сегменти със зададен размер».


Topic: Режим «Излъчване в IP-мрежа»

Режим «Излъчване в IP-мрежа»

Задаване на режим (направление) на поток за излъчване в IP-мрежа:

Излъчване в IP-мрежа насочва крайния поток в IP-мрежа. В зависимост от начина на запис са достъпни следните режими на излъчване:

  • HTTP Unicast

  • UDP Multicast

The contents of Режим «Излъчване в IP-мрежа»

HTTP Unicast
UDP Multicast
RTP Multicast


Topic: HTTP Unicast

HTTP Unicast

HTTP Unicast – Режим на ретранслиране в IP мрежа по протокол HTTP

В този режим се създава пасивен socket, който очаква включване на клиенти.

При постъпване на заявка от клиент се изпълняват условия за проверка и при положителен резултат се осъществява съединение, socket-ът преминава в активен режим и започва да предава на клиента поток. На всеки включен клиент последователно се изпраща отделно копие на всеки пакет.

Внимание! При голямо количество включени клиенти може да се стигне до недостиг на пропускателна способност на мрежата.

  • Настройки:

    Порт – Мрежов порт на socket-а за излъчване на поток. При указание „0” ще бъде автоматично назначен свободен порт. За да може да се включи клиент, трябва да му бъде известен номерът на порт. Готов URL ред за включване на клиент може да се вземе, както е показано тук .

    Внимание! Ако избраният порт е затворен от провайдера или от мрежовия администратор с цел безопасност, включване на клиенти е невъзможно. Необходимо е да се избере друг достъпен порт.

    Клиенти – Максимално разрешен брой клиенти за включване - 50.

    (отп., v.5.10 Трябва да се помни, че Windows 2000 Prof и Windows XP са работни станции и не могат да имат повече от 10 включвания. За избягване на това ограничение е необходима OS Windows 2000 Server (Advanced Server) или Windows 2003 Server.)

    – при натискане на този бутон се извиква ACL-лист [image] за администриране на включване на клиенти.

    По подразбиране ACL-листът е празен и включване е разрешено от всеки host. При желание могат да се въведат ограничения за включване. След внасяне на изменения в ACL-листа е достатъчно същият да бъде съхранен и отново да се пусне излъчване.

    Внимание! ACL-листът не се съхранява в пресети!

    (доп.,v.5.17) Наименование на сесия – Задаване на шаблон за име, под което ще се изобразява поток при клиента при приемане по протокол SHOUTcast. Протокол SHOUTcast представлява сам по себе си разширение на протокол HTTP и ще бъде автоматично задействан ако клиент изпълни SHOUTcast запитване (поддържа се в WinAmp, VLC и др.). Наименование може да се зададе във вид на шаблон с използване на подложки (рус. "подстановки").

The contents of HTTP Unicast

Ограничения за достъп


Topic: Ограничения за достъп

Ограничения за достъп

Настройки на [image] ограничения за достъп на клиенти

(превод на файл BhACL.cfg)

Behold TV

Access control list for Windows Media network broadcast server

Список администрирования доступа клиентов к серверу вещания Windows Media

Списък за администриране на достъп на клиенти към излъчващия сървър Windows Media

http://tuner.beholder.ru

mailto:support@beholder.ru

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

* Информация *

Данный список служит для ограничения доступа клиентов при подключении

к серверу вещания потока Windows Media.

Този списък служи за ограничаване на достъп на клиенти при включване към излъчващия сървър на поток Windows Media.

* Примеры заполнения списка *

Для добавления IP адреса (либо пула IP адресов), которым будет разрешен

доступ, используется следующая конструкция:

* Примери за попълване на списък *

За добавяне на IP адрес (или пул от IP адреси), на които ще бъде разрешен достъп, се използва следната конструкция:

include xxx.xxx.xxx.xxx mask xxx.xxx.xxx.xxx

Для добавления IP адреса (либо пула IP адресов), которым будет запрещен

доступ, используется следующая конструкция

За добавяне на IP адрес (или пул от IP адреси), на които ще бъде забранен достъп, се използва следната конструкция:

exclude xxx.xxx.xxx.xxx mask xxx.xxx.xxx.xxx

Например, чтобы разрешить доступ для пула адресов с 192.168.5.1 по 192.168.5.254,

нужно добавить строку:

Например, за да се разреши достъп за пул с адреси от 192.168.5.1 до 192.168.5.254, трябва да се добави ред:

include 192.168.5.1 mask 255.255.255.0

Например, чтобы запретить доступ для адреса 192.168.5.150, нужно добавить строку:

Например, за да се забрани достъп за адрес от 192.168.5.150, трябва да се добави ред:

exclude 192.168.5.150 mask 255.255.255.255

* Примечания *

- Чтобы разрешить подключение с любого IP адреса, данный список должен

быть пустым.

- Допустимый символ ремарки строки ";"

* Забележки *

- За да бъде разрешено включване от всеки IP адрес, списъкът трябва да бъде празен.

- Допустим символ за забележки на ред е ";"

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;exclude 127.0.0.1 mask 255.255.255.255


Topic: UDP Multicast

UDP Multicast

UDP Multicast – Режим на ретранслиране в IP мрежа посредством групова адресация по протокол UDP:

В този режим се създава датаграмен socket, който отправя датаграми във виртуална Multicast група.

Ако клиент е влязъл в дадена група, на съответния клиент маршрутизаторът ще достави копие на пакета. На всеки клиент ще бъде отправено едно и също копие на пакета. Този режим пести пропускателна способност на мрежата, но има някои особености:

  • Настройки:

    Мрежов интерфейс – Указване на локален мрежов интерфейс, който socket-а ще използва за изпращане на Multicast-съобщения.

    Ако интерфейсът е избран като «Всеки (авто)», socket-ът самостоятелно ще намери мрежов интерфейс, като чете таблицата на маршрутизация за избор на най-добър интерфейс.

    (изм.и доп.,v.5.17) Multicast IP (v~5.10 IP адрес на групата) – Указване на IP адрес от клас D (диапазон 224.0.0.1 - 239.255.255.254), който определя Multicast групата. Даденият адрес се съобщава на клиента при отваряне на UDP или RTP поток

    След въвеждане на IP адрес в прозореца същият се потвърждава с бутон [image]. Ако е въведен невалиден адрес, Behold TV ще изведе предупредително съобщение

    за резултата от проверка за коректност.

    (доп.,v.5.17) Порт – Указване на мрежов порт на socket-а за изпращане на Multicast съобщения. Даден порт се указва на клиента при отваряне на UDP или RTP поток.

    UDP пакет (доп.,v.5.15) – Максимален размер на UDP-пакет (включително IP-заглавия). Параметърът е важен, когато UDP-пакети се излъчват от маршрутизатора в друга подмрежа. В този случай пакетите могат да бъдат неправилно събрани при превишаване на размер MTU на мрежовия интерфейс.

    TTL на датаграмата – Указване на TTL (Time To Live) за датаграми с групови съобщения.

    При TTL=1 датаграмата е ограничена от подмрежата на host-а, който я е изпратил и няма да бъде обработена от нито един маршрутизатор. Такава стойност е подходяща за излъчване на поток само в една подмрежа. За да може датаграмата да бъде предадена в друга подмрежа, е необходимо да се зададе TTL с минимум такава стойност, на каквото количество подмрежи трябва да се предаде датаграмата.

    Параметър TTL зависи от IP-адреса на групата, който от своя страна въвежда някои ограничения:

    TTL

    IP адрес на групата

    Ограничения

    1

    224.0.0.0 - 224.0.0.255

    Датаграмата е ограничена от подмрежата на хоста на изпращащия и няма да бъде обработена от нито един маршрутизатор, независимо от TTL.

    <32

    239.255.0.0 - 239.255.255.255

    TTL ще бъде игнориран над 32

    <64

    239.192.0.0 - 239.195.255.255

    TTL ще бъде игнориран над 64

    <255

    224.0.1.0 - 238.255.255.255

    Няма ограничения, глобално използване

(доп.,v.5.17) Наименование на сесия – Задаване на шаблон за име на сесия, която се разпраща по протокол SАР. Клиент, при който се поддържа четене на SАР-разпращане автоматично ще види излъчване на UDP или RTP поток и ще може да го пусне бързо.

Например, за VLC player всички разпращания се виждат в Изглед>Плейлист>Local Network>Network Streams (SAP).

Наименование може да се зададе във вид на шаблон с използване на "подложки" (рус. "подстановки").


Topic: RTP Multicast

RTP Multicast

RTP Multicast – Режим на ретранслиране в IP мрежа посредством групова адресация по протокол RTP:

Протокол RTP се базира на основата на UDP транспорт и използва аналогично мултикаст-разпращане на поток, но допълнително има RTP заглавие за описане на поток. В заглавието също така има допълнителни полета за контрол на цялост и отчитане на пореден номер на UDP-пакети.

Достъпен е само за мултиплексирани MPEG PS/TS потоци.


Topic: Настройки Видео

Настройки Видео

ОБЩИ настройки за видео/аудио: Видео

Видеообработка на кадър – Настройки за обработка на кадър преди компресиране.

Позволява да се използва режим за допълнителна видеообработка, изграден на база на допълнително включвани плъгини.

Включени плъгини за запис се съхраняват отделно и не се пресичат с включени плъгини за гледане. Освен това, включени плъгини за запис се съхраняват в пресет.

Мащабиране на кадър – Настройки, които позволяват да се включи режим за отсечка по границите на кадър, както и да се измени крайния размер на кадър чрез ресемплиране (? англ. "sample" - "образец", аналог. преобразуване, редактиране) на изображение.

(нов., v.5.10) Дължина на активния видеоред –

– Задаване на количество отброявания (рус."отссчетов") в ред, което видеодекодерът прихваща след цифровизиране на видео.

За по-комфортно изображение на PC монитор се препоръчва да се използват 704 отброявания.

При извеждане на изображение на телевизор е необходимо да се използват 720 отброявания (ITU-601).

За чипсет (доп., v.5.11) SAA7231, ТМ6010 дължината на активния ред се задава от разрешението на кадър, където 704 отброявания се формират при разрешения, кратни на 704.

Ако се планира да се прави запис за последващо гледане на телевизор се препоръчва да се зададе дължина на активния ред 720 отброявания.

Съвместим режим за гледане по време на запис – Извеждане на видеопредпреглед по време на запис в DCI-съвместим видеорендер. Тази функция служи за съвместимост със стари видеокарти (от нивото на nVidia Riva 128 и по-древни) и не се препоръчва за съвременни видеокарти.

Опцията не е достъпна в Windows Vista / (доп., v.5.10) Windows 7.

Да не се показва записвано видео при гледане – При запис да не се показва видео поток. Това позволява допълнително да се намалят натоварването на CPU и вероятността от пропускане на кадри.

Внимание!. Ако вграденият «Модул за планирани задачи» извиква наближаващо по време задание за видеозапис и при това програмата е била свита в системния tray (намира се в режим на изчакване), то възможност за гледане при запис ще зависи от опция « Блокиране на поток за гледане при старт на запис от tray ».


Topic: Настройки Аудио

Настройки Аудио

ОБЩИ настройки за видео/аудио: Аудио

(изм. и доп., v.5.11) Запис на аудио поток по шина РСІ (USB)

( [image] доп.р. вж. също « Избор на устройство за запис »v.5.15; v.~5.09 - Запис на звук от чипсет SAA7134/35 по PCІ) –

Тази опция разрешава цифровизиране и запис на звук от чипсет SAA7134, SAA7135, SAA7231, ТМ6010 вместо от аудио картата. При използване на звукозапис от чипсет значително се намалява вероятността за разсинхронизация на аудио- и видео поток в крайния файл.

Внимание! Ако се използва функция за общо извеждане на звук от чипсет по шина PCI (USB) (вж. прозорец «Настройки», секция «Аудио») и аудио кабелът не е включен към аудио картата, тази опция трябва да бъде задължително включена, в противен случай в записания файл няма да има звук.

(доп., v.5.10) При модели, които нямат аналогов изход тази опция е включена винаги.

(изм., v.5.10. v.~5.09 - Опцията налага някои ограничения - чипсет SAA7135 поддържа честоти на дискретизация само 32/44.1/48 кHz, а SAA7134–само 32 кHz. При избор на аудио формати с различни от тези честоти на дискретизация, ще бъде изпълнено програмно ресемплиране на PCM-потока до нужните честоти, което слабо ще понижи качеството.).

Съгласуване на звук към честота на кадри – Включва режим за автоматична донастройка на звуковия тактов генератор на чипсета на тунера към скоростта на видеото. Опцията понижава вероятността от разсинхронизация на звук и видео при запис от некачествени видео източници, но може да предизвика неприятни шумови ефекти при промяна на тактовия генератор по време на срив на синхронизация на видеосигнал.

(доп., v.5.10) Не е достъпно за чипсет ТМ6010, (доп., v.5.11) SAA7231.

Аудиосемпли с къса дължина (ms) [image] –

По подразбиране времето за преминаване на аудио семпли е зададено на точно 500 мс. Това създава трудности за синхронизация при използване на пауза, аудио поток с видеопоток, при който времето за преминаване на аудио семпли е равно на 40 мс. за PAL / SECAM и 33 мс. за NTSC. Опцията намалява времето за преминаване на аудио семпли до няколко зададени стойности. По подразбиране се използва време, равно на 40 мс. (1 кадър PAL). Това позволява коректно да се работи с пауза.

Ако се използва пауза при запис, опцията трябва да бъде задължително включена!

Ако не се използва пауза, опцията може да се изключи.

(доп., v.5.10) Не е достъпно при активен запис на аудио поток по шина PCI (USB).

Закъснение на аудио поток (ms) [image] – Задаване на стартово закъснение на аудио поток спрямо видео.

При запис на аудио поток със звукова карта в болшинството случаи аудио потокът стартира по-рано от видео потока с около 100~200 мс. С тази опция може да се дорегулира начална синхронизация на потоци.

(доп., v.5.10) Не е достъпно при активен запис на аудио поток по шина PCI (USB).

Да не се записва аудио канал – Изпълнява се запис/излъчване без звук.


Topic: Видеообработка на кадър (режим запис)

Видеообработка на кадър (режим запис)

Видеообработка на кадър (режим на запис):

Този диалогов прозорец е предназначен за настройки на видеообработка на изображение при запис. Видеообработка се реализира по метода на включване на допълнителни модули-плъгини.

Ако се осъществява запис с ползване на апаратен МРEG енкодер, програмна видеообработка на изображения (шумопотискане, повишаване на острота, гама-корекции и пр.) не е възможна. Въпреки това при апаратен запис плъгините могат да контролират паралелния видеопоток, извеждан за гледане и по този начин да се управлява процесът на запис. По този начин плъгини като «Детектор на логотипи» и «Детектор на движение» ще изпълняват своите функции и в нужните моменти от време ще включват, спират и прекъсват на пауза запис.

  • ? Важно!!! Всеки наличен в списъка плъгин преминава през инициализация при стартиране на Behold TV*, следователно заема ресурси на операционната система (памет) дори когато е изключен от процесинг (т.е. не активен - не е поставена или е свалена отметка в "checkbox", но е наличен е в списъка). Поради това, ако даден плъгин не се използва е по-добре да бъде премахнат от списъка.

  • ? Група за настройки на процесинг «Използвани филтри за процесинг» -

    (? едновременно използвани плъгини могат да бъдат повече от един) - Списък с добавени в прозореца за активиране (? от наличните в системната папка \Plugins) плъгини за видеообработка и/или наслагване на всевъзможни ефекти.

    @ Добавяне на плъгин(и) към списъка в прозореца за плъгини в готовност за активиране/в процес на използване/за деактивиране от наличните такива в системната папка се извършва с бутон [image]; премахване - по аналогия с бутон [image].

    В зависимост от включените плъгини може да се сменя тяхната последователност за изпълнение * ? съответно с бутони [image] [image] .

    Също така даден плъгин може временно да бъде деактивиран (? не премахнат*, а оставен в списъка ако се предвижда да бъде използван в по-късен момент), като се свали отметката пред него. По време на запис прозорецът за настройки на видеообработка ще бъде достъпен, при което могат да се променят настройки на включени плъгини направо по време на запис (в реално време).

    Внимание! Ако в даден момент не е активен запис, настройките на плъгини за процесинг ще са недостъпни, т.к. плъгините се намират в offline режим. За да може да бъде настроен всеки плъгин и за да се види неговата реална работа, трябва да се натисне бутон [image] . С това всички плъгини от списъка автоматично се включват за текущо гледане, при което може визуално да се прецени тяхната работа, както и да се извършват настройки.

    ? Прозорците за настройки са специфични за всеки отделен плъгин. Достъп до съответните менюта с настройки се осъществява с натискане на бутон [image] в долната дясна част на списъка:

  • ? Група за настройки «Използван филтър за деинтерлейсинг» - Избор на достъпен (само един) плъгин за деинтерлейсинг:

    ? Филтър за деинтерлейсинг се избира от падащия списък:

    В полето под наименованието на филтъра автоматично се извежда кратка анотация за действието на съответния плъгин:

    Напомняне: Може да се избере само един плъгин, който ще се занимава с деинтерлейсинг!

    Деинтерлейсинг работи само при извеждане на двете видеополета на кадър, т.е. когато височината на кадър е избрана

    § 576 за PAL / SECAM (например 768x576), или

    § 480 за NTSC (например 720x480).

    (доп. р.) Достъп до съответното меню за настройки на избран плъгин се осъществява с натискане на бутон [image] "Свойства на филтъра" в дясно от реда с наименование на филтъра:

    (доп., v.5.10) Размяна на ред за последователност на видеополета - Много кодеци поддържат интерлейсна обработка на кадър (разделят кадър на полета и обработват полетата разделно). Такива например са DV кодеци и някои MPEG кодеци.

    За такива кодеци трябва правилно да се зададе ред на последователност на полетата. При неправилен порядък на полетата изображението, извеждано на интерлейсно устройство за визуализация (например телевизор) характерно ще „придръпва” при движение на сцени по хоризонтал. В болшинството случаи е необходим следният порядък на полета:

  • PAL / SECAM - Top Field First,

  • NTSC - Bottom Field First.

    BDA драйвер Beholder (изм., v.~5.09 - Чипсет SAA713x) извежда

  • за YUV формати винаги порядък Bottom Field First,

  • за RGB формати - Top Field First.

    Опцията позволява да се определи нужния порядък за последователност на полета при запис в интерлейсен режим. При използване на какъвто и да е алгоритъм за деинтерлейсинг тази настройка губи сила, тъй като деинтерлейсинг превръща интерлейсен кадър в прогресивен, като обработва (рус."смешивает") полета.

  • ? Група за настройки «Буферизация на видео при запис»:

    (доп., v.5.10) Форсиране на видеобуферизация в паметта (кадри) – Указване на

    количество кадри, които ще буферизира конвейер DirectShow по време на запис. Тази настройка позволява да се сведат до нула загуби на кадри по време на запис, предизвикани от кратковременни дискови колизии или от кратковременни пикови натоварвания на CPU. При изключване на тази опция ще се използва буферизация на WDM-драйвера по подразбиране. WDM-драйвер 5.0.0.0 и по-високи версии буферизира по подразбиране 25 кадъра (v.~5.09 - 18 кадъра).

    Препоръчва се да се използва буферизация на видео с дълбочина не по-малко от 1 секунда (25 кадъра). 1 секунда буферизация за поток 768x576 YUY2 ще отнеме ~22 МВ Nonpaged pool оперативна памет по време на запис.

    Не се препоръчва да се използва буферизация за видео повече от 50 кадъра - това може да доведе до разход на Nonpaged pool памет и да предизвика колапс на Windows при опит да бъдат освободени ресурси.

    Приложение: Малка таблица с препоръчителни стойности за буферизация в зависимост от обема на оперативната памет:

    RAM

    Буферизация видео

    (v.~5.09 - 128 МВ)

    (v.~5.09 - 18 кадъра)

    256 МВ

    25 кадъра

    384 МВ

    32 кадъра

    >= 512 МВ

    40 кадъра


Topic: Мащабиране на кадър

Мащабиране на кадър

Отсечка и мащабиране на кадър:

Този прозорец е предназначен за настройки на изходна геометрия на кадър, която ще се формира след видеообработка и непосредствено преди компресиране.

При запис с използване на апаратен MPEG енкодер този прозорец е недостъпен.

  • Група за настройки «Отсечка по границите на кадър» –

    Отсечка – Активиране/деактивиране на опцията, респ. задаване на параметри за отсечка по границите на кадър за отстраняване на нежелателни артефакти, каквито понякога възникват в края на изображение.

  • Група за настройки «Мащабиране на кадър» – Изменение на окончателния размер на изображение чрез ресемплиране на изображение.

    Мащабиране – Активиране/деактивиране на опцията, респ. задаване на параметри за мащабиране:

    Окончателен размер на кадър;

    Метод за ресемплиране - Възможност за подбор на подходящ метод за ресемплиране:

    Мащабирането на кадър е сравнително ресурсоемка процедура и значително увеличава натоварването на CPU.

    Трябва да се помни, че за качествено мащабиране на интерлейсен кадър трябва първо да се изпълни деинтерлейс, в противен случай артефакти след ресемплиране на интерлейс в последствие са неотстраними.

    @ Поради това, че при отсечка на граници и/или мащабиране на кадър изходните размери на кадъра се променят, по същия начин като при избор на първоначален размер на кадър е необходимо да се следи неговите геометрични размери да остават кратни на 8 или на 4. За ориентация в кратността на тези цифри помага подсветка (осветяване) на изходните стойности на размера на кадъра в определен цвят:

  • ако цифрата не е кратна дори на 4, подсветката ще бъде в червено;

  • ако цифрата е кратна на 4, но не е кратна на 8, подсветката ще бъде в жълто.

    Идеален вариант е ситуация, при която размерите на кадъра са кратни на 8 по ширина и 4 по височина (цифрите да не са осветени). В този случай никога няма да възникват проблеми с геометрията на кадър при използване на различни кодеци.

    При не кратност на 4 могат да възникнат проблеми както при запис, така и при възпроизвеждане на записан файл, включително до възникване на критични грешки.

Забележки:

§ За борба само с артефакти по границите на кадър най-добре е да се използва плъгин за видео обработка «Заливка бордюров» («Запълване на граници»), без да се използва отсечка.

§ (доп., v.5.10) При запис в MPEG не се препоръчва да се използват мащабиране или отсечка поради нарушаване на стандартните размери на кадър, приети за MPEG.


Topic: Аудио запис

Аудио запис

Секция за настройки на АУДИО запис

? вж. също Видео/Аудио запис .

? Подробните описания на основни групи/настройки/опции в този раздел имат принципно общи транскрипции при характерни индивидуални особености (в зависимост от тип/метод на запис) за още няколдо раздела.

Описанията в такива раздели са в съкратен вид, но с препратки към разширени описания, които се намират в

§ Секция за настройки на АУДИО/ВИДЕО запис .

Секции с принципно общи транскрипции са:

§§ Настройки за АУДИО запис (Настоящият раздел);

§§ Настройки за екранни снимки (Screenshots)

  • Група «Пресети за аудио запис»:

    Списък с готови пресети за аудио запис, в който се намират предварително настроени конфигурации. Вж. по-горе подробно описание на пресети за видео/аудио запис.

  • Метод за аудио запис (б. р. аналог. "начин", "способ") - Формати за аудио запис. Поддържат се следните формати:

    @ За да може да се записва във формат «Software MPEG Audio» е необходимо да е инсталиран InterVideo WinDVD Creator от втория диск в комплекта на тунера.

    @ За да се записва във формати «Microsoft ASF» и «Microsoft WMA» е необходима ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime - версия 9 или по-висока.

    @ Аудиозапис по метод «Hardware MPEG Audio» е възможен само за ТВ тунери с апаратен енкодер.

  • Основна група «Допълнителни настройки» - Вж. «§§ Общи настройки за Аудиозапис» .

В раздел «Аудио запис» за Аудиозапис, както и общо за Видео/Аудио и Аудиозапис са обособени отделни прозорци с помощна информация за:

§ Общи настройки :

§§ Общи настройки за Аудиозапис

§§ Общи настройки на звук за Видео/Аудио и Аудиозапис

Всеки метод за запис има собствени настройки :

§ Формат MS ACM / ACM DirectShow

§§ Software MPEG Audio (InterVideo);

§§ Software MPEG Audio (Microsoft Windows 7);

§§ Hardware MPEG Audio

§§§ Microsoft WMA

§§§§ Microsoft ASF

§§§§§ Digital Video Broadcating (DVB)

The contents of Аудио запис

Методи за запис
ОБЩИ настройки за АУДИО запис


Topic: Методи за запис

Методи за запис

Всеки отделен метод за запис има свои собствени настройки:

Предпочитан метод за аудиозапис се избира от падащо меню в прозорец с еднотипен интерфейс за всички методи:

2 Диалогов прозорец за настройки на различни методи / формати за запис:

? Различните методи за запис са достъпни (или неактивни) за избор в зависимост от инсталираната ОС, кодеци и конкретния модел тунер (с/без хардуерен енкодер).

The contents of Методи за запис

Формат MS ACM/ACM DirectShow
Формат Software/* Hardware MPEG
Формат Microsoft WMA
Формат Microsoft ASF
Формат Digital Video Broadcating


Topic: Формат MS ACM/ACM DirectShow

Формат MS ACM/ACM DirectShow

& Методи за аудио запис в WAV формат.

Внимание!

§ [image] не поддържа звукозапис по шина (изм. и доп., v.5.11) PCI (USB) (v.~5.09 - с чипсети SAA7134/35). Препоръчва се да се използва при запис през аудио карта.

§ [image] поддържа запис както през аудиокарта, така и от чипсет (v.~5.09 SAA7134/35) по шина (доп., v.5.11) PCI (USB).

Формат/компресиране на аудио - Избор на достъпен ACM аудиокодек от списъка с инсталирани аудио кодеци, както и на формат, свойствен за избрания кодек.

(изм. - вж. също ACM аудиокодек )

?

r Връзка към диалогов прозорец за избор/конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на формат и аудио компресия»:

2 От така отворен прозорец [image] е достъпен следващ диалог за избор/индивидуални фирмени настройки за всеки отделен кодек при натискане на аналогича икона - бутон [image] «Свойства на кодек»:

Различните фирмени прозорци имат свой специфичен интерфейс, които се разработва от отделните производители.

Да не се формира WAV контейнер за MP3 - При използване на аудиокодек MPEG Layer-3 програмата ще формира звуков файл без RIFF заглавие и с разширение *.mp3. Такава структура файла е присъща за формат MP3 и болшинството аудио плейъри възприемат именно такива файлове.


Topic: Формат Software/* Hardware MPEG

Формат Software/* Hardware MPEG

  • *

  • Software MPEG Audio (Microsoft Windows 7) **(доп., v.5.11)

  • Hardware MPEG Audio ***(v.~5.09 - отделно ) -

    & Методи за аудио запис в стандарт MPEG (v.~5.09 ...MPEG-1 Layer II формат).

    (v.~5.09 -Този формат се използва при стандарти MPEG1/2, а също така позволява да се записва само аудиопоток и достатъчно качествено да се кодира звук с нисък битрейт).

*** Hardware MPEG Audio е достъпен само за ТВ тунери с вграден апаратен MPEG енкодер.

** (доп., v.5.11) Software MPEG Audio (Microsoft Windows 7) е достъпен за операционна система Windows 7 (редакции по-високи от Home Basic).

* (доп., v.5.11) Software MPEG Audio (InterVideo) е достъпен след инсталиране на приложение WinDVD Creator от допълнителния диск в комплекта.

Интерфейс - v.5.11. | Интерфейс ~ v.5.09.

(изм., v.5.11) Профил на енкодер - Режим на инкапсулация на MPEG поток:

(v.~5.09 - "Режим мултиплексор" – Формат за представяне на MPEG поток)

§ Audio Elementary Stream - Чист аудио поток, състоящ се от звукови фреймове без инкапсулация в PS пак~ове. Файлът ще има разширение «.mpa». Препоръчително.

§ Program Stream - Звуковите фреймове са инкапсулирани в PS пак~ове във формат ISO/IEC13818-1. Файлът ще има разширение «.mpg».

Аудио формат - Избор на формат на аудио поток за кодиране. Достъпни формати са

и

Формат Dolby AC3 е достъпен само за ТВ тунери Behold TV M6 Extra.

Аудио битрейт - Определя скорост на запис на аудиопоток във файл. Колкото по-висок е битрейтът, толкова по-високо е качеството на звук.

Оптимален битрейт - (изм., v.5.11) 192 ~ 256 kBit/s.

Честота на подбор (Hz) - Честота за подбор на аудиосемпли при Аналого-Цифрово Преобразуване (АЦП):

(доп., v.5.07) Кодиране на канали - Режим за кодиране на аудиоканали:

Препоръчителни режими - Stereo и Joint Stereo.

The contents of Формат Software/* Hardware MPEG

* (Hardware MPEG Audio)


Topic: * (Hardware MPEG Audio)

* (Hardware MPEG Audio)

? (~v.5.09): «Hardware MPEG2 Audio» - вж. по-горе .

? Във v.5.10 описанието на метода се намира в обединен подраздел Формат «Software/* Hardware MPEG»:

«Software MPEG (InterVideo)»,

«Software MPEG (Microsoft Windows 7)»,

«Hardware MPEG»

? В българската редакция на раздела са оставени екранни снимки от предишни версии (v.5.05~v.5.09) като сравнителна информация за измененията в интерфейса.

(v. 5.05~v. 5.07)

NXP SAA6752 (Интерфейс - v.5.07) | NEC µPD61151 (Интерфейс - v.5.07)

(Интерфейс - v.5.05)


Topic: Формат Microsoft WMA

Формат Microsoft WMA

& Метод за запис или излъчване на аудио в новия формат Microsoft Windows Media в състава на контейнер ASF.

i Файл в контейнер ASF, съдържащ само компресиран с кодер Windows Media Audio аудиопоток, обикновено има разширение «.wma».

i Формат WMА (Windows Media Audio) е разработен като достоен конкурент на формат MPEG Layer-3 и в някои случаи превъзхожда MPEG Layer-3 по съотношение качество/размер на файл.

@ За кодиране на файлове във формат Windows Media, както и за излъчване (ретранслиране) на поток Windows Media в IP мрежа е необходима OS Windows XP SP2, по-висока или инсталиран ъпдейт Microsoft Windows Media Format Runtime - версия 9 или по-висока.

@ За запис във формат WMА са достъпни следните настройки:

Формат/компресиране на аудио - Избор на достъпен WMA кодек , както и настройки* на основните параметри на кодека. Описание на параметри на WMA кодек - вж. по-горе .

*? Връзка към диалогов прозорец за конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на аудио кодек и формат».

2 Отваря се прозорец за настройки

Файл-име (Собствено име за файл): - вж. по-горе .


Topic: Формат Microsoft ASF

Формат Microsoft ASF

& Метод за запис или излъчване на аудио в състава на контейнер ASF посредством кодиране на аудиопоток със странични ACM кодеци (не-Windows Media).

@ За запис на файлове във формат ASF, както и за излъчване (ретранслиране) на ASF поток в IP мрежа е необходима OS Windows XP SP2, по-висока или инсталиран ъпдейт Microsoft Windows Media Format Runtime - версия 9 или по-висока.

@ За запис във формат ASF са достъпни следните настройки:

Формат/компресиране на аудио - Избор на достъпен АСМ кодек от списък с инсталирани в системата аудиокодеци, както и на формат, свойствен за избрания кодек.

?

r Връзка към диалогов прозорец за избор/конфигурация на аудио кодек се осъществява при натискане на бутон [image] «Избор на формат и аудиокомпресия»:

2 От така отворен прозорец [image] е достъпен следващ диалог за избор/индивидуални фирмени настройки за всеки отделен кодек при натискане на аналогича икона - бутон [image] «Свойства на кодек»:

Различните фирмени прозорци имат свой специфичен интерфейс, които се разработва от отделните производители.

Файл-име (Собствено име за файл): - вж. по-горе .


Topic: Формат Digital Video Broadcating

Формат Digital Video Broadcating

& Метод за запис или ретранслиране на аудио за DVB режими на тунера.

? вж. също Видео/Аудио запис .

След превключване на тунера в DVB режим този начин на запис е единствено достъпен. Запис се извършва без прекодиране на съдържанието на цифровия поток, поради което качеството на звук остава неизменно.

  • Опции за настройки:

    Формат за запис на поток - Текущият DVB поток може да се записва в няколко формата на контейнер MPEG:

    1 Elementary Stream - Текущият сервис (канал) се записва като една аудио пътека без „опаковане” в някакъв контейнер.

    i За аудио запис това е най-подходящ режим, т.к. дава минимален резултативен битрейт.

    Разширението на файл зависи от текущия тип елементарен поток -

    § за MPEG Audio е «*.mpa»,

    § за AC-3 Audio е «*.ac3»,

    § за DTS Audio е «*.dts»,

    § за AAC Audio е «*.aac».

    1 Transport Stream & Текущият сервис (канал) се записва като една аудио пътека в контейнер ISO13818-1 Transport Stream.

    Разширение на файл «*.ts».

    1 Program Stream - & Текущият сервис (канал) се записва като една аудио пътека в контейнер ISO13818-1 Program Stream.

    Разширение на файл «*.mpg».

    Размер на PS-pack (пак) (? Активно само за Program Stream) -

    & „Рack”/„Пак” е минимален фрагмент на поток Program Stream, който носи в себе си PES-пакети (Packetized Elementary Stream).

    @ Избор на размер на pack в контейнер ISO13818-1 Program Stream:

    - вж. по-горе .

    За аудио запис се препоръчва Variable размер на pack за намаляване на битрейта.


Topic: ОБЩИ настройки за АУДИО запис

ОБЩИ настройки за АУДИО запис

Настройки за АУДИО запис - ОБЩИ настройки

> Общи настройки за Аудиозапис

№ Общи настройки на звук за Видео/Аудио и Аудиозапис

The contents of ОБЩИ настройки за АУДИО запис

Настройки за АУДИО запис
Настройки за Видео/Аудио + АУДИО запис


Topic: Настройки за АУДИО запис

Настройки за АУДИО запис

Общи настройки за АУДИО запис:

  • Група «Допълнителни настройки»:

    (изм. и доп., v.5.11) Запис на аудио поток по шина РСІ (USB) -

    (v.~5.09 - Запис на звук от чипсет SAA7134/35 по PCІ)

    - Тази опция разрешава цифровизиране и запис на звук от чипсети SAA7134, SAA7135, SAA7231, ТМ6010 вместо от аудио картата. При използване на звукозапис от чипсет значително се намалява вероятността за разсинхронизация на аудио- и видео поток в крайния файл.

    Внимание! Ако се използва функция за общо извеждане на звук от чипсет по шина PCI (USB) (вж. прозорец «Настройки», секция «Аудио») и аудио кабелът не е включен към аудио картата, тази опция трябва да бъде задължително включена, в противен случай в записвания файл няма да има звук.

    (доп., v.5.11) При модели, които нямат аналогов аудио изход тази опция е включена винаги.

    Изключване на прослушване по време на запис – Изключване на звук (Mute) по време на аудио запис.

    Висок приоритет на процеса при запис – Програмата ще задава висок приоритет на своя процес по време на аудио запис.

    ? Подробното описание на следващите настройки/опции е сходно с поместеното по-горе *.

    Запис във файл *

    Излъчване в IP-мрежа - вж. по-горе . (доп., v.5.11) Ако е избран начин на запис «Microsoft ACM чрез DirectShow», за компресиране на поток е необходимо да се използва АСМ кодек за МР3 формат, например Lame MP3..

    Път за записвани файлове *- По подразбиране

    1 Шаблон за име на файл * ? Бутон [image] *

    Log *

    Разрешаване презапис на съществуващ файл *

    Раздробяване на Файл на сегменти по... *


Topic: Настройки за Видео/Аудио + АУДИО запис

Настройки за Видео/Аудио + АУДИО запис

Общи настройки на звук за ВИДЕО/АУДИО и АУДИО запис:

? Прозорецът за общи настройки се отваря при натискане на бутон [image] в лявата долна част на секция [image].

Този прозорец е общ за видео/аудио и аудио запис и настройките в него не се съхраняват в пресети.

  • «Устройство за аудио запис» -

    Избор на устройство за запис на звук при видео/аудио запис, както и само при аудио запис. Трябва да се избере тази аудио карта, към входа на която е включен аудио кабелът от изхода на тунера. Това устройство не се използва при запис на звук от чипсет (изм. и доп., v.5.11 v.~5.09 - SAA7134/35) по шина PCI (USB).

    Под (доп., v.5.11) Windows Vista / 7 избор на устройство за запис не е достъпен поради това, че устройство за запис се избира чрез Аудиомиксер за запис:

  • Група «Аудиомиксер за запис»:

    Настройките в тази група по никакъв начин не оказват влияние при запис на звук от чипсета (изм. и доп., v.5.11 v.~5.09 - SAA7134/35) по шина PCI (USB) и се използват само за режим на запис чрез аудио карта.

    Миксер за запис - Избор на системен аудиомиксер (ако в системата има няколко такива устройства). Трябва да се избира само тази звукова карта, към която е включен аналоговият кабел от ТВ тунера. При смяна на миксер се сменят достъпните линии за запис.

    (доп., v.5.11) Под Windows Vista / 7 избраният миксер се явява също така и устройство за запис.

    ? При натискане на бутон [image] «свойства» се показва стандартен прозорец с настройки на запис

    Активна линия за запис - Избор на линия на миксера за регулиране нивото на запис на звук.

    Избира се тази линия, към която е включен звуковият кабел от тунера. Обикновено това е Line-In или Analog Mix.


Topic: Екранни снимки

Екранни снимки

Меню за настройки на екранни снимки (Screenshots):

  • ? Подробните описания на основни групи/настройки/опции в този раздел имат принципно общи транскрипции при характерни индивидуални особености (в зависимост от тип/метод на запис) за още няколдо раздела.

    Описанията в такива раздели са в съкратен вид, но с препратки към разширени описания, които се намират в

    § Секция за настройки на АУДИО/ВИДЕО запис .

    Секции с принципно общи транскрипции са:

    §§ Настройки за АУДИО запис ;

    §§ Настройки за екранни снимки (Настоящият раздел)

  • Група «Пресети за снимки» -

    Списък с готови пресети за снимки, в които се намират предварително настроени конфигурации. Вж. по-горе * описание на пресети за видео/аудио запис.

    *

    *

  • Група «Настройки за снимки»:

    Формат на снимки – Избор на формат:

    § без компресиране – BMP, или

    § формати с компресиране – JPEG и PNG.

    & Формат JPEG компресира със загуби и има регулатор за качество -

    ! Колкото по-високо е качеството, толкова по-голям е размерът на файл!.

    & Формат PNG изпълнява компресиране без загуби.

    i Текущ размер на кадър – Геометричен размер на видеобуфера, който се използва в дадения момент при извеждане на видеоизображение.

    Получената снимка ще бъде със същите геометрични размери ако отметка [image] Ресемплиране в... е изключена.

    Ресемплиране в...

    – Ресемплиране на изходния размер на кадър в зададен размер по метод Lanczos3.

    Интервал за серия (s) – Задаване на интервал от време за режим «Серия от снимки»:

    1 ? Режим «Серия от снимки» – вж. по-долу Прозорец за предварителен преглед...

    Добавяне име на канал в името на файл - Добавя името на текущия ТВ канал към името на файла, състоящ се от- ?"времева отметка" "timestamp" „таймштамп” с данни за момента на снимане: година/месец/дата-час/минути/секунди.

    Път за файлове със снимки – ? Behold TV browser за избор на папка за разполагане на файлове със снимки.

    По подразбиране - [image] вж. по-горе .

    Внимание! Пътят за записвани файлове не се съхранява в пресети.

    i Информационен прозорец за обем на снимка при зададени параметри и оставащо свободно място на диск:

  • В прозореца за предварителен преглед на снимки (preview) може да се отвори

    2 контекстно меню за изпълнение на няколко действия:

    ? Менюто се извиква с десен клик на мишката в областта на този прозорец.


Topic: Модул за планирани задачи

Модул за планирани задачи

Behold TV – «Модул за планиране на задачи»

(рус.„Планировщик”, аналог. англ.„Scheduler”)

В програмата е интегриран модул, който е предназначен за стартиране и изпълнение на задания по потребителско разписание. Модулът работи само

  • при включена основна програма Behold TV или

  • при зареден и работещ във фонов режим модул «Behold TV Agent».

    Модулът за задачи може да бъде извикан на екран с натискане на бутон

    от основния панел за управление, или

    от едноименните редове в контекстните менюта за управление на основния видеопрозорец и иконката на Behold TV в трея (десен клик във видеопрозореца или върху иконката):

След планиране на всички задания програмата Behold TV може да бъде свита в трея, където остава в режим на очакване. Ако Behold TV е стартирана с ключ от командния ред -r: (запис), планирани задания няма да бъдат изпълнявани докато не приключи запис.

По време на работа на модула на екран може да бъде изведена кратка справочна информация за текущо изпълнявана задача без да е необходимо да се отваря основният видеопрозорец или прозорец на модула за задачи, ако това не е необходимо. Това се извършва с позициониране на курсора на мишката върху иконката в трея.

Бутоните в долната лява част на основния интерфейс на модула са предназначени за изпълнение на команди и отваряне на други системни прозорци [image]:

Добавяне на нова задача

Промяна на име

Премахване на избрано задание

Такова действие не може да бъде извършено за текущо изпълнявана задача (докато не бъде отменена), за което програмата издава "балонно" предупреждение

Премахване на стари задания

Премахване на всички задания

Контрол за кръстосани задания

отваряне на прозорец « Настройки на модула за планирани задачи ».

По подразбиране след инсталиране списъкът със задания е празен. Добавяне на ред със задание се извършва с натискане на бутон [image] Добавяне на нова задача.

В дясната част на основния прозорец на модула се задават съответните предвидени параметри (трябва да бъдат съхранени преди изход или преминаване към следваща задача):

  • «Включване на задание» - потвърждение за предаване на настроено задание за изпълнение с отметка. По аналогичен начин съответна задача може да бъде изключена.

    Бутони [image] - едноименни действия за дадено задание.

  • Група «Време за стартиране»:

    задаване на час, минути,

    дата и

    ден от седмицата за стартиране на задача.

    С бутон [image] за удобство се задават текущо време и дата.

  • Група «Време за завършване»:

    време за край (час, минути). Автоматично се извежда контролна информация «Продължителност на задание», въз основа на която при запис и таймшифт може да бъде преценен необходим дисков обем за файл(ове) (вж. също така "Настройки за запис"!).

  • Група «Параметри на задание»:

    Планирани задания в модула могат да бъдат три типа:

    Тип на задание -

  1. Задания, които активират тунера в зададено време за гледане на телевизионна- или слушане на радиопрограма - «Гледане».

  2. Задания, стартиращи режим таймшифт - «Таймшифт».

  3. Задания, изпълняващи запис на телевизионна- или радиопрограма - «Запис».

За всеки отделен «Тип на задание» се избира

- режим на работа на тунера и

- съответен канал, към който тунерът да се превключи при изпълнение на заданието:

Избор на режим - режим на работа на тунера (TV, FM, (изм., v.5.11) А / V (~v.5.09 -VHS, S-VHS)).

Избор на канал - име на ТV канал / Радиостанция от "падащи" списъци в зависимост от съответния режим, към който тунерът да се превключи при изпълнение на заданието.

При избор на ред [image] за ТV канал / Радиостанция, задание ще се изпълнява за текущ или за активен в момента на завършване на работа с програмата канал.

  • Група «Параметри на задание за запис»:

    За задания тип «Запис» допълнително се указват

    Режим на запис -

    Пресет за зареждане на настройки за запис -

    При избиране на ред [image] за пресет за запис ще се изпълнява запис в съответствие с текущите настройки за запис в [image] «Панел за запис».

    Шаблон за име на файл - В модула е предвидено да могат да бъдат използвани макроси при задаване на шаблон.

    Шаблонът за име на файл може да включва всякакъв набор от допустими в имена на файлове символи, както и макроси , при което в името на файла ще се вмъкват дата, време, име на TV-канал, име на TV-програма и др. предопределени от съответния макрос елементи.

    Шаблонът трябва да съдържа само име на файл БЕЗ указания за път и БЕЗ разширение.

И трите типа задания имат ограничения за изпълнение по време. Максимално време за изпълнение на едно задание е 24 часа. Около 15 сек. предварително „изплуваща” подсказка оповестява за завършване на заданието (за WIN'98 вж. забележките в края).

Времето за завършване, както и избрано резултативно действие при завършване на задание могат да бъдат променяни непосредствено в процеса на неговото изпълнение. За това е необходимо да се отвори модулът за планирани задачи, в настройките на който за изпълнявано текущо задание ще са достъпни за изменения само параметрите за време на завършване на задание и действия след неговото изпълнение (вж. скрийншот-а).

Времето за започване и спиране на задание (съответно в посока намаляване или увеличаване) може да бъде автоматично коригирано с определена величина (вж. « Настройки » на модула). Ако зададеното време за започване на поредно задание се застъпва с интервала на изпълнение на предишно задание или съвпада с времето за неговото завършване, то поправката за време на спиране/започване се игнорира или се отчита частично (разчет за време се извършва фактически - в реално време).

Всякакви задания могат да бъдат както еднократни, така и периодични, т.е. с период на изпълнение един или няколко пъти седмично. Периодични задания нямат дата на изпълнение.

  • Група «Действия след изпълнение на задание»:

    При завършване на задание модулът за планирани задачи може да изпълнява ред от избрани действия:

    Свиване на приложението в tray за изчакване започване на следващо задание.

    Завършващо действие:

    Изход от програмата. В този случай за да бъдат изпълнявани останалите задания е необходимо да работи модул «Agent Behold TV».

    Активиране «Режим на очакване» в Windows (Suspend).

    Активиране «Режим на заспиване» в Windows (Hibernate). Ако «Режим на заспиване» е изключен или не се поддържа от системата, то компютърът ще преминава в «Режим на очакване» на Windows (Suspend).

    Внимание!

    За да може системата коректно да излиза от режими Hibernate или Suspend е необходимо в настройките на «Windows» > «Control Panel» > «Power Options» > «Advanced» да бъде свалена отметка за потвърждение с парола при изход от режим на очакване. В случай, че е спрян Windows-сервис «Съвместимост за бързо превключване на потребители», тази отметка няма да работи и потвърждение при вход няма да се извършва.

    В режими Hibernate и Suspend също така е недопустимо изключване на захранването на компютъра от мрежата.

    Изключване на компютъра.

    Внимание! От изключено състояние системата може да следи и да стартира планирани задания само за тунери с технология ARPC .

Всякакви изменения на параметри за задания трябва да бъдат съхранени с натискане на бутон [image]. Ако това не бъде направено се извежда напомнително съобщение

Зададени задачи могат да бъдат филтрирани по дни от седмицата. За това служат секциите с имена Понеделник ... Неделя (Пн...Нд, рус."Пн"..."Вс").

Секцията със знак "[!]" е предназначена за контрол на списък със задания по отношение наслагване ( [image] . по-долу аналог.: припокриване, кръстосване) едно върху друго по време на изпълнение. В случай, че бъдат намерени такива задания:

............

  • (изм. и доп. р.) програмата извежда "балонно" предупредително съобщение над иконката на Behold TV в трея (вж. по-горе "Контрол за кръстосани задания") и активният прозорец ("понеделник"~"неделя" / "всички") се прехвърля към секцията.

  • Ако в текущия момент се изпълнява кръстосано задание, самата иконка също се променя с предупредителна индикация за наличие и тип на задачата (в примера "REC" (Record) - задание за запис и параметри за завършващо действие припокриват по време друго задание).

По-подробна информация за текущо изпълнявана задача може да бъде изведена на екран при позициониране на курсора на мишката върху иконката, при което се показва "балонен" тип информационен прозорец.

В използвания пример задача за запис от FM радио е зададена за изпълнение по време, в което се изпълнява друго планирано действие - гледане на аналогов ТВ канал и двете задания се припокриват. Задачата за запис ще спре изпълнението на тази за гледане в съответствие с по-високия си приоритет (вж. по-долу).

............а

  • Показва се списък със задачи и в поле «Кръстосване» (рус.«Пересечения») ще бъдат отметнати индексите на задания, които имат общи пресечни точки:

Такива задания трябва да бъдат коригирани, изключени или премахнати! В противен случай част от тях няма да могат да бъдат изпълнени изцяло или ще се изпълнят частично.

Покриващи се по време на стартиране и изпълнение задания се изпълняват в съответствие със зададен приоритет:

»»» Запис

»» Таймшифт

» Гледане

Това означава, че

» Гледане на ТВ може да бъде прекъснато във всеки момент от задание, включващо таймшифт или запис.

»» Пуснат ръчно или като планирано задание Таймшифт може да бъде прекъснат от задание, активиращо запис.

»»» Пуснат ръчно или като планирано задание процес на Запис може да бъде прекъснат само ръчно или спрян от самото задание при изтичане на времето на същото.

От две задания за «Гледане» на едно ниво е приоритетно второто задание,

при «Таймшифт» и «Запис» - първото.

По същия начин, ако има две задания за «Запис» с припокриване по време на изпълнение, второто задание няма да се стартира, докато не бъде напълно завършено първото.

Аналогично, програмирано задание за «Запис» няма да започне да се изпълнява, ако в дадения момент се извършва ръчно стартиран запис.

Прекъснато задание се счита за отменено. По същия начин дадено задание се отбелязва като «отменено», ако:

  • В модула е бил натиснат бутон [image]. В този случай модулът губи контрол върху по-нататъшно изпълнение на задание, но самото стартирано действие (Запис, Таймшифт) не се отменя.

  • При изпълнение на задание «Гледане» е бил пуснат запис или включен «Таймшифт».

  • При изпълнение на задание «Таймшифт» е бил натиснат бутон «Спиране на Таймшифт».

  • При изпълнение на задание «Запис», самият запис е бил спрян ръчно.

  • Програма Behold TV е била затворена (изключена) по време на изпълнение на задание.

Отменено задание винаги може да бъде възстановено чрез натискане на бутон [image] в прозореца на модула. Ако времето за изпълнение на заданието не е изтекло, отмененото действие ще бъде пуснато отново.

Внимание! За периодични задания диспечерът на модула автоматично ще свали статуса «Отменено» и ще възстанови заданието след изтичане на времето, след което текущото задание трябва да завърши.

При промяна и съхранение на параметри на задание, ако такова е имало статус «Отменено», то неговия статус няма да се измени. В този случай заданието трябва допълнително да бъде възстановено с натискане на бутон [image]. При изтичане на времето за изпълнение статусът на отменено задание се сваля автоматично.

Ако задание е със статус «Изключено», то никога няма да бъде изпълнено и няма да бъде проверявано за кръстосвания.

Изпълнено, както и изтекло по време на завършване еднократно задание се отбелязва в списъка на модула като остаряло. Периодични задания със седмичен цикъл не могат да бъдат „остарели”.

Модулът за планирани задачи може да изпълнява задание, ако до времето на неговото завършване остават повече от 30 сек. Това означава, че модулът няма да пропусне задание дори ако времето за неговото пускане вече е минало.

Внимание! Ако до пускане на задание е бил ръчно зададен таймер за изключване, всякакво задание на модула при старт на заданието ще анулира таймера. Повторно ръчно задаване на таймера за изключване го активира. Ако таймерът за изключване сработи по-бързо, отколкото завърши заданието, даденото задание ще бъде отменено. Ако бъде отворен прозорецът на модула и се съхранят параметри на изпълнявано задание, то таймерът за изключване отново ще бъде анулиран.

Модулът за планирани задачи има свои собствени настройки , които могат да бъдат изведени на екран в отделен диалогов прозорец.

Забележки:

1. Win98 * не поддържа т.н.„балонни” подсказки.

2. Поддръжката на Win98 * е прекратена от Microsoft през м. Юли 2006 г.

3. (доп. р.) Поддръжката на Win98 * за Behold TV е прекратена в универсалния драйвер - версия 5.1.5.0 от м. Юли 2010 г.

The contents of Модул за планирани задачи

Настройки
Макроси


Topic: Настройки

Настройки

Настройки на модула за планирани задачи

Извикване на отделен диалогов прозорец за настройки се осъществява с натискане на бутон [image] от основния екран на модула за планирани задачи.

  • Група «Параметри на задание»:

    Автокорекция за старт и завършване на задание (-/+ мин.) – при необходимост дадена задача да може бъде стартирана по-рано и да спряна по-късно от планираното време със зададено време за корекция.

    Презапис на съществуващ файл при изпълнение на задание - Ако създаван от модула файл вече съществува на зададената дестинация за съхранение на файлове, този файл ще бъде презаписан. В противен случай към името на новия файл ще бъде добавено поредно число. За да се изключи дублиране на файлове с еднакви имена в шаблона за име на файла е необходимо да се използват макроси за време.

  • Група «Уведомяване»:

    Уведомяване преди старт на задание - При активирана опция, преди стартиране на каквото и да е задание модулът ще извежда уведомителен прозорец с описание на заданието и възможност то да бъде отменено ръчно. Уведомяването е с обратно броене, при изтичане на което заданието се пуска автоматично. Уведомителният прозорец задържа изпълнение на задание с 10 сек.

    Уведомяване за задания преди завършване на Windows-сесия - Ако в списъка на модула са останали някакви неизпълнени задачи (периодични седмични задания в този случай винаги се считат за неизпълнени), при изключване на компютъра модулът ще напомни за това с уведомяване в прозорец. Потребителите могат в течение на 15 секунди да откажат изключване на компютъра. Прозорецът за уведомяване на модула ще бъде игнориран от операционната система, ако изключването на компютъра е било генерирано от режим за форсиране на някакво друго приложение.

  • Група «Настройки по подразбиране при създаване на ново задание» -

    - настройки, които да се прилагат като параметри при създаване на произволно ново задание така, както са зададени по подразбиране в модула:

    Тип на задание

    Режим на запис

    Пресет за зареждане на настройки за запис.

    Ако избран по подразбиране пресет по някакви причини повече не съществува, вместо този параметър ще бъде избран ред <Не е избран> и при запис ще бъдат използвани текущи настройки на «Панел за запис».

    Шаблон за име на файл - В модула е предвидено да могат да бъдат използвани макроси при задаване на шаблон.

    Завършващо действие:

    Свиване на приложението в tray - Избор на завършващо действие.


Topic: Макроси

Макроси

Използване на макроси при задаване на шаблон

С нарастване на обема на потребителски файлове стават актуални въпросите за наименования на файлове и организиране на система от каталози и подкаталози за съхранение с цел по-лесна идентификация за бързо и лесно търсене. При боравене с файлове (особено в големи по структура и обем архиви), логиката при даване на имена на файлове и организацията на библиотеки е от съществено значение за класифициране и подреждане на файлове в каталози и подкаталози. Това е от изключително значение особено за "документални" файлове с видеозаписи на материали, за които е важно да се знае време на излъчване/запис, източник и пр.; камери за наблюдение от охранителни системи и др. Behold TV дава възможност името на записан файл да съдържа информация за

  • време на запис (година, месец, дата, ден от седмицата) в различни формати за представяне;

  • час-минути-секунди-милисекунди;

  • зададено име на запис (задача) за изпълнение;

  • вид на източник (TV, FM Radio, DVB-T TV, DVB-T Radio, AV CVBS, AV Y-C);

  • име на източник - канал/радиостанция/AV вход;

  • ТВ справочник.

При използване на шаблони този процес е достатъчно улеснен с предвидените за целта макроси.

Прозорецът за избор на макрос се извиква с натискане на бутон [image] в група «Стойности по подразбиране при създаване на ново задание» - до настройка «Шаблон за име на файл»:

В модула се поддържат 15 типа макроси, които позволяват гъвкаво да бъде зададен шаблон за име на файл за запис.

За облекчение при въвеждане на макроси, с двоен клик по необходимия ред може да бъде извикан диалог с подсказки от който да се избере макрос за вмъкване в съответния ред.

  • Макрос %channel% връща "_" (празно) при работа в режими (изм., v.5.11) А / V (~v.5.09 -VHS и S-VHS).

  • Макрос %tvguide% връща "_" (празно) ако не се използва режим ТВ или програма на ТВ-предаване отсъства или е остаряла. Максимална дължина на реда при обработка на този макрос се задава в настройките на модула за планирани задания.

    Внимание! Име на ТВ програма се изтегля от базата с ТВ програми по време на стартиране, указано в заданието.

    Пример: при задаване на шаблон във вид

    %mode%-%channel%(%yy%mm%dd%hh%nn%)%tvguide%

    той ще се конвертира в името на файла:

    "TV-Boomerang(1007182050) 'футбол' (DV".

    Разширение в името на файл се добавя автоматично, в зависимост от избрания тип на запис.


Topic: Електронна програма на предавания

Електронна програма на предавания

Behold TV – Модул «Програма с ТV-предавания»

Софтуерният комплекс Behold TV съдържа интегриран модул, който позволява да се извежда на екран текущо предаване, процент на изминало време от началото, име на програмата и друга полезна информация в контекстното меню със списък на канали.

Диалоговите прозорци на модула дават възможност за преглед на справочник с предавания за всеки канал, както и да се работи с желано предаване във функционално обособения « Модул за планирани задачи ».

Програма с предавания може да бъде извикана на екран от едноименните редове в контекстните менюта за управление на основния видеопрозорец или на иконката на Behold TV в трея ( [image] десен клик във видеопрозореца или върху иконката):

При смяна на канал в долната част на прозореца автоматично (в зависимост настройките на опция [image] «Изключване на автоматично показване на ТВ програми в OSD») се изобразява OSD-блок (On Screen Display) със сбита, но съдържателна информация за:

  • номер и наименование на канал с текущо предаване;

  • текущо време, (процент на изминало време от началото) на предаване;

  • наименование на текущо предаване;

  • цифрова и графична информация (лентова диаграма) за начало и край на предаване.

    При необходимост показване на този блок може да бъде изведено отново или да се покаже следващо или предишно предаване (вж. настройки на клавиши за управление).

    Кратка информация за предаване в канал се извежда и в "балонно" съобщение при насочване на курсора на мишката върху иконката на основното приложение в трея:

The contents of Електронна програма на предавания

1. JTV
2. EPG
3. Настройки


Topic: 1. JTV

1. JTV

1. ТВ Програма (формат JTV)

Програма с предавания в Behold TV се зарежда от файлове с бази данни във формат JTV. Базите могат да се обновяват през Интернет (ръчно или автоматично) от приложение « Агент BeholdTV ». Заредена база данни се визуализира в съответните секции на прозорец «Програма с предавания» -

  • ТВ Програма (формат JTV) за аналогова телевизия, и

  • DVB EPG за цифрови канали.

Ново! При липса на EPG или по желание на потребителите базата данни във формат JTV може да бъде използвана за (вместо) EPG. Опцията е валидна при актуализиране на Behold TV от версия 5.17. За подробности и настройки вж. раздели EPG и Настройки .

  • Файл на ТВ-програма – Свързване на файл от база данни на ТВ програма към избран канал. Файл може да се свърже чрез [image] клик с десния бутон на мишката по избран канал и в контекстното меню да се избере необходим файл.

    (изм..v.5.11) Актуализация: В интерфейса от v.5.17

    има промени спрямо предишни версии:

    По този начин избор на файл за свързване може да бъде избран от "падащ" списък, който се извиква в едноименния прозорец с бутон [image] за поканално свързване на файл към селектиран канал:

    Респ. са променени функционалните бутони и свързаните с тях действия. С бутоните може да се извърши автоматично търсене/свързване/премахване на връзки за файлове от базата с ТВ-програми към всички съществуващи канали.

    «Да се изпълни автотърсене и свързване на подходящ файл от базата»

    «Да се изпълни автотърсене и свързване на файлове с бази по всички канали»

    «Премахване на препратки към файлове с бази по всички канали»

    При натискане на бутон с изображение на верига [image] ще бъде изпълнено търсене на файл от базата данни по въведени няколко символа от името на канал в името на файл на ТВ програма.

    За коректно автоматично свързване на файлове от БД към съответни канали е необходимо в името на последните да има символен низ, който да кореспондира с името на файл, по примера на горния screenshot: канал БНТ1 се асоциира с файл от БД БНТ1.ndx. Иначе казано - за правилно асоцииране е добре за канали да се задават имена (и разширения) по наименования на файловете в БД. Така например, ако има само един канал с име "Discovery", а в БД три файла с програми - "Discovery Channel", "Discovery World" и "Discovery Science" програмата няма как да асоциира съответния файл с канала. Разбира се, такова асоцииране може да бъде направено ръчно по описания по-горе начин.

  • Корекция на време (минути) – Опцията е предназначена за синхронизиране на часови пояс за текущия регион спрямо БД с програми, която е правена за друг часови пояс.

    В съседство се изобразява време за корекция в часове и минути, както и бутон [image], с който тази корекция може да се приложи за всички канали.

  • Контекстен филтър - Опция, която позволява филтриране (само за удобство при гледане) на списък с програми по зададен контекстен ред. Филтрацията се извършва динамично в процеса на набор на текст. В списъка ще бъдат изобразени програми на предавания, в които присъства стринг от дадения ред.

    При активен филтър редовете от списъка за удобство са оцветени в червен цвят.

  • - Команда от контекстното меню, с която може да се добави избрано предаване във вградения модул за планиране на задачи във всеки достъпен режим на работа. Добавено задание може да бъде прегледано при отваряне на посочения модул. След добавяне на задание се препоръчва да се провери в модула за наличие на „кръстосани” задания.

  • С бутон [image] се извиква модул « Агент BeholdTV » и към същия се предава команда за изпълнение на ръчно зареждане и обновяване на бази с ТВ програми.

Забележки:

  • При избор на необходим ден от седмицата в група понеделник...неделя, в списъка ще се показват данни само за текущата седмица (в зависимост от текущата дата).

  • При избор на опция «Всички» ще бъдат показани всички данни в БД, независимо от текущата дата (както остарели, така и все още неактуални).


Topic: 2. EPG

2. EPG

2. DVB EPG

EPG (Electronic Program Guide) представлява Електронна База Данни за телевизионни- и радио програми, която се предава в състава на транспортния поток на избран транспондер.

Базата данни с програми се попълва автоматично (във фонов режим) от транспортните потоци и се съхранява в паметта на Behold TV, дори ако тунерът бъде превключен в аналогов режим или настроен на друг транспондер. Behold TV пази списъци с телевизионни и радио програми за всеки транспондер, към който тунерът е бил настройван.

При изход от Behold TV списъците с програми на предавания ще бъдат загубени, но при следващо стартиране на приложението и превключване на тунера в DVB режим, EPG данните ще започнат отново да се попълват.

Ако при избор в списъка на DVB канал таблицата с предавания е празна, значи за съответния канал (ONID / TSID / SID) в транспортния поток не се предават EPG-данни. Понякога за някои канали EPG-данни се предават във вид на денонощни „заглушки” - списъкът с предавания се състои само от 2 реда - «Current» и «Next» с продължителност 24 часа.

  • Корекция на време (минути) – В базата данни EPG времето за начало на предаване винаги се указва по Гринуич (GMT). Приложението Behold TV автоматично привежда GMT към регионално време с отчитане на преход към летен/зимен период. Тази опция позволява допълнително да се въведе корекция по време за всеки отделен DVB канал.

    В съседство се изобразява времето за корекция в часове и минути, както и бутон [image] , с който дадена корекция може да бъде приложена за всички канали.

  • Контекстен филтър – вж. по-горе

Забележки:

  • При избор на необходим ден от седмицата в група понеделник...неделя, в списъка ще се показват данни само за текущата седмица (в зависимост от текущата дата).

  • При избор на опция «Всички» ще бъдат показани всички данни за EPG, получени от транспортния поток за дадения сервис, независимо от текущата дата (както остарели, така и все още неактуални).


Topic: 3. Настройки

3. Настройки

3. Настройки на модула

  • «Папка с файлове-бази на ТВ програми» - Определяне на местоположение за файлове от базата данни с ТВ-програми във формат JTV.

  • Група «Програма в OSD»:

    Изключване на автоматично показване на ТВ програми в OSD - Забранява показване в OSD-блок с ТВ програми и EPG при смяна на канали.

    Извеждане на съобщение ако ТВ програма не е намерена или е остаряла - Ако базата данни с ТВ програми е остаряла или не е намерен файл от свързана програма, ще се издава последващо съобщение.

    Ново! При липса на EPG или по желание на потребителите базата данни във формат JTV може да бъде използвана за (вместо) EPG с активиране на опция

    Използване на ТВ-програма JTV вместо EPG за DVB ТВ-канали

    Опцията е валидна при актуализиране на Behold TV - версия 5.17.

  • Група «Параметри»:

    Показване на ТВ програма в менюто с канали - Показва име на текущо предаване и изминал процент време в контекстното меню на каналите.

    Може да се зададе максимално количество на символи от текст на програма, което да се показва в менюто [image].

    Дължина на макроподложки %tvguide% в име на файл (макроподложки - рус. "макроподстановки") - Ограничава дължината на ред при обработка на макрос %tvguide% с описание (име) на предаване, което да се включва в името на записван файл.

    Възможно е задаване на максимално количество символи в текст [image].

    Показване на Нов ден от седмицата от сутринта (X часа) в списъка - При преглед на списък с предавания по дни от седмицата, за удобство се показва началото на почасово излъчване в избраното време.


Topic: Агент BeholdTV

Агент BeholdTV

«Агент Behold TV» представлява самостоятелно обособено приложение ( [image] модул, съкр. само «Агент») в състава на комплексния софтуерен продукт Behold TV - собствена фирмена разработка на компания Beholder, предназначена за работа с телевизионни PC-тунери Behold ТV.

Модул «Агент» е предназначен за:

  • Стартиране на основното приложение Behold TV от пулта за ДУ;

  • Стартиране на Behold TV в зададено време за изпълнение на предварително планирани задачи от интегрирания модул за планиране на задания. При това Агент Behold TV може да възстановява системата от "спящ" режим (Hibernate) и от режим на „изчакване”;

  • Зареждане и обновяване на бази с ТВ Програми във формат JTV - ръчно или в автоматичен режим.

Първо стартиране:

«Агент» първоначално се стартира отделно (ръчно) от съответната папка в основната директория, в която е инсталирана програмата

(по подразбиране [image] [image] файл BhAgent.exe):

Ако в собствените настройки на модул «Аgent» - секция « Настройки » се зададе опция за автозареждане -

«Зареждане на «Аgent» при старт на Windows», по-нататък не е необходимо ново ръчно стартиране.

При стартиране модулът се визуализира като мини-иконка в системния tray:

Диалогов прозорец за извеждане на основния интерфейс на модула се отваря с [image] десен клик върху иконата в трея

и съдържа следните командни редове*:

«Behold TV» - стартиране на основното приложение.

«Настройки» - отваряне на основния диалогов прозорец на «Агент Behold TV».

*Забележка: При първо стартиране интерфейсът е с настройки по подразбиране - на руски език:

За [image] интерфейс - вж. по-долу ;

«Обновить базы»=«Обновяване на базата» - вж. по-долу «...зареждане и обновяване на бази...»;

«Выход»=«Изход».

The contents of Агент BeholdTV

Български интерфейс
1. ТВ Програма
2. Настройки
3. Информация


Topic: Български интерфейс

Български интерфейс

«Агент Behold TV» - български интерфейс

Напомняне: Модул «Agent BeholdTV» използва общ езиков ресурсен файл за целия комплексен софтуер Behold TV, който трябва да е инсталиран по описания в основната инструкция начин.

Езикови настройки за потребителски интерфейс могат да бъдат променяни в секция

« Настройки » [image] «Выбор языка»=« Избор на език ».

Видим индикатор за коректни настройки и инсталиран [image] езиков ресурсен файл (респ. съответен друг чужд език) са имената на дните от седмицата в "падащото" меню «День недели для обновления»=«Ден от седмицата за обновяване»

и опция за избор на български език в секция « Настройки »

Промени в интерфейса се отразяват и визуализират в прозореца веднага - без рестарт на модула или основната програма.


Topic: 1. ТВ Програма

1. ТВ Програма

1. Секция за настройки на зареждане и обновяване на бази с ТВ Програми:

  • Група «Настройки на URL»:

    "Падащ" списък с URL-адреси за зареждане на архив с бази на ТВ програми от Интернет-мрежата. Първият URL в списъка е текущ и се използва от «Агент» по подразбиране за зареждане на бази.

    При неправилно зададен (липсващ, невалиден...) адрес/файл модулът издава предупредително съобщение, че обновяване не може да бъде извършено:

    Ръчно обновяване на бази:

    При натискане на бутон «Старт!» се зарежда БД ("База Данни") от съответния избран

    URL-адрес в прозореца на група «Настройка на URL» (вж. също така [image] «Показване на процеса» по-долу). При повторно (случайно или принудително) зареждане програмата издава предупреждение с "обратно броене" в продължение на 10 секунди с опция за отказ (по подразбиране) от ново зареждане,

    като форма за предпазване на вече налична БД от презапис и икономия на интернет-трафик.

    За да бъде добавен URL в списъка трябва да се въведе съответен адрес и да се потвърди с Enter. Ако това се извършва върху (на мястото на) друг (съществуващ) адрес, програмата предлага две възможности:

    - добавяне на нов URL (със запазване на този, върху който е редактирано), или

    - промяна (редактиране) на адреса, върху който се работи -

    За да бъде премахнат URL трябва да се изтрие съдържанието на съответния ред и да се потвърди с Enter.

Внимание: «Агент» поддържа само преки препратки към архиви във формати .RAR и .ZIP

Ако за URL е въведена препратка без файл или препратка към html страница, то при ръчно изпълнение на

команда «Обновяване на базата»/«Update TV Guide» -

( [image] десен клик върху иконката «Agent BeholdTV» [image] в tray)

«Агент» ще отвори Internet browser* [image] по посочената препратка и ще завърши работа, като се предоставя възможност за ръчно изтегляне на бази с ТВ-програми.

Обикновено съставителите на бази с ТВ-програми във формат JTV обновяват архивите с бази в своите Интернет-сайтове веднъж седмично. Някои оператори на бази променят името на файл за препратка всяка седмица, или добавят различни идентификатори - най-често дата за начало на период, са който е актуална съответна БД.

За автоматизиране на процеси за зареждане на файлове от такива препратки, в модула могат да бъдат използвани т.н. макроподложки (рус."макроподстановки") в URL-адрес.

Внимание: За всеки URL се допуска използване на не повече от една макроподложка. Текущата версия на модула поддържа три типа макроподложки:

  1. Макроподложка Date <Допустим формат на дата>, където за допустим формат на дата могат да се използват букви d, dd, m, mm, yy, yyyy:

    Буква d поставя ден без водеща нула,

    букви dd поставят ден с водеща нула,

    буква m поставя месец без водеща нула,

    букви mm поставят месец с водеща нула,

    букви yy поставят двузначна година,

    букви yyyy поставят четиризначна година.

    Максимална дължина - 16 символа.

    Пример: препратка .../bases/moscow9102005.zip може всяка седмица да се изменя и да сменя датата в името на файла. За да може да бъде автоматизиран процесът на зареждане на такива препратки, за URL трябва да се посочи .../bases/moscow<dmmyyyy>.zip. В този случай Агент Behold TV сам ще може да намира и зарежда файл по тази препратка.

  2. Макроподложка Padding [xxx...], където за x се поставя която и да е буква или цифра.

    Максимална дължина - 10 символа.

    Агент-ът ще нараства дадения ред от x символа от ляво на дясно, започвайки от празно място.

    Пример: при препратка .../jtv[06b3g]5.zip ще бъдат прехвърлени файлове с имена jtv5.zip, jtv05.zip, jtv065.zip, jtv06b5.zip, jtv06b35.zip, jtv06b3g5.zip.

  3. Макроподложка Replacement {xxx...}, където за x се поставя която и да е буква или цифра.

    Максимална дължина - 10 символа.

    Агент-ът ще прехвърля дадения ред от x символа, като замества последователно всеки символ.

    Пример: при препратка .../jtv{06b3g}5.zip ще бъдат прегледани файлове с имена jtv05.zip, jtv65.zip, jtvb5.zip, jtv35.zip, jtvg5.zip.

  • Група «Планиране на обновяване» - включване и настройки на автоматично сваляне и обновяване на бази.

    Важно [image] За безопасност и икономия на интернет-трафик, «Агент» никога няма самостоятелно да се включва към Интернет. Модулът ще се опитва да сваля файлове само при наличие на активно съединение.

    Включване на автообновяване - включва автоматичен режим на «Агент» за проверка, сваляне и разархивиране на бази програми в зададено време.

    Ден от седмицата за обновяване – Избиране на ден от седмицата, в който «Агент» да прави опит за сваляне на нова база:

    Разрешен период от време – Избиране на интервал от време за ден от седмицата, в който на «Агент» е разрешено да сваля ъпдейт. В случай, че зададено начално време е след крайното такова, на «Агент» ще бъде разрешен интервал в течение на следващия ден, до зададеното крайно време.

  • Група «Параметри за обновяване»:

    Показване на процеса на зареждане - Извеждане на информационен прозорец за статус и напредване на процеса при сваляне на файл:

    При успешно протичане на процесите се издава потвърждение с "балонно" съобщение

    над иконката в systray

    Оставяне на архивен файл - След разархивиране на база с ТВ-програми да не се премахва свален архивен файл.

    Извличане без подкаталози - Разархивиране на база с ТВ-програми без включени подкаталози. Ако архивът съдържа включени папки, «Агент» ще разархивира всички файлове в основната папка, определена за бази с на ТВ-програми, като при това се игнорира йерархична структура на подкаталози в архива.

    Автоповторение-мин. - Интервал за повторни проверки при неуспешен опит за съединение с интернет и/или сваляне на файл. След зареждане на «Агент» и в случай, че

    - избраният ден от седмицата и разрешен интервал от време удовлетворява текущото време, както и

    - ако от времето на последно обновяване са изминали повече от 6 дни, и

    - при условие, че има активно Интернет-съединение, след зададеното време в минути модулът ще направи първи опит за сваляне на файл от зададения адрес.

    Log файл (кВ) - Максимален размер на log-файл, след достигане на който воденият log-файл ще бъде презаписан наново.

*Важно: По подразбиране «Агент» работи с настроени параметри за Интернет-съединение за MS Internet [image] xplorer. Ако в Windows е зададен друг предпочитан browser, за същия трябва да бъде настроен съответен тип на свързване (...«Control Panel»>«Properties»>«Connection»). При некоректни настройки от такъв характер «Агент» няма да може да се свързва към интернет и да работи поради независещи от програмния модул обстоятелства (настройки)!


Topic: 2. Настройки

2. Настройки

2. Секция за общи настройки:

  • Група «Общи настройки»:

Зареждане на «Аgent» при старт на Windows - Зарежда стартиране на «Агент» в автостарт (Startup) на Windows.

Очакване на събития от модула за планирани задачи в Behold TV за пускане на задания – Използване на «Агент» за да може чрез него да се стартира основното приложение Behold TV за изпълнение на планирани задачи от вградения модул за задания. Ако системата се намира в режими «заспиване» или «очакване», модулът самостоятелно ще активира системата преди стартиране на Behold TV.

Стартиране на Behold TV с двоен клик по иконката в tray – Стартиране на основното приложение Behold TV с двоен клик на мишката по иконата на «Агент» в системния tray. Ако опцията не е активирана се отваря панелът за настройки на модула.

Очакване за натискане на «Power» от пулта ДУ за старт на Behold TV – Използване на «Агент» за да може модулът да стартира основното приложение Behold TV с натискане на бутон Power на пулта за ДУ. В случай, че се използва „чужд” пулт за ДУ, «Агент» ще стартира приложението при натискане на бутон от този пулт, ако бутон от същия е определен за включване захранването на компютъра (вж. «Управление на захранване»).

За стартиране на Behold TV трябва кратковременно да се натисне и отпусне съответният бутон.

Команден ред за пускане на Behold TV от ПДУ - При стартиране на приложението Behold TV от пулта за ДУ, «Агент» може да предаде на приложението параметри чрез ключове от командния ред. В този ред могат да се задават допустими ключове, списък на които е посочен в разширената помощна информация.

Избор на език – Избор на език за интерфейс на «Агент»:

Приоритет на «Аgеnt» - Задаване на приоритет на основния процес на модула:


Topic: 3. Информация

3. Информация

3. Информационна секция:

(доп., v.5.17) При насочване на курсора на мишката върху иконката в tray [image] се извежда информация във вид на "балонно" съобщение

за моментно използван профил и статус на модула.


Topic: Съвети при видеозапис

Съвети при видеозапис

(отп.,v.5.17) Съвети при видеозапис, свързани с:

  • използване на различни видове кодеци ;

  • особености при видео/аудио запис;

  • поддръжка/ограничения от страна на операционната система .

The contents of Съвети при видеозапис

Кодеци
Видео / Аудио
Windows


Topic: Кодеци

Кодеци

За кодеците...

( [image] вж. също «Функции и настройки» [image] «Видеозапис» [image] « Кодеци »)

The contents of Кодеци

AVI
WMF


Topic: AVI

AVI

Microsoft AVI

  • Болшинството AVI видео кодеци в състава на пакет Microsoft DirectX са предназначени за пост-обработка на готово видео и са слабо пригодни за работа в режим на реално време. Повечето от тези кодеци не поддържат YUY2 и RGB24 видео формати.

  • Широко разпространеният кодек DivX също не е подходящ за компресиране на ефирно видео в реално време. За неговото използване е желателна предварителна обработка на видеоматериал за премахване на шум. Високочестотен шум много трудно се поддава на компресиране от този кодек и общото качество на изображение след компресиране при фиксиран битрейт е неудовлетворително.

  • Microsoft DirectX и DivX кодеци могат да бъдат използвани за окончателно компресиране на видео с помощта на програми като Virtual Dub .

Ако целта е да се получи видео с високо качество, запис трябва да се прави или без компресиране, или с малък коефициент на компресия за намаляване на потока данни.

  • Най-подходящ за такива цели е lossless кодек Huffyuv 2.2.0 , който е базиран на алгоритъма на Хафман, компресира без загуби и осигурява идеално качество на изображение. Кодек Huffyuv компресира с коефициент само 2~3, в следствие на което се формира поток от данни с обем 10~15 МВ/сек. Т.к. не всеки HDD може да записва подобен обем информация без пропускане на кадри, за компресиране без загуби се препоръчва използване на дискове с честота на въртене не по-малка от 7200 RPM или да се използва IDE RAID масив.

  • Ако HDD не позволява да се записва поток с висока скорост, може да се опита да се използват Motion JPEG кодеци - Morgan MJPEG , PICVideo MJPEG или MainConcept MJPEG . С тези кодеци може да се получи високо качество на изображение при сравнително нисък поток от данни (3~8 МВ/s). В настройките на PICVideo MJPEG кодек това съответства на качество 17~19. За Morgan MJPEG кодек – на 85~95.

    «-» Трябва да се има предвид, че тези кодеци компресират със загуби, т.к. са базирани на алгоритъм за вътрешнокадрова компресия JPEG.

  • Към кодеците, които осигуряват максимална компресия с максимално качество спада XviD .

    «-» Недостатък при него е, че изисква огромни изчислителни ресурси, но за сметка на това

    «+» качеството на изображение е високо.

По възможност трябва да се избягва да се записва в AVI с компресиране на аудио в реално време. Съществува опасност за разсинхронизация на видео- и аудио потоци, а при използване на някои аудио кодеци това може да предизвика внезапно спиране на запис.

Препоръчва се да се използва апаратен аудио формат - PCM.


Topic: WMF

WMF

Microsoft WMF

За висококачествен видео- и аудио запис може да се използва Windows Media Format (WMF). Постига се високо качество на изображение и звук при висока степен на компресия на съдържанието.

Този формат съхранява видео- и аудио потоци в контейнер ASF, който е продължение в развитието на AVI и има допълнителни функции по синхронизация на потоци.

Файл в контейнер ASF, в който видеопотокът е компресиран с Windows Media Video (WMV) обикновено е разширение .wmv.

В случай на запис и компресиране само на един аудиопоток с този кодек, файловете обикновено са с разширение .wma.

За кодиране на файлове в Windows Media Format с Behold TV е необходима ОС Windows XP SP2, по-висока версия или инсталирано обновяване (update) Microsoft Windows Media Format Runtime - версия 9.0/9.5/11 - може да се инсталира чрез Windows Update или от диска в комплекта на тунера). Ако това обновяване не е инсталирано, запис във формати WMV/WMA/ASF не е възможен.

Windows XP SP2 включва Windows Media Format Runtime 9.0.

Windows Vista включва Windows Media Format Runtime 11.


Topic: Видео / Аудио

Видео / Аудио

За видео и аудио...

При запис на видео съвместно със звук има ред особености. Съществуват няколко момента, за които трябва да се помни [image] :

При запис на видео- и аудио ред с ТВ тунер по правило винаги участват две независими устройства:

  • устройство за цифровизиране на видео (самата платка ТВ тунер), и

  • устройство за цифровизиране на звук (аудио карта на компютъра).

Тези устройства работят на опорни честоти на своите собствени кварцови генератори, всеки от които може да има известни отклонения. Вследствие на това, при цифровизиране на данни произтича разсинхронизация по време на видео- и аудио потоци, което в резултат води до забавяне или избързване на звук спрямо изображение в записан файл.

«+» Предимство на интегралните схеми NXP SAA7134 и SAA7135 е, че освен видеодекодер имат вграден и независим от звуковата карта на компютъра аудиодекодер и могат апаратно да свързват видео- и аудио потоци, благодарение на което с програмата Behold TV може гарантирано да се цифровизира звук в синхрон с видеоред. В този режим звуковата карта на компютъра не използва. Ако тунерът е базиран на чипсет SAA7134 или SAA7135 се препоръчва винаги да се използва тази уникална възможност.

Важно е да се знае, че аудиодекодерът на чипсет SAA7134 цифровизира звук само с честота на дискретизация 32 kHz.

Аудиодекодерът на чипсет SAA7135 може да цифровизира звук с честоти 32 kHz и 48 kHz (както и 44.1 kHz, но само за източник, включен към аналоговия вход на чипсета).


Topic: Windows

Windows

За файловата система...

(доп.р.,v5.15) Поддръжката на ОС Windows 98SE*/ME* е прекратена от страна на Microsoft® от м. Юли 2006 г. и в драйверите за Behold TV от м. Юли 2010 г. - версия 5.2.1.0. вкл., вж. забележките в края на раздел « Изисквания към системата ». В новите версии драйвери и BeholdTV това е отразено, като е посочено, че същите поддържат версии на ОС от ХР и по-нови. Въпреки това в настоящата редакция следващата информация е оставена за сведение, доколкото все още се срещат въпроси, свързани с особеностите на файлови системи FAT32 и NTFS:

Важно

  • Файлова система NTFS поддържа файлове с размер над 4 GB, благодарение на което под същата (Windows XP/2000/>) може да се осъществява продължителен пълноформатен видеозапис със слабо компресиране, както и продължителна работа на функция «Таймшифт».

  • Файлова система FAT32 (с която работят операционни системи Windows 98 */ ME *) не поддържа файлове с големина над 4 GB.


Topic: Въпроси и отговори

Въпроси и отговори

Често задавани въпроси и отговори (F.A.Q.)

Актуална информация е изведена на следните адреси в Интернет:

официален сайт (на руски език) - http://www.beholder.ru/support/faq.php

регионален сайт (на български) - http://www.beholder-europe.com/support/faq.php

В следващите раздели е представена преведена информация, публикувана в предишни версии на настоящия HELP, допълнена с въпроси/отговори от сайта към 16.01.2011 г.:

В режим на гледане

  • По границите на движещи се обекти има „гребеновидни” изкривявания

  • При пускане на програмата има звук, но няма изображение, а черен прозорец

  • При гледане на ТВ на екрана се наблюдават редуващи се вертикални ленти

  • При включване на режим за удвояване честотата на кадри, както и при припокриване на видео прозореца с други приложения, програмата зависва и забавя

  • Периодично при диалог с HDD възникват смущения на екрана във вид на множество тънки бели хоризонтални черти, линии или "изпаднали" редове

  • По границите на телевизионно изображение се вижда „шум” във вид на тънки ленти

  • Изображението „придърпва”, което осезаемо се забелязва например при преместване на текст в „бягащ ред”

  • Често задаван въпрос: Може ли тунерът да извежда изображение с по-висока разделителна способност,

    например 1024х768 или 1280х1024

  • При регулиране на силата на звук нивото не се променя; не работи и функцията за изключване на звук (Mute), въпреки че индикаторите за изменение на сила и «Mute» се изобразяват на панела за управление

  • (доп..,v.5.15) При гледане от S-Video вход изображението е черно-бяло

  • (доп.,v.5.15) При включване на външна видеоапаратура към тунера има изображение, но няма звук

  • (доп.,v.5.15) При извеждане на звук със средствата на DirectSound звукът изостава или изпреварва видеоизображението; чува се периодично прищракване и "заекване"

  • При гледане на ТВ-програми звукът периодично (на всеки половин~един час) се губи

  • При преход към ОС Vista/ [image] не може да се настрои звук. Тунерът е включен към аудиокартата с кабел. Липсва звук. Списъците за избор на линия за управление на звук и активна линия за запис в Behold TV са празни или недостъпни

В режим на запис

  • При запис в AVI със звук самият запис протича без грешки, но при възпроизвеждане на видеофайла няма звук

  • Не може да се записва видео със звук. При опит за запис се показва съобщение за грешка "Cannot start graph". Видео без звук се записва без проблеми

  • При запис във формат AVI става разсинхронизация на звук спрямо видео

  • При запис с двуядрени процесори в AVI има много пропуснати кадри, въпреки че натоварването на процесора не достига критични нива

  • При опит за видеозапис системата "зависва"

  • При видеозапис с MPEG кодек InterVideo и последващо възпроизвеждане или използване на функция Таймшифт се получава „плуващо” изкривяване и „заекване” на звук няколко секунди след началото на запис

  • При спиране на запис системата „зависва”

  • При видеозапис с кодек DivX в log-файла се изписва "Video codec: DivX Pro 5.0.5", независимо че реално инсталираната в системата е с по-нова версия

  • Запис спира при достигане размер на файла 4 GB

  • Видеозапис с апаратен енкодер (SAA6752HS тунер Behold TV M6). При възпроизвеждане на файла понякога се забелязват дефекти като случайни «блокови» ленти, както и осезаемо „придърпване” на изображението. При опит за прекодиране на файла с различни програми се извежда грешка от типа «Incompleted Frame at...». В хардуерния енкодер ли е причината

  • (доп.,v.5.15) При гледане и цифровизиране на VHS касети в долната част на екрана винаги присъства «подръпващ», «огледална», «просветваща» лента от «шум» с ширина няколко телевизионни реда. Откъде се появява и как да бъде премахнато това

Въпроси от предишни Help-версии:

  • При запис на звук с аудиокодек ACM Lame MP3 във формат 48000 Hz, 320 kbps CBR, Stereo, в получения файл няма звук

  • Видеозапис по способ „Microsoft WMV”. Използва се кодек Windows Media Video 9. При възпроизвеждане на записания файл изображението е с повредени и „изкривени” цветове и изглежда „а-ла фреска”

  • Видеозапис по способ «Microsoft WMV». Използва се кодек Windows Media Video 9. При възпроизвеждане на записания файл, при опит да се използва бързо «пренавиване», позициониране или да се превключи в прозоречен / пълноекранен режим, изображението застива. Помага само повторно отваряне на файла

В режим «Таймшифт»

  • Не може да се пусне режим «Таймшифт»

  • При работа в режим «Таймшифт» се чуват два звукови канала с изместване по време един спрямо друг

Въпроси от предишни Help-версии:

  • При включване на режим «Таймшифт» звукът изчезва

Драйвер

  • В процеса на инсталиране на драйвер се появява съобщение, че инсталираните програмни продукти не са тествани за съвместимост с Windows XP и се предлага отказ от по-нататъшни действия

  • Драйверът се инсталира и програмата работи нормално, но след рестартиране операционната система "забравя" за инсталирания драйвер, а при стартиране на програмата Behold TV се извежда съобщение "WDM устройство за видеозахват не е намерено!" Преинсталиране на драйвера решава проблема, но само до следващия рестарт на Windows

  • При опит да бъде инсталиран драйвер процесът завършва с неуспех. При инсталиране на драйвер чрез инсталатора от комплекта на драйвера се издава съобщение «Установка BDA драйвера не завершена!»«BDA driver installation failed!»

Системни съобщения

  • "WDM устройство за видеозахвата не обнаружено (не е намерено)!"

  • "Cannot render stream to Pin Preview"

  • "Cannot render stream on IVideo Compress filter"

  • "Cannot render videostream on Smart Tee!"

  • "Cannot render Audio stream"

Дистанционно управление

  • Компютърът не се включва от пулта за ДУ

  • Тунерът не реагира на команди от пулта за ДУ

Въпроси от предишни Help-версии:

  • Пултът за дистанционно управление не се използва в даден момент, а индикаторът в екранния панел на програмата непрекъснато мига (все едно, че е натиснат бутон «0»)

  • Некоректна работа на дистанционното управление

Други

  • По какъв начин е по-добре да се включват към тунера външни устройства (видеомагнетофон, плейър, ресивер...)

  • Къде се съхраняват потребителски настройки на програмата Behold TV

  • След преход към операционна система Windows Vista/Seven престават да се съхраняват настройките на тунера. След рестартиране на програмата Behold TV настройките се прехвърлят стойности по подразбиране

  • В комплекта на тунера е включена програма Win DVD Creator, но при инсталиране не се приема серийният номер

  • В програмата вместо руски (кирилица) букви се виждат "йероглифи"

  • След обновяване на Windows излиза съобщение: "WDM device "SAA7134 TV card" – is not Philips SAA713x card"

  • При работа на тунера системата „зависва”

  • Чипсетът и други елементи по платката на тунера се нагряват силно

  • Базата данни с телевизионни програми е обновявана отдавна

  • Често задаван въпрос: Може ли на един компютър да работят два или повече тунера едновременно

  • Windows Media Center не работи с тунера

  • От буксата (щекера/куплунга) на телевизионната антена "удря" ток. При включване на антената прескачат искри

  • Често задаван въпрос: Кога ще излезе нов модел тунер

Въпроси от предишни Help-версии:

  • При включване в режим «Телетекст» вместо шрифт се вижда „псевдографика”

Допълнение - въпроси и дискусионни теми от официалния форум и други източници

  • ...приемане на сигнали по цифров стандарт DVB-C?

  • В нашия район цифровото излъчване DVB-Т е във формат MPEG-4. Възможно ли е гледане с хибридeн тунер?

  • ...излъчването е във формат Н.264 part 10. Поддържат ли тунерите part 10 или това зависи изцяло от кодеците?

  • Инсталирах демо-версия на кодек Main Concept AVC. Windows Media Player (WMP) намира и използва успешно кодека, като в ъгъла се показва лого Main Concept ( [image] ограничение на демо-версията, би могло да се премахне с плъгин Logo Killer), но Behold TV не го намира. Аналогична е ситуацията и с Core AVC PRO?

  • MPEG-2/MPEG4 стандарти

The contents of Въпроси и отговори

При гледане
Запис
Таймшифт
Драйвер
Съобщения
Дистанционно Управление
Други
Допълнително / Форум


Topic: При гледане

При гледане

В режим на гледане

  • По границите на движещи се обекти има „гребеновидни” изкривявания

Телевизионното предаване има принципни особености - покадрово изображение с честота на кадри 25 (24) Hz се разделя на два полукадъра - т.н. "полета". Едното поле съдържа четни редове от кадър, другото - нечетните. По-нататък тези полета се предават вече с честота 50 полета/сек. При гледане на такова предаване на "традиционен" телевизор няма проблеми, доколкото две четни полета се извеждат последователно едно след друго и при това четните редове от кадър попадат между нечетните редове на екрана.

При гледане на видеоматериали на компютър се изобразява целият екран, получен от обединяване на две полета. Ако се гледа предаване с материал, който е сниман на филмова лента, при гледане не възникват проблеми, доколкото за излъчване "нормален" кадър се разбива на полета, които след това се обединяват по обратния път от компютъра, при което в резултат се получава оригинален кадър. Ако обаче се гледа материал, който е сниман с ТВ- (видео-) камера, при същите от матрицата се сваля вече готов видеосигнал по полета, а не по кадри, с честота 50 полета/сек. По този начин, ако в кадър има движение, следващо поле фиксира момент от време, който изостава с 1/50 част от секундата от предишното. При "сглобяване" на две последователни полета в прогресивен кадър, четни редове ще се взимат от едното поле, а нечетни - от другото. Доколкото между тях има времеви интервал от 20 ms, при сглобяването ще се получи неравност по границите на движещи се обекти.

За да не възниква описаният ефект при гледане на материали, записани от ТВ- (видео-) камера, в настройките на секция «Видео» [image] [image] «Видеообработка на изображение при гледане» да се добави един от наличните филтри за деинтерлейсинг (премахване на "гребеновидни" ефекти).

Може да бъде използван и апаратен деинтерлейсинг на видеокартата, ако такава функция се поддържа от същата, разбира се.

  • При пускане на програмата има звук, но няма изображение, а черен прозорец

Възможни са няколко причини:

  1. Видеокартата (драйверът) не поддържа overlay в зададената разделителна способност и битност на десктопа.

    Да се направи опит да се зададе 16-битов Windows-десктоп.

    Ако и това не помага, да се опита с

    - промяна на режим за извеждане на изображение («Овърлейна/Първична повърхнина») в настройките на програмата, както и

    - да се променят размери на видеопоток.

    При избор на овърлейна повърхност под Windows XP да се опита с включване/изключване на режим Video Mixing Renderer (VMR).

  2. Има още една причина за «черен екран». При някои дънни платки в BIOS по подразбиране е зададена неправилна величина за PCI Bus Latency.

    Тази величина може да се промени в секция за настройки «информация За тунера» [image] «Параметри на устройството» [image] параметри на PCI DMA-контролер, с което да се постигне нормална работа на PCI видеодекодера за SAA713x.

    Препоръчителна величина за PCI Latency е 16 ~ 64.

  3. Освен посочените причини, в сървърните версии на операционните системи (Win2000 Server, Win2003 Server) по подразбиране напълно или частично се изключва апаратно ускорение на видеоадаптера с цел повишаване на стабилността (оптимизиране на производителността). Това също води до «черен екран» или до изкривяване на цветопредаване при работа в различни режими на видео изображение.

    От меню «Диагностика»~«Troubleshooting» в допълнителните настройки на видеокартата да се зададе апаратно ускорение на максимум.

    (доп.,v.5.15) Да се стартира инструмент dxdiag.exe ("Start">"Run...">dxdiag.exe); да се провери в настройки display да е включено пълно апаратно ускорение DirectDraw и Direct3D.

  • При гледане на ТВ на екрана се наблюдават редуващи се вертикални ленти

Такива ленти могат да се появят по две причини:

  1. Първата е некоректно зададен параметър PCI Latency Timer в BIOS. В този случай смущенията изглеждат като зелени или малинови вертикални ленти, запълващи 4/5 от екрана.

    Такива ленти се отстраняват напълно с подбор на PCI Latency Timer непосредствено в настройки (изм.,v.5.15) «За тунера» ( [image] v.~5.10~«Видео») на Behold TV.

  2. Втората е при смущения от радио блока на тунера, възникващи при работа на PCI-шината при предаване на пакети данни. Смущението се формира непосредствено на входа на ВЧ-блока и не зависи нито от качеството на захранващия блок, нито от настройките в BIOS. Смущения при работа на PCI-шината са видими в нискочестотния TV диапазон (49 ~ 200 МHz) при отслабване на сигнал спрямо нормалното ниво с 15 ~ 20 dB.

    При обикновените телевизори такива ленти няма, защото просто няма шина PCI като източник на смущения.

    Единственият правилен и надежден начин за борба с такива явления е привеждане нивото на телевизионния сигнал към нормалното. За целта е необходимо:

    1) Всички кабелни съединения да са качествени, добре свързани и съгласувани;

    2) Да се минимизира количеството разклонители (сплитери). Всеки сплитер разделя мощността на сигнала между всички включени към него устройства. Да се използват само качествени делители;

    3) Да се използва качествен коаксиален телевизионен кабел – трябва да има вълново съпротивление 75 Ω и да не е твърде тънък. Кабелът трябва да е с добро екраниране, в идеалния случай – двойно (мрежеста оплетка и фолио). Да не се съединяват парчета кабели – при всяка връзка се получават загуби и отражения на сигнала. Да се минимизира броят на съединения/разклонения (преходници);

    4) (доп.,v.5.15) Да се използват метални екранирани куплунги (съединители). Не се препоръчва да се използват пластмасови такива.

    5) (доп.,v.5.15) Да се постави преходен феритен филтър непосредствено до антенния вход. Тези филтри потискат основния синфазен компонент на смущения (на практика не много силно и предимно в ниския честотен диапазон).

    6) Да се използва усилвател на сигнал. Усилвателят не трябва да бъде близо до компютъра или до други електронни устройства.

    По-точно определяне на причините за възникване на такива ленти може да се направи, като се подаде сигнал към нискочестотен видеовход от външен източник (напр. видеокасетофон).

    Ако лентите не изчезнат, причината е в неправилна стойност на PCI Latency Timer.

    При изчезване на лентите проблемът е в ниско ниво на ТВ-сигнал.

  • При включване на режим за удвояване честотата на кадри, както и при припокриване на видео прозореца с други приложения, програмата зависва и забавя

Вероятно е включен режим Clone и извеждане в overlay в настройките на видеоадаптера. Такъв проблем предизвикват някои драйвери за nVidia.

Да се изключи режим Clone или да се инсталира друг драйвер за видеоадаптер nVidia.

  • Периодично при диалог с HDD възникват смущения на екрана във вид на множество тънки бели хоризонтални черти, линии или "изпаднали" редове

Такива смущения се появяват при използване на някои SATA- и RAID- контролери и за съжаление понякога са неотстраними.

Този проблем се обуславя от това, че SATA-контролерът предава данни по шината на големи пакети, като не оставя време за работа на други PCI-устройства. Това предизвиква препълване на FIFO-буфера на чипсет SAA713x, което води до пропускане на данни, записвани в буфера на видеокадъра.

Количеството смущения може да се намали или отстрани напълно:

като се зададе в настройки (изм.,v.5.15) «За тунера» ( [image] v.~5.10~«Видео») на тунера параметър «DMA burst length»=64 или 32 Dwords,

или като се подбере друга стойност за PCI latency timer.

Да се направи опит да се променят настройките, касаещи шина PCI, SATA и RAID-контролерите в системния BIOS или в BIOS-контролера.

Също така да се провери тунерът и SATA (RAID) контролерите да не споделят едно прекъсване.

(доп.,v.5.15) Аналогични по вид смущения също така понякога възникват при включване на енергоспестяващи режими при съвременните процесори (Cool'n'Quiet, C1E, Intel SpeedStop), при което с цел понижаване на енергопотребление и топлоотдаване процесорът и системата се привеждат в състояние, при което потоковото предаване на данни по шина PCI не може да се изпълнява нормално. Тези режими могат да бъдат изключени в BIOS.

  • По границите на телевизионно изображение се вижда „шум” във вид на тънки ленти

Телевизионната техника се базира на факта, че при гледане на "традиционен" телевизор около 10% от изображението се изрязва от настройките на самите апарати (намира се извън пределите на видимата област на кадъра). Поради това в първите и последни редове на изображението често се кодира допълнителна служебна информация, която изглежда като електронен „шум”.

В телевизионен стандарт Betacam за маркери се използват първи ред и два първи пиксела от останалите редове – левият край на изображението.

Съществуват и ред други промишлени стандарти, които така или иначе използват краят на изображение за кодиране на маркери.

С помощта на бутони «+» и «-» на допълнителната клавиатура да се мащабира изображението така, че да бъдат скрити тези краища, или

Да се използва плъгин за видеообработка «Заливка бордюров»~«Запълване на рамка».

  • Изображението „придърпва”, което осезаемо се забелязва например при преместване на текст в „бягащ ред”

ТВ-изображение на монитор се опреснява с честота 25 кадъра/сек. или (при включено програмно удвояване честотата на кадри) 50 кадъра/сек. Екранът на монитор се опреснява с такава честота, каквато е зададена за desktop-а и се поддържа от видеокартата и монитора.

Когато честотата на обновяване на монитора не съвпада с честотата на телевизионните кадри възниква т.н. „биене”, което изглежда като „придърпване” при бягащ ред.

Теоретично „биене” възниква при всякаква честота на обновяване на монитора, но при 75 Hz честотата на биене е достатъчно висока, което снижава субективното възприемане като „придърпване”. Също така, при изключено удвояване на честота на кадри, 25 Hz са забележими с просто око.

При телевизорите това не се вижда, т.к. изображението се извежда реално с честота 50 полета в секунда.

  • Често задаван въпрос: Може ли тунерът да извежда изображение с по-висока разделителна способност, например 1024х768 или 1280х1024

В случая не трябва да се бъркат някои основни понятия и да се знае, че качеството на телевизионното изображение съответства на максимална разделителна способност:

  • 720х576 (в система PAL/SECAM) или

  • 640х480 (NTSC).

    Именно с такива разделителни способности работят практически всички известни модели ТВ тунери.

    Цифровизиране на изображение от страна на тунера с голяма разделителна способност по вертикал е невъзможно поради ограничението, наложено от количеството физически редове в телевизионния кадър (576 - PAL/SECAM, 480-NTSC).

    Използване на голяма разделителна способност при цифровизиране по хоризонтал е нерационално, т.к. това не води до повишаване качеството на изображение.

    На екран изображение може да бъде с произволни размери, но то се мащабира в такива размери (вкл. до пълен екран) от апаратния ускорител на графичната карта.

  • При регулиране на силата на звук нивото не се променя; не работи и функцията за изключване на звук (Mute), въпреки че индикаторите за изменение на сила и «Mute» се изобразяват на панела за управление

Да се провери дали тунерът е включен към аудио картата в съответствие с инструкцията:

вътрешния или външен аудио изход на тунера трябва да са включени съответно към вътрешния или външен вход на аудио картата.

Директно включване на акустична система към аудио изхода на тунера е неправилно.

(доп.,v.5.15) Да се провери дали тунерът е включен само с един аудиокабел. Едновременно включване на вътрешен и външен аудиокабел е неправилно.

Да се провери дали в настройки «Аудио» на тунера за миксер и линия за управление на звук са избрани съответната аудио карта и канал на същата, към който е включен вътрешния или външен аудио изход на тунера.

  • (доп.,v.5.15) При гледане от S-Video вход изображението е черно-бяло

Не бива да се включва композитен (RCA) изход [image] на външно устройство към S-Video [image] вход на тунера. Такова включване предполага наличие на специален преходник. Обикновени преходници могат да смесват цветовия компонент във видеосигнала, но не и да го отделят, поради което такива не са пригодни за подобно включване. Сложните преходници би трябвало да разделят сигналите, но от това качеството на сигнала няма да се подобри.

Композитен изход [image] на външно устройство трябва да се включва само към композитен [image] вход на тунера.

  • (доп.,v.5.15) При включване на външна видеоапаратура към тунера има изображение, но няма звук

Нискочестотните видео [image] входове на тунера, които се използват за включване на външна апаратура са предназначени изключително за предаване на изображение. За включване на звук към тунера се използва отделен стерео аудио [image] вход, който в зависимост от модела е изпълнен като два куплунга RCA на А/V кабела-преходник или един 3,5 мм. мини-жак куплунг със син цвят, разположен на задната планка на тунера. Монофонична апаратура се включва към левия или десния аудио [image] вход на тунера.

За да се чува звук и в двата канала, в секция за настройки «НЧ входове» да се подбере съответен ("Line mono L" или "Line mono R") режим за аудио [image] вход.

  • (доп.,v.5.15) При извеждане на звук със средствата на DirectSound звукът изостава или изпреварва видеоизображението; чува се периодично прищракване и "заекване"

Драйверът на аудиокартата не поддържа плавно регулиране на скорост за възпроизвеждане на звук. При извеждане на звук със средствата на DirectSound, звукът се цифровизира от аналогово-цифровия преобразувател (АЦП) на тунера; по шина РСІ, РСІ-е, РСМСІА или USB се предава в системната памет на компютъра и вече оттам цифровизираният поток се възпроизвежда от ЦАП-а на звуковата карта. По причина на винаги съществуващи технологични разлики в характеристиките на ЦАП и АЦП, без плавна донастройка на скорост за възпроизвеждане, звукът ще изпреварва или изостава от видеото по време, което на свой ред може да доведе до различен род непредсказуеми явления. "Прищракване и "припукване" при гледане се чуват в моменти на принудителна синхронизация на аудио- и видео- потоци, когато времето на тяхната разсинхронизация превишава определен праг.

Да се направи опит да се обнови драйвера на звуковата карта. Ако не може да се подбере нормално работещ аудиодрайвер, при гледане да се използва метод за извеждане на звук чрез аналогов аудио изход на тунера. За целта тунерът трябва да бъде включен с аудиокабел към съответния аудио [image] вход на звуковата карта. При използване на аудиокабел не се извършва никакво цифровизиране на звук и той в реално време, като не се използват каквито и да са програмни механизми се предава от тунера към вход на звуковата карта и впоследствие на съответен аудио изход. Каквото и да е закъснение и разсинхронизация на звука и видео при това са изключени.

  • При гледане на ТВ-програми звукът периодично (на всеки половин~един час) се губи

Ако работят едновременно и други приложения във фонов режим, да се направи опит да се изключват едно по едно.

Програми като Microsoft NetMeeting, Messenger, Norton Antivirus, както и някои други работещи във фонов режим могат да блокират каналите на звуковата карта.

  • При преход към ОС Vista/ [image] не може да се настрои звук. Тунерът е включен към аудиокартата с кабел. Липсва звук. Списъците за избор на линия за управление на звук и активна линия за запис в Behold TV са празни или недостъпни

Драйверите към най-популярните интегрирани аудиокарти, включени в дистрибутивите на операционни системи Windows Vista/ [image] и база данни WHQL не предоставят пълна информация за конфигурациите на аудиоустройства и не позволяват да се работи с входове/изходи на звуковите карти. За нормална работа на аудиокартата е необходимо да се свали и инсталира драйвер непосредствено от сайта на производителя на чипсета на звуковата карта, примерно http://www.realtek.com.tw . Марката на аудио-чипсета и неговия производител трябва да се намират в описанието към дънната (аудио) платка.


Topic: Запис

Запис

В режим на запис

  • При запис в AVI със звук самият запис протича без грешки, но при възпроизвеждане на видеофайла няма звук

Причините могат да бъдат няколко:

  1. Да се провери дали в настройките за аудио запис за миксер и активна линия за запис е избран точно този канал на аудиокартата, към който е включен вътрешният или външен аудио изход на тунера.

  2. Ако е избрана правилно активна линия за запис но отново няма звук е възможно драйверите на звуковата карта некоректно да поддържат коректно превключване на аудио източници през WDM. Така например драйверите за карта Creative SB PCI 128 под Win2000(XP), които се инсталират от самия Windows работят коректно. В същото време инсталирани драйвери от сайта на Creative под Win2000(XP) не позволяват превключване на източник за запис дори през системния миксер.

  3. Някои плейъри като LightAlloy не винаги възпроизвеждат коректно записан файл. Да се направи опит да се възпроизведе запис с MediaPlayer.

  4. Ако не е включен аудио кабел да се провери дали в избрания пресет за запис е поставена отметка «Запис на звук от чипсета по шина PCI» («Запис на аудио поток по шина РСІ (USB)»).

  • Не може да се записва видео със звук. При опит за запис се показва съобщение за грешка "Cannot start graph". Видео без звук се записва без проблеми

Някои устройства (например гласови модеми) добавят свои устройства за аудио запис.

От «Control Panel» > «Multimedia (Sound and Audio Devices)» > «Audio» в списъците «Default device» както за запис, така и за възпроизвеждане да се избере правилна звукова карта:

Включва се отметка «Use only default devices»;

Рестартира се Windows;

Отваря се «Панел за запис» на Behold TV - в секция « Настройки за аудио запис» от списъка се избира правилната звукова карта.

  • При запис във формат AVI става разсинхронизация на звук спрямо видео

Разсинхронизация на аудио- и видео потоците при запис може да се получи в резултат на множество причини.

Да се направи опит да се зададе формат PCM за звук. Някои аудио карти като Sound Blaster Live!/Audigy осигуряват синхрон само при честота на дискретизация 48000 Hz.

Да се подберат видеокодек и съответни параметри така, че натоварването на процесора да не е по-високо от 80%. Също така не се препоръчва в настройките да се задава най-висок приоритет. Да се пробват различни стойности на параметри «Последователност (Interleaving)(рус."Чередование")», «Главен поток AVI».

Ако тунерът е с чипсет SAA7134/ 35, при запис настоятелно се препоръчва да се използва вграденият аудио АЦП.

(доп.,v.5.15) Неголяма разсинхронизация произтича даже при цифровизиране на звук от чипсета поради работата на контейнер AVI и по-точно на AVI-мултиплексора, който "сглобява" видеоред и звук в един файл:

  1. Първо, този мултиплексор не формира пакети с пълно свързване на звук и видео във всеки пакет;

  2. Второ, същият натрупва своя вътрешна статистика, която е недостъпна за контрол и анализ от страна на програмното осигуряване и зависи от множество обстоятелства (например използвани аудио- и видео- кодеци) и получената в резултат честота на кадри, която по правило не съответства на дължината на аудио пътеката, се съхранява при завършване на запис в заглавието на AVI-файл.

    За да бъде избегната такава разсинхронизация е необходимо или при завършване на запис същият да се редактира във видеоредактор, като се зададе правилна честота на кадри в AVI-заглавието на базата на реалната продължителност на видео- и звукови пътеки, или

    да се използват други контейнери, например, ASF, WMV или MPEG.

  • При запис в AVI (доп.,v.5.15) с двуядрен процесор има много пропуснати кадри, въпреки че натоварването на процесора не достига критични нива

Това се получава при двуядрени процесори - предимно AMD Athlon64x2 поради разсинхронизация (drift) на броячите на ядрата. Програми и драйвери, които използват системно повикване QueryPerformanceCounter получават различни стойности за броячите, което поражда проблеми. Системата може да се диагностицира за разсинхронизация на броячите с ICEAffinityTest.exe.

Този проблем е официално описан от Microsoft.

За решаване на проблема е необходимо да се добави ключ /usepmtimer във файл boot.ini в реда за избор на операционна система и да се рестартира системата.

Пример:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

  • При опит за видеозапис системата "зависва"

Възможни са няколко типа проблеми:

  1. Системни:

    - За дънната платка не е инсталиран пакет драйвери от производителя, или

    - в системата няколко устройства (напр. тунер и звукова карта), които делят едно и също IRQ-прекъсване;

  2. Програмни - конфликт на драйвери или DirectShow филтри.

  • При видеозапис с MPEG кодек InterVideo и последващо възпроизвеждане или използване на функция Таймшифт се получава „плуващо” изкривяване и „заекване” на звук няколко секунди след началото на запис

(доп.,v.5.15) MPEG2 кодеци InterVideo, които се използват в програмата Behold TV при запис във формат MPEG и реализация на режим Таймшифт са разработвани за работа съвместно със звукови карти. Това означава, че при кодиране на звук кодекът предпочита да работи с аудиосемпли с голяма дължина (0.5сек), които по подразбиране се генерират от всички (без изключение) аудиоплатки. При цифровизиране на звук от чипсета на тунера, дължината на аудиосемплите не превишава 40 мс., което при някои стечения на обстоятелства, в някои конфигурации, както и при зареждане на системата може да доведе до срив в работата на кодека.

При възникване на такава ситуация:

в настройките за Таймшифт и при програмен запис във формат MPEG трябва да бъде изключено цифровизиране на звук от чипсета на тунера и да не се използват аудиосемпли с къса дължина. При това цифровизиране на звук ще се осъществява от аудиокартата, за което тунерът трябва да бъде включен към същата с вътрешен или външен аудиокабел.

Установено е, че такъв проблем се проявява при дънни платки с чипсет nVidia nForce2 при включена в BIOS опция «FSB Spread Spectrum»:

Изключването на тази опция отстранява проблема с кодек InterVideo. При болшинството дънни платки тази опция се намира в раздел «Advanced Chipset Features» на BIOS.

  • При спиране на запис системата „зависва”

Най-вероятно се записва във формат AVI с използване на кодек XviD (доп.,v.5.15) или с регистрирана версия на кодек DivX. Необходимо е да се извърши следното:

Отваря се «Панел за запис» - секция «Настройки за видео/аудио запис», избира се метод за видеозапис Microsoft AVI. В "падащия" списък «Компресиране на видео поток» се избира кодек XviD (DivX) и в дясно от него се натиска бутон «Свойства на видео кодек». В следващия прозорец за настройки на кодека да се намери (местоположението зависи от версията на кодека) и да се свали отметка «Display encoding status» при кодек XviD и да се зададе отметка «Disable the feedback window» за кодек DivX. Именно това води до зависване при спиране на запис.

(v.~5.10 - да се влезе в настройките на кодека и да се изключи Debug Window.)

  • При видеозапис с кодек DivX в log-файла се изписва "Video codec: DivX Pro 5.0.5", независимо че реално инсталираната в системата е с по-нова версия

Приложението извежда това име на кодек, което му съобщава DirectShow. От своя страна DirectShow пази името само на най-първата версия на който и да е инсталиран в системата кодек. При обновяване на версията на кодек неговото име не се променя.

Това е недоработка в самия DirectShow.

За да се сменя името на кодек след обновяване на версия (в случая DivX) е необходимо да се намери и ръчно да се премахне клон от регистъра:

HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum\{33D9A760-90C8-11D0-BD43-00A0C911CE86}\divx

След премахване този клон от регистъра се появява отново, но вече с коректно име на кодека, а в самото приложение трябва да се преизбере DivX кодек, за да се съхрани новото име в настройките.

  • Често задаван въпрос:Запис спира при достигане размер на файла 4 GB

Файлова система FAT32 не поддържа размер на файл над 4 GB

За запис на по-големи файлове трябва да се конвертира файловата система в NTFS.

Освен това при запис във формат MPEG-2, (v.~5.10 WMV или ASF) може да се зададе опция [image] «Автоматично разделяне на записван файл на сегменти със зададен размер»

  • Видеозапис с апаратен енкодер (SAA6752HS - тунер Behold TV M6). При възпроизвеждане на файла понякога се забелязват дефекти като случайни «блокови» ленти, както и осезаемо „придърпване” на изображението. При опит за прекодиране на файла с различни програми се извежда грешка от типа «Incompleted Frame at...». В хардуерния енкодер ли е причината

Такива грешки не са причинени от енкодера, а от повреди на предавания поток MPEG2 по PCI-шина, както и от загуба на фрагменти в потока. За повреди в потока са „виновни” някои PCI-устройства (обикновено IDE и SATA контролери), които задържат дълго арбитража на PCI-шината, поради което FiFo буфера на чипсета се препълва и в семплите на потока се получава изкривяване на данни.

За контрол на потока DMA трябва да се включи log-файл при запис. След завършване на записа трябва да се отвори log-файла и в раздел *Record task statistics* да се проверят статистики «Total corrupted MPEG DMA samples» и «Total lost MPEG DMA samples». Ако системата работи изправно, в тези статистики трябва да има нули. Ако някоя от стойностите е ненулева (особено corrupted), тунерът трябва

да се премести в друг слот или

да се направи опит да се настроят параметрите на PCI DMA-контролера в настройките на Behold TV. С намаляване на Burst length, FiFo threshold или увеличаване на Latency timer трябва да се постигне резултат, при който в log-файла показателите за грешки MPEG DMA да са нулеви.

(доп.,v.5.15) да се изключи режим Cool'n'Quiet. В този режим с цел понижаване на енергопотребление и топлоотдаване процесорът и системата се привеждат в състояние, при което потоковото предаване на данни по шина PCI не може да се изпълнява нормално. Режимът може да бъде изключен в BIOS.

  • (доп.,v.5.15) При гледане и цифровизиране на VHS касети в долната част на екрана винаги присъства «подръпващ», «огледална», «просветваща» лента от «шум» с ширина няколко телевизионни реда. Откъде се появява и как да бъде премахнато това

Такава лента присъства непосредствено в самия видеосигнал от VHS магнетофон/видеокамера и може да бъде премахната само чрез мащабиране на кадър, подрязване на краищата на кадър или със запълване на граници на кадър.

Въпроси от предишни Help-версии:

  • При запис на звук с аудиокодек ACM Lame MP3 във формат 48000 Hz, 320 kbps CBR, Stereo, в получения файл няма звук

В комплекта на Windows XP има DirectShow декодер «Fraunhofer IIS MPEG Layer-3 DirectShow Decoder» със стара версия 1.5, който не умее да декодира VBR MP3, както и някои MP3 формати, записани с Fraunhofer кодиране.

Да се обнови този декодер (файл l3codecx.ax) до версия 1.9.0.311. С това записани по-рано файлове ще бъдат възпроизвеждани коректно.

  • Видеозапис по способ „Microsoft WMV”. Използва се кодек Windows Media Video 9. При възпроизвеждане на записания файл изображението е с повредени и „изкривени” цветове и изглежда „а-ла фреска”

В системата е инсталиран стар декодер Windows Media Video. Възможни решения:

Да се обнови пакетът декодери Windows Media от сайта на Microsoft;

Да се инсталира Windows Media Player 10, или

Да се използва кодек Windows Media Video V8.

  • Видеозапис по способ «Microsoft WMV». Използва се кодек Windows Media Video 9. При възпроизвеждане на записания файл, при опит да се използва бързо «пренавиване», позициониране или да се превключи в прозоречен / пълноекранен режим, изображението застива. Помага само повторно отваряне на файла

Установено е, че при видеокарти ATI Radeon такова поведение е предизвикано от активна опция «Ускорение WMV» в настройките на драйвера на видеокартата при някои версии на драйвери ATI Catalyst 5.xx.

Да се изключи опция «Ускорение WMV».


Topic: Таймшифт

Таймшифт

В режим «Таймшифт»

вж. също така описание на функция TimeShift ; описание на интертейса - настройки TimeShift .

  • Не може да се пусне режим «Таймшифт»

«Таймшифт» в Behold TV работи само при инсталирани кодеци Inter Video MPEG от CD «Inter Video WinDVD Creator», който е приложен в комплекта на тунера.

Проверка дали в системата има коректно инсталирани MPEG кодеци може да се направи в раздел «Настройки» на «Таймшифт», поле « Статус за готовност на режим Таймшифт ».

«Таймшифт» също така може да не работи поради конфликти между различни версии на Inter Video кодеци, които понякога се включват в състава на някои разпространявани кодек-пакети. Статусът за готовност не е в състояние да проследи за наличие на такива конфликти.

В случая помага деинсталиране на външни кодек-пакети и преинсталиране на програма Inter Video WinDVD Creator.

  • При работа в режим «Таймшифт» се чуват два звукови канала с изместване по време един спрямо друг

При работа с «Таймшифт» Behold TV изключва основния канал за работа с аудиокартата (за да не се чува звук от предаването в реално време) и извежда звук от записвания файл.

Ако се чуват два аудио канала по описания начин, това означава, че в настройки «Аудио» са неправилно избрани «Миксер за възпроизвеждане» или «Линия за управление на звук» с които работи тунерът, или са включени едновременно два аудиокабела – вътрешен и външен:

- Да се проверят настройките и да се изключи единият кабел.

Въпроси от предишни Help-версии:

  • При включване на режим «Таймшифт» звукът изчезва

Проблемът се наблюдава при звукови карти Creative Labs Audigy, Audigy II и SB16.

При работа с «Таймшифт» програмата изключва основния канал за работа с аудио картата (за да не се чува звук от предаването в реално време) и извежда звук от записвания файл.

Драйвери Creative Labs съдържат грешка, в резултат на която при опит да се изключи канал за възпроизвеждане се изключва и запис от този канал.

При никои други известни звукови карти и аудио кодеци досега не са регистрирани такива грешки. Creative Labs са уведомени за тази грешка, но до момента същата не е отстранена.

В новите версии на Behold TV тази грешка е „заобиколена”, но понякога се случва да възникне. Проблемът не може да бъде решен елементарно.


Topic: Драйвер

Драйвер

Драйвер

вж. също така « Инсталиране на драйвери »

  • В процеса на инсталиране на драйвер се появява съобщение, че инсталираните програмни продукти не са тествани за съвместимост с Windows XP и се предлага отказ от по-нататъшни действия

(по-подробни описания със снимкови илюстрации са поместени в отделния материал за инсталиране на драйвери и софтуер)

Това е формално предупреждение, което косвено напомня че драйверът, който се инсталира няма цифров подпис от Microsoft® и като следствие от това не може да има логотип "Designed for Microsoft Windows XP", отсъства от официалната база с драйвери Microsoft®WHQL, не се разпространява и не може да бъде инсталиран чрез системата Windows Update.

Цифров подпис от Microsoft® не е задължителен. Новите версии фирмени драйвери се разпространяват директно от компанията Beholder®. Всички версии преминават през щателно тестване в средата на операционните системи Windows и тяхната коректна работа може да бъде гарантирана само от производителя на оборудването, за което е бил написан съответен драйвер, което се потвърждава с цифровия подпис на компанията Beholder International Ltd, който е необходим за инсталиране на драйвери под 64-битовите версии на ОС Vista / [image] .

При появяване на подобно съобщение трябва да се избере опция за продължаване ( [image] ). Ако в диалоговия прозорец липсва такава възможност, е необходимо да се разреши инсталиране на неподписан (?от Microsoft®) драйвер.

За целта в [image] _ [image] _ [image] _ [image] трябва да се избере опция

«Ignore - Install the software anyway and don't ask for my approval », или

«Warn - prompt me each time to choose an action»:

След потвърждение [image] трябва да се отвори [image], в категория [image] («Звукови, видео и игрови устройства») да се намери неопознато устройство «Multimedia Controller», в неговото контекстно меню да се избере опция [image] и да се повтори процедурата по инсталиране на драйвер.

  • Драйверът се инсталира и програмата работи нормално, но след рестартиране операционната система "забравя" за инсталирания драйвер, а при стартиране на програмата Behold TV се извежда съобщение "WDM устройство за видеозахват не е намерено!" Преинсталиране на драйвера решава проблема, но само до следващия рестарт на Windows

Едно от системните устройства, което по правило се явява GAME-порт на дънната платка в процеса на своята инициализация по време на старт на операционната система блокира зареждане на драйвер за тунера.

Да се отворят настройките за BIOS на дънната платка и да се изключат неизползваните GAME, COM, LPT и USB портове.

  • При опит да бъде инсталиран драйвер процесът завършва с неуспех. При инсталиране на драйвер чрез инсталатора от комплекта на драйвера се издава съобщение «Установка BDA драйвера не завершена!»~«BDA driver installation failed!»

При всякакви верии на ОС могат да възникнат проблеми с инсталиране на драйвери, предизвикани от работата на т.нар. „tweak-програми” (предназначени за т.н. ”оптимизация” на ОС).

Твърде често с цел икономия на място на системните дискове или за намаляване размера на дистрибутивите на ОС, такива програми премахват "ненужни" (от "тяхна" гледна точка) системни файлове, без които инсталиране и работа на драйвери става невъзможно.

Изход от подобна ситуация се свежда до преинсталиране на операционната система от нормален дистрибутив / легална версия на Windows.


Topic: Съобщения

Съобщения

Системни съобщения

  • "WDM устройство за видеозахвата не обнаружено (не е намерено)!"

В операционната система не е инсталиран драйвер за тунера.

За инсталиране на драйвер може да се ползва CD от комплекта на тунера или да се свали драйвер от фирмения web-сайт, след което се изпълнява стандартен процес по инсталация (в зависимост от ОС) или с помощта на инсталатора (файл Install.exe) в пакета на драйвера.

Трябва да се има предвид, че новите версии на софтуера могат да не работят със стари драйвери и обратно.

Препоръчва се да се инсталират обновени версии както за драйвер, така и за програмата.

  • "Cannot render stream to Pin Preview"

Такова съобщение се извежда от DirectX, когато не може да се предаде видеопоток за изображение към видеокартата.

В частност това съобщение може да се появява при опит за пускане на тунер от отдалечен компютър в случай, че в програмата Behold TV е настроено извеждане на видео чрез апаратен овърлей на видеокартата, който за отдалечен терминал е недостъпен.

Да се опита да се зададе друг тип за извеждане на видео в настройки «Видео» на тунера. Да се провери дали е напълно включено апаратно ускорение настройките на видеоадаптера. За целта се влиза в меню «Диагностика»~«Troubleshooting» на допълнителните настройки на видеоадаптера и се задава апаратно ускорение на максимум. Също така да се стартира инструмент dxdiag.exe (бутон «Start» [image] Run...dxdiag.exe) и да се провери дали в настройки «Дисплей» на този инструмент е напълно включено апаратно ускорение DirectDraw и Direct3D. Да се преинсталира или обнови драйвер за видеокартата и DirectX.

Отказ на DirectX да работи с драйвер на видеокартата може да бъде следствие от повреда или подмяна на неработеща или остаряла версия на системна библиотека quartz.dll. В този случай може да се опита да се възстанови библиотеката, като се изпълни команда regsvr32 quartz.dll. В този случай обаче, трябва да е сигурно, че някакъв страничен софтуер (кодек-пакети и пр.) не е подменил системния файл quartz.dll.

  • "Cannot render stream on IVideo Compress filter"

В системата отсъстват компоненти на InterVideo MPEG енкодер.

InterVideo MPEG енкодер/декодер се регистрира в системата при инсталиране на програма WinDVD Creator от втория CD, включен в комплекта на тунера.

  • "Cannot render videostream on Smart Tee!"

Smart Tee е компонент на DirectX, който при запис отговаря за разделяне на видеопоток на две части – за запис и за гледане.

Ако конкретната операционна система е с интегриран интерфейс Windows Media Center, да се отвори списъкът със стартирани сервиси на Windows и да се намери Media Center Receiver сервис (ehRecvr). За същия да се избере ръчен режим за стартиране и този сервис да бъде спрян.

Това е сервис на WMC, който се опитва да работи с тунера и блокира достъпа до фирменото програмно осигуряване.

  • "Cannot render Audio stream"

Такова съобщение може да се извежда в случай, че за работа със звук в програмата Behold TV е избрано аудиоустройство, което не е предназначено за такива цели (Bluetooth, гласов модем и пр.).

Да се стартира се инструмент Behold TV config от групата програми «Behold TV» и да се избере като миксер за възпроизвеждане и запис звукова карта, към която е включен тунерът.


Topic: Дистанционно Управление

Дистанционно Управление

Работа с дистанционно управление

вж. също така Функции: Управление на захранването (ARPC) ; Описание на интерфейса: Пулт за ДУ .

  • Компютърът не се включва от пулта за ДУ

Преди всичко да се провери дали изобщо е настроено включване от пулта за ДУ в програмата: «Настройки»«Пулт ДУ»«Включване на РС». Да се зададат необходим режим за включване на компютъра и бутон от пулта за включване.

Да се използва само IR-датчик от комплекта именно на самия тунер. С датчици от други модели тунери функцията за включване на РС от пулт за ДУ може да не работи.

Ако е избран режим за включване чрез линия PME по шина PCI и компютърът не се включва, да се провери дали в настройките на BIOS е разрешено включване на компютъра по шина PCI. Тази опция в BIOS може да е обозначена като "Wake up on PME", "Wake up on PCI" или нещо подобно.

При някои дънни платки компютърът не се включва от пулта за ДУ при подаване на захранване на системния блок до първо включване на компютъра, ако в настройките за управление на захранване е зададено включване с помощта на PME. Това са особености на чипсета на дънните платки. Да не се изключва захранването на системния блок.

Ако е настроено включване като емулация на бутон Power-on, да се провери дали е включен кабелът от комплекта на тунера към съответните клеми Power-on на дънната платка и клеми MB на тунера. Бутонът за включване на компютъра се включва към клеми BTN на тунера. При някои модели дънни платки емулация на бутон за захранване може да не работи или да работи нестабилно. В такива случаи се препоръчва да се настрои включване по шина PCI.

Да се провери напрежението за дежурно (standby) захранване на захранващия блок. Нормално то трябва да бъде 3.3 волта. По-ниско напрежение с голяма доза вероятност може да бъде причина за нестабилна работа на декодера на пулта за ДУ.

При някои стари дънни платки на слотовете на PCI не се подава дежурно захранване. В този случай функция за включване на компютъра не може да се използва.

От "спящ" режим (sleep) компютърът може да не се събужда от пулта за ДУ в този случай, ако от слотовете PCI не се свали основното захранване. За да се сваля основното захранване е необходимо в BIOS да се зададе “спящ режим" D3 вместо D1.

  • Тунерът не реагира на команди от пулта за ДУ

Да се провери за стабилно закрепване на IR-датчика в гнездото на платката на тунера.

Да се провери за правилна полярност на батериите в пулта за ДУ, както и дали същите не са изтощени. Работоспособността на ДУ може да се провери косвено, като се насочи към обектива на цифров фотоапарат или цифрова камера. Инфрачервеното излъчване се визуализира от матриците на такива цифрови уреди.

Да се провери дали не е изключено използването на пулта за ДУ в настройките на тунера.

Допълнение от предишни версии на HELP-файлове към Behold TV – Дистанционно управление

  • Пултът за дистанционно управление не се използва в даден момент, а индикаторът в екранния панел на програмата непрекъснато мига (все едно, че е натиснат бутон «0»)

Постоянно натискане на бутон «0» се детектира в случай, че е неизправна самата микросхема на IR-декодера или веригата за прехвърляне на микросхемата. Понякога такава неизправност има «плуващ» характер, в резултат на което декодерът ту работи, ту не.

В такива случаи тунерът трябва да се замени (ако е гаранционен) или да се отремонтира в сервизен център.

Постоянно натискане на бутон «0» също така може да се проявява при конфликт на прекъсвания на тунера с други PCI устройства.

В този случай тунерът трябва да се премести в друг PCI-слот и на избрания слот да бъде присвоено отделно прекъсване.

  • Некоректна работа на дистанционното управление

Ситуацията се дели на две категории:

  1. IR-датчикът погрешно улавя и разпознава повторение на сигнали от източници на IR-смущения - най-вече от луминесцентни лампи;

  2. IR -датчикът съдържа високочувствителен фототранзистор. В резултат електрическите намотки на кабела на датчика или на самият датчик също могат да предизвикат лъжливо сработване, особено в случай че датчикът е закрепен към корпуса на компютъра или към друга метална повърхност.

В зависимост от характера на въздействие също има два механизма за смущения:

Смущение погрешно се разпознава като код за повторени е (по-рядък случай). В такива случаи се наблюдава периодично случайно сработване на последно натискан бутон;

Смущение „изкривява” кода на бутон, в резултат на което при натискане същият не се определя. След кода на бутона тече код за повторение, който се възприема от декодера и предизвиква сработване на предходния бутон, останал в буфера на декодера.

Към момента може да се препоръча следното:

Да се избягва закрепване на датчика на корпуса на компютъра. Да се направи опит датчикът да се закрепи на известно разстояние от компютъра върху непроводима повърхност.

Ако има луминесцентни осветителни тела да се провери тяхната изправност, да се подменят «пурите» с нови и да се изолира IR-датчикът от попадане на пряка луминесцентна светлина.

В новите модели тунери и в последните партиди на модели 401 и 403 FM изцяло е преработена логиката на работа на микросхемата на IR-декодера, в резултат на което на практика напълно са изключени лъжливо сработване от смущения или погрешно разпознаване на инфрачервени сигнали.


Topic: Други

Други

Други [image] въпроси - отговори

  • По какъв начин е по-добре да се включват към тунера външни устройства (видеомагнетофон, плейър, ресивер...)

Външни устройства могат да бъдат включвани към тунера по три основни начина:

  1. По S-Video кабел (черен куплунг мини-DIN). Това е най-добрият начин за включване:

    S-Video съдържа два отделни сигнала – яркостен и цветоразликов. При такъв начин на включване е най-добра разделителната способност по хоризонтал, има най-малко шумове, цветопредаването е добро.

  2. С композитeн VHS кабел (куплунг RCA или т.н."опашка"). Това е следващ (по качество) начин за включване след S-Video.

    При такова включване яркостната и цветоразликова съставни са смесени в един сигнал. Този сигнал в тунера обратно се разделя на цвят и яркост. Процесите по смесване и последващо разделяне влошава качеството на изображение.

  3. Високочестотен сигнал по антенен кабел. Това е най-лошият начин за включване.

    При такъв начин на включване към смесен сигнал се добавя модулиран звук и цялата тази "смесица" допълнително се модулира по висока честота, както при телевизионен сигнал. Всички тези процеси по смесване и модулация предизвикват ограничаване на честотния диапазон, добавят допълнителни шумове, предизвикват кръстосани изкривявания между отделните сигнали и не могат да бъдат идеално разделени обратно като изходните сигнали. Поради това към такъв начин може да се пристъпва само в случай, че предходните начини поради различни причини не могат да се използват.

    Трябва да се помни, че по S-Video и VHS кабели се предава само видеосигнал, но не и звук. Звук се включва по отделен кабел. Ако тунерите са 4-а или 5-а серия, за включване на звук е необходим преходник тип RCA ("опашка") на мини-жак. Ако външното устройство е монофонично, в настройките на програмата може да се наложи да се зададе по кой канал (ляв или десен) се предава звук.

    За целта с [image] десен клик на мишката се извиква контекстното меню и в раздел «Аудио канал» се избира този канал, към който е включено външното устройство. При правилен избор звук трябва да се чува и в двата канала.

    VHS-видеомагнетофон е напълно достатъчно да бъде включен с композитен (VHS) кабел. Доколкото на магнитна лента яркостният и цветоразликов сигнали са смесени, няма принципиална разлика къде ще се извършва окончателно разделение – във видеомагнетофона (при включване по S-Video) или в тунера (при включване по VHS). Главното е видеомагнетофонът да не е настроен за прекодиране от една система за кодиране на цвят в друга. При включване на други източници (DVD-плейър, спътников приемник) включване по S-Video може да доведе до сериозно влошаване на качеството.

  • Къде се съхраняват потребителски настройки на програмата Behold TV

В зависимост от зададеното за параметър «Съхраняване на настройки отделно за всеки потребителски профил» в програмата Behold TV, настройките се пазят или в директорията и поддиректориите на самата програма Behold TV (файлове *.ini, *.cfg, *.bak, *.bir, *pst), или в потребителски директории "c:\Documents and Settings\*User*\Application Data\BeholdTV\" под Windows XP и "C:\Потребители\*User*\AppData\Roaming\BeholdTV\" под Windows Vista, където *User* е име на потребител.

  • След преход към операционна система Windows Vista/Seven престават да се съхраняват настройките на тунера. След рестартиране на програмата Behold TV настройките се прехвърлят стойности по подразбиране

Чрез инструмента «Behold TV config» (вж. меню «Start», група «Behold TV») с административни права да се зададе отметка «Съхраняване на настройки отделно за всеки потребителски профил» и да се съхранят измененията.

В операционни системи Windows Vista/7 еднократно стартиране на приложения с административни права се осъществява чрез избор на ред «Стартиране от името на администратор» на контекстното меню ( [image] десен клик) на иконката на приложението в Explorer на desktop или в менюто на бутон

  • В комплекта на тунера има диск с програма Win DVD Creator, но при инсталиране не се приема серийният номер

При въвеждане на серийния номер да се обърне внимание при набиране на букви «O», «I», «G», «S» и приличащите на тях цифри «0», «1», «6», «5».

Особено внимание да се обърне на символ «O». Цифра «0» в серийния номер е зачеркната. Ако символът не е зачертан - това е буква «O».

Да се има предвид, че на CD освен Win DVD Creator може да има записани и други продукти на Intervideo, например Win DVR. Серийният номер е само за програмата Win DVD Creator.

  • В програмата вместо руски (кирилица) букви се виждат "йероглифи"

Неправилно са зададени регионални настройки:

Control PanelRegional and Language Options...

в секция Regional Options («Регионални настройки») трябва да бъде избрано Russian (Bulgarian),

както и за формати (на дати, числови и пр.)

в секция «Advanced» («Допълнително») за не-Unicode приложения също трябва да бъде зададен «руски» («български») език (за Български - след тестване...).

  • След обновяване на Windows излиза съобщение: «WDM device "SAA7134 TV card" – is not Philips SAA713x card»

Подобно съобщение се появява поради това, че ( при автоматично или ръчно обновяване) модулът за обновяване на WinXP по „своя” преценка инсталира за тунера собствен драйвер от интернет-база данни WHQL, който не е съвместим с фирменото оборудване.

За преинсталиране на драйвер (от комплекта с тунера или свален от сайта) се пуска инсталаторът от пакета на драйвера (файл Install.exe), премахват се всички предишни инсталации за чипсет Philips SAA713x и се преинсталира WDM драйвер Behold TV наново.

Подобно съобщение се появява след като обновени версии на WinXP по подразбиране инсталират за тунера собствени драйвери (автоматично свалени от сайта на MS), които са несъвместими с тунери Behold TV.

В такива случаи трябва да се преинсталира фирмения драйвер с тези от комплекта към тунера (или актуализирана версия от официалния сайт).

За целта трябва да се пусне инсталатора от комплекта (файл Install.exe) и да се премине през опцията за премахване на всички предишни инсталации за чипсет Philips SAA713x. След това "на чисто" се инсталира WDM драйвер Behold TV.

  • При работа на тунера системата „зависва”

Основна причина за такова поведение на системата са PCI-конфликти. Основни източници на такива конфликти са:

  1. Непълна или некоректна поддръжка на спецификации за шина на апаратната част на устройства или PCI-контролери.

    Като правило това се проявява в следното:

    a) Устройството и дънната платка са несъвместими едно с друго, възпроизвеждат работата на шината по различен начин.

    b) Устройство или контролер на шината работят нестабилно или не работят при някои настройки на шината.

    c) Системата работи нестабилно като цяло, доколкото няколко устройства изискват взаимно изключващи се настройки.

    Много често такива проблеми могат да бъдат отстранени с определени настройки на BIOS, но понякога са неотстраними. Към такива случаи се отнасят:

    некоректно програмиране на PCI-контролера в BIOS на дънната платка;

    некоректна инициализация на PCI-устройства от системата,

    неправилна настройка на собственото конфигурационно пространство от устройство.

    Същността на проблемите се състои в това, че инициализацията на PCI-устройства сама по себе си представлява сложна процедура, свързана с установяване на конфигурационното пространство на устройството и настройки на контролера на шината в съответствие с получените данни.

  2. Хардуерни (апаратни) проблеми, свързани с арбитраж на шината.

    Същността на проблемите се състои в това, че шината се използва съвместно от всички устройства, включени към нея.

    Ако възникне необходимост от обмен на данни със системата на две или повече устройства едновременно, то в процеса на арбитраж се определя кое от устройствата да получи достъп към шината и кое е длъжно да изчака. На този етап съществуват множество „подводни камъни” свързани с това, че едни от устройствата могат да чакат неопределено дълго, а за други времето е критичен фактор.

    Типичен случай на такъв проблем е несъвместимост (понякога неотстранима) с някои SATA, SCSI или RAID-контролери.

    Други възможни случаи са просто некоректна обработка на процедурата по арбитраж от едно от устройствата или от контролера на шината.

  3. Проблеми, свързани с разпределение на прекъсвания.

    Теоретично спецификациите на шина PCI позволяват да се използва едно прекъсване от няколко устройства.

    На практика това е свързано с някои сложности. Механизмът на прекъсвания в шина PCI е на две нива:

    - На първо ниво е задействана само шината (апаратна част).

    - На второто ниво (по пътя на пресмятане и програмиране на PCI-регистри от няколко устройства) се отделят едно или повече устройства, действително активиращи прекъсване. В такъв случай могат да се получат грешки в драйверите на всяко от двете устройства, разделящи едно прекъсване. В случай, че прекъсване не се споделя от няколко устройства, такива грешки не се проявяват. За съжаление, при такава ситуация не е достатъчно само драйверът на нужното устройство да е написан без грешки. Необходимо е да няма грешки в драйверите на всички устройства, разделящи прекъсване.

  4. Косвени проблеми, несвързани пряко със спецификациите на PCI.

    Първо в този ред от проблеми е взаимно влияние на устройства по линия на захранването.

    Същността на проблемите се състои в това, че

    - което и да е цифрово устройство (към които безусловно се отнасят PCI-устройствата) е активен източник на смущения по веригите за захранване и заземяване. Също така, самото устройство може да е чувствително към смущения при достигане на определено гранично ниво.

    - Друг проблем (също свързан със захранване) се състои в изменение на нивото на натоварване при работа на устройство, което води до спад или «плуване» на напрежението на такова или съседно устройство. Възможно е самата система да се окаже просто неспособна да обезпечи необходимото натоварване. Към този вид проблеми се отнасят също:

    изменение на способностите за натоварване на сигналните линии на шината;

    изменение на стръмността на фронтовете и временните диаграми на сигналите при включване на допълнителни устройства.

    Не бива да се подценява вероятността за възникване на която и да е ситуация. Всички описани случаи се срещат в практиката. Описаното по-горе показва степента на сложност за диагностика и отстраняване на подобни конфликти.

    При възникване на конфликт могат да се дадат само най-общи препоръки, като:

    1) Да се премести устройството в друг слот;

    2) Да се направи опит да се разпределят прекъсвания за устройства в BIOS Setup.

    3) Да се направи опит за изменение на настройки в BIOS, касаещи шина PCI.

    4) Да се опита временно да се забранят или по възможност да се премахват поред (едно след друго) от системата устройства, за да се намерят конфликтни устройства.

    5) Да се осигури качествено захранване на системата.

    6) В настройките на програмата - секция «Видео» да се изменят параметрите на PCI DMA контролера.

    По отношение на фирмените тунери Behold ТV:

    Безусловно Beholder не прави опит да прехвърля отговорност върху други. Прави се всичко, за да бъдат предотвратени възможни конфликти. Въпреки това има ред фактори, които не зависят от това желание:

  5. Използваните в тунерите чипсети не са разработени и произведени от Beholder. Независимо от това, че Philips Semiconductor произвежда едни от най-стабилно работещите чипсети, хардуерни проблеми все още се срещат.

  6. При възникване на конфликти има ред обективни трудности за изясняване на причините и "виновника" за такива.

  • Чипсетът и други елементи по платката на тунера се нагряват силно

Това е напълно нормално:

Нормалният праг на топлинно възприятие за болка при повечето хора е 56° – достатъчно нисък. В съответствие с техническите спецификации е допустима работна температура на чипсета и стабилизаторите до 70~80°, която температура при пипане се възприема като гореща. Освен това топлоотдаването се обуславя от конструкцията на микросхемата на чипсета и по никакъв начин не зависи от самите разработчици на тунерите.

Стабилизаторът в близост до ВЧ-блока отделя точно такава топлинна мощност, както и всеки друга модел тунер на произволен производител със стабилизация на захранване на класически ВЧ-блок с помощта на линеен регулатор на напрежение. Такова топлоотдаване по никакъв начин не зависи от използваните компоненти. Разликата при тунери Behold TV се състои в това, че стабилизаторът на захранване на ВЧ-блока се намира не до слота, а в съседство с ВЧ-блока, което от друга страна увеличава устойчивост на захранването към смущения и подобрява неговата вентилация в корпуса. Недостатък при такова разположение е само това, че потребителите с по-голяма вероятност могат да докоснат по-горещи елементи на платката при отворен корпус на РС. Стабилизаторът на практика не нагрява разположени в съседство елементи. ВЧ-блокът е топъл не поради причината, че се нагрява от стабилизатора или другите елементи, а защото неговата собствена топлинна мощност е почти такава, както на стабилизатора на захранване.

  • Базата данни с телевизионни програми е обновявана отдавна

Beholder (респ. beholder-europe.com/.eu) не включва като основна дейност самостоятелна подготовка или разпространение на бази данни с ТВ-програми. В програмата Behold TV се осъществява само поддръжка на бази с ТВ-програми във формат JTV, които могат ръчно или автоматично да се свалят от Интернет. Някои такива ресурси по различни причини могат да не работят или да не се обновяват редовно.

Достъпни препратки за допълнителни ресурси в мрежата, от които може да се сваля обновяване се намират в падащия списък «Настройка на URL» в опциите на приложението Behold TV Аgent. Допълнителни препратки могат да се добавят в модула и самостоятелно.

По default са заредени само URL-адвеси за Русия.

Български адреси не са нанесени, т.к. до момента на публикуване на материала при търсене в мрежата не са намерени подходящи и работещи такива. В сферата на добрите намерения е програми с ТВ-предавания, които са актуални за България или препратки към такива да се поддържат на сайтовете beholder-europe.

  • Често задаван въпрос: Може ли на един компютър да работят два или повече тунера едновременно

  • (доп.,v.5.15) Важно: В новата версия на Behold TV се поддържа едновременна работа на тунери Beholder!

Възможно е, но във всички случаи фирмената програмна поддръжка ще работи едновременно само с един тунер и само с фирмения комплекс Behold TV.

Работа с два или повече тунера, както и с тунери на други производители [image] във версии преди v.5.17 не се поддържа [image] . Независимо от това, за различни тунери може едновременно да работи различна софтуерна поддръжка – на един тунер комплекс Behold TV, на друг – алтернативен софтуер.

Ограничена поддръжка на няколко тунера, в това число и тунери на други производители е реализирана под формата на функция "Кадър в кадъра" (РІР) при използване на плъгин BPP_PIP.

От драйвери от версия 5.0.5.0 и следващи [image] до v.5.17 се поддържат до 8 тунера.

От драйвер от версия 5.3.2.0 / ВeholdTV v.5.17 няма ограничение.

По-стари версии драйвери поддържат до 4 тунера. Ако съвместно с тунер Behold TV се използва и тунер на друг производител с чипсет NXP (Philips), то за Behold TV е необходимо да се използва драйвер - версия 3.0 или следващ и софтуерен комплекс версия 4.72 или следваща. При по-стари драйвери са възможни конфликти с драйвери на други производители.

При инсталиране на няколко тунера настоятелно се препоръчва да се използва еднокомпонентен драйвер – версия 2.70 или следваща, доколкото страничен софтуер (дори на известни производители) далеч не винаги използва правилно системния еномератор за търсене на нужно устройство. С еднокомпонентен драйвер вероятността за коректна работа на страничен софтуер е много по-висока.

Фирменият софтуер Behold TV винаги коректно намира фирмените тунери.

За информация:

Еднокомпонентен драйвер е такъв драйвер, при работа на който в системата се „вижда" само едно устройство.

При многокомпонентен драйвер се „виждат” две различни устройства:

  • устройство за видеозахват и

  • ТВ тунер.

Инсталиране и настройка на два тунера:

Драйвер във всеки случай се инсталира от операционната система отделно за всяко устройство.

За тунери Behold TV е необходимо да се инсталира един и същи драйвер. След това в софтуера Behold TV е необходимо да се избере единия тунер, а в алтернативния – друг такъв. Също така е важно коректно да се включат и настроят линии за предаване на звук. Доколкото е невъзможно да се задейства една и съща линия на звуковата карта за включване на два тунера, такива или трябва да използват различни линии, или да се използва предаване на звук по шина PCI. Ако ще се използва предаване на звук по PCI за един тунер, за препоръчване е това да се прави с програмния комплекс Behold TV, доколкото това се извършва по-коректно. Ако са задействани няколко различни линии на звуковата карта, е необходимо същите правилно да бъдат избрани в съответните настройки на софтуера.

Трябва да се има предвид, че при едновременна работа на няколко тунера овърлейна повърхнина ще бъде достъпна само за една работеща програма.

Трябва да се помни, че Beholdеr не носи отговорност за работоспособност на тунери на други производители с плъгин BPP_PIP и за коректна работа на чужд софтуер в конфигурация с много тунери.

  • Windows [image] не работи с тунера

Windows Media Center в операционни системи Windows XP/Vista работи само с тунери с интегрира апаратен (хардуерен) MPEG2 енкодер. В производствената листа на тунери Beholder това са модели Behold TV M6, M63, M6 Extra, X7.

  • От буксата (щекера/куплунга) на телевизионната антена "удря" ток. При включване на антената прескачат искри

По правило под напрежение се намира не буксата на телевизионна антена, а незаземен корпус на системния блок на компютъра, който поради конструктивни особености на захранващите блокове се намира под [image] потенциал 110 V спрямо заземено екраниране на телевизионния кабел при колективни (кабелни) антени. Антенния вход на тунера, както и всички други съединителни интерфейси по корпуса на компютъра са галванически свързани с корпуса на системния блока, и при включване на антена към тунера се «заземява» системният блок и цялата апаратура, която е включена към него. При изправен захранващ блок максималният ток на утечка чрез такова «заземяване» не превишава 1мА, което освен неприятно усещане не представлява опасност нито за хората, нито за антенния вход на тунера. Едни от възможните последствия при такова заземяване могат да бъдат смущения (рус."наводки") и трептене на изображението на екрана.

При подобни ситуации между телевизионната антена и тунера трябва да се включва изолатор, с което да се осигури галванично разделяне по постоянен ток и значително да се намали токът на утечка по ниска честота.

Значително по-сериозни проблеми могат да възникнат, ако и телевизионната антена и системният блок са заземени, но заземяването е изпълнено в различни, несвързани помежду си точки, между които може да има значителна (рус. "наведённая") потенциална разлика. При това величината на тока на утечка чрез антенния вход и антенния кабел ще зависи от цял ред фактори, като:

  • начин на заземяване/зануляване;

  • влажност на въздуха;

  • количество и качество на включена апаратура;

  • време от денонощието и пр.

Голям ток на утечка може да доведе до пренагряване и разрушаване на антенния кабел и свързващата букса; смущения/повреди между екраните на компютърния монитор и включен паралелно към същата антена телевизор; сработване на автоматични защити и пр. Такива проблеми могат да бъдат преодоляни по описания по-горе начин - чрез включване на галваничен разделител (изолатор/заземяване).

Най-сериозен случай е неизправност на захранващия блок на компютър; друга техника, включена към антенния кабел или неправилно включване на клеми за заземяване в електрическа розетка, в резултат на което корпусът на системния блок може да се окаже под силово напрежение 220 V

По правило в такъв случай включване на телевизионна антена към тунера води до късо съединение в електрическата мрежа, обгаряне на антенния вход/букса и сработване на автоматични защити от претоварване на мрежата. В такива ситуации е необходима незабавна намеса на квалифициран електротехник.

  • Кога ще излезе нов модел тунер

Фирмено правило е бъдещи планове да не се разгласяват предварително. Това е принцип, зад който стоят достатъчно основания. Защо?...това е вътрешнофирмено решение и не подлежи на обсъждане. Въпреки разбирането, че това може да предизвиква определено недоволство и факта, че такъв род неизвестност може да пречи да се направи моментен индивидуален избор, позицията на Beholder по този въпрос остава неизменна.

  • При включване в режим «Телетекст» вместо шрифт се вижда „псевдографика”

Това е грешка при регистрация на шрифтове в инсталатора DX8.

В папка ...\WSTRus се намира файл wst_w9x.reg (за Windows 98~ME) и wst_w2k.reg (за Windows 2000). Необходимо е

- да се стартира съответният файл, и

- да се рестартира Windows.

Некоректно изобразяване на страници с телетекст е възможно също поради това, че вграденият в Microsoft Direct X програмен декодер за телетекст е крайно чувствителен към качеството на приемания сигнал.


Topic: Допълнително / Форум

Допълнително / Форум

Въпроси и дискусионни теми от официалния форум и други източници

  • (Ясный/21.11.2007): ...приемане на сигнали по цифров стандарт DVB-C

    (Support/22.11.2007): Хибридните тунери не приемат цифрова ТВ DVB-C*/S*/H*.

    * [image] ...за момента? Beholder никога не са оповестявали предварително фирмените намерения и стратегия преди всички нови модели (респ. нови версии на драйвери/софдуер) да бъдат щателно проверени и тествани. Въпреки това в последните версии на BeholdTV е загатната информация за вероятни перспективи:

  • (Aleksey-Forest/23.11.2007): В ...Х... район цифровото излъчване DVB-Т е във формат MPEG-4. Възможно ли е гледане с хибридeн тунер Н6

    (Support/16.11.2007): Ако излъчването е по стандарт Н.264 (подстандарт/разширение MPEG-4) е възможно гледане при наличие на програмен декодер Н.264 (не влиза в комплекта!).

  • (Aleksey-Forest/27.11.2007): ...излъчването е във формат Н.264 part 10. Поддържат ли тунерите part 10 или това зависи изцяло от кодеците

    (Support/27.11.2007): Това е Н.264 / АVС, по-точно името на стандарта е ISO/IEC 14496 part 10 (Advanced Video Coding). За декодиране е достатъчно да има инсталиран подходящ видеодекодер, например от изброените по-долу:

    Сyber Link Н.264 / AVC Decoder v7.x (PowerDVD 7.3);

    Main Concept AVC / Н.264 Video Decoder;

    Core AVC Video Decoder

  • (Aleksey-Forest/27.11.2007): (Aleksey-Forest/30.12.2007): Инсталирах демо-версия на кодек Main Concept AVC. Windows Media Player (WMP) намира и използва успешно кодека, като в ъгъла се показва лого Main Concept ( [image] ограничение на демо-версията, би могло да се премахне с плъгин Logo Killer), но Behold TV не го намира. Аналогична е ситуацията и с Core AVC PRO

    ( [image] В новите версии на Behold TV интерфейсът за добавяне на Видео и Аудио декодери се намира в секция DVB поток и описаните в отговора процеси са улеснени)

    (Support/10.01.2008): За добавяне на допълнителни видео/а удио декодери, в списъка с декодери за DVB поток трябва да се редактират файлове MPEG4 audio decoders.ini в директория ...\Behold TV\Decoders.

    Параметър CLSID може да се вземе от свойствата на нужния декодер, като се използва програма за разглеждане и редактиране на DS компоненти (например DSFMgr.exe).

MPEG-2/MPEG4 стандарти

  • Дискусия: (Okint/16.04.2008): ... твърди се, че стандарт MPEG-4, по-точно MPEG-4 AVC / H.264 е по-съвременен и по-добър от MPEG-2. Занимавам се отдавна с мултимедия и зная, че нова не е така...

    MPEG-4 AVC/H.264 се използва при цифрова телевизия изключително за HD-излъчване, а

    за нормално изображение е напълно достатъчно излъчване в MPEG-2.

    Много често се бъркат понятията "цифрова телевизия" и "HD", което не е едно и също! Излъчване на цифрова телевизия съвсем не означава, че ще бъде непременно с HD качество!!

    По принцип при еднаква визуална картина телевизионно изображение с висока разделителна способност от материал, кодиран по AVC / H.264 напълно съответства на пропускателната способност на мрежите, използвани за излъчване на телевизия с обикновена разделителна способност във формат MPEG-2, но по принцип HD телевизия с висока разделителна способност във формат MPEG-2 превъзхожда формат AVC / H.264 по качество, т.к. просто за такава телевизия се изисква много голяма разделителна способност, за което е необходима подмяна на огромно количество предаващо оборудване, което е свързано с много проблеми.

    Зависи и от качеството на излъчването. Има примери, при които в (Х) район се излъчва по стандарт MPEG-4 AVC / H.264 с параметри:

    § размер на изображение 538х576,

    § битрейт 2 Мbit и

    § звук MPEG-1 Layer 1 (MP1),

    което е архаично...например при сравнение със същия материал,

    § излъчван от спътников канал,

    § записан от аналогова ТВ,

    § изчистен от шумове и пр.,

    § компресиран с XviD,

    при което качеството е по-добро от посочената по-горе цифрова телевизия...

    Освен това файлове, записани при такива параметри на цифрова телевизия не могат да бъдат „преглътнати” от болшинството стационарни DVD плейъри, докато от файл във формат MPEG-2 лесно може да се направи DVD видео... В подкрепа на това е факта, че най-голямо количество видеоматериали с добро качество се издават именно във формат MPEG-2 (DVD-видео) Такива материали могат да се излъчват в цифров вид без прекодиране, респ. без загуби в качеството, каквито безспорно ще има при прекодиране за излъчване по стандарт MPEG-4 AVC / H.264...


Topic: Информация за контакти

Информация за контакти

Информация за контакти:

Официален сайт:

http://www.beholder.ru

Страница за поддръжка:

http://www.beholder.ru/support

Форум:

http://www.beholder.ru/bb

E-mail:

support@beholder.ru

Регионална информация:

Автор и редактор на материали на български език *:

  • Официален сайт:

http://www.beholder-europe.com

http://www.beholder-europe.eu

*вж. също пояснителни бележки по превод и редактиране на български език и полезни връзки

The contents of Информация за контакти

Превод и редакция
Вместо епилог


Topic: Превод и редакция

Превод и редакция

Някои особености в българската редакция на материалите

  • Оригинална инструкция на руски език:

    http://www.beholder.ru/support/install.htm

  • Материали на български език в официалния сайт:

    http://www.beholder.ru/bb/viewtopic.php?t=7940

Бележки по [image] превода и редактирането [image] :

Инструкциите за инсталиране на драйвери и софтуерния комплекс са приложими за всички модели PCI / USB / PCIe тунери BeholdTV.

(доп., v.5.11.) Появата на нови модели тунери (Behold TV серии «7» и «8», тунери с USB и PCIe интерфейс) обективно налагат своевременни промени в програмното осигуряване (драйвери, фирмен софтуер, плъгини), респ. изискват функционален и лесен за употреба потребителски интерфейс с многоезикова поддръжка в съответствие с реализирането на нови технологии и възможности на база на внедряваните чипсети, ВЧ-модули и ред други фактори.

В съответствие с горното, при редакцията на първоначално публикуваните оригинални материали на български език за v.5.05 своевременно са нанесени всички ключови изменения и допълнения за версии 5.07~5.09~5.10~5.11~5.15 и 5.17, с което се цели да се предостави база за по-пълно сравнение и вникване във възможностите и функционалните/софтуерни промени при новите модели.

Целта е материалите за последната редактирана версия да съдържат още по-изчерпателна информация, при което да могат да се ползват по желание и за предишни версии* с отчитане на функционалните/хардуерни особености на различните модели/серии и свързаните с това изменения в софтуерната поддръжка, респ. промените във възможностите и интерфейса за управление в новите версии на програмния комплекс.

  • Структуриране на материалите

  1. При превода на интерфейса, помощни инструкции и др. материали по правило са полагани усилия да се следват стриктно постройките на оригиналните текстове и структура с цел избягване на смислови и/или терминологични неточности и при необходимост - предоставяне на възможности за по-лесно сравнение с основните източници.

  2. Така например, разделът за инсталиране на драйвери и софтуер след излизането на версии BeholdTV v.5.07~5.11 е изведен отделно от Help-файла на официалния сайт на производителя.

    За по-пълно придържане към структурата на оригиналната версия, българският превод на този раздел по аналогия също е изведен като самостоятелен раздел в обособен материал . От друга страна, в този материал допълнително е включена структурна част за предварителна подготовка и инсталиране на хардуер, при което се обединяват инструкциите на хартиен носител със съответните възможности за по-лесно търсене на различна информация в електронния вариант.

  3. Материалите за плъгини се публикуват като обособена част - продължение/допълнение на софтуерния комплекс BeholdTV.

  4. Някои относително самостоятелни части в рамките на дадени раздели са допълнително отделени в подраздели с цел обособяване на конкретна терминология,

    например: , при което

  • общи особености при излъчване на потоци в мрежа са оставени в основния раздел, а

  • специфични настройки за протоколи HTTP и UDP са структурирани в съответни подраздели.

    *Софтуерът се обновява и развива непрекъснато, като своевременно се усъвършенства, отстраняват се евентуално намерени грешки и забележки, вкл. от форумните дискусии. В официалния форум битуват и мнения, че в някои случаи (например при конфликти) могат да се ползват предишни версии. Без да се изразява лично мнение, това е една от причините в последната редакция на материалите да се оставят някои текстове от предишни версии, които са съответно обозначени в различен цвят (вж. по-долу).

Стилово оформление

*За ориентиране в промените на софтуера, в българската редакция са използвани различни цветове на шрифт:

  • Изменения и допълнения след v.5.05 (5.07~5.15 вкл.) са в по-светъл цвят,

  • такива за обновен интерфейс след версия 5.11 - в светло синьо,

  • някои неактивни, отпаднали или редактирани/разместени менюта от версии 5.05~5.10 в сравнение с предишни версии – в светло сиво/сиво (“gray”),

  • авторски коментари, забележки и допълнения/пояснения са в тъмно-сив цвят,

  • препоръчителни величини, настройки и пр. са подчертани в зелен цвят,

  • забележки, [image] предупреждения, [image] напомняния и други важни моменти са в червено.

    При превода беше забелязано, че части от терминологията принадлежат смислово към отделни групи и има относително обособяване по такъв признак.

    Такива например са различни абзаци (изречения, таблици и пр.) за

    настройки и технически параметри/величини,

    теоретични понятия/термини,

    по-общо информационно съдържание, и пр.

    При стиловото оформление в българската редакция пред такава терминология допълнително са използвани символи (Wingdings) или мини-иконки, с които да бъде "подсказано" за какво става въпрос в следващото съдържание.

    Таблица с пояснения на използвани символи е поместена тук .

  • Терминология, кратък речник - общи бележки*

    *Речници на използвани термини и съкращения; описание на символи/икони са изведени в отделен материал .

  1. При превода и редактирането някои термини (най-вече свързани с менюта на програми, опции и съобщения на операционната система) са възстановени от руски на английски език (без да се превеждат на български език). Това е направено умишлено при редактирането – лично мнение на редактора е, че в ХХІ век не е уместно да се превеждат специфични термини (от сорта на „Recycle Bin” » „Кошче за отпадъци” и пр.), с които масовият потребител би трябвало да борави свободно. Такива термини са представени в курсив (Italic) и са оцветени в тъмно син цвят.

    В самия софтуерен продукт също така има някои менюта/прозорци, оригиналният интерфейс на които е в англоезичен вариант (например диалогови прозорци за настройки на апаратен декодер, матрица за квантоване и др.). Това не са „недоработки” или пропуски в програмата, a e направено от разработчиците умишлено – в случая става въпрос за форма на допълнителна защита срещу непрофесионални действия, доколкото някои фини настройки изискват значително по-задълбочени познания на материята и по-богат практически опит. За болшинството потребители тези настройки са зададени с оптимални стойности по подразбиране и няма необходимост от допълнително експериментиране. Въпреки това, за професионалисти в програмата са предвидени и такива настройки.

  2. Някои по-специфични термини и текстове (при превода на които е възникнало съмнение за коректните термини на български език или е необходимо последващо доуточняване и/или редактиране) са оставени непреведени. Такива текстове/термини са оцветени в „orange”. При всяка следваща редакция се полагат усилия проблеми от такъв характер да бъдат окончателно уточнени и преведени (или обяснени), доколкото това е по възможностите на автора/редакцията.

  3. На този етап интерфейсът на системата от плъгини е на руски език. До пълното адаптиране на български език опциите за настройка са обяснени паралелно (руска дума/термин»българско значение/превод) с оригиналните руски текстове.

  4. Трябва да се има предвид, че при различните версии на операционната система (по-нататък съкр. "ОС", "OS") някои системни екрани, падащи менюта, прозорци, команди за изпълнение и пр. имат различен интерфейс и транскрипция в сравнение с описаните такива по-долу. Примерите и екранни снимки (screen shots) в материалите са изведени при инсталиране и тестване на драйвери и основна програма на базата на сравнително широко разпространената ОС Windows XP (SP2) в англоезичен вариант.

  5. Преводът на български език на оригинални менюта, подменюта, команди, съобщения, опции и пр. в прозорци/подпрозорци на оригиналния рускоезичен интерфейс са в курсив и различен цвят.

  6. При всяка възможност са правени екранни снимки от българския интерфейс на програмите при инсталиране на софтуер Behold TV v.5.05~5.17; драйвер v.5.3.2.0; хардуерни модули – ТВ тунери:

  • Behold TV М63 с апаратен енкодер и

  • хибриден тунер Behold TV H6

    с чипсети SAA7135 и "традиционен" ВЧ-модул МК3

    (поради което някои screen shots за тунери с чипсети, различни от SAA7135 и посочения ВЧ-модул са в непроменен вид - на руски език от оригиналните материали, без български интерфейс/превод).

    ............

The contents of Превод и редакция

Източници


Topic: Източници

Източници

Основни източници на информация и полезни връзки

  • Последняя версия справки к программному обеспечению Beholder: Help_v517.zip (947 kb)

  • Статии в раздели " Новини "/" Преса "

  • ...

Обособени / свързани материали

Материали на български език:

  • Избор на ТВ тунер - Помощна и справочна информация при подбор на ТВ тунер

  • Инсталиране на хардуер, драйвери и софтуер

  • Behold TV Help (PCI / USB / PCMCIA) - настоящата инструкция

    Ресурсни файлове за Български интерфейс - Behold TV v.5.05~5.07~5.09~5.10~5.11~5.15~5.17

    F1, вградена помощ

  • Behold TV Help (STB)

    Български интерфейс Behold TV INTRO (bh_tvbox_2)

    F1, вградена помощ

  • Plugins Review: Многократно разширяване на възможностите при гледане, запис и видеообработка с използване на плъгини;

  • Ефективна борба с реклами:

    Видеообработка с Inter Video Win DVD Creator

    Автоматизиране на борбата с реклами с използване на плъгини (Logo Detector, Logo Killer, Logo Extractor, My Logo)

  • Дистанционно управление на компютъра:

    - Behold IR;

    - Perehvat -

    Български интерфейс и Help

  • Работа с програми за ТВ-предавания:

    - List TV;

    - tv2jtv

  • други материали по темата от същия автор, както и:

Пълен списък с ползвани/свързани с темата източници на информация, които обхващат всички обособени части е публикуван в първия материал (по логическа последователност) - TVTunerChoice_BG.

В отделните части са обособени само източници, които имат връзка със съответната структурна част:

Beholder - официален сайт :

  • " О компании " Beholder - фирмен сайт

  • Последняя версия справки к программному обеспечению Beholder: Help_v517.zip ;

  • Плъгини - страница за техническа поддръжка ;

  • Инструкция по установке драйвера и программного обеспечения ;

  • Bulgarian (Болгарский, Български) интерфейс & инструкции ;

  • * Beholder.ru/форум/Вопросы про стандарты цифрового тв *

  • Статии в раздели " Новини "/" Преса "

  • ...

Публикации в интернет (на руски език):

  • "Beholder – два года спустя…" Дата: 23.05.2006 | Автор: Reviews.ru

  • "Beholder – пять лет на тропе ТВ-тюнеров" Автор: Воевода Денис

  • " ТВ-тюнеры Beholder – что выбрать? Советы покупателю " Автор: Денисов Евгений

  • " Станислав Стельмахов – о Beholder, и не только! " Автор: Воевода Денис

  • " Спутниковый интернет без тарелки - эфирное цифровое вещание по стандарту DVB-T "

  • Ferra.ru : Особенности нового софта для ТВ-тюнеров Beholder (Timeshift, плъгини - общо ревю към.08.12.2004.)

  • Tom'sHardwareGuide.ru: Обзор ТВ-тюнера BeholdTV 403 (ВРР_ВТVGuard,BPP_AMPPlugin)

  • HardwarePortal.ru: Видеонаблюдение для дома с помощью ТВ-тюнера Beholder (вж.ВРР_ВТVGuard)

  • ...

Публикации в интернет (на български език):

  • " Програма за реализиране на прехода от наземно аналогово към наземно цифрово телевизионно радиоразпръскване "

  • ...


Topic: Вместо епилог

Вместо епилог

Епилог (*С продължение...)

Както се вижда от този материал, реализираните до момента възможности на Behold TV са твърде широки. Предвид утвърдената многогодишна фирмената политика, стратегия и постигнати реални резултати уверено може да се прогнозира, че разнообразието от серии и модели с все по-широки възможности и нови функции тепърва предстои да се развива. Тези процеси безспорно са неразривно свързани с безупречна софтуерна поддръжка, внедряване на иновационни решения и собствени фирмени разработки, в които дейности Beholder са специализирани. Доказателства за такива изводи са факти, които могат лесно да бъдат проверени:

  • От напълно неизвестна марката израства "от кота нула" до втора (засега) водеща сила в условията на жестока конкуренция на огромен пазар, при това само за 5-годишен период от създаването на компанията. С ясно заявени амбиции и пазарно поведение Beholder вече осезаемо "диша във врата" на досегашния временен лидер, а тунерите печелят довериено на все повече привърженици в международен мащаб:

    (цит.) "... Где, кроме России, можно приобрести Ваши ТВ-тюнеры?

    - Наши партнёры продают Beholder в Болгарии, Украине, Белоруссии, Казахстане, Молдове, Азербаджане, Латвии и ряде других стран. Более подробно узнать точки продаж можно на нашем сайте в разделе Где купить ." (кр.цит.)

  • продукцията непрекъснато се обновява и развива - за посочения период на пазара са пуснати 37 различни модели тунери, от които:

    § 28 модела за вграждане в 5 серии с РСІ/РСІе интерфейс, със стандартна и нископрофилна архитектура;

    § 4 модела в 3 серии STB;

    § 4 модела с USB интерфейс;

    § 1 модел с PCMCIA интерфейс,

    които обхващат всички широко разпространени възможности от страна на хардуерен интерфейс. Само за последния едногодишен период на бял свят са пуснати 10 нови модела, като няколкократно са обновени драйверите и програмното осигуряване;

  • Поддръжката на нови версии на ОС се извършва изпреварващо, а не със закъснение (справка - датиране на драйвери и програмни актуализации в официалния сайт);

  • Бърза реакция на пазарните условия с пускане както на конкурентни нискобюджетни модели (без това да се отразява съществено на функционалните възможности), така и на пълнофункционални "топ" модели с пълен набор от "екстри",

  • и ред други.

Предвид горните редове и при по-задълбоченото вникване във възможностите на софтуерно-хардуерния комплекс Behold TV, в процеса на работа върху настоящия материал постепенно на преден план се наложиха изводи, че само в една публикация не е възможно да бъдат обхванати всички аспекти, без да бъде допуснато разпростиране в по-обемни разклонения. От друга страна материята обхваща относително самостоятелни раздели, които могат да бъдат тематично обособени като отделни, но взаимосвързани модули, поради което част от материалите вече са обособени като отделни теми , а друга е в процес на разработване или във финална фаза на редактиране.

Всички посочени по-горе материали също така се публикуват и актуализират в секция " Локализация " на официалния сайт на Beholder.

*...С пожелание информацията да е била полезна - лека и успешна работа!

*...To be continued...


Topic: Reserve

< Previous page

Reserve

Reserved for updates

Created with DrExplain

< Previous page